From: Atish Patra <atishp@rivosinc.com>
To: linux-kernel@vger.kernel.org
Cc: Atish Patra <atishp@rivosinc.com>,
Andrew Jones <ajones@ventanamicro.com>,
Ajay Kaher <ajay.kaher@broadcom.com>,
Albert Ou <aou@eecs.berkeley.edu>,
Alexandre Ghiti <alexghiti@rivosinc.com>,
Alexey Makhalov <alexey.amakhalov@broadcom.com>,
Anup Patel <anup@brainfault.org>,
Atish Patra <atishp@atishpatra.org>,
Broadcom internal kernel review list
<bcm-kernel-feedback-list@broadcom.com>,
Conor Dooley <conor.dooley@microchip.com>,
Juergen Gross <jgross@suse.com>,
kvm-riscv@lists.infradead.org, kvm@vger.kernel.org,
linux-kselftest@vger.kernel.org, linux-riscv@lists.infradead.org,
Mark Rutland <mark.rutland@arm.com>,
Palmer Dabbelt <palmer@dabbelt.com>,
Paolo Bonzini <pbonzini@redhat.com>,
Paul Walmsley <paul.walmsley@sifive.com>,
Shuah Khan <shuah@kernel.org>,
virtualization@lists.linux.dev, Will Deacon <will@kernel.org>,
x86@kernel.org
Subject: [PATCH v6 09/24] drivers/perf: riscv: Fix counter mask iteration for RV32
Date: Wed, 10 Apr 2024 17:07:37 -0700 [thread overview]
Message-ID: <20240411000752.955910-10-atishp@rivosinc.com> (raw)
In-Reply-To: <20240411000752.955910-1-atishp@rivosinc.com>
For RV32, used_hw_ctrs can have more than 1 word if the firmware chooses
to interleave firmware/hardware counters indicies. Even though it's a
unlikely scenario, handle that case by iterating over all the words
instead of just using the first word.
Reviewed-by: Andrew Jones <ajones@ventanamicro.com>
Signed-off-by: Atish Patra <atishp@rivosinc.com>
---
drivers/perf/riscv_pmu_sbi.c | 21 ++++++++++++---------
1 file changed, 12 insertions(+), 9 deletions(-)
diff --git a/drivers/perf/riscv_pmu_sbi.c b/drivers/perf/riscv_pmu_sbi.c
index e2881415ca0a..a6e74f4ad1c2 100644
--- a/drivers/perf/riscv_pmu_sbi.c
+++ b/drivers/perf/riscv_pmu_sbi.c
@@ -772,13 +772,15 @@ static inline void pmu_sbi_stop_hw_ctrs(struct riscv_pmu *pmu)
{
struct cpu_hw_events *cpu_hw_evt = this_cpu_ptr(pmu->hw_events);
unsigned long flag = 0;
+ int i;
if (sbi_pmu_snapshot_available())
flag = SBI_PMU_STOP_FLAG_TAKE_SNAPSHOT;
- /* No need to check the error here as we can't do anything about the error */
- sbi_ecall(SBI_EXT_PMU, SBI_EXT_PMU_COUNTER_STOP, 0,
- cpu_hw_evt->used_hw_ctrs[0], flag, 0, 0, 0);
+ for (i = 0; i < BITS_TO_LONGS(RISCV_MAX_COUNTERS); i++)
+ /* No need to check the error here as we can't do anything about the error */
+ sbi_ecall(SBI_EXT_PMU, SBI_EXT_PMU_COUNTER_STOP, i * BITS_PER_LONG,
+ cpu_hw_evt->used_hw_ctrs[i], flag, 0, 0, 0);
}
/*
@@ -790,7 +792,7 @@ static inline void pmu_sbi_stop_hw_ctrs(struct riscv_pmu *pmu)
static noinline void pmu_sbi_start_ovf_ctrs_sbi(struct cpu_hw_events *cpu_hw_evt,
unsigned long ctr_ovf_mask)
{
- int idx = 0;
+ int idx = 0, i;
struct perf_event *event;
unsigned long flag = SBI_PMU_START_FLAG_SET_INIT_VALUE;
unsigned long ctr_start_mask = 0;
@@ -798,11 +800,12 @@ static noinline void pmu_sbi_start_ovf_ctrs_sbi(struct cpu_hw_events *cpu_hw_evt
struct hw_perf_event *hwc;
u64 init_val = 0;
- ctr_start_mask = cpu_hw_evt->used_hw_ctrs[0] & ~ctr_ovf_mask;
-
- /* Start all the counters that did not overflow in a single shot */
- sbi_ecall(SBI_EXT_PMU, SBI_EXT_PMU_COUNTER_START, 0, ctr_start_mask,
- 0, 0, 0, 0);
+ for (i = 0; i < BITS_TO_LONGS(RISCV_MAX_COUNTERS); i++) {
+ ctr_start_mask = cpu_hw_evt->used_hw_ctrs[i] & ~ctr_ovf_mask;
+ /* Start all the counters that did not overflow in a single shot */
+ sbi_ecall(SBI_EXT_PMU, SBI_EXT_PMU_COUNTER_START, i * BITS_PER_LONG, ctr_start_mask,
+ 0, 0, 0, 0);
+ }
/* Reinitialize and start all the counter that overflowed */
while (ctr_ovf_mask) {
--
2.34.1
next prev parent reply other threads:[~2024-04-11 0:08 UTC|newest]
Thread overview: 38+ messages / expand[flat|nested] mbox.gz Atom feed top
2024-04-11 0:07 [PATCH v6 00/24] RISC-V SBI v2.0 PMU improvements and Perf sampling in KVM guest Atish Patra
2024-04-11 0:07 ` [PATCH v6 01/24] RISC-V: Fix the typo in Scountovf CSR name Atish Patra
2024-04-15 13:01 ` Andrew Jones
2024-04-11 0:07 ` [PATCH v6 02/24] RISC-V: Add FIRMWARE_READ_HI definition Atish Patra
2024-04-11 0:07 ` [PATCH v6 03/24] drivers/perf: riscv: Read upper bits of a firmware counter Atish Patra
2024-04-11 0:07 ` [PATCH v6 04/24] drivers/perf: riscv: Use BIT macro for shifting operations Atish Patra
2024-04-11 0:07 ` [PATCH v6 05/24] RISC-V: Add SBI PMU snapshot definitions Atish Patra
2024-04-11 0:07 ` [PATCH v6 06/24] RISC-V: KVM: Rename the SBI_STA_SHMEM_DISABLE to a generic name Atish Patra
2024-04-11 0:07 ` [PATCH v6 07/24] RISC-V: Use the minor version mask while computing sbi version Atish Patra
2024-04-15 13:06 ` Andrew Jones
2024-04-16 8:31 ` Atish Patra
2024-04-16 8:49 ` Andrew Jones
2024-04-11 0:07 ` [PATCH v6 08/24] drivers/perf: riscv: Implement SBI PMU snapshot function Atish Patra
2024-04-15 13:15 ` Andrew Jones
2024-04-16 8:33 ` Atish Patra
2024-04-11 0:07 ` Atish Patra [this message]
2024-04-11 0:07 ` [PATCH v6 10/24] RISC-V: KVM: Fix the initial sample period value Atish Patra
2024-04-11 0:07 ` [PATCH v6 11/24] RISC-V: KVM: No need to update the counter value during reset Atish Patra
2024-04-11 0:07 ` [PATCH v6 12/24] RISC-V: KVM: No need to exit to the user space if perf event failed Atish Patra
2024-04-11 0:07 ` [PATCH v6 13/24] RISC-V: KVM: Implement SBI PMU Snapshot feature Atish Patra
2024-04-15 13:19 ` Andrew Jones
2024-04-11 0:07 ` [PATCH v6 14/24] RISC-V: KVM: Add perf sampling support for guests Atish Patra
2024-04-15 13:23 ` Andrew Jones
2024-04-11 0:07 ` [PATCH v6 15/24] RISC-V: KVM: Support 64 bit firmware counters on RV32 Atish Patra
2024-04-11 0:07 ` [PATCH v6 16/24] RISC-V: KVM: Improve firmware counter read function Atish Patra
2024-04-11 0:07 ` [PATCH v6 17/24] KVM: riscv: selftests: Move sbi definitions to its own header file Atish Patra
2024-04-11 0:07 ` [PATCH v6 18/24] KVM: riscv: selftests: Add helper functions for extension checks Atish Patra
2024-04-11 0:07 ` [PATCH v6 19/24] KVM: riscv: selftests: Add Sscofpmf to get-reg-list test Atish Patra
2024-04-11 0:07 ` [PATCH v6 20/24] KVM: riscv: selftests: Add SBI PMU extension definitions Atish Patra
2024-04-11 0:07 ` [PATCH v6 21/24] KVM: riscv: selftests: Add SBI PMU selftest Atish Patra
2024-04-15 13:31 ` Andrew Jones
2024-04-11 0:07 ` [PATCH v6 22/24] KVM: riscv: selftests: Add a test for PMU snapshot functionality Atish Patra
2024-04-15 13:32 ` Andrew Jones
2024-04-11 0:07 ` [PATCH v6 23/24] KVM: riscv: selftests: Add a test for counter overflow Atish Patra
2024-04-15 13:36 ` Andrew Jones
2024-04-11 0:07 ` [PATCH v6 24/24] KVM: riscv: selftests: Add commandline option for SBI PMU test Atish Patra
2024-04-15 13:43 ` Andrew Jones
2024-04-16 8:49 ` Atish Patra
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20240411000752.955910-10-atishp@rivosinc.com \
--to=atishp@rivosinc.com \
--cc=ajay.kaher@broadcom.com \
--cc=ajones@ventanamicro.com \
--cc=alexey.amakhalov@broadcom.com \
--cc=alexghiti@rivosinc.com \
--cc=anup@brainfault.org \
--cc=aou@eecs.berkeley.edu \
--cc=atishp@atishpatra.org \
--cc=bcm-kernel-feedback-list@broadcom.com \
--cc=conor.dooley@microchip.com \
--cc=jgross@suse.com \
--cc=kvm-riscv@lists.infradead.org \
--cc=kvm@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-kselftest@vger.kernel.org \
--cc=linux-riscv@lists.infradead.org \
--cc=mark.rutland@arm.com \
--cc=palmer@dabbelt.com \
--cc=paul.walmsley@sifive.com \
--cc=pbonzini@redhat.com \
--cc=shuah@kernel.org \
--cc=virtualization@lists.linux.dev \
--cc=will@kernel.org \
--cc=x86@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox