Linux virtualization list
 help / color / mirror / Atom feed
From: Atish Patra <atishp@rivosinc.com>
To: Andrew Jones <ajones@ventanamicro.com>
Cc: linux-kernel@vger.kernel.org,
	Ajay Kaher <ajay.kaher@broadcom.com>,
	Albert Ou <aou@eecs.berkeley.edu>,
	Alexandre Ghiti <alexghiti@rivosinc.com>,
	Anup Patel <anup@brainfault.org>,
	Atish Patra <atishp@atishpatra.org>,
	Conor Dooley <conor.dooley@microchip.com>,
	Juergen Gross <jgross@suse.com>,
	kvm-riscv@lists.infradead.org, kvm@vger.kernel.org,
	linux-kselftest@vger.kernel.org, linux-riscv@lists.infradead.org,
	Mark Rutland <mark.rutland@arm.com>,
	Palmer Dabbelt <palmer@dabbelt.com>,
	Paolo Bonzini <pbonzini@redhat.com>,
	Paul Walmsley <paul.walmsley@sifive.com>,
	Shuah Khan <shuah@kernel.org>,
	virtualization@lists.linux.dev, Will Deacon <will@kernel.org>,
	x86@kernel.org
Subject: Re: [PATCH v6 24/24] KVM: riscv: selftests: Add commandline option for SBI PMU test
Date: Tue, 16 Apr 2024 01:49:04 -0700	[thread overview]
Message-ID: <be9a80a3-64f1-4848-94a4-031a3ea797ad@rivosinc.com> (raw)
In-Reply-To: <20240415-8b9ad5a7e968b1808e99e3da@orel>

On 4/15/24 06:43, Andrew Jones wrote:
> On Wed, Apr 10, 2024 at 05:07:52PM -0700, Atish Patra wrote:
>> SBI PMU test comprises of multiple tests and user may want to run
>> only a subset depending on the platform. The most common case would
>> be to run all to validate all the tests. However, some platform may
>> not support all events or all ISA extensions.
>>
>> The commandline option allows user to disable particular test if they
>> want to.
>>
>> Suggested-by: Andrew Jones <ajones@ventanamicro.com>
>> Signed-off-by: Atish Patra <atishp@rivosinc.com>
>> ---
>>   .../selftests/kvm/riscv/sbi_pmu_test.c        | 77 ++++++++++++++++---
>>   1 file changed, 68 insertions(+), 9 deletions(-)
>>
>> diff --git a/tools/testing/selftests/kvm/riscv/sbi_pmu_test.c b/tools/testing/selftests/kvm/riscv/sbi_pmu_test.c
>> index 0fd9b76ae838..57025b07a403 100644
>> --- a/tools/testing/selftests/kvm/riscv/sbi_pmu_test.c
>> +++ b/tools/testing/selftests/kvm/riscv/sbi_pmu_test.c
>> @@ -33,6 +33,16 @@ static unsigned long counter_mask_available;
>>   
>>   static bool illegal_handler_invoked;
>>   
>> +enum sbi_pmu_test_id {
>> +	SBI_PMU_TEST_BASIC = 0,
>> +	SBI_PMU_TEST_EVENTS,
>> +	SBI_PMU_TEST_SNAPSHOT,
>> +	SBI_PMU_TEST_OVERFLOW,
>> +	SBI_PMU_TEST_MAX,
>> +};
>> +
>> +static int disabled_test_id = SBI_PMU_TEST_MAX;
> 
> I think we should allow specifying '-d' multiple times in case a user
> wants to disable more than one type of test. So we should set a bit
> in this variable instead of assigning it. We could also flip it
> around. If the user uses '-e' to enable test type then only type
> will be run, but then we'd probably want to allow multiple '-e'
> too so it doesn't gain anything.
> 

Sure. Added multiple disable option.

>> +
>>   unsigned long pmu_csr_read_num(int csr_num)
>>   {
>>   #define switchcase_csr_read(__csr_num, __val)		{\
>> @@ -608,19 +618,68 @@ static void test_vm_events_overflow(void *guest_code)
>>   	test_vm_destroy(vm);
>>   }
>>   
>> -int main(void)
>> +static void test_print_help(char *name)
>>   {
>> -	test_vm_basic_test(test_pmu_basic_sanity);
>> -	pr_info("SBI PMU basic test : PASS\n");
>> +	pr_info("Usage: %s [-h] [-d <test name>]\n", name);
>> +	pr_info("\t-d: Test to disable. Available tests are 'basic', 'events', 'snapshot', 'overflow'\n");
>> +	pr_info("\t-h: print this help screen\n");
>> +}
>>   
>> -	test_vm_events_test(test_pmu_events);
>> -	pr_info("SBI PMU event verification test : PASS\n");
>> +static bool parse_args(int argc, char *argv[])
>> +{
>> +	int opt;
>> +
>> +	while ((opt = getopt(argc, argv, "hd:")) != -1) {
>> +		switch (opt) {
>> +		case 'd':
>> +			if (!strncmp("basic", optarg, 5))
>> +				disabled_test_id = SBI_PMU_TEST_BASIC;
>> +			else if (!strncmp("events", optarg, 6))
>> +				disabled_test_id = SBI_PMU_TEST_EVENTS;
>> +			else if (!strncmp("snapshot", optarg, 8))
>> +				disabled_test_id = SBI_PMU_TEST_SNAPSHOT;
>> +			else if (!strncmp("overflow", optarg, 8))
>> +				disabled_test_id = SBI_PMU_TEST_OVERFLOW;
>> +			else
>> +				goto done;
>> +			break;
>> +		break;
> 
> Extra 'break'
> 

Fixed. Thanks for catching this.

>> +		case 'h':
>> +		default:
>> +			goto done;
>> +		}
>> +	}
>>   
>> -	test_vm_events_snapshot_test(test_pmu_events_snaphost);
>> -	pr_info("SBI PMU event verification with snapshot test : PASS\n");
>> +	return true;
>> +done:
>> +	test_print_help(argv[0]);
>> +	return false;
>> +}
>>   
>> -	test_vm_events_overflow(test_pmu_events_overflow);
>> -	pr_info("SBI PMU event verification with overflow test : PASS\n");
>> +int main(int argc, char *argv[])
>> +{
>> +	if (!parse_args(argc, argv))
>> +		exit(KSFT_SKIP);
>> +
>> +	if (disabled_test_id != SBI_PMU_TEST_BASIC) {
>> +		test_vm_basic_test(test_pmu_basic_sanity);
>> +		pr_info("SBI PMU basic test : PASS\n");
>> +	}
>> +
>> +	if (disabled_test_id != SBI_PMU_TEST_EVENTS) {
>> +		test_vm_events_test(test_pmu_events);
>> +		pr_info("SBI PMU event verification test : PASS\n");
>> +	}
>> +
>> +	if (disabled_test_id != SBI_PMU_TEST_SNAPSHOT) {
>> +		test_vm_events_snapshot_test(test_pmu_events_snaphost);
>> +		pr_info("SBI PMU event verification with snapshot test : PASS\n");
>> +	}
>> +
>> +	if (disabled_test_id != SBI_PMU_TEST_OVERFLOW) {
>> +		test_vm_events_overflow(test_pmu_events_overflow);
>> +		pr_info("SBI PMU event verification with overflow test : PASS\n");
>> +	}
>>   
>>   	return 0;
>>   }
>> -- 
>> 2.34.1
>>
> 
> Thanks,
> drew
> 
> _______________________________________________
> linux-riscv mailing list
> linux-riscv@lists.infradead.org
> http://lists.infradead.org/mailman/listinfo/linux-riscv


      reply	other threads:[~2024-04-16  8:49 UTC|newest]

Thread overview: 38+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2024-04-11  0:07 [PATCH v6 00/24] RISC-V SBI v2.0 PMU improvements and Perf sampling in KVM guest Atish Patra
2024-04-11  0:07 ` [PATCH v6 01/24] RISC-V: Fix the typo in Scountovf CSR name Atish Patra
2024-04-15 13:01   ` Andrew Jones
2024-04-11  0:07 ` [PATCH v6 02/24] RISC-V: Add FIRMWARE_READ_HI definition Atish Patra
2024-04-11  0:07 ` [PATCH v6 03/24] drivers/perf: riscv: Read upper bits of a firmware counter Atish Patra
2024-04-11  0:07 ` [PATCH v6 04/24] drivers/perf: riscv: Use BIT macro for shifting operations Atish Patra
2024-04-11  0:07 ` [PATCH v6 05/24] RISC-V: Add SBI PMU snapshot definitions Atish Patra
2024-04-11  0:07 ` [PATCH v6 06/24] RISC-V: KVM: Rename the SBI_STA_SHMEM_DISABLE to a generic name Atish Patra
2024-04-11  0:07 ` [PATCH v6 07/24] RISC-V: Use the minor version mask while computing sbi version Atish Patra
2024-04-15 13:06   ` Andrew Jones
2024-04-16  8:31     ` Atish Patra
2024-04-16  8:49       ` Andrew Jones
2024-04-11  0:07 ` [PATCH v6 08/24] drivers/perf: riscv: Implement SBI PMU snapshot function Atish Patra
2024-04-15 13:15   ` Andrew Jones
2024-04-16  8:33     ` Atish Patra
2024-04-11  0:07 ` [PATCH v6 09/24] drivers/perf: riscv: Fix counter mask iteration for RV32 Atish Patra
2024-04-11  0:07 ` [PATCH v6 10/24] RISC-V: KVM: Fix the initial sample period value Atish Patra
2024-04-11  0:07 ` [PATCH v6 11/24] RISC-V: KVM: No need to update the counter value during reset Atish Patra
2024-04-11  0:07 ` [PATCH v6 12/24] RISC-V: KVM: No need to exit to the user space if perf event failed Atish Patra
2024-04-11  0:07 ` [PATCH v6 13/24] RISC-V: KVM: Implement SBI PMU Snapshot feature Atish Patra
2024-04-15 13:19   ` Andrew Jones
2024-04-11  0:07 ` [PATCH v6 14/24] RISC-V: KVM: Add perf sampling support for guests Atish Patra
2024-04-15 13:23   ` Andrew Jones
2024-04-11  0:07 ` [PATCH v6 15/24] RISC-V: KVM: Support 64 bit firmware counters on RV32 Atish Patra
2024-04-11  0:07 ` [PATCH v6 16/24] RISC-V: KVM: Improve firmware counter read function Atish Patra
2024-04-11  0:07 ` [PATCH v6 17/24] KVM: riscv: selftests: Move sbi definitions to its own header file Atish Patra
2024-04-11  0:07 ` [PATCH v6 18/24] KVM: riscv: selftests: Add helper functions for extension checks Atish Patra
2024-04-11  0:07 ` [PATCH v6 19/24] KVM: riscv: selftests: Add Sscofpmf to get-reg-list test Atish Patra
2024-04-11  0:07 ` [PATCH v6 20/24] KVM: riscv: selftests: Add SBI PMU extension definitions Atish Patra
2024-04-11  0:07 ` [PATCH v6 21/24] KVM: riscv: selftests: Add SBI PMU selftest Atish Patra
2024-04-15 13:31   ` Andrew Jones
2024-04-11  0:07 ` [PATCH v6 22/24] KVM: riscv: selftests: Add a test for PMU snapshot functionality Atish Patra
2024-04-15 13:32   ` Andrew Jones
2024-04-11  0:07 ` [PATCH v6 23/24] KVM: riscv: selftests: Add a test for counter overflow Atish Patra
2024-04-15 13:36   ` Andrew Jones
2024-04-11  0:07 ` [PATCH v6 24/24] KVM: riscv: selftests: Add commandline option for SBI PMU test Atish Patra
2024-04-15 13:43   ` Andrew Jones
2024-04-16  8:49     ` Atish Patra [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=be9a80a3-64f1-4848-94a4-031a3ea797ad@rivosinc.com \
    --to=atishp@rivosinc.com \
    --cc=ajay.kaher@broadcom.com \
    --cc=ajones@ventanamicro.com \
    --cc=alexghiti@rivosinc.com \
    --cc=anup@brainfault.org \
    --cc=aou@eecs.berkeley.edu \
    --cc=atishp@atishpatra.org \
    --cc=conor.dooley@microchip.com \
    --cc=jgross@suse.com \
    --cc=kvm-riscv@lists.infradead.org \
    --cc=kvm@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-kselftest@vger.kernel.org \
    --cc=linux-riscv@lists.infradead.org \
    --cc=mark.rutland@arm.com \
    --cc=palmer@dabbelt.com \
    --cc=paul.walmsley@sifive.com \
    --cc=pbonzini@redhat.com \
    --cc=shuah@kernel.org \
    --cc=virtualization@lists.linux.dev \
    --cc=will@kernel.org \
    --cc=x86@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox