From: Goncalo Gomes <gomesgoncalo@gmail.com>
To: amit@kernel.org
Cc: arnd@arndb.de, gregkh@linuxfoundation.org,
virtualization@lists.linux.dev, linux-kernel@vger.kernel.org,
Goncalo Gomes <gomesgoncalo+linuxkernel@gmail.com>
Subject: [PATCH] virtio_console: clean up port name sysfs attribute
Date: Mon, 1 Jun 2026 15:25:08 +0100 [thread overview]
Message-ID: <20260601142508.3740862-1-gomesgoncalo+linuxkernel@gmail.com> (raw)
Fix issues flagged by checkpatch.pl:
Replace `sprintf` with `sysfs_emit` in the `name_show` callback.
sysfs.rst states that `show` methods should only use `sysfs_emit`
when formatting output for user space.
Rename `show_port_name` to `name_show` to follow the naming convention
for sysfs attribute callbacks, and replace the open-coded DEVICE_ATTR()
with DEVICE_ATTR_RO(name) which encodes both the mode and the expected
function name.
Also fix a missing blank line after a declaration in free_buf().
Signed-off-by: Goncalo Gomes <gomesgoncalo+linuxkernel@gmail.com>
---
drivers/char/virtio_console.c | 9 +++++----
1 file changed, 5 insertions(+), 4 deletions(-)
diff --git a/drivers/char/virtio_console.c b/drivers/char/virtio_console.c
index 9a33217c68d9..56bf0f1b8a00 100644
--- a/drivers/char/virtio_console.c
+++ b/drivers/char/virtio_console.c
@@ -352,6 +352,7 @@ static void free_buf(struct port_buffer *buf, bool can_sleep)
for (i = 0; i < buf->sgpages; i++) {
struct page *page = sg_page(&buf->sg[i]);
+
if (!page)
break;
put_page(page);
@@ -1237,17 +1238,17 @@ static int init_port_console(struct port *port)
return 0;
}
-static ssize_t show_port_name(struct device *dev,
- struct device_attribute *attr, char *buffer)
+static ssize_t name_show(struct device *dev,
+ struct device_attribute *attr, char *buffer)
{
struct port *port;
port = dev_get_drvdata(dev);
- return sprintf(buffer, "%s\n", port->name);
+ return sysfs_emit(buffer, "%s\n", port->name);
}
-static DEVICE_ATTR(name, S_IRUGO, show_port_name, NULL);
+static DEVICE_ATTR_RO(name);
static struct attribute *port_sysfs_entries[] = {
&dev_attr_name.attr,
--
2.54.0
next reply other threads:[~2026-06-01 14:25 UTC|newest]
Thread overview: 2+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-06-01 14:25 Goncalo Gomes [this message]
2026-06-01 14:30 ` [PATCH] virtio_console: clean up port name sysfs attribute Greg KH
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20260601142508.3740862-1-gomesgoncalo+linuxkernel@gmail.com \
--to=gomesgoncalo@gmail.com \
--cc=amit@kernel.org \
--cc=arnd@arndb.de \
--cc=gomesgoncalo+linuxkernel@gmail.com \
--cc=gregkh@linuxfoundation.org \
--cc=linux-kernel@vger.kernel.org \
--cc=virtualization@lists.linux.dev \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox