All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH v7 0/2] drm/xe/sysctrl: Add helper to query application status
@ 2026-08-14  9:53 Anoop, Vijay
  2026-08-14  9:53 ` [PATCH v7 1/2] " Anoop, Vijay
                   ` (4 more replies)
  0 siblings, 5 replies; 11+ messages in thread
From: Anoop, Vijay @ 2026-08-14  9:53 UTC (permalink / raw)
  To: intel-xe
  Cc: umesh.nerlige.ramappa, badal.nilawar, rodrigo.vivi,
	aravind.iddamsetty, riana.tauro, anshuman.gupta, matthew.d.roper,
	michael.j.ruhl, paul.e.luse, mohamed.mansoor.v, kam.nasim,
	anoop.c.vijay

From: Anoop Vijay <anoop.c.vijay@intel.com>

This series adds helpers to query the readiness state of individual
System Controller (sysctrl) firmware applications via the
get_app_status_by_id mailbox command.

xe_sysctrl_check_app_status() maps an xe_sysctrl_app_id to its firmware
application identifier and returns the reported application state:
not supported, communication failure, booted, or fully initialized.

Convenience wrappers are added on top of this helper to check
readiness of the Diagnostics (diag) and oCode firmware applications.
Initial consumers of these wrappers are added in the following series.
- https://patchwork.freedesktop.org/series/171728/
- https://patchwork.freedesktop.org/series/161655/

---
v2: (Badal)
- Return SysCtrl firmware application states instead of errno for
  application lifecycle conditions

v3: (Riana, Badal)
- Replace string-based app identifiers with enum xe_sysctrl_app_id
- Use get_app_status_by_id (opcode 0x05)
- Move mailbox definitions to xe_sysctrl_mailbox_types.h
- Return enum xe_sysctrl_fw_status consistently
- Map communication failures to COMM_FAILURE
- Add INITIALIZED state and status helpers
- Fix Diagnostics typo

v4: (Anshuman)
- Make xe_sysctrl_check_app_status() internal
- Remove unused app identifier

v5: (Anshuman)
- Rename OOBMSM status helper to use xe_sysctrl_* prefix
- Remove xe_is_diag_fw_ready() helper

v6: (Riana)
- Use xe_sysctrl_create_command() helper instead of manual FIELD_PREP
  header packing
- Rename xe_sysctrl_get_app_status_by_id_{req,resp} to shorter names
- Use hex constant for application ID
- Split oCode application readiness helper into its own patch
- Add xe_sysctrl_is_diag_fw_ready() helper; consumer lands in the RAS
  error-injection series

v7: (Umesh)
- Clarify diag/oCode firmware readiness helper comments for platforms
  without System Controller support
- Move XE_SYSCTRL_APP_RESP_* flags and enum xe_sysctrl_app_id out of
  xe_sysctrl_mailbox_types.h into xe_sysctrl.c
---

Anoop Vijay (2):
  drm/xe/sysctrl: Add helper to query application status
  drm/xe/sysctrl: Add helper to check oCode firmware readiness

 drivers/gpu/drm/xe/xe_sysctrl.c               | 103 ++++++++++++++++++
 drivers/gpu/drm/xe/xe_sysctrl.h               |   2 +
 drivers/gpu/drm/xe/xe_sysctrl_mailbox_types.h |  47 ++++++++
 3 files changed, 152 insertions(+)

-- 
2.43.0


^ permalink raw reply	[flat|nested] 11+ messages in thread

end of thread, other threads:[~2026-08-20 16:37 UTC | newest]

Thread overview: 11+ messages (download: mbox.gz follow: Atom feed
-- links below jump to the message on this page --
2026-08-14  9:53 [PATCH v7 0/2] drm/xe/sysctrl: Add helper to query application status Anoop, Vijay
2026-08-14  9:53 ` [PATCH v7 1/2] " Anoop, Vijay
2026-08-14 21:21   ` Umesh Nerlige Ramappa
2026-08-18 17:41     ` Anoop Vijay
2026-08-19 21:00       ` Umesh Nerlige Ramappa
2026-08-20 16:37         ` Umesh Nerlige Ramappa
2026-08-14  9:53 ` [PATCH v7 2/2] drm/xe/sysctrl: Add helper to check oCode firmware readiness Anoop, Vijay
2026-08-14 21:22   ` Umesh Nerlige Ramappa
2026-08-14 10:00 ` ✓ CI.KUnit: success for drm/xe/sysctrl: Add helper to query application status (rev7) Patchwork
2026-08-14 10:40 ` ✓ Xe.CI.BAT: " Patchwork
2026-08-14 12:10 ` ✓ Xe.CI.FULL: " Patchwork

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.