All of lore.kernel.org
 help / color / mirror / Atom feed
From: Pavel Roskin <proski@gnu.org>
To: Johannes Berg <johannes@sipsolutions.net>
Cc: Jouni Malinen <jouni.malinen@atheros.com>,
	"John W. Linville" <linville@tuxdriver.com>,
	linux-wireless@vger.kernel.org
Subject: Re: [PATCH v2] mac80211: Use a separate CCMP PN receive counter for management frames
Date: Sat, 12 Jun 2010 13:58:26 -0400	[thread overview]
Message-ID: <1276365506.2625.31.camel@ct> (raw)
In-Reply-To: <1276364839.7894.2.camel@jlt3.sipsolutions.net>

On Sat, 2010-06-12 at 19:47 +0200, Johannes Berg wrote:
> On Sat, 2010-06-12 at 13:34 -0400, Pavel Roskin wrote:
> > On Fri, 2010-06-11 at 10:27 -0700, Jouni Malinen wrote:
> > 
> > > -		for (i = 0; i < NUM_RX_DATA_QUEUES; i++) {
> > > +		for (i = 0; i < NUM_RX_DATA_QUEUES + 1; i++) {
> > 
> > Perhaps we could have a define for NUM_RX_DATA_QUEUES + 1, e.g.
> > NUM_RX_ALL_QUEUES
> 
> I kinda disagree. Yes, this is tricky code, but adding a define wouldn't
> make it clearer. In fact, it isn't really related to queues to start
> with, and ALL_QUEUES would just strengthen that mostly wrong notion.

That's certainly not my intention to strengthen wrong notions.

> I guess it really should be renamed to TIDs with the last two being
> special for non-QoS (so no TID) traffic + mgmt traffic. But then
> sequence numbers are allocated from the same counter (so there we just
> have 17 possibilities) while PNs have 18 counters...

Then let's replace QUEUE with TID in all RX defines.  Two special TIDs
could be used for non-QoS traffic and management frames when
appropriate.

-- 
Regards,
Pavel Roskin

      reply	other threads:[~2010-06-12 17:58 UTC|newest]

Thread overview: 6+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2010-06-11  2:46 [PATCH] mac80211: Use a separate CCMP PN receive counter for management frames Jouni Malinen
2010-06-11  9:04 ` Johannes Berg
2010-06-11 17:27 ` [PATCH v2] " Jouni Malinen
2010-06-12 17:34   ` Pavel Roskin
2010-06-12 17:47     ` Johannes Berg
2010-06-12 17:58       ` Pavel Roskin [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=1276365506.2625.31.camel@ct \
    --to=proski@gnu.org \
    --cc=johannes@sipsolutions.net \
    --cc=jouni.malinen@atheros.com \
    --cc=linux-wireless@vger.kernel.org \
    --cc=linville@tuxdriver.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.