All of lore.kernel.org
 help / color / mirror / Atom feed
From: Wolfgang Denk <wd@denx.de>
To: u-boot@lists.denx.de
Subject: [U-Boot] [PATCH 0/3] Makefile cleanup
Date: Mon, 11 Oct 2010 11:45:07 +0200	[thread overview]
Message-ID: <1286790310-5865-1-git-send-email-wd@denx.de> (raw)

The following series of patches prepares the ground to move the
remaining board configuration entries out of the Makefile into the
boards.cfg file, replacing multi-line scripts to fiddle with config.h
and config.mk files into simple, single-line entries.

[PATCH 1/3] Build: Add "board options" column to boards.cfg

    Build: Add "board options" column to boards.cfg

    There are some boards where it's currently not possible to detect all
    board information at runtime, therefore a new column was added to
    boards.cfg .

    This column can contain multiple options: a board configuration name,
    optionally followed by a colon (':') and a list of options, which are
    separated by comma (',').

    In case of simple options like '256M_U_BOOT', these expand to
    "#define CONFIG_MK_256M_U_BOOT 1" in config.h . In case of
    assignments like 'RAM=8192', these expand to "#define CONFIG_MK_RAM
    8192" in config.h .

    Example:

    	FOO:HAS_BAR,BAZ=64

    means:
    	- the name of the board config file is include/configs/FOO.h
    	- the generated file include/config.h will contain these
    	  lines:

    		#define CONFIG_HAS_BAR  1
    		#define CONFIG_BAZ  64

    Signed-off-by: Marek Vasut <marek.vasut@gmail.com>

    [wd at denx.de: edited commit message; added code to deal with an
    optional board configuration name]

    Signed-off-by: Wolfgang Denk <wd@denx.de>

 2 files changed, 31 insertions(+), 7 deletions(-)

[PATCH 2/3] mkconfig: change CONFIG_MK_ prefix into plain CONFIG_

    mkconfig: change CONFIG_MK_ prefix into plain CONFIG_

    When planning for more generalization and Makefile cleanup it became
    obvious that the introduction of a separate CONFIG_MK_ name space for
    config options that were set through scripting in the Makefile was
    not a good idea.

    Originally the idea was to provide a script-free approach to supply
    configuration options - there was no real need for a separate name
    space. But when we now convert the existing Makefile entries to make
    use of this approach, it would mean that we have to touch a large
    number of board config files and add #ifdef / #define sequences to
    "convert" from the CONFIG_MK_ to the CONFIG_ name space.

    It seems much cleaner to get rid of this somewhat arbitrary _MK
    string now for the few boards that actually use it.

    Signed-off-by: Wolfgang Denk <wd@denx.de>

 21 files changed, 54 insertions(+), 59 deletions(-)

[PATCH 3/3] Rename TEXT_BASE into CONFIG_SYS_TEXT_BASE

    Rename TEXT_BASE into CONFIG_SYS_TEXT_BASE

    The change is currently needed to be able to remove the board
    configuration scripting from the top level Makefile and replace it by
    a simple, table driven script.

    Moving this configuration setting into the "CONFIG_*" name space is
    also desirable because it is needed if we ever should move forward to
    a Kconfig driven configuration system.

    Signed-off-by: Wolfgang Denk <wd@denx.de>

 799 files changed, 1494 insertions(+), 1436 deletions(-)


Potential testers can find these (and some more experimental) commits
in the "Makefile-cleanup" branch in the u-boot-testing repository.


Best regards,

Wolfgang Denk

-- 
DENX Software Engineering GmbH,     MD: Wolfgang Denk & Detlev Zundel
HRB 165235 Munich, Office: Kirchenstr.5, D-82194 Groebenzell, Germany
Phone: (+49)-8142-66989-10 Fax: (+49)-8142-66989-80 Email: wd at denx.de
Brontosaurus Principle: Organizations  can  grow  faster  than  their
brains  can manage them in relation to their environment and to their
own physiology: when this occurs, they are an endangered species.
                                                - Thomas K. Connellan

             reply	other threads:[~2010-10-11  9:45 UTC|newest]

Thread overview: 23+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2010-10-11  9:45 Wolfgang Denk [this message]
2010-10-11  9:45 ` [U-Boot] [PATCH 1/3] Build: Add "board options" column to boards.cfg Wolfgang Denk
2010-10-11  9:45 ` [U-Boot] [PATCH 2/3] mkconfig: change CONFIG_MK_ prefix into plain CONFIG_ Wolfgang Denk
2010-10-11 19:17   ` Mike Frysinger
2010-10-12 19:46     ` Wolfgang Denk
2010-10-11  9:45 ` [U-Boot] [PATCH 3/3] Rename TEXT_BASE into CONFIG_SYS_TEXT_BASE Wolfgang Denk
2010-10-16 23:57 ` [U-Boot] [PATCH v2 0/5] Makefile cleanup Wolfgang Denk
2010-10-16 23:57 ` [U-Boot] [PATCH v2 1/5] Build: Add "board options" column to boards.cfg Wolfgang Denk
2010-10-17  0:12   ` Marek Vasut
2010-10-17  7:16     ` Wolfgang Denk
2010-10-17  0:13   ` Reinhard Meyer
2010-10-17  7:33     ` Wolfgang Denk
2010-10-18 20:00   ` Wolfgang Denk
2010-10-16 23:57 ` [U-Boot] [PATCH v2 2/5] mkconfig: change CONFIG_MK_ prefix into plain CONFIG_ Wolfgang Denk
2010-10-17  6:24   ` Mike Frysinger
2010-10-18 20:02   ` Wolfgang Denk
2010-10-16 23:57 ` [U-Boot] [PATCH v2 3/5] Rename TEXT_BASE into CONFIG_SYS_TEXT_BASE Wolfgang Denk
2010-10-18 20:08   ` Wolfgang Denk
2010-10-16 23:57 ` [U-Boot] [PATCH v2 4/5] autoconfig.mk: avoid apostophes around hex values Wolfgang Denk
2010-10-17  6:23   ` Mike Frysinger
2010-10-18 20:09   ` Wolfgang Denk
2010-10-16 23:57 ` [U-Boot] [PATCH v2 5/5] Makefile: move all Power Architecture boards into boards.cfg Wolfgang Denk
2010-10-18 20:12   ` Wolfgang Denk

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=1286790310-5865-1-git-send-email-wd@denx.de \
    --to=wd@denx.de \
    --cc=u-boot@lists.denx.de \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.