All of lore.kernel.org
 help / color / mirror / Atom feed
From: Wolfgang Denk <wd@denx.de>
To: u-boot@lists.denx.de
Subject: [U-Boot] [PATCH v2 2/5] mkconfig: change CONFIG_MK_ prefix into plain CONFIG_
Date: Mon, 18 Oct 2010 22:02:02 +0200	[thread overview]
Message-ID: <20101018200202.EAF43136320@gemini.denx.de> (raw)
In-Reply-To: <1287273462-14872-3-git-send-email-wd@denx.de>

In message <1287273462-14872-3-git-send-email-wd@denx.de> I wrote:
> When planning for more generalization and Makefile cleanup it became
> obvious that the introduction of a separate CONFIG_MK_ name space for
> config options that were set through scripting in the Makefile was
> not a good idea.
> 
> Originally the idea was to provide a script-free approach to supply
> configuration options - there was no real need for a separate name
> space. But when we now convert the existing Makefile entries to make
> use of this approach, it would mean that we have to touch a large
> number of board config files and add #ifdef / #define sequences to
> "convert" from the CONFIG_MK_ to the CONFIG_ name space.
> 
> It seems much cleaner to get rid of this somewhat arbitrary _MK
> string now for the few boards that actually use it.
> 
> Signed-off-by: Wolfgang Denk <wd@denx.de>
> ---
>  board/bf527-ezkit/video.c             |   10 +++++-----
>  board/freescale/mpc8315erdb/config.mk |    2 +-
>  board/freescale/mpc8536ds/config.mk   |    6 +++---
>  board/freescale/mpc8569mds/config.mk  |    2 +-
>  board/freescale/p1_p2_rdb/config.mk   |    6 +++---
>  include/configs/MPC8315ERDB.h         |    2 +-
>  include/configs/MPC8536DS.h           |    8 ++++----
>  include/configs/MPC8569MDS.h          |    4 ++--
>  include/configs/MPC8572DS.h           |    2 +-
>  include/configs/P1_P2_RDB.h           |   14 +++++++-------
>  include/configs/P2020DS.h             |    4 ++--
>  include/configs/SBC8540.h             |    2 +-
>  include/configs/astro_mcf5373l.h      |    4 ++--
>  include/configs/bf527-ezkit.h         |    2 +-
>  include/configs/edb93xx.h             |   16 ++++++++--------
>  include/configs/sbc8349.h             |    8 ++------
>  include/configs/sbc8548.h             |    9 ++++-----
>  include/configs/sbc8560.h             |    2 +-
>  include/configs/spear3xx.h            |    6 +++---
>  include/configs/vme8349.h             |    2 +-
>  mkconfig                              |    2 +-
>  21 files changed, 54 insertions(+), 59 deletions(-)

Applied.

Best regards,

Wolfgang Denk

-- 
DENX Software Engineering GmbH,     MD: Wolfgang Denk & Detlev Zundel
HRB 165235 Munich, Office: Kirchenstr.5, D-82194 Groebenzell, Germany
Phone: (+49)-8142-66989-10 Fax: (+49)-8142-66989-80 Email: wd at denx.de
"In the long run, every program becomes rococo, and then rubble."
- Alan Perlis

  parent reply	other threads:[~2010-10-18 20:02 UTC|newest]

Thread overview: 23+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2010-10-11  9:45 [U-Boot] [PATCH 0/3] Makefile cleanup Wolfgang Denk
2010-10-11  9:45 ` [U-Boot] [PATCH 1/3] Build: Add "board options" column to boards.cfg Wolfgang Denk
2010-10-11  9:45 ` [U-Boot] [PATCH 2/3] mkconfig: change CONFIG_MK_ prefix into plain CONFIG_ Wolfgang Denk
2010-10-11 19:17   ` Mike Frysinger
2010-10-12 19:46     ` Wolfgang Denk
2010-10-11  9:45 ` [U-Boot] [PATCH 3/3] Rename TEXT_BASE into CONFIG_SYS_TEXT_BASE Wolfgang Denk
2010-10-16 23:57 ` [U-Boot] [PATCH v2 0/5] Makefile cleanup Wolfgang Denk
2010-10-16 23:57 ` [U-Boot] [PATCH v2 1/5] Build: Add "board options" column to boards.cfg Wolfgang Denk
2010-10-17  0:12   ` Marek Vasut
2010-10-17  7:16     ` Wolfgang Denk
2010-10-17  0:13   ` Reinhard Meyer
2010-10-17  7:33     ` Wolfgang Denk
2010-10-18 20:00   ` Wolfgang Denk
2010-10-16 23:57 ` [U-Boot] [PATCH v2 2/5] mkconfig: change CONFIG_MK_ prefix into plain CONFIG_ Wolfgang Denk
2010-10-17  6:24   ` Mike Frysinger
2010-10-18 20:02   ` Wolfgang Denk [this message]
2010-10-16 23:57 ` [U-Boot] [PATCH v2 3/5] Rename TEXT_BASE into CONFIG_SYS_TEXT_BASE Wolfgang Denk
2010-10-18 20:08   ` Wolfgang Denk
2010-10-16 23:57 ` [U-Boot] [PATCH v2 4/5] autoconfig.mk: avoid apostophes around hex values Wolfgang Denk
2010-10-17  6:23   ` Mike Frysinger
2010-10-18 20:09   ` Wolfgang Denk
2010-10-16 23:57 ` [U-Boot] [PATCH v2 5/5] Makefile: move all Power Architecture boards into boards.cfg Wolfgang Denk
2010-10-18 20:12   ` Wolfgang Denk

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20101018200202.EAF43136320@gemini.denx.de \
    --to=wd@denx.de \
    --cc=u-boot@lists.denx.de \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.