All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH 00/25] update for 3.1
@ 2011-06-18 15:34 Wey-Yi Guy
  2011-06-18 15:34 ` [PATCH 01/25] iwlagn: Remove un-necessary indirect call Wey-Yi Guy
                   ` (24 more replies)
  0 siblings, 25 replies; 30+ messages in thread
From: Wey-Yi Guy @ 2011-06-18 15:34 UTC (permalink / raw)
  To: linville; +Cc: linux-wireless, Wey-Yi Guy

We introduce the PCI bus encapsulation layer, which is the fundation to
support different bus interface.
We also add few more module parameters to control power management

Emmanuel Grumbach (15):
  iwlagn: don't disable interrupts after the NIC has been reset
  iwlagn: add a iwl_pci.[ch] files that will contain all PCI specific
    code
  iwlagn: remove uneeded include to pci.h and dma_mapping.h from a few
    files
  iwlagn: introduce iwl_bus and iwl_bus_ops
  iwlagn: add get_dev to iwl_bus_ops
  iwlagn: move PCI related operations from probe and remove to PCI
    layer
  iwlagn: don't use the PCI wrappers for DMA operation
  iwlagn: add a method to get the HW ID description as a string to
    iwl_bus_ops
  iwlagn: don't read the PCI_REVISION_ID from iwl-agn.c
  iwlagn: add a get_irq method to iwl_bus_ops and use it
  iwlagn: finally kill the pointer to pci_dev from iwl-dev.h
  iwlagn: waterfall the bus level if prepare card failed
  iwlagn: fix misplaced bracket
  iwlagn: warn about nested SYNC commands
  iwlagn: store the irq number to iwl_bus just like dev

Wey-Yi Guy (10):
  iwlagn: Remove un-necessary indirect call
  iwlagn: add PAN to tx flush
  iwlagn: Support flush queues for specified interface
  iwlagn: move PCI power related functions to the PCI layer
  iwlagn: add power_save module parameter
  iwlagn: Add power_level module parameter
  iwlagn: add offset define for subsystem id
  iwlagn: code alignment
  iwlagn: merge duplicate code into single function
  iwlagn: remove incorrect define

these patches are also available from wireless-next-2.6 branch on
 git://git.kernel.org/pub/scm/linux/kernel/git/iwlwifi/iwlwifi-2.6.git

 drivers/net/wireless/iwlwifi/Makefile       |    1 +
 drivers/net/wireless/iwlwifi/iwl-1000.c     |    4 -
 drivers/net/wireless/iwlwifi/iwl-2000.c     |   20 +-
 drivers/net/wireless/iwlwifi/iwl-5000.c     |   23 +-
 drivers/net/wireless/iwlwifi/iwl-6000.c     |   22 +-
 drivers/net/wireless/iwlwifi/iwl-agn-hw.h   |    7 -
 drivers/net/wireless/iwlwifi/iwl-agn-ict.c  |    4 +-
 drivers/net/wireless/iwlwifi/iwl-agn-lib.c  |   35 ++-
 drivers/net/wireless/iwlwifi/iwl-agn-tx.c   |   30 +-
 drivers/net/wireless/iwlwifi/iwl-agn.c      |  441 ++++-----------------
 drivers/net/wireless/iwlwifi/iwl-agn.h      |    6 +-
 drivers/net/wireless/iwlwifi/iwl-commands.h |   23 +-
 drivers/net/wireless/iwlwifi/iwl-core.c     |   54 +---
 drivers/net/wireless/iwlwifi/iwl-core.h     |   37 +--
 drivers/net/wireless/iwlwifi/iwl-debug.h    |    8 +-
 drivers/net/wireless/iwlwifi/iwl-debugfs.c  |    5 +-
 drivers/net/wireless/iwlwifi/iwl-dev.h      |   48 ++-
 drivers/net/wireless/iwlwifi/iwl-eeprom.c   |   25 ++
 drivers/net/wireless/iwlwifi/iwl-eeprom.h   |    3 +-
 drivers/net/wireless/iwlwifi/iwl-hcmd.c     |   11 +-
 drivers/net/wireless/iwlwifi/iwl-io.h       |    6 +-
 drivers/net/wireless/iwlwifi/iwl-led.c      |    5 +-
 drivers/net/wireless/iwlwifi/iwl-pci.c      |  571 +++++++++++++++++++++++++++
 drivers/net/wireless/iwlwifi/iwl-pci.h      |   69 ++++
 drivers/net/wireless/iwlwifi/iwl-power.c    |   22 +-
 drivers/net/wireless/iwlwifi/iwl-power.h    |    2 +-
 drivers/net/wireless/iwlwifi/iwl-rx.c       |    4 +-
 drivers/net/wireless/iwlwifi/iwl-sv-open.c  |    4 +-
 drivers/net/wireless/iwlwifi/iwl-tx.c       |   33 +-
 29 files changed, 927 insertions(+), 596 deletions(-)
 create mode 100644 drivers/net/wireless/iwlwifi/iwl-pci.c
 create mode 100644 drivers/net/wireless/iwlwifi/iwl-pci.h


^ permalink raw reply	[flat|nested] 30+ messages in thread

end of thread, other threads:[~2011-06-27  8:44 UTC | newest]

Thread overview: 30+ messages (download: mbox.gz follow: Atom feed
-- links below jump to the message on this page --
2011-06-18 15:34 [PATCH 00/25] update for 3.1 Wey-Yi Guy
2011-06-18 15:34 ` [PATCH 01/25] iwlagn: Remove un-necessary indirect call Wey-Yi Guy
2011-06-18 15:34 ` [PATCH 02/25] iwlagn: add PAN to tx flush Wey-Yi Guy
2011-06-18 15:34 ` [PATCH 03/25] iwlagn: Support flush queues for specified interface Wey-Yi Guy
2011-06-18 15:34 ` [PATCH 04/25] iwlagn: don't disable interrupts after the NIC has been reset Wey-Yi Guy
2011-06-18 15:34 ` [PATCH 05/25] iwlagn: add a iwl_pci.[ch] files that will contain all PCI specific code Wey-Yi Guy
2011-06-18 15:34 ` [PATCH 06/25] iwlagn: remove uneeded include to pci.h and dma_mapping.h from a few files Wey-Yi Guy
2011-06-18 15:34 ` [PATCH 07/25] iwlagn: introduce iwl_bus and iwl_bus_ops Wey-Yi Guy
2011-06-18 15:34 ` [PATCH 08/25] iwlagn: add get_dev to iwl_bus_ops Wey-Yi Guy
2011-06-18 15:34 ` [PATCH 09/25] iwlagn: move PCI related operations from probe and remove to PCI layer Wey-Yi Guy
2011-06-18 15:34 ` [PATCH 10/25] iwlagn: don't use the PCI wrappers for DMA operation Wey-Yi Guy
2011-06-18 15:34 ` [PATCH 11/25] iwlagn: move PCI power related functions to the PCI layer Wey-Yi Guy
2011-06-18 15:34 ` [PATCH 12/25] iwlagn: add a method to get the HW ID description as a string to iwl_bus_ops Wey-Yi Guy
2011-06-18 15:34 ` [PATCH 13/25] iwlagn: don't read the PCI_REVISION_ID from iwl-agn.c Wey-Yi Guy
2011-06-18 15:34 ` [PATCH 14/25] iwlagn: add a get_irq method to iwl_bus_ops and use it Wey-Yi Guy
2011-06-18 15:34 ` [PATCH 15/25] iwlagn: finally kill the pointer to pci_dev from iwl-dev.h Wey-Yi Guy
2011-06-18 15:34 ` [PATCH 16/25] iwlagn: waterfall the bus level if prepare card failed Wey-Yi Guy
2011-06-18 15:34 ` [PATCH 17/25] iwlagn: fix misplaced bracket Wey-Yi Guy
2011-06-18 15:34 ` [PATCH 18/25] iwlagn: warn about nested SYNC commands Wey-Yi Guy
2011-06-27  8:40   ` Johannes Berg
2011-06-27  8:42     ` Johannes Berg
2011-06-27  8:43       ` Grumbach, Emmanuel
2011-06-27  8:43     ` Grumbach, Emmanuel
2011-06-18 15:34 ` [PATCH 19/25] iwlagn: store the irq number to iwl_bus just like dev Wey-Yi Guy
2011-06-18 15:34 ` [PATCH 20/25] iwlagn: add power_save module parameter Wey-Yi Guy
2011-06-18 15:34 ` [PATCH 21/25] iwlagn: Add power_level " Wey-Yi Guy
2011-06-18 15:34 ` [PATCH 22/25] iwlagn: add offset define for subsystem id Wey-Yi Guy
2011-06-18 15:34 ` [PATCH 23/25] iwlagn: code alignment Wey-Yi Guy
2011-06-18 15:34 ` [PATCH 24/25] iwlagn: merge duplicate code into single function Wey-Yi Guy
2011-06-18 15:34 ` [PATCH 25/25] iwlagn: remove incorrect define Wey-Yi Guy

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.