From: Andrew Morton <akpm@linux-foundation.org>
To: Minchan Kim <minchan.kim@gmail.com>
Cc: minchan.kim@gmail.com, linux-kernel@vger.kernel.org,
linux-mm@kvack.org, mel@csn.ul.ie,
kosaki.motohiro@jp.fujitsu.com, riel@redhat.com,
hannes@cmpxchg.org, y-goto@jp.fujitsu.com
Subject: Re: [PATCH 1/3] clean up functions related to pages_min V2
Date: Wed, 27 May 2009 13:38:45 -0700 [thread overview]
Message-ID: <20090527133845.a26df9cb.akpm@linux-foundation.org> (raw)
In-Reply-To: <20090527202955.2260a232.minchan.kim@barrios-desktop>
On Wed, 27 May 2009 20:29:55 +0900
Minchan Kim <minchan.kim@gmail.com> wrote:
> This patch change names of two functions. so It doesn't affect behavior.
> Now, setup_per_zone_pages_min changes low, high of zone as well as min.
> So, a better name might have been setup_per_zone_wmarks.That's because
> Mel changed zone->pages_[hig/low/min] to zone->watermark array.(434b5394fd85c212619306cda6bf087be737b35a)
>
When quoting changeset IDs, please do it in the form
0594ad1a66381076f0fa06f5605ea5023f600586 ("mfd/pcf50633-gpio.c: add MODULE_LICENSE")
There's a good reason for this, but I forget what it is. Perhaps so
that the same commit can be located if it has a different hash? I
expect that commits get a different hash when backported into -stable,
for example.
I spend my life making changes like that to changelogs, but when I went
to fix up your 434b5394fd85c212619306cda6bf087be737b35a, I was unable
to locate any commit which has that hash.
<searches for a while>
Ah, you're referring to a -mmotm patch. The hashes in -mmotm aren't
useful because the tree gets regenerated each time. So let's refer to
that patch via just its title, "page allocator: replace the
watermark-related union in struct zone with a watermark[] array".
WARNING: multiple messages have this Message-ID (diff)
From: Andrew Morton <akpm@linux-foundation.org>
To: Minchan Kim <minchan.kim@gmail.com>
Cc: linux-kernel@vger.kernel.org, linux-mm@kvack.org, mel@csn.ul.ie,
kosaki.motohiro@jp.fujitsu.com, riel@redhat.com,
hannes@cmpxchg.org, y-goto@jp.fujitsu.com
Subject: Re: [PATCH 1/3] clean up functions related to pages_min V2
Date: Wed, 27 May 2009 13:38:45 -0700 [thread overview]
Message-ID: <20090527133845.a26df9cb.akpm@linux-foundation.org> (raw)
In-Reply-To: <20090527202955.2260a232.minchan.kim@barrios-desktop>
On Wed, 27 May 2009 20:29:55 +0900
Minchan Kim <minchan.kim@gmail.com> wrote:
> This patch change names of two functions. so It doesn't affect behavior.
> Now, setup_per_zone_pages_min changes low, high of zone as well as min.
> So, a better name might have been setup_per_zone_wmarks.That's because
> Mel changed zone->pages_[hig/low/min] to zone->watermark array.(434b5394fd85c212619306cda6bf087be737b35a)
>
When quoting changeset IDs, please do it in the form
0594ad1a66381076f0fa06f5605ea5023f600586 ("mfd/pcf50633-gpio.c: add MODULE_LICENSE")
There's a good reason for this, but I forget what it is. Perhaps so
that the same commit can be located if it has a different hash? I
expect that commits get a different hash when backported into -stable,
for example.
I spend my life making changes like that to changelogs, but when I went
to fix up your 434b5394fd85c212619306cda6bf087be737b35a, I was unable
to locate any commit which has that hash.
<searches for a while>
Ah, you're referring to a -mmotm patch. The hashes in -mmotm aren't
useful because the tree gets regenerated each time. So let's refer to
that patch via just its title, "page allocator: replace the
watermark-related union in struct zone with a watermark[] array".
--
To unsubscribe, send a message with 'unsubscribe linux-mm' in
the body to majordomo@kvack.org. For more info on Linux MM,
see: http://www.linux-mm.org/ .
Don't email: <a href=mailto:"dont@kvack.org"> email@kvack.org </a>
next prev parent reply other threads:[~2009-05-27 20:40 UTC|newest]
Thread overview: 10+ messages / expand[flat|nested] mbox.gz Atom feed top
2009-05-21 0:23 [PATCH 1/3] clean up functions related to pages_min V2 Minchan Kim
2009-05-21 0:23 ` Minchan Kim
2009-05-27 5:25 ` Andrew Morton
2009-05-27 5:25 ` Andrew Morton
2009-05-27 6:06 ` Minchan Kim
2009-05-27 6:06 ` Minchan Kim
2009-05-27 11:29 ` Minchan Kim
2009-05-27 11:29 ` Minchan Kim
2009-05-27 20:38 ` Andrew Morton [this message]
2009-05-27 20:38 ` Andrew Morton
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20090527133845.a26df9cb.akpm@linux-foundation.org \
--to=akpm@linux-foundation.org \
--cc=hannes@cmpxchg.org \
--cc=kosaki.motohiro@jp.fujitsu.com \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-mm@kvack.org \
--cc=mel@csn.ul.ie \
--cc=minchan.kim@gmail.com \
--cc=riel@redhat.com \
--cc=y-goto@jp.fujitsu.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.