All of lore.kernel.org
 help / color / mirror / Atom feed
From: Dan Carpenter <dan.carpenter@oracle.com>
To: Mirsal Ennaime <mirsal@mirsal.fr>
Cc: "Greg Kroah-Hartman" <greg@kroah.com>,
	devel@driverdev.osuosl.org,
	"Brian Swetland" <swetland@google.com>,
	kernel-janitors@vger.kernel.org, linux-kernel@vger.kernel.org,
	"Arve Hjønnevåg" <arve@android.com>
Subject: Re: [PATCH 4/4] drivers: android: binder: Fix compiler warning
Date: Mon, 11 Mar 2013 21:44:47 +0000	[thread overview]
Message-ID: <20130311214447.GB9138@mwanda> (raw)
In-Reply-To: <1363030315-10229-5-git-send-email-mirsal@mirsal.fr>

On Mon, Mar 11, 2013 at 08:31:55PM +0100, Mirsal Ennaime wrote:
> Fix an instance of -Wdeclaration-after-statement
> 

That's a compiler warning you introduced yourself on the previous
patch.  Obviously, we're not going to accept the original patch. :P

> Signed-off-by: Mirsal Ennaime <mirsal@mirsal.fr>
> ---
>  drivers/staging/android/binder.c |    3 ++-
>  1 file changed, 2 insertions(+), 1 deletion(-)
> 
> diff --git a/drivers/staging/android/binder.c b/drivers/staging/android/binder.c
> index 18a83e2..c833b53 100644
> --- a/drivers/staging/android/binder.c
> +++ b/drivers/staging/android/binder.c
> @@ -3001,11 +3001,12 @@ static void binder_deferred_release(struct binder_proc *proc)
>  	page_count = 0;
>  	if (proc->pages) {
>  		int i;
> +		void *page_addr;

Put a blank line after the variable declaration section.  Really
the "int i" should go at the start of the function and the page_addr
should go inside the for loop.

regards,
dan carpenter



WARNING: multiple messages have this Message-ID (diff)
From: Dan Carpenter <dan.carpenter@oracle.com>
To: Mirsal Ennaime <mirsal@mirsal.fr>
Cc: "Greg Kroah-Hartman" <greg@kroah.com>,
	devel@driverdev.osuosl.org,
	"Brian Swetland" <swetland@google.com>,
	kernel-janitors@vger.kernel.org, linux-kernel@vger.kernel.org,
	"Arve Hjønnevåg" <arve@android.com>
Subject: Re: [PATCH 4/4] drivers: android: binder: Fix compiler warning
Date: Tue, 12 Mar 2013 00:44:47 +0300	[thread overview]
Message-ID: <20130311214447.GB9138@mwanda> (raw)
In-Reply-To: <1363030315-10229-5-git-send-email-mirsal@mirsal.fr>

On Mon, Mar 11, 2013 at 08:31:55PM +0100, Mirsal Ennaime wrote:
> Fix an instance of -Wdeclaration-after-statement
> 

That's a compiler warning you introduced yourself on the previous
patch.  Obviously, we're not going to accept the original patch. :P

> Signed-off-by: Mirsal Ennaime <mirsal@mirsal.fr>
> ---
>  drivers/staging/android/binder.c |    3 ++-
>  1 file changed, 2 insertions(+), 1 deletion(-)
> 
> diff --git a/drivers/staging/android/binder.c b/drivers/staging/android/binder.c
> index 18a83e2..c833b53 100644
> --- a/drivers/staging/android/binder.c
> +++ b/drivers/staging/android/binder.c
> @@ -3001,11 +3001,12 @@ static void binder_deferred_release(struct binder_proc *proc)
>  	page_count = 0;
>  	if (proc->pages) {
>  		int i;
> +		void *page_addr;

Put a blank line after the variable declaration section.  Really
the "int i" should go at the start of the function and the page_addr
should go inside the for loop.

regards,
dan carpenter



  reply	other threads:[~2013-03-11 21:44 UTC|newest]

Thread overview: 54+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2013-03-11 19:31 [PATCH 0/4] Cosmetic changes to the android binder proc release code Mirsal Ennaime
2013-03-11 19:31 ` Mirsal Ennaime
2013-03-11 19:31 ` [PATCH 1/4] drivers: android: binder: Move the node release code to a separate function Mirsal Ennaime
2013-03-11 19:31   ` Mirsal Ennaime
2013-03-11 21:46   ` Dan Carpenter
2013-03-11 21:46     ` Dan Carpenter
2013-03-11 19:31 ` [PATCH 2/4] drivers: android: binder: Fix code style Mirsal Ennaime
2013-03-11 19:31   ` Mirsal Ennaime
2013-03-11 21:54   ` Dan Carpenter
2013-03-11 21:54     ` Dan Carpenter
2013-03-11 22:27     ` mirsal
2013-03-11 22:27       ` mirsal
2013-03-11 19:31 ` [PATCH 3/4] drivers: android: binder: Remove excessive indentation Mirsal Ennaime
2013-03-11 19:31   ` Mirsal Ennaime
2013-03-11 20:25   ` Joe Perches
2013-03-11 20:25     ` Joe Perches
2013-03-11 20:51     ` mirsal
2013-03-11 20:51       ` mirsal
2013-03-11 19:31 ` [PATCH 4/4] drivers: android: binder: Fix compiler warning Mirsal Ennaime
2013-03-11 19:31   ` Mirsal Ennaime
2013-03-11 21:44   ` Dan Carpenter [this message]
2013-03-11 21:44     ` Dan Carpenter
2013-03-11 23:26 ` [PATCH v2 0/3] Cosmetic changes to the android binder proc release code Mirsal Ennaime
2013-03-11 23:26   ` Mirsal Ennaime
2013-03-11 23:26   ` [PATCH v2 1/3] drivers: android: binder: Move the node release code to a separate function Mirsal Ennaime
2013-03-11 23:26     ` Mirsal Ennaime
2013-03-11 23:26   ` [PATCH v2 2/3] drivers: android: binder: Fix code style Mirsal Ennaime
2013-03-11 23:26     ` Mirsal Ennaime
2013-03-11 23:57     ` Arve Hjønnevåg
2013-03-11 23:57       ` Arve Hjønnevåg
2013-03-12  8:52       ` mirsal
2013-03-12  8:52         ` mirsal
2013-03-11 23:26   ` [PATCH v2 3/3] drivers: android: binder: Remove excessive indentation Mirsal Ennaime
2013-03-11 23:26     ` Mirsal Ennaime
2013-03-12  0:04     ` Joe Perches
2013-03-12  0:04       ` Joe Perches
2013-03-12  0:21       ` Arve Hjønnevåg
2013-03-12  0:21         ` Arve Hjønnevåg
2013-03-12  0:29         ` Joe Perches
2013-03-12  0:29           ` Joe Perches
2013-03-12  9:52       ` mirsal
2013-03-12  9:52         ` mirsal
2013-03-12 10:41   ` [PATCH v3 0/4] Cosmetic changes to the android binder proc release code Mirsal Ennaime
2013-03-12 10:41     ` Mirsal Ennaime
2013-03-12 10:41     ` [PATCH v3 1/4] drivers: android: binder: Move the node release code to a separate function Mirsal Ennaime
2013-03-12 10:41       ` Mirsal Ennaime
2013-03-12 10:42     ` [PATCH v3 2/4] drivers: android: binder: Fix code style in binder_deferred_release Mirsal Ennaime
2013-03-12 10:42       ` Mirsal Ennaime
2013-03-12 10:42     ` [PATCH v3 3/4] drivers: android: binder: Remove excessive indentation Mirsal Ennaime
2013-03-12 10:42       ` Mirsal Ennaime
2013-03-12 10:42     ` [PATCH v3 4/4] drivers: android: binder: Use __func__ in debug messages Mirsal Ennaime
2013-03-12 10:42       ` Mirsal Ennaime
2013-03-12 10:56     ` [PATCH v3 0/4] Cosmetic changes to the android binder proc release code Dan Carpenter
2013-03-12 10:56       ` Dan Carpenter

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20130311214447.GB9138@mwanda \
    --to=dan.carpenter@oracle.com \
    --cc=arve@android.com \
    --cc=devel@driverdev.osuosl.org \
    --cc=greg@kroah.com \
    --cc=kernel-janitors@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mirsal@mirsal.fr \
    --cc=swetland@google.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.