All of lore.kernel.org
 help / color / mirror / Atom feed
* Recipe naming
@ 2013-08-03 10:52 Paul Barker
  2013-08-03 11:07 ` Paul Barker
  0 siblings, 1 reply; 4+ messages in thread
From: Paul Barker @ 2013-08-03 10:52 UTC (permalink / raw)
  To: Yocto discussion list

I've looked at the OE versionning policy
(http://www.openembedded.org/wiki/Versioning_Policy) and I can't quite
figure out the correct name for my recipe from that.

I have a testing branch for opkg which I would like to put a recipe
for in a meta-opkg layer to simplify testing. The testing branch will
be fetched from git. Should I call this:

    "opkg_testing.bb"
    set PREFERRED_VERSION_opkg = "testing" to use

or

    "opkg-testing_git.bb", PROVIDES opkg
    set PREFERRED_PROVIDER_opkg = "opkg-testing" to use

I'd lean towards the former as it is a version of opkg not a separate fork.

Is there a convention for this or should I just make my own decision?

-- 
Paul Barker

Email: paul@paulbarker.me.uk
http://www.paulbarker.me.uk


^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: Recipe naming
  2013-08-03 10:52 Recipe naming Paul Barker
@ 2013-08-03 11:07 ` Paul Barker
  2013-08-03 11:17   ` Martin Jansa
  0 siblings, 1 reply; 4+ messages in thread
From: Paul Barker @ 2013-08-03 11:07 UTC (permalink / raw)
  To: Yocto discussion list

On 3 August 2013 11:52, Paul Barker <paul@paulbarker.me.uk> wrote:
> Should I call this:
>
>     "opkg_testing.bb"
>     set PREFERRED_VERSION_opkg = "testing" to use
>

Martin has just commented elsewhere that having this recipe in a meta-opkg layer
will always override the recipe in oe-core:

> You probably know about this already, but for other possible users of this
> layer:
>
> bitbake will always select "devel" version from meta-opkg layer if it has
> higher BBFILE_PRIORITY even if you put negative DEFAULT_PREFERRENCE into
> "devel" recipes. Only if you put lower-than-oe-core BBFILE_PRIORITY in
> layer.conf then it will force user to select "devel" version by
> PREFERRED_VERSION.

So maybe opkg-testing_{version} would work better.

-- 
Paul Barker

Email: paul@paulbarker.me.uk
http://www.paulbarker.me.uk


^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: Recipe naming
  2013-08-03 11:07 ` Paul Barker
@ 2013-08-03 11:17   ` Martin Jansa
  2013-08-03 11:43     ` Paul Barker
  0 siblings, 1 reply; 4+ messages in thread
From: Martin Jansa @ 2013-08-03 11:17 UTC (permalink / raw)
  To: Paul Barker; +Cc: Yocto discussion list

[-- Attachment #1: Type: text/plain, Size: 1417 bytes --]

On Sat, Aug 03, 2013 at 12:07:41PM +0100, Paul Barker wrote:
> On 3 August 2013 11:52, Paul Barker <paul@paulbarker.me.uk> wrote:
> > Should I call this:
> >
> >     "opkg_testing.bb"
> >     set PREFERRED_VERSION_opkg = "testing" to use
> >
> 
> Martin has just commented elsewhere that having this recipe in a meta-opkg layer
> will always override the recipe in oe-core:
> 
> > You probably know about this already, but for other possible users of this
> > layer:
> >
> > bitbake will always select "devel" version from meta-opkg layer if it has
> > higher BBFILE_PRIORITY even if you put negative DEFAULT_PREFERRENCE into
> > "devel" recipes. Only if you put lower-than-oe-core BBFILE_PRIORITY in
> > layer.conf then it will force user to select "devel" version by
> > PREFERRED_VERSION.
> 
> So maybe opkg-testing_{version} would work better.

opkg-testing with PROVIDES = "opkg" won't work well for runtime dependencies
(even if you add RPROVIDES unless something will explicitly pull
opkg-testing into the image - VIRTUAL-RUNTIME vars...)

I would name the recipe opkg_git.bb with PV corresponding to real
version based on SRCREV e.g. "1.9+git${SRCPV}".

with
BBFILE_PRIORITY = "4"
and
PREFERRED_VERSION_opkg = "1.9+git%"
it should work as expected

This should be discussed on oe-core ML rather then yocto ML.

-- 
Martin 'JaMa' Jansa     jabber: Martin.Jansa@gmail.com

[-- Attachment #2: Digital signature --]
[-- Type: application/pgp-signature, Size: 205 bytes --]

^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: Recipe naming
  2013-08-03 11:17   ` Martin Jansa
@ 2013-08-03 11:43     ` Paul Barker
  0 siblings, 0 replies; 4+ messages in thread
From: Paul Barker @ 2013-08-03 11:43 UTC (permalink / raw)
  To: Martin Jansa; +Cc: Yocto discussion list

On 3 August 2013 12:17, Martin Jansa <martin.jansa@gmail.com> wrote:
>
> This should be discussed on oe-core ML rather then yocto ML.
>

I still get confused over which mailing list to post certain questions
to. I'll start a fresh discussion on oe-core once I've had another
think about this.

-- 
Paul Barker

Email: paul@paulbarker.me.uk
http://www.paulbarker.me.uk


^ permalink raw reply	[flat|nested] 4+ messages in thread

end of thread, other threads:[~2013-08-03 11:52 UTC | newest]

Thread overview: 4+ messages (download: mbox.gz follow: Atom feed
-- links below jump to the message on this page --
2013-08-03 10:52 Recipe naming Paul Barker
2013-08-03 11:07 ` Paul Barker
2013-08-03 11:17   ` Martin Jansa
2013-08-03 11:43     ` Paul Barker

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.