All of lore.kernel.org
 help / color / mirror / Atom feed
* Recipe naming
@ 2013-08-03 10:52 Paul Barker
  2013-08-03 11:07 ` Paul Barker
  0 siblings, 1 reply; 4+ messages in thread
From: Paul Barker @ 2013-08-03 10:52 UTC (permalink / raw)
  To: Yocto discussion list

I've looked at the OE versionning policy
(http://www.openembedded.org/wiki/Versioning_Policy) and I can't quite
figure out the correct name for my recipe from that.

I have a testing branch for opkg which I would like to put a recipe
for in a meta-opkg layer to simplify testing. The testing branch will
be fetched from git. Should I call this:

    "opkg_testing.bb"
    set PREFERRED_VERSION_opkg = "testing" to use

or

    "opkg-testing_git.bb", PROVIDES opkg
    set PREFERRED_PROVIDER_opkg = "opkg-testing" to use

I'd lean towards the former as it is a version of opkg not a separate fork.

Is there a convention for this or should I just make my own decision?

-- 
Paul Barker

Email: paul@paulbarker.me.uk
http://www.paulbarker.me.uk


^ permalink raw reply	[flat|nested] 4+ messages in thread

end of thread, other threads:[~2013-08-03 11:52 UTC | newest]

Thread overview: 4+ messages (download: mbox.gz follow: Atom feed
-- links below jump to the message on this page --
2013-08-03 10:52 Recipe naming Paul Barker
2013-08-03 11:07 ` Paul Barker
2013-08-03 11:17   ` Martin Jansa
2013-08-03 11:43     ` Paul Barker

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.