All of lore.kernel.org
 help / color / mirror / Atom feed
From: Christoph Hellwig <hch@infradead.org>
To: Sinan Kaya <okaya@codeaurora.org>
Cc: linux-pci@vger.kernel.org, timur@codeaurora.org,
	alex.williamson@redhat.com, linux-arm-msm@vger.kernel.org,
	linux-arm-kernel@lists.infradead.org,
	Bjorn Helgaas <bhelgaas@google.com>,
	linux-kernel@vger.kernel.org
Subject: Re: [PATCH 3/5] PCI: make pci_flr_wait() generic and rename to pci_dev_wait()
Date: Sun, 24 Sep 2017 06:08:06 -0700	[thread overview]
Message-ID: <20170924130806.GA12285@infradead.org> (raw)
In-Reply-To: <1506212218-29103-3-git-send-email-okaya@codeaurora.org>

On Sat, Sep 23, 2017 at 08:16:56PM -0400, Sinan Kaya wrote:
> Rev 3.1 Sec 2.3.1 Request Handling Rules:
> Valid reset conditions after which a device is permitted to return CRS
> are:
> * Cold, Warm, and Hot Resets,
> * FLR
> * A reset initiated in response to a D3hot to D0 uninitialized
> 
> Try to reuse FLR implementation towards other reset types.

Maybe call it pci_reset_wait instead of pci_dev_wait?

WARNING: multiple messages have this Message-ID (diff)
From: Christoph Hellwig <hch@infradead.org>
To: Sinan Kaya <okaya@codeaurora.org>
Cc: linux-pci@vger.kernel.org, timur@codeaurora.org,
	linux-kernel@vger.kernel.org, alex.williamson@redhat.com,
	linux-arm-msm@vger.kernel.org,
	Bjorn Helgaas <bhelgaas@google.com>,
	linux-arm-kernel@lists.infradead.org
Subject: Re: [PATCH 3/5] PCI: make pci_flr_wait() generic and rename to pci_dev_wait()
Date: Sun, 24 Sep 2017 06:08:06 -0700	[thread overview]
Message-ID: <20170924130806.GA12285@infradead.org> (raw)
In-Reply-To: <1506212218-29103-3-git-send-email-okaya@codeaurora.org>

On Sat, Sep 23, 2017 at 08:16:56PM -0400, Sinan Kaya wrote:
> Rev 3.1 Sec 2.3.1 Request Handling Rules:
> Valid reset conditions after which a device is permitted to return CRS
> are:
> * Cold, Warm, and Hot Resets,
> * FLR
> * A reset initiated in response to a D3hot to D0 uninitialized
> 
> Try to reuse FLR implementation towards other reset types.

Maybe call it pci_reset_wait instead of pci_dev_wait?

_______________________________________________
linux-arm-kernel mailing list
linux-arm-kernel@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-arm-kernel

WARNING: multiple messages have this Message-ID (diff)
From: hch@infradead.org (Christoph Hellwig)
To: linux-arm-kernel@lists.infradead.org
Subject: [PATCH 3/5] PCI: make pci_flr_wait() generic and rename to pci_dev_wait()
Date: Sun, 24 Sep 2017 06:08:06 -0700	[thread overview]
Message-ID: <20170924130806.GA12285@infradead.org> (raw)
In-Reply-To: <1506212218-29103-3-git-send-email-okaya@codeaurora.org>

On Sat, Sep 23, 2017 at 08:16:56PM -0400, Sinan Kaya wrote:
> Rev 3.1 Sec 2.3.1 Request Handling Rules:
> Valid reset conditions after which a device is permitted to return CRS
> are:
> * Cold, Warm, and Hot Resets,
> * FLR
> * A reset initiated in response to a D3hot to D0 uninitialized
> 
> Try to reuse FLR implementation towards other reset types.

Maybe call it pci_reset_wait instead of pci_dev_wait?

  reply	other threads:[~2017-09-24 13:08 UTC|newest]

Thread overview: 37+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2017-09-24  0:16 [PATCH 1/5] PCI: protect restore with device lock to be consistent Sinan Kaya
2017-09-24  0:16 ` Sinan Kaya
2017-09-24  0:16 ` Sinan Kaya
2017-09-24  0:16 ` [PATCH 2/5] PCI: handle FLR failure and allow other reset types Sinan Kaya
2017-09-24  0:16   ` Sinan Kaya
2017-09-24  0:16   ` Sinan Kaya
2017-10-11 21:00   ` Bjorn Helgaas
2017-10-11 21:00     ` Bjorn Helgaas
2017-10-11 21:00     ` Bjorn Helgaas
2017-10-12 16:42     ` Sinan Kaya
2017-10-12 16:42       ` Sinan Kaya
2017-09-24  0:16 ` [PATCH 3/5] PCI: make pci_flr_wait() generic and rename to pci_dev_wait() Sinan Kaya
2017-09-24  0:16   ` Sinan Kaya
2017-09-24 13:08   ` Christoph Hellwig [this message]
2017-09-24 13:08     ` Christoph Hellwig
2017-09-24 13:08     ` Christoph Hellwig
2017-09-25  0:30     ` Sinan Kaya
2017-09-25  0:30       ` Sinan Kaya
2017-09-25  0:30       ` Sinan Kaya
2017-09-24  0:16 ` [PATCH 4/5] PCI: wait device ready after pci_pm_reset() Sinan Kaya
2017-09-24  0:16   ` Sinan Kaya
2017-09-24  0:16   ` Sinan Kaya
2017-10-11 22:06   ` Bjorn Helgaas
2017-10-11 22:06     ` Bjorn Helgaas
2017-10-11 22:06     ` Bjorn Helgaas
2017-10-12 16:48     ` Sinan Kaya
2017-10-12 16:48       ` Sinan Kaya
2017-10-16 12:51       ` Sinan Kaya
2017-10-16 12:51         ` Sinan Kaya
2017-09-24  0:16 ` [PATCH 5/5] PCI: add device wait after slot and bus reset Sinan Kaya
2017-09-24  0:16   ` Sinan Kaya
2017-09-24  0:20   ` Sinan Kaya
2017-09-24  0:20     ` Sinan Kaya
2017-10-11 22:08 ` [PATCH 1/5] PCI: protect restore with device lock to be consistent Bjorn Helgaas
2017-10-11 22:08   ` Bjorn Helgaas
2017-10-12 16:39   ` Sinan Kaya
2017-10-12 16:39     ` Sinan Kaya

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20170924130806.GA12285@infradead.org \
    --to=hch@infradead.org \
    --cc=alex.williamson@redhat.com \
    --cc=bhelgaas@google.com \
    --cc=linux-arm-kernel@lists.infradead.org \
    --cc=linux-arm-msm@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-pci@vger.kernel.org \
    --cc=okaya@codeaurora.org \
    --cc=timur@codeaurora.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.