All of lore.kernel.org
 help / color / mirror / Atom feed
From: Kees Cook <keescook@chromium.org>
To: Christophe Leroy <christophe.leroy@csgroup.eu>
Cc: Benjamin Herrenschmidt <benh@kernel.crashing.org>,
	Paul Mackerras <paulus@samba.org>,
	Michael Ellerman <mpe@ellerman.id.au>,
	Andrew Morton <akpm@linux-foundation.org>,
	"James E.J. Bottomley" <James.Bottomley@hansenpartnership.com>,
	Helge Deller <deller@gmx.de>, Arnd Bergmann <arnd@arndb.de>,
	Greg Kroah-Hartman <gregkh@linuxfoundation.org>,
	linux-kernel@vger.kernel.org, linuxppc-dev@lists.ozlabs.org,
	linux-ia64@vger.kernel.org, linux-parisc@vger.kernel.org,
	linux-arch@vger.kernel.org, linux-mm@kvack.org
Subject: Re: [PATCH v3 01/12] powerpc: Move and rename func_descr_t
Date: Thu, 10 Feb 2022 16:51:59 -0800	[thread overview]
Message-ID: <202202101651.E6AACB3D4F@keescook> (raw)
In-Reply-To: <637a9a11263afa216fdfa7fb470a54479c67c61c.1634457599.git.christophe.leroy@csgroup.eu>

On Sun, Oct 17, 2021 at 02:38:14PM +0200, Christophe Leroy wrote:
> There are three architectures with function descriptors, try to
> have common names for the address they contain in order to
> refactor some functions into generic functions later.
> 
> powerpc has 'entry'
> ia64 has 'ip'
> parisc has 'addr'
> 
> Vote for 'addr' and update 'func_descr_t' accordingly.
> 
> Move it in asm/elf.h to have it at the same place on all
> three architectures, remove the typedef which hides its real
> type, and change it to a smoother name 'struct func_desc'.
> 
> Signed-off-by: Christophe Leroy <christophe.leroy@csgroup.eu>

I like the name. :)

Reviewed-by: Kees Cook <keescook@chromium.org>

-- 
Kees Cook

WARNING: multiple messages have this Message-ID (diff)
From: Kees Cook <keescook@chromium.org>
To: Christophe Leroy <christophe.leroy@csgroup.eu>
Cc: Benjamin Herrenschmidt <benh@kernel.crashing.org>,
	Paul Mackerras <paulus@samba.org>,
	Michael Ellerman <mpe@ellerman.id.au>,
	Andrew Morton <akpm@linux-foundation.org>,
	"James E.J. Bottomley" <James.Bottomley@hansenpartnership.com>,
	Helge Deller <deller@gmx.de>, Arnd Bergmann <arnd@arndb.de>,
	Greg Kroah-Hartman <gregkh@linuxfoundation.org>,
	linux-kernel@vger.kernel.org, linuxppc-dev@lists.ozlabs.org,
	linux-ia64@vger.kernel.org, linux-parisc@vger.kernel.org,
	linux-arch@vger.kernel.org, linux-mm@kvack.org
Subject: Re: [PATCH v3 01/12] powerpc: Move and rename func_descr_t
Date: Fri, 11 Feb 2022 00:51:59 +0000	[thread overview]
Message-ID: <202202101651.E6AACB3D4F@keescook> (raw)
In-Reply-To: <637a9a11263afa216fdfa7fb470a54479c67c61c.1634457599.git.christophe.leroy@csgroup.eu>

On Sun, Oct 17, 2021 at 02:38:14PM +0200, Christophe Leroy wrote:
> There are three architectures with function descriptors, try to
> have common names for the address they contain in order to
> refactor some functions into generic functions later.
> 
> powerpc has 'entry'
> ia64 has 'ip'
> parisc has 'addr'
> 
> Vote for 'addr' and update 'func_descr_t' accordingly.
> 
> Move it in asm/elf.h to have it at the same place on all
> three architectures, remove the typedef which hides its real
> type, and change it to a smoother name 'struct func_desc'.
> 
> Signed-off-by: Christophe Leroy <christophe.leroy@csgroup.eu>

I like the name. :)

Reviewed-by: Kees Cook <keescook@chromium.org>

-- 
Kees Cook

WARNING: multiple messages have this Message-ID (diff)
From: Kees Cook <keescook@chromium.org>
To: Christophe Leroy <christophe.leroy@csgroup.eu>
Cc: linux-arch@vger.kernel.org, linux-ia64@vger.kernel.org,
	linux-parisc@vger.kernel.org, Arnd Bergmann <arnd@arndb.de>,
	Greg Kroah-Hartman <gregkh@linuxfoundation.org>,
	Helge Deller <deller@gmx.de>,
	linux-kernel@vger.kernel.org,
	"James E.J. Bottomley" <James.Bottomley@hansenpartnership.com>,
	linux-mm@kvack.org, Paul Mackerras <paulus@samba.org>,
	Andrew Morton <akpm@linux-foundation.org>,
	linuxppc-dev@lists.ozlabs.org
Subject: Re: [PATCH v3 01/12] powerpc: Move and rename func_descr_t
Date: Thu, 10 Feb 2022 16:51:59 -0800	[thread overview]
Message-ID: <202202101651.E6AACB3D4F@keescook> (raw)
In-Reply-To: <637a9a11263afa216fdfa7fb470a54479c67c61c.1634457599.git.christophe.leroy@csgroup.eu>

On Sun, Oct 17, 2021 at 02:38:14PM +0200, Christophe Leroy wrote:
> There are three architectures with function descriptors, try to
> have common names for the address they contain in order to
> refactor some functions into generic functions later.
> 
> powerpc has 'entry'
> ia64 has 'ip'
> parisc has 'addr'
> 
> Vote for 'addr' and update 'func_descr_t' accordingly.
> 
> Move it in asm/elf.h to have it at the same place on all
> three architectures, remove the typedef which hides its real
> type, and change it to a smoother name 'struct func_desc'.
> 
> Signed-off-by: Christophe Leroy <christophe.leroy@csgroup.eu>

I like the name. :)

Reviewed-by: Kees Cook <keescook@chromium.org>

-- 
Kees Cook

  parent reply	other threads:[~2022-02-11  0:52 UTC|newest]

Thread overview: 99+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2021-10-17 12:38 [PATCH v3 00/12] Fix LKDTM for PPC64/IA64/PARISC Christophe Leroy
2021-10-17 12:38 ` Christophe Leroy
2021-10-17 12:38 ` Christophe Leroy
2021-10-17 12:38 ` [PATCH v3 01/12] powerpc: Move and rename func_descr_t Christophe Leroy
2021-10-17 12:38   ` Christophe Leroy
2021-10-17 12:38   ` Christophe Leroy
2021-10-18  5:58   ` Nicholas Piggin
2021-10-18  5:58     ` Nicholas Piggin
2021-10-18  5:58     ` Nicholas Piggin
2022-02-11  0:51   ` Kees Cook [this message]
2022-02-11  0:51     ` Kees Cook
2022-02-11  0:51     ` Kees Cook
2021-10-17 12:38 ` [PATCH v3 02/12] powerpc: Use 'struct func_desc' instead of 'struct ppc64_opd_entry' Christophe Leroy
2021-10-17 12:38   ` Christophe Leroy
2021-10-17 12:38   ` Christophe Leroy
2021-10-17 12:38 ` [PATCH v3 03/12] powerpc: Remove " Christophe Leroy
2021-10-17 12:38   ` Christophe Leroy
2021-10-17 12:38   ` Christophe Leroy
2021-10-17 12:38 ` [PATCH v3 04/12] powerpc: Prepare func_desc_t for refactorisation Christophe Leroy
2021-10-17 12:38   ` Christophe Leroy
2021-10-17 12:38   ` Christophe Leroy
2021-10-18  6:27   ` Nicholas Piggin
2021-10-18  6:27     ` Nicholas Piggin
2021-10-18  6:27     ` Nicholas Piggin
2021-10-18  7:08     ` Christophe Leroy
2021-10-18  7:08       ` Christophe Leroy
2021-10-18  7:08       ` Christophe Leroy
2022-02-11  0:54   ` Kees Cook
2022-02-11  0:54     ` Kees Cook
2022-02-11  0:54     ` Kees Cook
2022-02-11  7:39     ` Segher Boessenkool
2022-02-11  7:39       ` Segher Boessenkool
2022-02-11  7:39       ` Segher Boessenkool
2022-02-14 10:30     ` Christophe Leroy
2022-02-14 10:30       ` Christophe Leroy
2022-02-14 10:30       ` Christophe Leroy
2021-10-17 12:38 ` [PATCH v3 05/12] ia64: Rename 'ip' to 'addr' in 'struct fdesc' Christophe Leroy
2021-10-17 12:38   ` Christophe Leroy
2021-10-17 12:38   ` Christophe Leroy
2021-10-17 12:38 ` [PATCH v3 06/12] asm-generic: Define CONFIG_HAVE_FUNCTION_DESCRIPTORS Christophe Leroy
2021-10-17 12:38   ` Christophe Leroy
2021-10-17 12:38   ` Christophe Leroy
2021-10-17 12:38 ` [PATCH v3 07/12] asm-generic: Define 'func_desc_t' to commonly describe function descriptors Christophe Leroy
2021-10-17 12:38   ` Christophe Leroy
2021-10-17 12:38   ` Christophe Leroy
2021-10-18  6:29   ` Nicholas Piggin
2021-10-18  6:29     ` Nicholas Piggin
2021-10-18  6:29     ` Nicholas Piggin
2021-10-18  7:07     ` Christophe Leroy
2021-10-18  7:07       ` Christophe Leroy
2021-10-18  7:07       ` Christophe Leroy
2021-10-18  9:16       ` Nicholas Piggin
2021-10-18  9:16         ` Nicholas Piggin
2021-10-18  9:16         ` Nicholas Piggin
2021-10-17 12:38 ` [PATCH v3 08/12] asm-generic: Refactor dereference_[kernel]_function_descriptor() Christophe Leroy
2021-10-17 12:38   ` Christophe Leroy
2021-10-17 12:38   ` Christophe Leroy
2022-02-10 10:30   ` Michael Ellerman
2022-02-10 10:30     ` Michael Ellerman
2022-02-10 10:30     ` Michael Ellerman
2022-02-11  0:56     ` Kees Cook
2022-02-11  0:56       ` Kees Cook
2022-02-11  0:56       ` Kees Cook
2022-02-14 10:32       ` Christophe Leroy
2022-02-14 10:32         ` Christophe Leroy
2022-02-14 10:32         ` Christophe Leroy
2021-10-17 12:38 ` [PATCH v3 09/12] lkdtm: Force do_nothing() out of line Christophe Leroy
2021-10-17 12:38   ` Christophe Leroy
2021-10-17 12:38   ` Christophe Leroy
2021-10-17 12:38 ` [PATCH v3 10/12] lkdtm: Really write into kernel text in WRITE_KERN Christophe Leroy
2021-10-17 12:38   ` Christophe Leroy
2021-10-17 12:38   ` Christophe Leroy
2021-10-17 12:38 ` [PATCH v3 11/12] lkdtm: Fix execute_[user]_location() Christophe Leroy
2021-10-17 12:38   ` Christophe Leroy
2021-10-17 12:38   ` Christophe Leroy
2021-12-17 11:49   ` Christophe Leroy
2021-12-17 11:49     ` Christophe Leroy
2021-12-17 11:49     ` Christophe Leroy
2021-12-17 17:12     ` Helge Deller
2021-12-17 17:12       ` Helge Deller
2021-12-17 17:12       ` Helge Deller
2022-01-19 19:28     ` Christophe Leroy
2022-01-19 19:28       ` Christophe Leroy
2022-01-19 19:28       ` Christophe Leroy
2022-01-19 21:58       ` Kees Cook
2022-01-19 22:00         ` Kees Cook
2022-01-19 22:00         ` Kees Cook
2022-02-11  1:01   ` Kees Cook
2022-02-11  1:01     ` Kees Cook
2022-02-11  1:01     ` Kees Cook
2021-10-17 12:38 ` [PATCH v3 12/12] lkdtm: Add a test for function descriptors protection Christophe Leroy
2021-10-17 12:38   ` Christophe Leroy
2021-10-17 12:38   ` Christophe Leroy
2022-02-11  1:09   ` Kees Cook
2022-02-11  1:09     ` Kees Cook
2022-02-11  1:09     ` Kees Cook
2022-02-14 10:34     ` Christophe Leroy
2022-02-14 10:34       ` Christophe Leroy
2022-02-14 10:34       ` Christophe Leroy

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=202202101651.E6AACB3D4F@keescook \
    --to=keescook@chromium.org \
    --cc=James.Bottomley@hansenpartnership.com \
    --cc=akpm@linux-foundation.org \
    --cc=arnd@arndb.de \
    --cc=benh@kernel.crashing.org \
    --cc=christophe.leroy@csgroup.eu \
    --cc=deller@gmx.de \
    --cc=gregkh@linuxfoundation.org \
    --cc=linux-arch@vger.kernel.org \
    --cc=linux-ia64@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-mm@kvack.org \
    --cc=linux-parisc@vger.kernel.org \
    --cc=linuxppc-dev@lists.ozlabs.org \
    --cc=mpe@ellerman.id.au \
    --cc=paulus@samba.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.