All of lore.kernel.org
 help / color / mirror / Atom feed
From: Bjorn Helgaas <helgaas@kernel.org>
To: "Pali Rohár" <pali@kernel.org>
Cc: "Lorenzo Pieralisi" <lorenzo.pieralisi@arm.com>,
	"Bjorn Helgaas" <bhelgaas@google.com>,
	"Rob Herring" <robh+dt@kernel.org>,
	"Andrew Lunn" <andrew@lunn.ch>,
	"Thomas Petazzoni" <thomas.petazzoni@bootlin.com>,
	"Krzysztof Wilczyński" <kw@linux.com>,
	"Marek Behún" <kabel@kernel.org>,
	"Russell King" <rmk+kernel@armlinux.org.uk>,
	linux-pci@vger.kernel.org, linux-arm-kernel@lists.infradead.org,
	linux-kernel@vger.kernel.org
Subject: Re: [PATCH v3 3/4] PCI: Add function for parsing 'slot-power-limit-milliwatt' DT property
Date: Mon, 11 Apr 2022 14:54:34 -0500	[thread overview]
Message-ID: <20220411195434.GA531670@bhelgaas> (raw)
In-Reply-To: <20220411111407.7ycuoldxjvqnkoo4@pali>

On Mon, Apr 11, 2022 at 01:14:07PM +0200, Pali Rohár wrote:
> On Friday 08 April 2022 10:27:50 Bjorn Helgaas wrote:
> > On Fri, Mar 25, 2022 at 10:38:26AM +0100, Pali Rohár wrote:
> > > Add function of_pci_get_slot_power_limit(), which parses the
> > > 'slot-power-limit-milliwatt' DT property, returning the value in
> > > milliwatts and in format ready for the PCIe Slot Capabilities Register.
> > > 
> > > Signed-off-by: Pali Rohár <pali@kernel.org>
> > > Signed-off-by: Marek Behún <kabel@kernel.org>
> > > Reviewed-by: Rob Herring <robh@kernel.org>
> > > ---
> > > Changes in v3:
> > > * Set 600 W when DT slot-power-limit-milliwatt > 600 W
> > > Changes in v2:
> > > * Added support for PCIe 6.0 slot power limit encodings
> > > * Round down slot power limit value
> > > ---
> > >  drivers/pci/of.c  | 64 +++++++++++++++++++++++++++++++++++++++++++++++
> > >  drivers/pci/pci.h | 15 +++++++++++
> > >  2 files changed, 79 insertions(+)
> > > 
> > > diff --git a/drivers/pci/of.c b/drivers/pci/of.c
> > > index cb2e8351c2cc..5ebff26edd41 100644
> > > --- a/drivers/pci/of.c
> > > +++ b/drivers/pci/of.c
> > > @@ -633,3 +633,67 @@ int of_pci_get_max_link_speed(struct device_node *node)
> > >  	return max_link_speed;
> > >  }
> > >  EXPORT_SYMBOL_GPL(of_pci_get_max_link_speed);
> > > +
> > > +/**
> > > + * of_pci_get_slot_power_limit - Parses the "slot-power-limit-milliwatt"
> > > + *				 property.
> > > + *
> > > + * @node: device tree node with the slot power limit information
> > > + * @slot_power_limit_value: pointer where the value should be stored in PCIe
> > > + *			    Slot Capabilities Register format
> > > + * @slot_power_limit_scale: pointer where the scale should be stored in PCIe
> > > + *			    Slot Capabilities Register format
> > > + *
> > > + * Returns the slot power limit in milliwatts and if @slot_power_limit_value
> > > + * and @slot_power_limit_scale pointers are non-NULL, fills in the value and
> > > + * scale in format used by PCIe Slot Capabilities Register.
> > > + *
> > > + * If the property is not found or is invalid, returns 0.
> > > + */
> > > +u32 of_pci_get_slot_power_limit(struct device_node *node,
> > > +				u8 *slot_power_limit_value,
> > > +				u8 *slot_power_limit_scale)
> > > +{
> > > +	u32 slot_power_limit_mw;
> > > +	u8 value, scale;
> > > +
> > > +	if (of_property_read_u32(node, "slot-power-limit-milliwatt",
> > > +				 &slot_power_limit_mw))
> > > +		slot_power_limit_mw = 0;
> > > +
> > > +	/* Calculate Slot Power Limit Value and Slot Power Limit Scale */
> > > +	if (slot_power_limit_mw == 0) {
> > > +		value = 0x00;
> > > +		scale = 0;
> > > +	} else if (slot_power_limit_mw <= 255) {
> > > +		value = slot_power_limit_mw;
> > > +		scale = 3;
> > > +	} else if (slot_power_limit_mw <= 255*10) {
> > > +		value = slot_power_limit_mw / 10;
> > > +		scale = 2;
> > > +	} else if (slot_power_limit_mw <= 255*100) {
> > > +		value = slot_power_limit_mw / 100;
> > > +		scale = 1;
> > > +	} else if (slot_power_limit_mw <= 239*1000) {
> > > +		value = slot_power_limit_mw / 1000;
> > > +		scale = 0;
> > > +	} else if (slot_power_limit_mw <= 250*1000) {
> > > +		value = 0xF0;
> > > +		scale = 0;
> > 
> > I think the spec is poorly worded here.  PCIe r6.0, sec 7.5.3.9, says:
> > 
> >   F0h   > 239 W and <= 250 W Slot Power Limit
> > 
> > I don't think it's meaningful for the spec to include a range here.
> > The amount of power the slot can supply has a single maximum.  I
> > suspect the *intent* of F0h/00b is that a device in the slot may
> > consume up to 250W.
> > 
> > Your code above would mean that slot_power_limit_mw == 245,000 would
> > cause the slot to advertise F0h/00b (250W), which seems wrong.
> 
> So for slot_power_limit_mw == 245 W we should set following values?
> 
>   slot_power_limit_mw = 239 W
>   value = 0xF0
>   scale = 0

I think Slot Cap should never advertise more power than the slot can
supply.  So if the DT tells us the slot can supply 245 W, I don't
think Slot Cap should advertise that it can supply 250 W.  I think we
should drop down to the next lower possible value, which is 239 W
(value 0xEF, scale 0).  I think this is what your v4 does.

> > I think we should do something like this instead:
> > 
> >   scale = 0;
> >   if (slot_power_limit_mw >= 600*1000) {
> >     value = 0xFE;
> >     slot_power_limit_mw = 600*1000;
> >   } else if (slot_power_limit_mw >= 575*1000) {
> >     value = 0xFD;
> >     slot_power_limit_mw = 575*1000;
> >   } ...
> 
> This is already implemented in branch:
> 
>   } else if (slot_power_limit_mw <= 600*1000) {
>   	value = 0xF0 + (slot_power_limit_mw / 1000 - 250) / 25;
>   	scale = 0;

OK, I was thinking there was a hole here, but I guess not.  I think do
think it's easier to read and verify if it's structured as "the slot
can supply at least X, so advertise X", as opposed to "the slot can
supply X or less, so advertise Y".

Bjorn

WARNING: multiple messages have this Message-ID (diff)
From: Bjorn Helgaas <helgaas@kernel.org>
To: "Pali Rohár" <pali@kernel.org>
Cc: "Lorenzo Pieralisi" <lorenzo.pieralisi@arm.com>,
	"Bjorn Helgaas" <bhelgaas@google.com>,
	"Rob Herring" <robh+dt@kernel.org>,
	"Andrew Lunn" <andrew@lunn.ch>,
	"Thomas Petazzoni" <thomas.petazzoni@bootlin.com>,
	"Krzysztof Wilczyński" <kw@linux.com>,
	"Marek Behún" <kabel@kernel.org>,
	"Russell King" <rmk+kernel@armlinux.org.uk>,
	linux-pci@vger.kernel.org, linux-arm-kernel@lists.infradead.org,
	linux-kernel@vger.kernel.org
Subject: Re: [PATCH v3 3/4] PCI: Add function for parsing 'slot-power-limit-milliwatt' DT property
Date: Mon, 11 Apr 2022 14:54:34 -0500	[thread overview]
Message-ID: <20220411195434.GA531670@bhelgaas> (raw)
In-Reply-To: <20220411111407.7ycuoldxjvqnkoo4@pali>

On Mon, Apr 11, 2022 at 01:14:07PM +0200, Pali Rohár wrote:
> On Friday 08 April 2022 10:27:50 Bjorn Helgaas wrote:
> > On Fri, Mar 25, 2022 at 10:38:26AM +0100, Pali Rohár wrote:
> > > Add function of_pci_get_slot_power_limit(), which parses the
> > > 'slot-power-limit-milliwatt' DT property, returning the value in
> > > milliwatts and in format ready for the PCIe Slot Capabilities Register.
> > > 
> > > Signed-off-by: Pali Rohár <pali@kernel.org>
> > > Signed-off-by: Marek Behún <kabel@kernel.org>
> > > Reviewed-by: Rob Herring <robh@kernel.org>
> > > ---
> > > Changes in v3:
> > > * Set 600 W when DT slot-power-limit-milliwatt > 600 W
> > > Changes in v2:
> > > * Added support for PCIe 6.0 slot power limit encodings
> > > * Round down slot power limit value
> > > ---
> > >  drivers/pci/of.c  | 64 +++++++++++++++++++++++++++++++++++++++++++++++
> > >  drivers/pci/pci.h | 15 +++++++++++
> > >  2 files changed, 79 insertions(+)
> > > 
> > > diff --git a/drivers/pci/of.c b/drivers/pci/of.c
> > > index cb2e8351c2cc..5ebff26edd41 100644
> > > --- a/drivers/pci/of.c
> > > +++ b/drivers/pci/of.c
> > > @@ -633,3 +633,67 @@ int of_pci_get_max_link_speed(struct device_node *node)
> > >  	return max_link_speed;
> > >  }
> > >  EXPORT_SYMBOL_GPL(of_pci_get_max_link_speed);
> > > +
> > > +/**
> > > + * of_pci_get_slot_power_limit - Parses the "slot-power-limit-milliwatt"
> > > + *				 property.
> > > + *
> > > + * @node: device tree node with the slot power limit information
> > > + * @slot_power_limit_value: pointer where the value should be stored in PCIe
> > > + *			    Slot Capabilities Register format
> > > + * @slot_power_limit_scale: pointer where the scale should be stored in PCIe
> > > + *			    Slot Capabilities Register format
> > > + *
> > > + * Returns the slot power limit in milliwatts and if @slot_power_limit_value
> > > + * and @slot_power_limit_scale pointers are non-NULL, fills in the value and
> > > + * scale in format used by PCIe Slot Capabilities Register.
> > > + *
> > > + * If the property is not found or is invalid, returns 0.
> > > + */
> > > +u32 of_pci_get_slot_power_limit(struct device_node *node,
> > > +				u8 *slot_power_limit_value,
> > > +				u8 *slot_power_limit_scale)
> > > +{
> > > +	u32 slot_power_limit_mw;
> > > +	u8 value, scale;
> > > +
> > > +	if (of_property_read_u32(node, "slot-power-limit-milliwatt",
> > > +				 &slot_power_limit_mw))
> > > +		slot_power_limit_mw = 0;
> > > +
> > > +	/* Calculate Slot Power Limit Value and Slot Power Limit Scale */
> > > +	if (slot_power_limit_mw == 0) {
> > > +		value = 0x00;
> > > +		scale = 0;
> > > +	} else if (slot_power_limit_mw <= 255) {
> > > +		value = slot_power_limit_mw;
> > > +		scale = 3;
> > > +	} else if (slot_power_limit_mw <= 255*10) {
> > > +		value = slot_power_limit_mw / 10;
> > > +		scale = 2;
> > > +	} else if (slot_power_limit_mw <= 255*100) {
> > > +		value = slot_power_limit_mw / 100;
> > > +		scale = 1;
> > > +	} else if (slot_power_limit_mw <= 239*1000) {
> > > +		value = slot_power_limit_mw / 1000;
> > > +		scale = 0;
> > > +	} else if (slot_power_limit_mw <= 250*1000) {
> > > +		value = 0xF0;
> > > +		scale = 0;
> > 
> > I think the spec is poorly worded here.  PCIe r6.0, sec 7.5.3.9, says:
> > 
> >   F0h   > 239 W and <= 250 W Slot Power Limit
> > 
> > I don't think it's meaningful for the spec to include a range here.
> > The amount of power the slot can supply has a single maximum.  I
> > suspect the *intent* of F0h/00b is that a device in the slot may
> > consume up to 250W.
> > 
> > Your code above would mean that slot_power_limit_mw == 245,000 would
> > cause the slot to advertise F0h/00b (250W), which seems wrong.
> 
> So for slot_power_limit_mw == 245 W we should set following values?
> 
>   slot_power_limit_mw = 239 W
>   value = 0xF0
>   scale = 0

I think Slot Cap should never advertise more power than the slot can
supply.  So if the DT tells us the slot can supply 245 W, I don't
think Slot Cap should advertise that it can supply 250 W.  I think we
should drop down to the next lower possible value, which is 239 W
(value 0xEF, scale 0).  I think this is what your v4 does.

> > I think we should do something like this instead:
> > 
> >   scale = 0;
> >   if (slot_power_limit_mw >= 600*1000) {
> >     value = 0xFE;
> >     slot_power_limit_mw = 600*1000;
> >   } else if (slot_power_limit_mw >= 575*1000) {
> >     value = 0xFD;
> >     slot_power_limit_mw = 575*1000;
> >   } ...
> 
> This is already implemented in branch:
> 
>   } else if (slot_power_limit_mw <= 600*1000) {
>   	value = 0xF0 + (slot_power_limit_mw / 1000 - 250) / 25;
>   	scale = 0;

OK, I was thinking there was a hole here, but I guess not.  I think do
think it's easier to read and verify if it's structured as "the slot
can supply at least X, so advertise X", as opposed to "the slot can
supply X or less, so advertise Y".

Bjorn

_______________________________________________
linux-arm-kernel mailing list
linux-arm-kernel@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-arm-kernel

  parent reply	other threads:[~2022-04-11 19:54 UTC|newest]

Thread overview: 22+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2022-03-25  9:38 [PATCH v3 0/4] PCI: mvebu: Slot support Pali Rohár
2022-03-25  9:38 ` Pali Rohár
2022-03-25  9:38 ` [PATCH v3 1/4] PCI: Add PCI_EXP_SLTCTL_ASPL_DISABLE macro Pali Rohár
2022-03-25  9:38   ` Pali Rohár
2022-03-25  9:38 ` [PATCH v3 2/4] dt-bindings: Add 'slot-power-limit-milliwatt' PCIe port property Pali Rohár
2022-03-25  9:38   ` Pali Rohár
2022-04-08 10:31   ` Lorenzo Pieralisi
2022-04-08 10:31     ` Lorenzo Pieralisi
2022-03-25  9:38 ` [PATCH v3 3/4] PCI: Add function for parsing 'slot-power-limit-milliwatt' DT property Pali Rohár
2022-03-25  9:38   ` Pali Rohár
2022-04-08 15:27   ` Bjorn Helgaas
2022-04-08 15:27     ` Bjorn Helgaas
2022-04-11 11:14     ` Pali Rohár
2022-04-11 11:14       ` Pali Rohár
2022-04-11 19:02       ` Pali Rohár
2022-04-11 19:02         ` Pali Rohár
2022-04-11 19:54       ` Bjorn Helgaas [this message]
2022-04-11 19:54         ` Bjorn Helgaas
2022-10-27 19:05     ` Bjorn Helgaas
2022-10-27 19:05       ` Bjorn Helgaas
2022-03-25  9:38 ` [PATCH v3 4/4] PCI: mvebu: Add support for sending Set_Slot_Power_Limit message Pali Rohár
2022-03-25  9:38   ` Pali Rohár

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20220411195434.GA531670@bhelgaas \
    --to=helgaas@kernel.org \
    --cc=andrew@lunn.ch \
    --cc=bhelgaas@google.com \
    --cc=kabel@kernel.org \
    --cc=kw@linux.com \
    --cc=linux-arm-kernel@lists.infradead.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-pci@vger.kernel.org \
    --cc=lorenzo.pieralisi@arm.com \
    --cc=pali@kernel.org \
    --cc=rmk+kernel@armlinux.org.uk \
    --cc=robh+dt@kernel.org \
    --cc=thomas.petazzoni@bootlin.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.