All of lore.kernel.org
 help / color / mirror / Atom feed
From: Laurent Pinchart <laurent.pinchart@ideasonboard.com>
To: Bryan O'Donoghue <bryan.odonoghue@linaro.org>
Cc: rfoss@kernel.org, todor.too@gmail.com, agross@kernel.org,
	andersson@kernel.org, konrad.dybcio@linaro.org,
	mchehab@kernel.org, hverkuil-cisco@xs4all.nl,
	sakari.ailus@linux.intel.com, andrey.konovalov@linaro.org,
	linux-media@vger.kernel.org, linux-arm-msm@vger.kernel.org,
	linux-kernel@vger.kernel.org
Subject: Re: [PATCH v3 01/15] media: qcom: camss: Amalgamate struct resource with struct resource_ispif
Date: Mon, 28 Aug 2023 20:30:55 +0300	[thread overview]
Message-ID: <20230828173055.GF14596@pendragon.ideasonboard.com> (raw)
In-Reply-To: <20230823104444.1954663-2-bryan.odonoghue@linaro.org>

Hi Bryan,

Thank you for the patch.

On Wed, Aug 23, 2023 at 11:44:30AM +0100, Bryan O'Donoghue wrote:
> There is no good reason to differentiate the two resource structures
> here. As part of a general tidyup of the declaration and passing of
> resources within in the CAMSS driver it will be advantageous to have
> one unified resource structure.
> 
> The two structures are very similar anyway thus leading more credence
> still to the argument there should be only one.
> 
> Signed-off-by: Bryan O'Donoghue <bryan.odonoghue@linaro.org>
> ---
>  drivers/media/platform/qcom/camss/camss-ispif.c |  4 ++--
>  drivers/media/platform/qcom/camss/camss-ispif.h |  4 ++--
>  drivers/media/platform/qcom/camss/camss.c       | 14 +++++++-------
>  drivers/media/platform/qcom/camss/camss.h       |  8 +-------
>  4 files changed, 12 insertions(+), 18 deletions(-)
> 
> diff --git a/drivers/media/platform/qcom/camss/camss-ispif.c b/drivers/media/platform/qcom/camss/camss-ispif.c
> index 1c7e4b1b49401..61765b874b9a2 100644
> --- a/drivers/media/platform/qcom/camss/camss-ispif.c
> +++ b/drivers/media/platform/qcom/camss/camss-ispif.c
> @@ -1095,7 +1095,7 @@ static int ispif_init_formats(struct v4l2_subdev *sd, struct v4l2_subdev_fh *fh)
>   * Return 0 on success or a negative error code otherwise
>   */
>  int msm_ispif_subdev_init(struct camss *camss,
> -			  const struct resources_ispif *res)
> +			  const struct resources *res)
>  {
>  	struct device *dev = camss->dev;
>  	struct ispif_device *ispif = camss->ispif;
> @@ -1152,7 +1152,7 @@ int msm_ispif_subdev_init(struct camss *camss,
>  
>  	/* Interrupt */
>  
> -	ret = platform_get_irq_byname(pdev, res->interrupt);
> +	ret = platform_get_irq_byname(pdev, res->interrupt[0]);
>  	if (ret < 0)
>  		return ret;
>  
> diff --git a/drivers/media/platform/qcom/camss/camss-ispif.h b/drivers/media/platform/qcom/camss/camss-ispif.h
> index fdf28e68cc7d8..c7c41f7afcaad 100644
> --- a/drivers/media/platform/qcom/camss/camss-ispif.h
> +++ b/drivers/media/platform/qcom/camss/camss-ispif.h
> @@ -66,10 +66,10 @@ struct ispif_device {
>  	struct camss *camss;
>  };
>  
> -struct resources_ispif;
> +struct resources;
>  
>  int msm_ispif_subdev_init(struct camss *camss,
> -			  const struct resources_ispif *res);
> +			  const struct resources *res);
>  
>  int msm_ispif_register_entities(struct ispif_device *ispif,
>  				struct v4l2_device *v4l2_dev);
> diff --git a/drivers/media/platform/qcom/camss/camss.c b/drivers/media/platform/qcom/camss/camss.c
> index f4948bdf3f8f9..de39dc987444f 100644
> --- a/drivers/media/platform/qcom/camss/camss.c
> +++ b/drivers/media/platform/qcom/camss/camss.c
> @@ -93,14 +93,14 @@ static const struct resources csid_res_8x16[] = {
>  	},
>  };
>  
> -static const struct resources_ispif ispif_res_8x16 = {
> +static const struct resources ispif_res_8x16 = {
>  	/* ISPIF */
>  	.clock = { "top_ahb", "ahb", "ispif_ahb",
>  		   "csi0", "csi0_pix", "csi0_rdi",
>  		   "csi1", "csi1_pix", "csi1_rdi" },
>  	.clock_for_reset = { "vfe0", "csi_vfe0" },
>  	.reg = { "ispif", "csi_clk_mux" },
> -	.interrupt = "ispif"
> +	.interrupt = { "ispif" }
>  
>  };
>  
> @@ -234,7 +234,7 @@ static const struct resources csid_res_8x96[] = {
>  	}
>  };
>  
> -static const struct resources_ispif ispif_res_8x96 = {
> +static const struct resources ispif_res_8x96 = {
>  	/* ISPIF */
>  	.clock = { "top_ahb", "ahb", "ispif_ahb",
>  		   "csi0", "csi0_pix", "csi0_rdi",
> @@ -243,7 +243,7 @@ static const struct resources_ispif ispif_res_8x96 = {
>  		   "csi3", "csi3_pix", "csi3_rdi" },
>  	.clock_for_reset = { "vfe0", "csi_vfe0", "vfe1", "csi_vfe1" },
>  	.reg = { "ispif", "csi_clk_mux" },
> -	.interrupt = "ispif"
> +	.interrupt = { "ispif" }
>  };
>  
>  static const struct resources vfe_res_8x96[] = {
> @@ -410,7 +410,7 @@ static const struct resources csid_res_660[] = {
>  	}
>  };
>  
> -static const struct resources_ispif ispif_res_660 = {
> +static const struct resources ispif_res_660 = {
>  	/* ISPIF */
>  	.clock = { "top_ahb", "ahb", "ispif_ahb",
>  		   "csi0", "csi0_pix", "csi0_rdi",
> @@ -419,7 +419,7 @@ static const struct resources_ispif ispif_res_660 = {
>  		   "csi3", "csi3_pix", "csi3_rdi" },
>  	.clock_for_reset = { "vfe0", "csi_vfe0", "vfe1", "csi_vfe1" },
>  	.reg = { "ispif", "csi_clk_mux" },
> -	.interrupt = "ispif"
> +	.interrupt = { "ispif" }
>  };
>  
>  static const struct resources vfe_res_660[] = {
> @@ -1122,7 +1122,7 @@ static int camss_init_subdevices(struct camss *camss)
>  {
>  	const struct resources *csiphy_res;
>  	const struct resources *csid_res;
> -	const struct resources_ispif *ispif_res;
> +	const struct resources *ispif_res;
>  	const struct resources *vfe_res;
>  	unsigned int i;
>  	int ret;
> diff --git a/drivers/media/platform/qcom/camss/camss.h b/drivers/media/platform/qcom/camss/camss.h
> index f6c326cb853b8..e95211cdb1fd6 100644
> --- a/drivers/media/platform/qcom/camss/camss.h
> +++ b/drivers/media/platform/qcom/camss/camss.h
> @@ -44,18 +44,12 @@
>  struct resources {

While at it, or in a separate patch, could you rename this to
camss_resources ? resources is a too generic name, too likely to clash.
With this fixed,

Reviewed-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com>

>  	char *regulators[CAMSS_RES_MAX];
>  	char *clock[CAMSS_RES_MAX];
> +	char *clock_for_reset[CAMSS_RES_MAX];
>  	u32 clock_rate[CAMSS_RES_MAX][CAMSS_RES_MAX];
>  	char *reg[CAMSS_RES_MAX];
>  	char *interrupt[CAMSS_RES_MAX];
>  };
>  
> -struct resources_ispif {
> -	char *clock[CAMSS_RES_MAX];
> -	char *clock_for_reset[CAMSS_RES_MAX];
> -	char *reg[CAMSS_RES_MAX];
> -	char *interrupt;
> -};
> -
>  struct icc_bw_tbl {
>  	u32 avg;
>  	u32 peak;

-- 
Regards,

Laurent Pinchart

  parent reply	other threads:[~2023-08-28 17:31 UTC|newest]

Thread overview: 63+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2023-08-23 10:44 [PATCH v3 00/15] media: qcom: camss: Add parameter passing to remove several outstanding bugs Bryan O'Donoghue
2023-08-23 10:44 ` [PATCH v3 01/15] media: qcom: camss: Amalgamate struct resource with struct resource_ispif Bryan O'Donoghue
2023-08-26  9:55   ` Konrad Dybcio
2023-08-28 17:30   ` Laurent Pinchart [this message]
2023-08-23 10:44 ` [PATCH v3 02/15] media: qcom: camss: Start to move to module compat matched resources Bryan O'Donoghue
2023-08-28 17:33   ` Laurent Pinchart
2023-08-23 10:44 ` [PATCH v3 03/15] media: qcom: camss: Pass icc bandwidth table as a platform parameter Bryan O'Donoghue
2023-08-28 17:35   ` Laurent Pinchart
2023-08-23 10:44 ` [PATCH v3 04/15] media: qcom: camss: Pass remainder of variables as resources Bryan O'Donoghue
2023-08-26  9:57   ` Konrad Dybcio
2023-08-28 17:51   ` Laurent Pinchart
2023-08-23 10:44 ` [PATCH v3 05/15] media: qcom: camss: Pass line_num from compat resources Bryan O'Donoghue
2023-08-28 18:36   ` Laurent Pinchart
2023-08-28 19:31     ` Bryan O'Donoghue
2023-08-23 10:44 ` [PATCH v3 06/15] media: qcom: camss: Assign the correct number of RDIs per VFE Bryan O'Donoghue
2023-08-28 18:43   ` Laurent Pinchart
2023-08-23 10:44 ` [PATCH v3 07/15] media: qcom: camss: Capture VFE CSID dependency in a helper function Bryan O'Donoghue
2023-08-26 10:02   ` Konrad Dybcio
2023-08-26 12:01     ` Bryan O'Donoghue
2023-08-26 12:04       ` Konrad Dybcio
2023-08-26 12:12         ` Bryan O'Donoghue
2023-08-26 12:13           ` Konrad Dybcio
2023-08-26 12:16             ` Bryan O'Donoghue
2023-08-28 18:47   ` Laurent Pinchart
2023-08-28 19:37     ` Bryan O'Donoghue
2023-08-28 19:40       ` Laurent Pinchart
2023-08-28 19:41         ` Bryan O'Donoghue
2023-09-04 10:15         ` Bryan O'Donoghue
2023-08-23 10:44 ` [PATCH v3 08/15] media: qcom: camss: Untangle if/else spaghetti in camss Bryan O'Donoghue
2023-08-26 10:03   ` Konrad Dybcio
2023-08-28 18:51   ` Laurent Pinchart
2023-08-28 19:43     ` Bryan O'Donoghue
2023-09-04 12:24     ` Bryan O'Donoghue
2023-08-23 10:44 ` [PATCH v3 09/15] media: qcom: camss: Improve error printout on icc_get fail Bryan O'Donoghue
2023-08-26 10:05   ` Konrad Dybcio
2023-08-26 12:01     ` Bryan O'Donoghue
2023-08-23 10:44 ` [PATCH v3 10/15] media: qcom: camss: Allow clocks vfeN vfe_liteN or vfe_lite Bryan O'Donoghue
2023-08-26 10:08   ` Konrad Dybcio
2023-08-26 12:05     ` Bryan O'Donoghue
2023-08-28 18:55   ` Laurent Pinchart
2023-08-23 10:44 ` [PATCH v3 11/15] media: qcom: camss: Functionally decompose CSIPHY clock lookups Bryan O'Donoghue
2023-08-26 10:12   ` Konrad Dybcio
2023-08-26 12:07     ` Bryan O'Donoghue
2023-08-26 12:11       ` Konrad Dybcio
2023-08-26 12:14         ` Bryan O'Donoghue
2023-08-26 12:48           ` Konrad Dybcio
2023-08-28 18:59   ` Laurent Pinchart
2023-08-23 10:44 ` [PATCH v3 12/15] media: qcom: camss: Fix support for setting CSIPHY clock name csiphyX Bryan O'Donoghue
2023-08-26 10:13   ` Konrad Dybcio
2023-08-26 12:08     ` Bryan O'Donoghue
2023-08-26 12:12       ` Konrad Dybcio
2023-09-04 19:11         ` Bryan O'Donoghue
2023-09-04 19:32           ` Konrad Dybcio
2023-09-04 19:33             ` Bryan O'Donoghue
2023-08-23 10:44 ` [PATCH v3 13/15] media: qcom: camss: Support RDI3 for VFE 17x Bryan O'Donoghue
2023-08-28 19:03   ` Laurent Pinchart
2023-08-23 10:44 ` [PATCH v3 14/15] media: qcom: camss: Convert vfe_disable() from int to void Bryan O'Donoghue
2023-08-26 10:16   ` Konrad Dybcio
2023-08-23 10:44 ` [PATCH v3 15/15] media: qcom: camss: Comment CSID dt_id field Bryan O'Donoghue
2023-08-26 10:18   ` Konrad Dybcio
2023-08-28 15:34     ` Bryan O'Donoghue
2023-08-28 15:38       ` Konrad Dybcio
2023-08-28 15:43         ` Bryan O'Donoghue

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20230828173055.GF14596@pendragon.ideasonboard.com \
    --to=laurent.pinchart@ideasonboard.com \
    --cc=agross@kernel.org \
    --cc=andersson@kernel.org \
    --cc=andrey.konovalov@linaro.org \
    --cc=bryan.odonoghue@linaro.org \
    --cc=hverkuil-cisco@xs4all.nl \
    --cc=konrad.dybcio@linaro.org \
    --cc=linux-arm-msm@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-media@vger.kernel.org \
    --cc=mchehab@kernel.org \
    --cc=rfoss@kernel.org \
    --cc=sakari.ailus@linux.intel.com \
    --cc=todor.too@gmail.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.