From: Jamin Lin via <qemu-devel@nongnu.org>
To: "Cédric Le Goater" <clg@kaod.org>,
"Peter Maydell" <peter.maydell@linaro.org>,
"Steven Lee" <steven_lee@aspeedtech.com>,
"Troy Lee" <leetroy@gmail.com>,
"Andrew Jeffery" <andrew@codeconstruct.com.au>,
"Joel Stanley" <joel@jms.id.au>,
"open list:All patches CC here" <qemu-devel@nongnu.org>,
"open list:ASPEED BMCs" <qemu-arm@nongnu.org>
Cc: <jamin_lin@aspeedtech.com>, <troy_lee@aspeedtech.com>
Subject: [PATCH v3 20/28] hw/misc/aspeed_hace: Add AST2700 support
Date: Thu, 13 Feb 2025 11:35:23 +0800 [thread overview]
Message-ID: <20250213033531.3367697-21-jamin_lin@aspeedtech.com> (raw)
In-Reply-To: <20250213033531.3367697-1-jamin_lin@aspeedtech.com>
Introduce a new ast2700 class to support AST2700.
Signed-off-by: Jamin Lin <jamin_lin@aspeedtech.com>
Reviewed-by: Andrew Jeffery <andrew@codeconstruct.com.au>
---
hw/misc/aspeed_hace.c | 20 ++++++++++++++++++++
include/hw/misc/aspeed_hace.h | 1 +
2 files changed, 21 insertions(+)
diff --git a/hw/misc/aspeed_hace.c b/hw/misc/aspeed_hace.c
index 18b85081c7..86422cb3be 100644
--- a/hw/misc/aspeed_hace.c
+++ b/hw/misc/aspeed_hace.c
@@ -552,12 +552,32 @@ static const TypeInfo aspeed_ast1030_hace_info = {
.class_init = aspeed_ast1030_hace_class_init,
};
+static void aspeed_ast2700_hace_class_init(ObjectClass *klass, void *data)
+{
+ DeviceClass *dc = DEVICE_CLASS(klass);
+ AspeedHACEClass *ahc = ASPEED_HACE_CLASS(klass);
+
+ dc->desc = "AST2700 Hash and Crypto Engine";
+
+ ahc->src_mask = 0x7FFFFFFF;
+ ahc->dest_mask = 0x7FFFFFF8;
+ ahc->key_mask = 0x7FFFFFF8;
+ ahc->hash_mask = 0x00147FFF;
+}
+
+static const TypeInfo aspeed_ast2700_hace_info = {
+ .name = TYPE_ASPEED_AST2700_HACE,
+ .parent = TYPE_ASPEED_HACE,
+ .class_init = aspeed_ast2700_hace_class_init,
+};
+
static void aspeed_hace_register_types(void)
{
type_register_static(&aspeed_ast2400_hace_info);
type_register_static(&aspeed_ast2500_hace_info);
type_register_static(&aspeed_ast2600_hace_info);
type_register_static(&aspeed_ast1030_hace_info);
+ type_register_static(&aspeed_ast2700_hace_info);
type_register_static(&aspeed_hace_info);
}
diff --git a/include/hw/misc/aspeed_hace.h b/include/hw/misc/aspeed_hace.h
index 4af9919195..d13fd3da07 100644
--- a/include/hw/misc/aspeed_hace.h
+++ b/include/hw/misc/aspeed_hace.h
@@ -18,6 +18,7 @@
#define TYPE_ASPEED_AST2500_HACE TYPE_ASPEED_HACE "-ast2500"
#define TYPE_ASPEED_AST2600_HACE TYPE_ASPEED_HACE "-ast2600"
#define TYPE_ASPEED_AST1030_HACE TYPE_ASPEED_HACE "-ast1030"
+#define TYPE_ASPEED_AST2700_HACE TYPE_ASPEED_HACE "-ast2700"
OBJECT_DECLARE_TYPE(AspeedHACEState, AspeedHACEClass, ASPEED_HACE)
--
2.34.1
next prev parent reply other threads:[~2025-02-13 3:38 UTC|newest]
Thread overview: 89+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-02-13 3:35 [PATCH v3 00/28] Support AST2700 A1 Jamin Lin via
2025-02-13 3:35 ` Jamin Lin via
2025-02-13 3:35 ` [PATCH v3 01/28] hw/intc/aspeed: Support setting different memory and register size Jamin Lin via
2025-02-18 5:33 ` Cédric Le Goater
2025-02-20 5:45 ` Jamin Lin
2025-02-21 15:15 ` Cédric Le Goater
2025-02-26 3:40 ` Jamin Lin
2025-02-27 9:57 ` Cédric Le Goater
2025-03-03 2:52 ` Jamin Lin
2025-02-13 3:35 ` [PATCH v3 02/28] hw/intc/aspeed: Introduce helper functions for enable and status registers Jamin Lin via
2025-02-13 3:35 ` Jamin Lin via
2025-02-18 5:36 ` Cédric Le Goater
2025-02-20 3:24 ` Jamin Lin
2025-02-13 3:35 ` [PATCH v3 03/28] hw/intc/aspeed: Add object type name to trace events for better debugging Jamin Lin via
2025-02-13 3:35 ` Jamin Lin via
2025-02-18 5:43 ` Cédric Le Goater
2025-02-13 3:35 ` [PATCH v3 04/28] hw/arm/aspeed: Rename IRQ table and machine name for AST2700 A0 Jamin Lin via
2025-02-13 3:35 ` Jamin Lin via
2025-02-18 5:47 ` Cédric Le Goater
2025-02-21 2:23 ` Jamin Lin
2025-02-21 14:04 ` Cédric Le Goater
2025-02-13 3:35 ` [PATCH v3 05/28] hw/arm/aspeed_ast27x0: Sort the IRQ table by IRQ number Jamin Lin via
2025-02-13 3:35 ` Jamin Lin via
2025-02-18 5:48 ` Cédric Le Goater
2025-02-13 3:35 ` [PATCH v3 06/28] hw/intc/aspeed: Support different memory region ops Jamin Lin via
2025-02-13 3:35 ` Jamin Lin via
2025-02-18 5:48 ` Cédric Le Goater
2025-02-13 3:35 ` [PATCH v3 07/28] hw/intc/aspeed: Rename num_ints to num_inpins for clarity Jamin Lin via
2025-02-13 3:35 ` Jamin Lin via
2025-02-18 5:49 ` Cédric Le Goater
2025-02-13 3:35 ` [PATCH v3 08/28] hw/intc/aspeed: Add support for multiple output pins in INTC Jamin Lin via
2025-02-18 5:53 ` Cédric Le Goater
2025-02-21 1:31 ` Jamin Lin
2025-02-13 3:35 ` [PATCH v3 09/28] hw/intc/aspeed: Refactor INTC to support separate input and output pin indices Jamin Lin via
2025-02-13 3:35 ` Jamin Lin via
2025-02-18 6:20 ` Cédric Le Goater
2025-02-13 3:35 ` [PATCH v3 10/28] hw/intc/aspeed: Introduce AspeedINTCIRQ structure to save the irq index and register address Jamin Lin via
2025-02-13 3:35 ` Jamin Lin via
2025-02-13 3:35 ` [PATCH v3 11/28] hw/intc/aspeed: Introduce IRQ handler function to reduce code duplication Jamin Lin via
2025-02-13 3:35 ` Jamin Lin via
2025-02-18 9:17 ` Cédric Le Goater
2025-02-20 3:14 ` Jamin Lin
2025-02-13 3:35 ` [PATCH v3 12/28] hw/intc/aspeed: Add Support for Multi-Output IRQ Handling Jamin Lin via
2025-02-13 3:35 ` [PATCH v3 13/28] hw/intc/aspeed: Add Support for AST2700 INTCIO Controller Jamin Lin via
2025-02-13 3:35 ` Jamin Lin via
2025-02-18 9:15 ` Cédric Le Goater
2025-02-20 5:57 ` Jamin Lin
2025-02-13 3:35 ` [PATCH v3 14/28] hw/misc/aspeed_scu: Add Support for AST2700/AST2750 A1 Silicon Revisions Jamin Lin via
2025-02-18 6:35 ` Cédric Le Goater
2025-02-13 3:35 ` [PATCH v3 15/28] hw/misc/aspeed_scu: Fix the revision ID cannot be set in the SOC layer for AST2700 Jamin Lin via
2025-02-13 3:35 ` Jamin Lin via
2025-02-18 6:47 ` Cédric Le Goater
2025-02-26 6:38 ` Jamin Lin
2025-02-27 9:33 ` Cédric Le Goater
2025-03-03 2:51 ` Jamin Lin
2025-02-13 3:35 ` [PATCH v3 16/28] hw/arm/aspeed_ast27x0.c Support AST2700 A1 GIC Interrupt Mapping Jamin Lin via
2025-02-13 3:35 ` Jamin Lin via
2025-02-13 3:35 ` [PATCH v3 17/28] hw/arm/aspeed_ast27x0: Support two levels of INTC controllers for AST2700 A1 Jamin Lin via
2025-02-13 3:35 ` [PATCH v3 18/28] hw/arm/aspeed: Add SoC and Machine Support " Jamin Lin via
2025-02-18 6:49 ` Cédric Le Goater
2025-02-21 1:37 ` Jamin Lin
2025-02-13 3:35 ` [PATCH v3 19/28] hw/misc/aspeed_hace: Fix coding style Jamin Lin via
2025-02-13 3:35 ` Jamin Lin via
2025-02-18 6:21 ` Cédric Le Goater
2025-02-13 3:35 ` Jamin Lin via [this message]
2025-02-13 3:35 ` [PATCH v3 21/28] hw/misc/aspeed_hace: Fix boot issue in the Crypto Manager Self Test Jamin Lin via
2025-02-13 3:35 ` Jamin Lin via
2025-02-18 6:26 ` Cédric Le Goater
2025-02-21 5:43 ` Jamin Lin
2025-02-21 6:55 ` Jamin Lin
2025-02-21 13:53 ` Cédric Le Goater
2025-02-24 5:10 ` Jamin Lin
2025-02-13 3:35 ` [PATCH v3 22/28] hw/arm/aspeed_ast27x0: Add HACE support for AST2700 Jamin Lin via
2025-02-13 3:35 ` Jamin Lin via
2025-02-13 3:35 ` [PATCH v3 23/28] test/functional/aspeed: Introduce new function to fetch assets Jamin Lin via
2025-02-18 6:30 ` Cédric Le Goater
2025-02-21 1:35 ` Jamin Lin
2025-02-13 3:35 ` [PATCH v3 24/28] tests/functional/aspeed: Introduce start_ast2700_test API and update hwmon path Jamin Lin via
2025-02-13 3:35 ` Jamin Lin via
2025-02-13 3:35 ` [PATCH v3 25/28] tests/functional/aspeed: Update test ASPEED SDK v09.05 Jamin Lin via
2025-02-13 3:35 ` [PATCH v3 26/28] tests/functional/aspeed: Renamed test case and machine for AST2700 A0 Jamin Lin via
2025-02-13 3:35 ` Jamin Lin via
2025-02-13 3:35 ` [PATCH v3 27/28] tests/functional/aspeed: Add test case for AST2700 A1 Jamin Lin via
2025-02-13 3:35 ` Jamin Lin via
2025-02-13 3:35 ` [PATCH v3 28/28] docs/specs: add aspeed-intc Jamin Lin via
2025-02-18 9:25 ` [PATCH v3 00/28] Support AST2700 A1 Cédric Le Goater
2025-02-20 5:11 ` Jamin Lin
2025-02-21 17:24 ` Cédric Le Goater
2025-02-25 8:02 ` Jamin Lin
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20250213033531.3367697-21-jamin_lin@aspeedtech.com \
--to=qemu-devel@nongnu.org \
--cc=andrew@codeconstruct.com.au \
--cc=clg@kaod.org \
--cc=jamin_lin@aspeedtech.com \
--cc=joel@jms.id.au \
--cc=leetroy@gmail.com \
--cc=peter.maydell@linaro.org \
--cc=qemu-arm@nongnu.org \
--cc=steven_lee@aspeedtech.com \
--cc=troy_lee@aspeedtech.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.