All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH mm 1/1] filemap: Remove redundant folio_test_large check in filemap_free_folio
@ 2025-02-13  5:56 'Guanjun'
  2025-02-13 13:00 ` David Hildenbrand
  0 siblings, 1 reply; 2+ messages in thread
From: 'Guanjun' @ 2025-02-13  5:56 UTC (permalink / raw)
  To: willy, akpm, linux-fsdevel, linux-mm, linux-kernel; +Cc: guanjun

From: Guanjun <guanjun@linux.alibaba.com>

The folio_test_large check in filemap_free_folio is unnecessary because
folio_nr_pages, which is called internally, already performs this check.
Removing the redundant condition simplifies the code and avoids double
validation.

This change improves code readability and reduces unnecessary operations
in the folio freeing path.

Signed-off-by: Guanjun <guanjun@linux.alibaba.com>
---
 mm/filemap.c | 5 +----
 1 file changed, 1 insertion(+), 4 deletions(-)

diff --git a/mm/filemap.c b/mm/filemap.c
index 804d7365680c..2b860b59a521 100644
--- a/mm/filemap.c
+++ b/mm/filemap.c
@@ -227,15 +227,12 @@ void __filemap_remove_folio(struct folio *folio, void *shadow)
 void filemap_free_folio(struct address_space *mapping, struct folio *folio)
 {
 	void (*free_folio)(struct folio *);
-	int refs = 1;
 
 	free_folio = mapping->a_ops->free_folio;
 	if (free_folio)
 		free_folio(folio);
 
-	if (folio_test_large(folio))
-		refs = folio_nr_pages(folio);
-	folio_put_refs(folio, refs);
+	folio_put_refs(folio, folio_nr_pages(folio));
 }
 
 /**
-- 
2.43.5


^ permalink raw reply related	[flat|nested] 2+ messages in thread

end of thread, other threads:[~2025-02-13 13:00 UTC | newest]

Thread overview: 2+ messages (download: mbox.gz follow: Atom feed
-- links below jump to the message on this page --
2025-02-13  5:56 [PATCH mm 1/1] filemap: Remove redundant folio_test_large check in filemap_free_folio 'Guanjun'
2025-02-13 13:00 ` David Hildenbrand

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.