All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH v2 0/3] btrfs: random code cleanup
@ 2025-03-11  8:13 Sun YangKai
  2025-03-11  8:13 ` [PATCH v2 1/3] btrfs: simplify the return value handling in search_ioctl() Sun YangKai
                   ` (3 more replies)
  0 siblings, 4 replies; 5+ messages in thread
From: Sun YangKai @ 2025-03-11  8:13 UTC (permalink / raw)
  To: linux-btrfs; +Cc: David Sterba, Sun YangKai

These patches are not intended to change any behavior of current code.
Just trying to make the codes easier to read, and, maybe, perform better.
I'm working on btrfs_search_forward(), trying to improve it and fix some
misbehaviors. And I'll send some patches that will change the behavior of
the code later.

I'm new to the maillist, trying to read the implements, and improve it from
my perspective.
If you have any feedback or questions, please let me know :)

--
Changelog
v2:
- Improve the commit messages advised by David Sterba
- Fix some code style issues advised by David Sterba

Sun YangKai (3):
  btrfs: simplify the return value handling in search_ioctl()
  btrfs: remove the unnecessary local variable in btrfs_search_forward()
  btrfs: avoid redundant slot assignment in btrfs_search_forward()

 fs/btrfs/ctree.c | 15 ++++++---------
 fs/btrfs/ioctl.c | 15 +++++++--------
 2 files changed, 13 insertions(+), 17 deletions(-)

-- 
2.48.1


^ permalink raw reply	[flat|nested] 5+ messages in thread

end of thread, other threads:[~2025-03-11 19:08 UTC | newest]

Thread overview: 5+ messages (download: mbox.gz follow: Atom feed
-- links below jump to the message on this page --
2025-03-11  8:13 [PATCH v2 0/3] btrfs: random code cleanup Sun YangKai
2025-03-11  8:13 ` [PATCH v2 1/3] btrfs: simplify the return value handling in search_ioctl() Sun YangKai
2025-03-11  8:13 ` [PATCH v2 2/3] btrfs: remove the unnecessary local variable in btrfs_search_forward() Sun YangKai
2025-03-11  8:13 ` [PATCH v2 3/3] btrfs: avoid redundant slot assignment " Sun YangKai
2025-03-11 19:07 ` [PATCH v2 0/3] btrfs: random code cleanup David Sterba

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.