From: Wei Yang <richard.weiyang@gmail.com>
To: Zi Yan <ziy@nvidia.com>
Cc: Wei Yang <richard.weiyang@gmail.com>,
akpm@linux-foundation.org, david@kernel.org,
lorenzo.stoakes@oracle.com, baolin.wang@linux.alibaba.com,
Liam.Howlett@oracle.com, npache@redhat.com, ryan.roberts@arm.com,
dev.jain@arm.com, baohua@kernel.org, lance.yang@linux.dev,
linux-mm@kvack.org
Subject: Re: [Patch v3 2/2] mm/huge_memory: merge uniform_split_supported() and non_uniform_split_supported()
Date: Fri, 7 Nov 2025 01:17:21 +0000 [thread overview]
Message-ID: <20251107011721.ez6pile62o3vmjz3@master> (raw)
In-Reply-To: <0D94CF57-A9C9-4C01-A9E5-CE47AE3F10EB@nvidia.com>
On Thu, Nov 06, 2025 at 07:46:14PM -0500, Zi Yan wrote:
>On 5 Nov 2025, at 22:41, Wei Yang wrote:
>
>> The functions uniform_split_supported() and
>> non_uniform_split_supported() share significantly similar logic.
>>
>> The only functional difference is that uniform_split_supported()
>> includes an additional check on the requested @new_order.
>>
>> The reason for this check comes from the following two aspects:
>>
>> * some file system or swap cache just supports order-0 folio
>> * the behavioral difference between uniform/non-uniform split
>>
>> The behavioral difference between uniform split and non-uniform:
>>
>> * uniform split splits folio directly to @new_order
>> * non-uniform split creates after-split folios with orders from
>> folio_order(folio) - 1 to new_order.
>>
>> This means for non-uniform split or !new_order split we should check the
>> file system and swap cache respectively.
>>
>> This commit unifies the logic and merge the two functions into a single
>> combined helper, removing redundant code and simplifying the split
>> support checking mechanism.
>>
>> Signed-off-by: Wei Yang <richard.weiyang@gmail.com>
>> Cc: Zi Yan <ziy@nvidia.com>
>> Cc: "David Hildenbrand (Red Hat)" <david@kernel.org>
>>
>> ---
>> v3:
>> * adjust to use split_type
>> * rebase on Zi Yan fix lkml.kernel.org/r/20251105162910.752266-1-ziy@nvidia.com
>> v2:
>> * remove need_check
>> * update comment
>> * add more explanation in change log
>> ---
>> include/linux/huge_mm.h | 8 ++---
>> mm/huge_memory.c | 71 +++++++++++++++++------------------------
>> 2 files changed, 33 insertions(+), 46 deletions(-)
>>
>LGTM. Thanks. Reviewed-by: Zi Yan <ziy@nvidia.com>
Hi, Zi
I am thinking whether it is proper to move the check (new_order < min_order)
from __folio_split() to folio_split_supported(). So that we could bail out
early if file system couldn't split to new_order.
Not sure you like it or not.
--
Wei Yang
Help you, Help me
next prev parent reply other threads:[~2025-11-07 1:17 UTC|newest]
Thread overview: 32+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-11-06 3:41 [Patch v3 0/2] mm/huge_memory: Define split_type and consolidate split support checks Wei Yang
2025-11-06 3:41 ` [Patch v3 1/2] mm/huge_memory: introduce enum split_type for clarity Wei Yang
2025-11-06 10:17 ` David Hildenbrand (Red Hat)
2025-11-06 14:57 ` Wei Yang
2025-11-07 0:44 ` Zi Yan
2025-11-06 3:41 ` [Patch v3 2/2] mm/huge_memory: merge uniform_split_supported() and non_uniform_split_supported() Wei Yang
2025-11-06 10:20 ` David Hildenbrand (Red Hat)
2025-11-07 0:46 ` Zi Yan
2025-11-07 1:17 ` Wei Yang [this message]
2025-11-07 2:07 ` Zi Yan
2025-11-07 2:49 ` Wei Yang
2025-11-07 3:21 ` Zi Yan
2025-11-07 7:29 ` Wei Yang
2025-11-14 3:03 ` Wei Yang
2025-11-17 1:22 ` Wei Yang
2025-11-17 15:56 ` Zi Yan
2025-11-18 2:10 ` Wei Yang
2025-11-18 3:33 ` Wei Yang
2025-11-18 4:10 ` Zi Yan
2025-11-18 18:32 ` Andrew Morton
2025-11-18 18:55 ` Zi Yan
2025-11-18 22:06 ` Andrew Morton
2025-11-19 0:52 ` Wei Yang
2025-11-20 21:16 ` Andrew Morton
2025-11-21 0:55 ` Zi Yan
2025-11-21 9:00 ` Wei Yang
2025-11-21 14:59 ` Zi Yan
2025-11-21 16:50 ` Andrew Morton
2025-11-21 17:00 ` Zi Yan
2025-11-21 18:39 ` Andrew Morton
2025-11-21 19:09 ` Zi Yan
2025-11-21 19:15 ` Andrew Morton
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20251107011721.ez6pile62o3vmjz3@master \
--to=richard.weiyang@gmail.com \
--cc=Liam.Howlett@oracle.com \
--cc=akpm@linux-foundation.org \
--cc=baohua@kernel.org \
--cc=baolin.wang@linux.alibaba.com \
--cc=david@kernel.org \
--cc=dev.jain@arm.com \
--cc=lance.yang@linux.dev \
--cc=linux-mm@kvack.org \
--cc=lorenzo.stoakes@oracle.com \
--cc=npache@redhat.com \
--cc=ryan.roberts@arm.com \
--cc=ziy@nvidia.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.