All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH 00/33] accel: Unassorted cleanups around debugging
@ 2026-06-30 22:00 Philippe Mathieu-Daudé
  2026-06-30 22:00 ` [PATCH 01/33] cpu: Constify CPUState::cc (cached CPUClass pointer) Philippe Mathieu-Daudé
                   ` (32 more replies)
  0 siblings, 33 replies; 93+ messages in thread
From: Philippe Mathieu-Daudé @ 2026-06-30 22:00 UTC (permalink / raw)
  To: qemu-devel
  Cc: qemu-s390x, Peter Maydell, Alex Bennée, Paolo Bonzini,
	Xiaoyao Li, Chao Liu, Zhao Liu, Daniel Henrique Barboza, qemu-ppc,
	Richard Henderson

Refreshing the `split-accel' preparatory work; this series follows
"accel: Preparatory cleanups for split-accel" from last year:
https://lore.kernel.org/qemu-devel/20250703173248.44995-1-philmd@linaro.org/

Nothing really noteworthy here, generic code refactoring with the
objective to strengthen the various APIs, introducing few enums or
headers.

Philippe Mathieu-Daudé (33):
  cpu: Constify CPUState::cc (cached CPUClass pointer)
  target/i386: Remove duplicate tlb_flush() call in cpu_post_load()
  accel/tcg: Restrict tlb_protect/unprotect_code() to TCG
  accel/hvf: Remove left-over comment
  accel/mshv: Replace @dirty field by generic CPUState::vcpu_dirty field
  gdbstub: Add trace event for STEP packet handler
  gdbstub: Only return E22 when reverse GDB is not supported
  accel/kvm: Always define AccelOpsClass::supports_guest_debug
  accel/kvm: Simplify kvm_init() w.r.t. TARGET_KVM_HAVE_GUEST_DEBUG
  accel: Change gdbstub_supported_sstep_flags() -> get_gdbstub_config()
  gdbstub: Store @can_reverse in GDBState
  gdbstub: Make default replay_mode value explicit in stubs
  accel: Have get_gdbstub_config() return @can_reverse value
  accel: Move supports_guest_debug() declaration to AccelClass
  accel/kvm: Hold have_guest_supported in KVMState
  accel/kvm: Hold gdbstub_sstep_flags in KVMState
  cpu: Move BREAKPOINT definitions to 'exec/breakpoint.h'
  cpu: Define BreakpointFlags type
  accel: Remove unnecessary 'inline' qualifier in remove_all_breakpoints
  gdbstub/user: Directly call gdb_breakpoint_remove_all() in user mode
  gdbstub: Reduce @type variable scope
  gdbstub: Introduce GdbBreakpointType enumerator
  accel: Use GdbBreakpointType enum
  target/arm: Inline check_watchpoints() in arm_debug_check_watchpoint()
  target/arm: Factor arm_check_watchpoint_hit() out
  target/xtensa: Move watchpoints handling to check_hw_watchpoints()
  target/ppc: Ensure TCG is used in ppc_update_daw()
  accel/tcg: Improve docstrings around TCGCPUOps::*watchpoint* handlers
  cpu: Move CPUWatchpoint definition to 'exec/watchpoint.h'
  cpu: Better name cpu_single_step() trace event
  cpu: Introduce cpu_single_stepping() helper
  cpu: Rename CPUState @singlestep_enabled -> @singlestep_flags
  cpu: Only check SSTEP_ENABLE flag in cpu_single_stepping()

 accel/kvm/kvm-cpus.h               | 12 +++--
 accel/tcg/system-page-protection.h | 17 +++++++
 gdbstub/internals.h                | 10 ++--
 include/accel/accel-cpu-ops.h      | 10 ++--
 include/accel/accel-ops.h          |  4 +-
 include/accel/tcg/cpu-ops.h        | 12 +++--
 include/exec/breakpoint.h          | 26 ++++++----
 include/exec/cputlb.h              |  8 +--
 include/exec/watchpoint.h          | 20 ++++++--
 include/gdbstub/enums.h            | 12 +++--
 include/hw/core/cpu.h              | 42 ++++++++--------
 include/qemu/accel.h               | 10 ++--
 include/system/hvf_int.h           | 11 ++--
 include/system/kvm.h               |  9 ++--
 include/system/kvm_int.h           |  2 +
 include/system/mshv_int.h          |  1 -
 include/system/whpx-all.h          |  4 +-
 target/arm/internals.h             |  6 ++-
 accel/accel-common.c               | 22 ++++++--
 accel/hvf/hvf-accel-ops.c          | 23 ++++-----
 accel/hvf/hvf-all.c                |  9 ++--
 accel/kvm/kvm-accel-ops.c          |  7 ++-
 accel/kvm/kvm-all.c                | 55 +++++++++++---------
 accel/mshv/mshv-all.c              | 18 +++----
 accel/tcg/cpu-exec-common.c        |  2 +-
 accel/tcg/cpu-exec.c               | 12 ++---
 accel/tcg/cputlb.c                 | 15 +++---
 accel/tcg/tb-maint.c               |  1 +
 accel/tcg/tcg-accel-ops-rr.c       |  2 +-
 accel/tcg/tcg-accel-ops.c          | 31 ++++++------
 accel/tcg/tcg-all.c                | 16 ++++--
 accel/tcg/translate-all.c          |  3 +-
 accel/tcg/user-exec-stub.c         | 11 ++--
 accel/tcg/watchpoint.c             |  9 ++--
 accel/whpx/whpx-accel-ops.c        |  7 ---
 accel/whpx/whpx-common.c           |  1 +
 cpu-common.c                       |  8 +--
 cpu-target.c                       | 10 ++--
 gdbstub/gdbstub.c                  | 11 ++--
 gdbstub/system.c                   | 39 ++++++--------
 gdbstub/user.c                     | 20 ++------
 linux-user/riscv/cpu_loop.c        |  2 +-
 linux-user/s390x/cpu_loop.c        |  2 +-
 stubs/replay-mode.c                |  2 +-
 system/cpus.c                      |  2 +-
 system/watchpoint.c                |  8 +--
 target/arm/hvf/hvf.c               | 24 +++++----
 target/arm/hyp_gdbstub.c           |  9 ++--
 target/arm/kvm.c                   | 14 +++---
 target/arm/tcg/debug.c             | 81 +++++++++++++++---------------
 target/arm/tcg/mte_helper.c        |  3 +-
 target/arm/whpx/whpx-all.c         |  2 +-
 target/i386/hvf/hvf.c              | 10 ++--
 target/i386/kvm/kvm.c              | 15 +++---
 target/i386/machine.c              |  1 -
 target/i386/mshv/mshv-cpu.c        |  6 +--
 target/i386/whpx/whpx-all.c        |  8 +--
 target/loongarch/kvm/kvm.c         | 10 ++--
 target/microblaze/translate.c      |  2 +-
 target/ppc/cpu.c                   |  4 +-
 target/ppc/kvm.c                   | 20 +++++---
 target/ppc/translate.c             | 16 +++---
 target/riscv/cpu_helper.c          |  2 +-
 target/riscv/debug.c               | 12 ++---
 target/riscv/kvm/kvm-cpu.c         |  8 +--
 target/s390x/kvm/kvm.c             | 11 ++--
 target/s390x/tcg/debug.c           |  3 +-
 target/xtensa/dbg_helper.c         |  2 +-
 target/xtensa/helper.c             | 36 ++++++-------
 trace-events                       |  2 +-
 70 files changed, 477 insertions(+), 388 deletions(-)
 create mode 100644 accel/tcg/system-page-protection.h

-- 
2.53.0



^ permalink raw reply	[flat|nested] 93+ messages in thread

end of thread, other threads:[~2026-07-03  3:14 UTC | newest]

Thread overview: 93+ messages (download: mbox.gz follow: Atom feed
-- links below jump to the message on this page --
2026-06-30 22:00 [PATCH 00/33] accel: Unassorted cleanups around debugging Philippe Mathieu-Daudé
2026-06-30 22:00 ` [PATCH 01/33] cpu: Constify CPUState::cc (cached CPUClass pointer) Philippe Mathieu-Daudé
2026-07-02 13:16   ` Daniel Henrique Barboza
2026-07-02 16:08   ` Richard Henderson
2026-07-03  0:41   ` Chao Liu
2026-06-30 22:00 ` [PATCH 02/33] target/i386: Remove duplicate tlb_flush() call in cpu_post_load() Philippe Mathieu-Daudé
2026-07-02 16:27   ` Richard Henderson
2026-07-03  0:42   ` Chao Liu
2026-06-30 22:00 ` [PATCH 03/33] accel/tcg: Restrict tlb_protect/unprotect_code() to TCG Philippe Mathieu-Daudé
2026-07-02 13:17   ` Daniel Henrique Barboza
2026-07-02 16:29   ` Richard Henderson
2026-07-03  3:13   ` Chao Liu
2026-06-30 22:00 ` [PATCH 04/33] accel/hvf: Remove left-over comment Philippe Mathieu-Daudé
2026-07-02 13:36   ` Daniel Henrique Barboza
2026-07-02 16:29   ` Richard Henderson
2026-06-30 22:00 ` [PATCH 05/33] accel/mshv: Replace @dirty field by generic CPUState::vcpu_dirty field Philippe Mathieu-Daudé
2026-07-02 13:00   ` Philippe Mathieu-Daudé
2026-07-02 13:41     ` Magnus Kulke
2026-07-02 16:56   ` Richard Henderson
2026-06-30 22:00 ` [PATCH 06/33] gdbstub: Add trace event for STEP packet handler Philippe Mathieu-Daudé
2026-07-02 13:18   ` Daniel Henrique Barboza
2026-07-02 13:25   ` Alex Bennée
2026-06-30 22:00 ` [PATCH 07/33] gdbstub: Only return E22 when reverse GDB is not supported Philippe Mathieu-Daudé
2026-07-02 13:18   ` Daniel Henrique Barboza
2026-07-02 13:26   ` Alex Bennée
2026-06-30 22:00 ` [PATCH 08/33] accel/kvm: Always define AccelOpsClass::supports_guest_debug Philippe Mathieu-Daudé
2026-07-02 13:19   ` Daniel Henrique Barboza
2026-07-02 17:16   ` Richard Henderson
2026-06-30 22:00 ` [PATCH 09/33] accel/kvm: Simplify kvm_init() w.r.t. TARGET_KVM_HAVE_GUEST_DEBUG Philippe Mathieu-Daudé
2026-07-02 17:18   ` Richard Henderson
2026-06-30 22:00 ` [PATCH 10/33] accel: Change gdbstub_supported_sstep_flags() -> get_gdbstub_config() Philippe Mathieu-Daudé
2026-07-02 13:50   ` Alex Bennée
2026-07-02 13:58     ` Philippe Mathieu-Daudé
2026-06-30 22:00 ` [PATCH 11/33] gdbstub: Store @can_reverse in GDBState Philippe Mathieu-Daudé
2026-07-02 13:20   ` Daniel Henrique Barboza
2026-06-30 22:00 ` [PATCH 12/33] gdbstub: Make default replay_mode value explicit in stubs Philippe Mathieu-Daudé
2026-07-02 17:21   ` Richard Henderson
2026-06-30 22:00 ` [PATCH 13/33] accel: Have get_gdbstub_config() return @can_reverse value Philippe Mathieu-Daudé
2026-06-30 22:00 ` [PATCH 14/33] accel: Move supports_guest_debug() declaration to AccelClass Philippe Mathieu-Daudé
2026-07-02 17:29   ` Richard Henderson
2026-06-30 22:00 ` [PATCH 15/33] accel/kvm: Hold have_guest_supported in KVMState Philippe Mathieu-Daudé
2026-07-02 13:22   ` Daniel Henrique Barboza
2026-07-02 17:37   ` Richard Henderson
2026-06-30 22:00 ` [PATCH 16/33] accel/kvm: Hold gdbstub_sstep_flags " Philippe Mathieu-Daudé
2026-07-02 13:22   ` Daniel Henrique Barboza
2026-07-02 17:42   ` Richard Henderson
2026-06-30 22:00 ` [PATCH 17/33] cpu: Move BREAKPOINT definitions to 'exec/breakpoint.h' Philippe Mathieu-Daudé
2026-07-02 13:24   ` Daniel Henrique Barboza
2026-07-02 17:43   ` Richard Henderson
2026-06-30 22:00 ` [PATCH 18/33] cpu: Define BreakpointFlags type Philippe Mathieu-Daudé
2026-07-02 13:26   ` Daniel Henrique Barboza
2026-07-02 13:57     ` Philippe Mathieu-Daudé
2026-07-02 17:44   ` Richard Henderson
2026-06-30 22:00 ` [PATCH 19/33] accel: Remove unnecessary 'inline' qualifier in remove_all_breakpoints Philippe Mathieu-Daudé
2026-07-02 13:27   ` Daniel Henrique Barboza
2026-07-02 17:45   ` Richard Henderson
2026-06-30 22:00 ` [PATCH 20/33] gdbstub/user: Directly call gdb_breakpoint_remove_all() in user mode Philippe Mathieu-Daudé
2026-07-02 13:27   ` Daniel Henrique Barboza
2026-07-02 17:46   ` Richard Henderson
2026-06-30 22:00 ` [PATCH 21/33] gdbstub: Reduce @type variable scope Philippe Mathieu-Daudé
2026-07-02 13:27   ` Daniel Henrique Barboza
2026-07-02 17:47   ` Richard Henderson
2026-06-30 22:00 ` [PATCH 22/33] gdbstub: Introduce GdbBreakpointType enumerator Philippe Mathieu-Daudé
2026-07-02 13:29   ` Daniel Henrique Barboza
2026-07-02 13:53     ` Philippe Mathieu-Daudé
2026-07-02 17:50   ` Richard Henderson
2026-06-30 22:00 ` [PATCH 23/33] accel: Use GdbBreakpointType enum Philippe Mathieu-Daudé
2026-07-02 13:31   ` Daniel Henrique Barboza
2026-07-02 17:52   ` Richard Henderson
2026-06-30 22:00 ` [PATCH 24/33] target/arm: Inline check_watchpoints() in arm_debug_check_watchpoint() Philippe Mathieu-Daudé
2026-07-02 17:53   ` Richard Henderson
2026-06-30 22:00 ` [PATCH 25/33] target/arm: Factor arm_check_watchpoint_hit() out Philippe Mathieu-Daudé
2026-07-02 18:02   ` Richard Henderson
2026-06-30 22:00 ` [PATCH 26/33] target/xtensa: Move watchpoints handling to check_hw_watchpoints() Philippe Mathieu-Daudé
2026-07-02 18:06   ` Richard Henderson
2026-06-30 22:00 ` [PATCH 27/33] target/ppc: Ensure TCG is used in ppc_update_daw() Philippe Mathieu-Daudé
2026-07-02 13:34   ` Daniel Henrique Barboza
2026-06-30 22:00 ` [PATCH 28/33] accel/tcg: Improve docstrings around TCGCPUOps::*watchpoint* handlers Philippe Mathieu-Daudé
2026-07-02 13:34   ` Daniel Henrique Barboza
2026-07-02 18:04   ` Richard Henderson
2026-06-30 22:00 ` [PATCH 29/33] cpu: Move CPUWatchpoint definition to 'exec/watchpoint.h' Philippe Mathieu-Daudé
2026-07-02 18:06   ` Richard Henderson
2026-06-30 22:00 ` [PATCH 30/33] cpu: Better name cpu_single_step() trace event Philippe Mathieu-Daudé
2026-07-02 13:35   ` Daniel Henrique Barboza
2026-06-30 22:00 ` [PATCH 31/33] cpu: Introduce cpu_single_stepping() helper Philippe Mathieu-Daudé
2026-07-02 18:11   ` Richard Henderson
2026-06-30 22:00 ` [PATCH 32/33] cpu: Rename CPUState @singlestep_enabled -> @singlestep_flags Philippe Mathieu-Daudé
2026-07-02 18:11   ` Richard Henderson
2026-07-03  1:27   ` Xiaoyao Li
2026-07-03  1:50     ` Philippe Mathieu-Daudé
2026-06-30 22:01 ` [PATCH 33/33] cpu: Only check SSTEP_ENABLE flag in cpu_single_stepping() Philippe Mathieu-Daudé
2026-07-02 13:36   ` Daniel Henrique Barboza
2026-07-02 18:11   ` Richard Henderson

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.