All of lore.kernel.org
 help / color / mirror / Atom feed
From: sashiko-bot@kernel.org
To: "Komal Bajaj" <komal.bajaj@oss.qualcomm.com>
Cc: conor+dt@kernel.org, devicetree@vger.kernel.org,
	neil.armstrong@linaro.org, robh@kernel.org, vkoul@kernel.org,
	linux-phy@lists.infradead.org, olteanv@gmail.com
Subject: Re: [PATCH v7 4/5] arm64: dts: qcom: Add Shikra IQ2390S SoM platform
Date: Wed, 08 Jul 2026 12:30:58 +0000	[thread overview]
Message-ID: <20260708123058.887D01F000E9@smtp.kernel.org> (raw)
In-Reply-To: <20260708-shikra-dt-v7-4-977b65a300c1@oss.qualcomm.com>

Thank you for your contribution! Sashiko AI review found 1 potential issue(s) to consider:
- [Low] The top-level GPIO keys node is incorrectly named `gpio-key` instead of the standard `gpio-keys`.
--

--- Patch [4]: [PATCH v7 4/5] arm64: dts: qcom: Add Shikra IQ2390S SoM platform ---
commit e39fa2dd470c78fd482e4061f2bce87250dda523
Author: Komal Bajaj <komal.bajaj@oss.qualcomm.com>

arm64: dts: qcom: Add Shikra IQ2390S SoM platform

This commit adds the device tree include for the IQ2390S variant of the
Shikra System-on-Module. It includes the common shikra.dtsi and adds
PM8150 PMIC regulator definitions specific to this variant.

> diff --git a/arch/arm64/boot/dts/qcom/shikra-iqs-som.dtsi b/arch/arm64/boot/dts/qcom/shikra-iqs-som.dtsi
> new file mode 100644
> index 0000000000000..73945bf42112d
> --- /dev/null
> +++ b/arch/arm64/boot/dts/qcom/shikra-iqs-som.dtsi
> @@ -0,0 +1,170 @@
> +// SPDX-License-Identifier: BSD-3-Clause
> +/*
> + * Copyright (c) Qualcomm Technologies, Inc. and/or its subsidiaries.
> + */
> +
> +#include <dt-bindings/gpio/gpio.h>
> +#include <dt-bindings/pinctrl/qcom,pmic-gpio.h>
> +
> +#include "shikra.dtsi"
> +#include "pm8150.dtsi"
> +
> +/ {
> +	gpio-key {
> +		compatible = "gpio-keys";

[Severity: Low]
This isn't a bug, but is this top-level node named correctly? Devicetree
conventions typically use standard generic names like gpio-keys across the
subsystem rather than the singular gpio-key. 

> +		label = "gpio-keys";
> +		pinctrl-names = "default";
> +		pinctrl-0 = <&vol_up_n>;

[ ... ]

-- 
Sashiko AI review · https://sashiko.dev/#/patchset/20260708-shikra-dt-v7-0-977b65a300c1@oss.qualcomm.com?part=4

WARNING: multiple messages have this Message-ID (diff)
From: sashiko-bot@kernel.org
To: "Komal Bajaj" <komal.bajaj@oss.qualcomm.com>
Cc: conor+dt@kernel.org, devicetree@vger.kernel.org,
	neil.armstrong@linaro.org, robh@kernel.org, vkoul@kernel.org,
	linux-phy@lists.infradead.org, olteanv@gmail.com
Subject: Re: [PATCH v7 4/5] arm64: dts: qcom: Add Shikra IQ2390S SoM platform
Date: Wed, 08 Jul 2026 12:30:58 +0000	[thread overview]
Message-ID: <20260708123058.887D01F000E9@smtp.kernel.org> (raw)
In-Reply-To: <20260708-shikra-dt-v7-4-977b65a300c1@oss.qualcomm.com>

Thank you for your contribution! Sashiko AI review found 1 potential issue(s) to consider:
- [Low] The top-level GPIO keys node is incorrectly named `gpio-key` instead of the standard `gpio-keys`.
--

--- Patch [4]: [PATCH v7 4/5] arm64: dts: qcom: Add Shikra IQ2390S SoM platform ---
commit e39fa2dd470c78fd482e4061f2bce87250dda523
Author: Komal Bajaj <komal.bajaj@oss.qualcomm.com>

arm64: dts: qcom: Add Shikra IQ2390S SoM platform

This commit adds the device tree include for the IQ2390S variant of the
Shikra System-on-Module. It includes the common shikra.dtsi and adds
PM8150 PMIC regulator definitions specific to this variant.

> diff --git a/arch/arm64/boot/dts/qcom/shikra-iqs-som.dtsi b/arch/arm64/boot/dts/qcom/shikra-iqs-som.dtsi
> new file mode 100644
> index 0000000000000..73945bf42112d
> --- /dev/null
> +++ b/arch/arm64/boot/dts/qcom/shikra-iqs-som.dtsi
> @@ -0,0 +1,170 @@
> +// SPDX-License-Identifier: BSD-3-Clause
> +/*
> + * Copyright (c) Qualcomm Technologies, Inc. and/or its subsidiaries.
> + */
> +
> +#include <dt-bindings/gpio/gpio.h>
> +#include <dt-bindings/pinctrl/qcom,pmic-gpio.h>
> +
> +#include "shikra.dtsi"
> +#include "pm8150.dtsi"
> +
> +/ {
> +	gpio-key {
> +		compatible = "gpio-keys";

[Severity: Low]
This isn't a bug, but is this top-level node named correctly? Devicetree
conventions typically use standard generic names like gpio-keys across the
subsystem rather than the singular gpio-key. 

> +		label = "gpio-keys";
> +		pinctrl-names = "default";
> +		pinctrl-0 = <&vol_up_n>;

[ ... ]

-- 
Sashiko AI review · https://sashiko.dev/#/patchset/20260708-shikra-dt-v7-0-977b65a300c1@oss.qualcomm.com?part=4

-- 
linux-phy mailing list
linux-phy@lists.infradead.org
https://lists.infradead.org/mailman/listinfo/linux-phy

  reply	other threads:[~2026-07-08 12:30 UTC|newest]

Thread overview: 18+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2026-07-08 12:17 [PATCH v7 0/5] arm64: dts: qcom: Add initial device tree support for Shikra Komal Bajaj
2026-07-08 12:17 ` Komal Bajaj
2026-07-08 12:17 ` [PATCH v7 1/5] dt-bindings: arm: qcom: Document Shikra and its EVK boards Komal Bajaj
2026-07-08 12:17   ` Komal Bajaj
2026-07-08 12:17 ` [PATCH v7 2/5] arm64: dts: qcom: Introduce Shikra SoC base dtsi Komal Bajaj
2026-07-08 12:17   ` Komal Bajaj
2026-07-14 21:58   ` Rob Herring
2026-07-14 21:58     ` Rob Herring
2026-07-08 12:17 ` [PATCH v7 3/5] arm64: dts: qcom: Add Shikra CQ2390M SoM platform Komal Bajaj
2026-07-08 12:17   ` Komal Bajaj
2026-07-08 12:17 ` [PATCH v7 4/5] arm64: dts: qcom: Add Shikra IQ2390S " Komal Bajaj
2026-07-08 12:17   ` Komal Bajaj
2026-07-08 12:30   ` sashiko-bot [this message]
2026-07-08 12:30     ` sashiko-bot
2026-07-08 12:17 ` [PATCH v7 5/5] arm64: dts: qcom: Add Shikra EVK boards Komal Bajaj
2026-07-08 12:17   ` Komal Bajaj
2026-07-08 12:26   ` sashiko-bot
2026-07-08 12:26     ` sashiko-bot

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20260708123058.887D01F000E9@smtp.kernel.org \
    --to=sashiko-bot@kernel.org \
    --cc=conor+dt@kernel.org \
    --cc=devicetree@vger.kernel.org \
    --cc=komal.bajaj@oss.qualcomm.com \
    --cc=linux-phy@lists.infradead.org \
    --cc=neil.armstrong@linaro.org \
    --cc=olteanv@gmail.com \
    --cc=robh@kernel.org \
    --cc=sashiko-reviews@lists.linux.dev \
    --cc=vkoul@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.