From: sashiko-bot@kernel.org
To: "Sebastian Reichel" <sebastian.reichel@collabora.com>
Cc: conor+dt@kernel.org, vkoul@kernel.org,
devicetree@vger.kernel.org, linux-phy@lists.infradead.org,
neil.armstrong@linaro.org, olteanv@gmail.com, robh@kernel.org
Subject: Re: [PATCH v11 33/36] phy: rockchip: usbdp: Rename mode to hw_mode
Date: Thu, 09 Jul 2026 19:35:10 +0000 [thread overview]
Message-ID: <20260709193511.49EDA1F000E9@smtp.kernel.org> (raw)
In-Reply-To: <20260709-rockchip-usbdp-cleanup-v11-33-a149ac60f76c@collabora.com>
Thank you for your contribution! Sashiko AI review found 2 potential issue(s) to consider:
Pre-existing issues:
- [High] TYPEC_STATE_USB and TYPEC_STATE_SAFE mux events incorrectly configure the PHY for DisplayPort instead of USB-only.
- [High] rk_udphy_power_off and rk_udphy_usb3_phy_exit incorrectly use hw_mode to bypass power-off, permanently leaking the PHY state and preventing rk_udphy_disable() from being called.
--
--- Patch [33]: [PATCH v11 33/36] phy: rockchip: usbdp: Rename mode to hw_mode ---
commit 6f61047a0ab430913024fc15e4a26038f67189e4
Author: Sebastian Reichel <sebastian.reichel@collabora.com>
phy: rockchip: usbdp: Rename mode to hw_mode
Rename mode field to hw_mode to make clear that this is the modes
currently supported by the hardware, but not necessarily requested
by software. It is only set by either the USB-C state machine
or device-tree if the PHY is used in a fixed routing setup.
> diff --git a/drivers/phy/rockchip/phy-rockchip-usbdp.c b/drivers/phy/rockchip/phy-rockchip-usbdp.c
> index 3fb6eea2979b9..e2cd72643a7d7 100644
> --- a/drivers/phy/rockchip/phy-rockchip-usbdp.c
> +++ b/drivers/phy/rockchip/phy-rockchip-usbdp.c
[ ... ]
> @@ -616,12 +616,12 @@ static void rk_udphy_set_typec_state(struct rk_udphy *udphy, unsigned long state
> udphy->lane_mux_sel[2] = PHY_LANE_MUX_DP;
> udphy->lane_mux_sel[3] = PHY_LANE_MUX_DP;
> }
> - mode = UDPHY_MODE_DP_USB;
> + hw_mode = UDPHY_MODE_DP_USB;
[Severity: High]
This isn't a bug introduced by this patch, but since the switch statement lacks
explicit cases for TYPEC_STATE_USB and TYPEC_STATE_SAFE, do they fall through
to the default case here and incorrectly configure the PHY for DisplayPort
instead of USB-only?
If a standard USB device is connected or the port is in a safe/unattached state,
the Type-C subsystem fires a mux event with state->mode = TYPEC_STATE_USB (or
TYPEC_STATE_SAFE), and it seems they would erroneously be assigned
UDPHY_MODE_DP_USB with two DisplayPort lanes instead of just UDPHY_MODE_USB.
> udphy->dp_lanes = 2;
> break;
> }
[ ... ]
> @@ -1033,7 +1033,7 @@ static int rk_udphy_power_on(struct rk_udphy *udphy, u8 mode)
>
> static void rk_udphy_power_off(struct rk_udphy *udphy, u8 mode)
> {
> - if (!(udphy->mode & mode)) {
> + if (!(udphy->hw_mode & mode)) {
[Severity: High]
This is a pre-existing issue, but does using hw_mode here bypass the power-off
sequence and permanently leak the physical PHY state?
If a Type-C event changes the hardware mode to DP-only (hw_mode =
UDPHY_MODE_DP), the USB mode is dropped. If rk_udphy_power_off() is called
afterwards, this check will bypass physical shutdown since the requested mode
was already removed from hw_mode, preventing rk_udphy_disable() from being
called.
> dev_info(udphy->dev, "mode 0x%02x is not support\n", mode);
> return;
> }
[ ... ]
> @@ -1307,7 +1307,7 @@ static int rk_udphy_usb3_phy_exit(struct phy *phy)
> guard(mutex)(&udphy->mutex);
>
> /* DP only or high-speed */
> - if (!(udphy->mode & UDPHY_MODE_USB) || udphy->hs) {
> + if (!(udphy->hw_mode & UDPHY_MODE_USB) || udphy->hs) {
[Severity: High]
This is a pre-existing issue, but this appears to have the same flaw as
rk_udphy_power_off() above.
When the USB consumer subsequently calls phy_exit(), and hw_mode has already
dropped the USB mode, this returns early without delegating to
rk_udphy_power_off(). If the PHY status reached UDPHY_MODE_NONE,
rk_udphy_disable() is never called, and the PHY remains physically powered on
indefinitely.
> udphy->status &= ~UDPHY_MODE_USB;
> return 0;
> }
--
Sashiko AI review · https://sashiko.dev/#/patchset/20260709-rockchip-usbdp-cleanup-v11-0-a149ac60f76c@collabora.com?part=33
--
linux-phy mailing list
linux-phy@lists.infradead.org
https://lists.infradead.org/mailman/listinfo/linux-phy
WARNING: multiple messages have this Message-ID (diff)
From: sashiko-bot@kernel.org
To: "Sebastian Reichel" <sebastian.reichel@collabora.com>
Cc: conor+dt@kernel.org, vkoul@kernel.org,
devicetree@vger.kernel.org, linux-phy@lists.infradead.org,
neil.armstrong@linaro.org, olteanv@gmail.com, robh@kernel.org
Subject: Re: [PATCH v11 33/36] phy: rockchip: usbdp: Rename mode to hw_mode
Date: Thu, 09 Jul 2026 19:35:10 +0000 [thread overview]
Message-ID: <20260709193511.49EDA1F000E9@smtp.kernel.org> (raw)
In-Reply-To: <20260709-rockchip-usbdp-cleanup-v11-33-a149ac60f76c@collabora.com>
Thank you for your contribution! Sashiko AI review found 2 potential issue(s) to consider:
Pre-existing issues:
- [High] TYPEC_STATE_USB and TYPEC_STATE_SAFE mux events incorrectly configure the PHY for DisplayPort instead of USB-only.
- [High] rk_udphy_power_off and rk_udphy_usb3_phy_exit incorrectly use hw_mode to bypass power-off, permanently leaking the PHY state and preventing rk_udphy_disable() from being called.
--
--- Patch [33]: [PATCH v11 33/36] phy: rockchip: usbdp: Rename mode to hw_mode ---
commit 6f61047a0ab430913024fc15e4a26038f67189e4
Author: Sebastian Reichel <sebastian.reichel@collabora.com>
phy: rockchip: usbdp: Rename mode to hw_mode
Rename mode field to hw_mode to make clear that this is the modes
currently supported by the hardware, but not necessarily requested
by software. It is only set by either the USB-C state machine
or device-tree if the PHY is used in a fixed routing setup.
> diff --git a/drivers/phy/rockchip/phy-rockchip-usbdp.c b/drivers/phy/rockchip/phy-rockchip-usbdp.c
> index 3fb6eea2979b9..e2cd72643a7d7 100644
> --- a/drivers/phy/rockchip/phy-rockchip-usbdp.c
> +++ b/drivers/phy/rockchip/phy-rockchip-usbdp.c
[ ... ]
> @@ -616,12 +616,12 @@ static void rk_udphy_set_typec_state(struct rk_udphy *udphy, unsigned long state
> udphy->lane_mux_sel[2] = PHY_LANE_MUX_DP;
> udphy->lane_mux_sel[3] = PHY_LANE_MUX_DP;
> }
> - mode = UDPHY_MODE_DP_USB;
> + hw_mode = UDPHY_MODE_DP_USB;
[Severity: High]
This isn't a bug introduced by this patch, but since the switch statement lacks
explicit cases for TYPEC_STATE_USB and TYPEC_STATE_SAFE, do they fall through
to the default case here and incorrectly configure the PHY for DisplayPort
instead of USB-only?
If a standard USB device is connected or the port is in a safe/unattached state,
the Type-C subsystem fires a mux event with state->mode = TYPEC_STATE_USB (or
TYPEC_STATE_SAFE), and it seems they would erroneously be assigned
UDPHY_MODE_DP_USB with two DisplayPort lanes instead of just UDPHY_MODE_USB.
> udphy->dp_lanes = 2;
> break;
> }
[ ... ]
> @@ -1033,7 +1033,7 @@ static int rk_udphy_power_on(struct rk_udphy *udphy, u8 mode)
>
> static void rk_udphy_power_off(struct rk_udphy *udphy, u8 mode)
> {
> - if (!(udphy->mode & mode)) {
> + if (!(udphy->hw_mode & mode)) {
[Severity: High]
This is a pre-existing issue, but does using hw_mode here bypass the power-off
sequence and permanently leak the physical PHY state?
If a Type-C event changes the hardware mode to DP-only (hw_mode =
UDPHY_MODE_DP), the USB mode is dropped. If rk_udphy_power_off() is called
afterwards, this check will bypass physical shutdown since the requested mode
was already removed from hw_mode, preventing rk_udphy_disable() from being
called.
> dev_info(udphy->dev, "mode 0x%02x is not support\n", mode);
> return;
> }
[ ... ]
> @@ -1307,7 +1307,7 @@ static int rk_udphy_usb3_phy_exit(struct phy *phy)
> guard(mutex)(&udphy->mutex);
>
> /* DP only or high-speed */
> - if (!(udphy->mode & UDPHY_MODE_USB) || udphy->hs) {
> + if (!(udphy->hw_mode & UDPHY_MODE_USB) || udphy->hs) {
[Severity: High]
This is a pre-existing issue, but this appears to have the same flaw as
rk_udphy_power_off() above.
When the USB consumer subsequently calls phy_exit(), and hw_mode has already
dropped the USB mode, this returns early without delegating to
rk_udphy_power_off(). If the PHY status reached UDPHY_MODE_NONE,
rk_udphy_disable() is never called, and the PHY remains physically powered on
indefinitely.
> udphy->status &= ~UDPHY_MODE_USB;
> return 0;
> }
--
Sashiko AI review · https://sashiko.dev/#/patchset/20260709-rockchip-usbdp-cleanup-v11-0-a149ac60f76c@collabora.com?part=33
next prev parent reply other threads:[~2026-07-09 19:35 UTC|newest]
Thread overview: 149+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-07-09 19:02 [PATCH v11 00/36] phy: rockchip: usbdp: Clean up the mess Sebastian Reichel
2026-07-09 19:02 ` Sebastian Reichel
2026-07-09 19:02 ` Sebastian Reichel
2026-07-09 19:02 ` [PATCH v11 01/36] dt-bindings: phy: rockchip-usbdp: add improved ports scheme Sebastian Reichel
2026-07-09 19:02 ` Sebastian Reichel
2026-07-09 19:02 ` Sebastian Reichel
2026-07-09 19:02 ` [PATCH v11 02/36] phy: rockchip: usbdp: Update mode_change after error handling Sebastian Reichel
2026-07-09 19:02 ` Sebastian Reichel
2026-07-09 19:02 ` Sebastian Reichel
2026-07-09 19:20 ` sashiko-bot
2026-07-09 19:20 ` sashiko-bot
2026-07-09 19:02 ` [PATCH v11 03/36] phy: rockchip: usbdp: Do not lose USB3 PHY status Sebastian Reichel
2026-07-09 19:02 ` Sebastian Reichel
2026-07-09 19:02 ` Sebastian Reichel
2026-07-09 19:19 ` sashiko-bot
2026-07-09 19:19 ` sashiko-bot
2026-07-09 19:02 ` [PATCH v11 04/36] phy: rockchip: usbdp: Fix devm_clk_bulk_get_all check Sebastian Reichel
2026-07-09 19:02 ` Sebastian Reichel
2026-07-09 19:02 ` Sebastian Reichel
2026-07-09 19:02 ` [PATCH v11 05/36] phy: rockchip: usbdp: Handle missing clock-names DT property gracefully Sebastian Reichel
2026-07-09 19:02 ` Sebastian Reichel
2026-07-09 19:02 ` Sebastian Reichel
2026-07-09 19:02 ` [PATCH v11 06/36] phy: rockchip: usbdp: Drop seamless DP takeover Sebastian Reichel
2026-07-09 19:02 ` Sebastian Reichel
2026-07-09 19:02 ` Sebastian Reichel
2026-07-09 19:19 ` sashiko-bot
2026-07-09 19:19 ` sashiko-bot
2026-07-09 19:02 ` [PATCH v11 07/36] phy: rockchip: usbdp: Keep clocks running on PHY re-init Sebastian Reichel
2026-07-09 19:02 ` Sebastian Reichel
2026-07-09 19:02 ` Sebastian Reichel
2026-07-09 19:18 ` sashiko-bot
2026-07-09 19:18 ` sashiko-bot
2026-07-09 19:02 ` [PATCH v11 08/36] phy: rockchip: usbdp: Amend SSC modulation deviation Sebastian Reichel
2026-07-09 19:02 ` Sebastian Reichel
2026-07-09 19:02 ` Sebastian Reichel
2026-07-09 19:19 ` sashiko-bot
2026-07-09 19:19 ` sashiko-bot
2026-07-09 19:02 ` [PATCH v11 09/36] phy: rockchip: usbdp: Fix LFPS detect threshold control Sebastian Reichel
2026-07-09 19:02 ` Sebastian Reichel
2026-07-09 19:02 ` Sebastian Reichel
2026-07-09 19:02 ` [PATCH v11 10/36] phy: rockchip: usbdp: Add missing mode_change update Sebastian Reichel
2026-07-09 19:02 ` Sebastian Reichel
2026-07-09 19:02 ` Sebastian Reichel
2026-07-09 19:19 ` sashiko-bot
2026-07-09 19:19 ` sashiko-bot
2026-07-09 19:02 ` [PATCH v11 11/36] phy: rockchip: usbdp: Support single-lane DP Sebastian Reichel
2026-07-09 19:02 ` Sebastian Reichel
2026-07-09 19:02 ` Sebastian Reichel
2026-07-09 19:19 ` sashiko-bot
2026-07-09 19:19 ` sashiko-bot
2026-07-09 19:02 ` [PATCH v11 12/36] phy: rockchip: usbdp: Limit DP lane count to muxed lanes Sebastian Reichel
2026-07-09 19:02 ` Sebastian Reichel
2026-07-09 19:02 ` Sebastian Reichel
2026-07-09 19:21 ` sashiko-bot
2026-07-09 19:21 ` sashiko-bot
2026-07-09 19:02 ` [PATCH v11 13/36] phy: rockchip: usbdp: Rename DP lane functions Sebastian Reichel
2026-07-09 19:02 ` Sebastian Reichel
2026-07-09 19:02 ` Sebastian Reichel
2026-07-09 19:02 ` [PATCH v11 14/36] phy: rockchip: usbdp: Use FIELD_PREP_WM16_CONST Sebastian Reichel
2026-07-09 19:02 ` Sebastian Reichel
2026-07-09 19:02 ` Sebastian Reichel
2026-07-09 19:02 ` [PATCH v11 15/36] phy: rockchip: usbdp: Cleanup DP lane selection function Sebastian Reichel
2026-07-09 19:02 ` Sebastian Reichel
2026-07-09 19:02 ` Sebastian Reichel
2026-07-09 19:02 ` [PATCH v11 16/36] phy: rockchip: usbdp: Register DP aux bridge Sebastian Reichel
2026-07-09 19:02 ` Sebastian Reichel
2026-07-09 19:02 ` Sebastian Reichel
2026-07-09 19:02 ` [PATCH v11 17/36] phy: rockchip: usbdp: Drop DP HPD handling Sebastian Reichel
2026-07-09 19:02 ` Sebastian Reichel
2026-07-09 19:02 ` Sebastian Reichel
2026-07-09 19:23 ` sashiko-bot
2026-07-09 19:23 ` sashiko-bot
2026-07-09 19:02 ` [PATCH v11 18/36] phy: rockchip: usbdp: Rename mode_change to phy_needs_reinit Sebastian Reichel
2026-07-09 19:02 ` Sebastian Reichel
2026-07-09 19:02 ` Sebastian Reichel
2026-07-09 19:02 ` [PATCH v11 19/36] phy: rockchip: usbdp: Re-init the PHY on orientation change Sebastian Reichel
2026-07-09 19:02 ` Sebastian Reichel
2026-07-09 19:02 ` Sebastian Reichel
2026-07-09 19:26 ` sashiko-bot
2026-07-09 19:26 ` sashiko-bot
2026-07-09 19:02 ` [PATCH v11 20/36] phy: rockchip: usbdp: Factor out lane_mux_sel setup Sebastian Reichel
2026-07-09 19:02 ` Sebastian Reichel
2026-07-09 19:02 ` Sebastian Reichel
2026-07-09 19:02 ` [PATCH v11 21/36] phy: rockchip: usbdp: Properly handle TYPEC_STATE_SAFE and TYPEC_STATE_USB Sebastian Reichel
2026-07-09 19:02 ` Sebastian Reichel
2026-07-09 19:02 ` Sebastian Reichel
2026-07-09 19:27 ` sashiko-bot
2026-07-09 19:27 ` sashiko-bot
2026-07-09 19:02 ` [PATCH v11 22/36] phy: rockchip: usbdp: Use guard functions for mutex Sebastian Reichel
2026-07-09 19:02 ` Sebastian Reichel
2026-07-09 19:02 ` Sebastian Reichel
2026-07-09 19:02 ` [PATCH v11 23/36] phy: rockchip: usbdp: Clear USB status on PHY exit Sebastian Reichel
2026-07-09 19:02 ` Sebastian Reichel
2026-07-09 19:02 ` Sebastian Reichel
2026-07-09 19:28 ` sashiko-bot
2026-07-09 19:28 ` sashiko-bot
2026-07-09 19:02 ` [PATCH v11 24/36] phy: rockchip: usbdp: Hold mutex in DP PHY configure Sebastian Reichel
2026-07-09 19:02 ` Sebastian Reichel
2026-07-09 19:02 ` Sebastian Reichel
2026-07-09 19:02 ` [PATCH v11 25/36] phy: rockchip: usbdp: Add some extra debug messages Sebastian Reichel
2026-07-09 19:02 ` Sebastian Reichel
2026-07-09 19:02 ` Sebastian Reichel
2026-07-09 19:02 ` [PATCH v11 26/36] phy: rockchip: usbdp: Avoid xHCI SErrors Sebastian Reichel
2026-07-09 19:02 ` Sebastian Reichel
2026-07-09 19:02 ` Sebastian Reichel
2026-07-09 19:28 ` sashiko-bot
2026-07-09 19:28 ` sashiko-bot
2026-07-09 19:02 ` [PATCH v11 27/36] phy: rockchip: usbdp: Handle rk_udphy_reset_deassert errors Sebastian Reichel
2026-07-09 19:02 ` Sebastian Reichel
2026-07-09 19:02 ` Sebastian Reichel
2026-07-09 19:02 ` [PATCH v11 28/36] phy: rockchip: usbdp: Only enable USB3 when not in high-speed mode Sebastian Reichel
2026-07-09 19:02 ` Sebastian Reichel
2026-07-09 19:02 ` Sebastian Reichel
2026-07-09 19:35 ` sashiko-bot
2026-07-09 19:35 ` sashiko-bot
2026-07-09 19:02 ` [PATCH v11 29/36] phy: core: add notifier infrastructure Sebastian Reichel
2026-07-09 19:02 ` Sebastian Reichel
2026-07-09 19:02 ` Sebastian Reichel
2026-07-09 19:31 ` sashiko-bot
2026-07-09 19:31 ` sashiko-bot
2026-07-09 19:02 ` [PATCH v11 30/36] usb: dwc3: core: support PHY reset notifications Sebastian Reichel
2026-07-09 19:02 ` Sebastian Reichel
2026-07-09 19:02 ` Sebastian Reichel
2026-07-09 19:02 ` [PATCH v11 31/36] phy: rockchip: usbdp: Add phy reset notification support Sebastian Reichel
2026-07-09 19:02 ` Sebastian Reichel
2026-07-09 19:02 ` Sebastian Reichel
2026-07-09 19:32 ` sashiko-bot
2026-07-09 19:32 ` sashiko-bot
2026-07-09 19:02 ` [PATCH v11 32/36] phy: rockchip: usbdp: Drop -EPROBE_DEFER hack Sebastian Reichel
2026-07-09 19:02 ` Sebastian Reichel
2026-07-09 19:02 ` Sebastian Reichel
2026-07-09 19:34 ` sashiko-bot
2026-07-09 19:34 ` sashiko-bot
2026-07-09 19:02 ` [PATCH v11 33/36] phy: rockchip: usbdp: Rename mode to hw_mode Sebastian Reichel
2026-07-09 19:02 ` Sebastian Reichel
2026-07-09 19:02 ` Sebastian Reichel
2026-07-09 19:35 ` sashiko-bot [this message]
2026-07-09 19:35 ` sashiko-bot
2026-07-09 19:02 ` [PATCH v11 34/36] phy: rockchip: usbdp: Fix power state handling Sebastian Reichel
2026-07-09 19:02 ` Sebastian Reichel
2026-07-09 19:02 ` Sebastian Reichel
2026-07-09 19:02 ` [PATCH v11 35/36] phy: rockchip: usbdp: Re-init PHY on mux change Sebastian Reichel
2026-07-09 19:02 ` Sebastian Reichel
2026-07-09 19:02 ` Sebastian Reichel
2026-07-09 19:41 ` sashiko-bot
2026-07-09 19:41 ` sashiko-bot
2026-07-09 19:02 ` [PATCH v11 36/36] phy: rockchip: usbdp: Add USB-C state without DP enabled Sebastian Reichel
2026-07-09 19:02 ` Sebastian Reichel
2026-07-09 19:02 ` Sebastian Reichel
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20260709193511.49EDA1F000E9@smtp.kernel.org \
--to=sashiko-bot@kernel.org \
--cc=conor+dt@kernel.org \
--cc=devicetree@vger.kernel.org \
--cc=linux-phy@lists.infradead.org \
--cc=neil.armstrong@linaro.org \
--cc=olteanv@gmail.com \
--cc=robh@kernel.org \
--cc=sashiko-reviews@lists.linux.dev \
--cc=sebastian.reichel@collabora.com \
--cc=vkoul@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.