All of lore.kernel.org
 help / color / mirror / Atom feed
From: sashiko-bot@kernel.org
To: "Mikhail Kshevetskiy" <mikhail.kshevetskiy@iopsys.eu>
Cc: devicetree@vger.kernel.org, robh@kernel.org, conor+dt@kernel.org
Subject: Re: [PATCH v7 13/34] pinctrl: airoha: add set_direction() helper for gpio_chip
Date: Mon, 27 Jul 2026 07:58:45 +0000	[thread overview]
Message-ID: <20260727075845.89D301F000E9@smtp.kernel.org> (raw)
In-Reply-To: <20260727074234.3761170-14-mikhail.kshevetskiy@iopsys.eu>

Thank you for your contribution! Sashiko AI review found 1 potential issue(s) to consider:
- [Medium] Unintended modification of adjacent bits in the GPIO direction register due to incorrect mask size, violating the 'No functional changes' claim.
--

--- Patch [13]: [PATCH v7 13/34] pinctrl: airoha: add set_direction() helper for gpio_chip ---
commit e729e6b2ed1ea68da146d1ea646d1135a1f27b5e
Author: Mikhail Kshevetskiy <mikhail.kshevetskiy@iopsys.eu>

pinctrl: airoha: add set_direction() helper for gpio_chip
    
The patch creates a set_direction() helper for the gpio_chip abstraction and
reimplements existing direction configuration to use this helper. The commit
message claims this is purely a cosmetic patch with no functional changes.

> diff --git a/drivers/pinctrl/airoha/pinctrl-airoha.c b/drivers/pinctrl/airoha/pinctrl-airoha.c
> index 6a0ba54053fe7..fcf498f7720c9 100644
> --- a/drivers/pinctrl/airoha/pinctrl-airoha.c
> +++ b/drivers/pinctrl/airoha/pinctrl-airoha.c
[ ... ]
> @@ -2523,12 +2523,43 @@ static int airoha_gpio_get_direction(struct gpio_chip *chip, unsigned int gpio)
[ ... ]
> +static int airoha_gpio_set_direction(struct gpio_chip *chip, unsigned int gpio,
> +				     bool input)
> +{
[ ... ]
> +	/* set direction */
> +	field_shift = 2 * (gpio % AIROHA_REG_GPIOCTRL_NUM_PIN);
> +	mask = GENMASK(field_shift + 1, field_shift);
> +	index = gpio / AIROHA_REG_GPIOCTRL_NUM_PIN;
> +
> +	return regmap_update_bits(pinctrl->regmap,
> +				  pinctrl->gpiochip.dir[index],
> +				  mask, !input ? BIT(field_shift) : 0);
> +}

[Severity: Medium]
Does this new helper introduce a functional change contrary to the commit
message?

In the removed airoha_pinmux_set_direction() code shown below, the mask
covered exactly 1 bit:

    mask = BIT(2 * (pin % AIROHA_REG_GPIOCTRL_NUM_PIN));

Here in the new airoha_gpio_set_direction(), the mask spans 2 bits via
GENMASK(field_shift + 1, field_shift). The regmap_update_bits() call now
explicitly clears the upper bit of this 2-bit field.

Could this zeroing of the upper bit, which was previously preserved,
alter undocumented hardware state?

[ ... ]
> @@ -2752,27 +2783,13 @@ static int airoha_pinmux_set_direction(struct pinctrl_dev *pctrl_dev,
[ ... ]
> -	/* set direction */
> -	mask = BIT(2 * (pin % AIROHA_REG_GPIOCTRL_NUM_PIN));
> -	index = pin / AIROHA_REG_GPIOCTRL_NUM_PIN;
> -	return regmap_update_bits(pinctrl->regmap,
> -				  pinctrl->gpiochip.dir[index], mask,
> -				  !input ? mask : 0);
> +	return airoha_gpio_set_direction(&pinctrl->gpiochip.chip, gpio, input);
>  }

-- 
Sashiko AI review · https://sashiko.dev/#/patchset/20260727074234.3761170-1-mikhail.kshevetskiy@iopsys.eu?part=13

  reply	other threads:[~2026-07-27  7:58 UTC|newest]

Thread overview: 75+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2026-07-27  7:42 [PATCH v7 00/34] pinctrl: airoha: split on shared and SoC drivers, add more SoCs Mikhail Kshevetskiy
2026-07-27  7:42 ` [PATCH v7 01/34] dt-bindings: pinctrl: airoha: en7581: fix misprint in i2s function name Mikhail Kshevetskiy
2026-07-27  7:46   ` Lorenzo Bianconi
2026-07-27  7:50   ` sashiko-bot
2026-07-27  7:42 ` [PATCH v7 02/34] dt-bindings: pinctrl: airoha: en7581: fix pwm pin-groups Mikhail Kshevetskiy
2026-07-27  7:47   ` Lorenzo Bianconi
2026-07-27  7:42 ` [PATCH v7 03/34] dt-bindings: pinctrl: airoha: an7583: fix device tree binding schema Mikhail Kshevetskiy
2026-07-27  7:42 ` [PATCH v7 04/34] pinctrl: airoha: an7581: fix misprint in bitfield name Mikhail Kshevetskiy
2026-07-27  7:50   ` Lorenzo Bianconi
2026-07-27  7:52   ` sashiko-bot
2026-07-27  7:42 ` [PATCH v7 05/34] pinctrl: airoha: an7583: fix I2C0_SDA_PD register bit order Mikhail Kshevetskiy
2026-07-27  7:54   ` sashiko-bot
2026-07-27  7:42 ` [PATCH v7 06/34] pinctrl: airoha: an7583: there are no muxes to enable i2c buses Mikhail Kshevetskiy
2026-07-27  7:53   ` sashiko-bot
2026-07-27  7:42 ` [PATCH v7 07/34] dt-bindings: pinctrl: airoha: an7583: remove i2c pin function Mikhail Kshevetskiy
2026-07-27  7:51   ` Lorenzo Bianconi
2026-07-27  7:42 ` [PATCH v7 08/34] pinctrl: airoha: an7581: fix mux/conf of pcie_reset pins Mikhail Kshevetskiy
2026-07-27  7:55   ` sashiko-bot
2026-07-27  7:42 ` [PATCH v7 09/34] dt-bindings: pinctrl: airoha: en7581: allow configuration of pcie_reset pins as gpio or pwm Mikhail Kshevetskiy
2026-07-27  7:42 ` [PATCH v7 10/34] pinctrl: airoha: an7583: fix muxing of non-gpio default pins Mikhail Kshevetskiy
2026-07-27  7:42 ` [PATCH v7 11/34] dt-bindings: pinctrl: airoha: an7583: allow configuration of non-gpio default pins as gpio and pwm Mikhail Kshevetskiy
2026-07-27  7:42 ` [PATCH v7 12/34] pinctrl: airoha: add missed get_direction() function for gpio_chip Mikhail Kshevetskiy
2026-07-27  7:57   ` sashiko-bot
2026-07-27  8:04   ` Lorenzo Bianconi
2026-07-27  9:40     ` Mikhail Kshevetskiy
2026-07-27  9:46       ` Lorenzo Bianconi
2026-07-27  7:42 ` [PATCH v7 13/34] pinctrl: airoha: add set_direction() helper " Mikhail Kshevetskiy
2026-07-27  7:58   ` sashiko-bot [this message]
2026-07-27  8:06   ` Lorenzo Bianconi
2026-07-27  7:42 ` [PATCH v7 14/34] pinctrl: airoha: fix potential kenel panic in IRQ handling code Mikhail Kshevetskiy
2026-07-27  7:55   ` sashiko-bot
2026-07-27  8:31   ` Lorenzo Bianconi
2026-07-27  9:02     ` Mikhail Kshevetskiy
2026-07-27  7:42 ` [PATCH v7 15/34] pinctrl: airoha: fix IRQ mask/unmask code Mikhail Kshevetskiy
2026-07-27  7:59   ` sashiko-bot
2026-07-27  8:37   ` Lorenzo Bianconi
2026-07-27  7:42 ` [PATCH v7 16/34] pinctrl: airoha: add missed IRQ resource helpers Mikhail Kshevetskiy
2026-07-27  8:02   ` sashiko-bot
2026-07-27  8:34   ` Lorenzo Bianconi
2026-07-27  7:42 ` [PATCH v7 17/34] pinctrl: airoha: fix edge-triggered interrupts handling Mikhail Kshevetskiy
2026-07-27  7:59   ` sashiko-bot
2026-07-27  9:01   ` Lorenzo Bianconi
2026-07-27  7:42 ` [PATCH v7 18/34] pinctrl: airoha: remove not needed irq_type[] array Mikhail Kshevetskiy
2026-07-27  8:00   ` sashiko-bot
2026-07-27  9:03   ` Lorenzo Bianconi
2026-07-27  7:42 ` [PATCH v7 19/34] pinctrl: airoha: move common definitions to the separate header Mikhail Kshevetskiy
2026-07-27  8:04   ` sashiko-bot
2026-07-27  7:42 ` [PATCH v7 20/34] pinctrl: airoha: split driver on shared code and SoC specific drivers Mikhail Kshevetskiy
2026-07-27  8:19   ` sashiko-bot
2026-07-27  9:14   ` Lorenzo Bianconi
2026-07-27  9:23     ` Mikhail Kshevetskiy
2026-07-27  9:27       ` Lorenzo Bianconi
2026-07-27  9:28         ` Mikhail Kshevetskiy
2026-07-27 12:48           ` Lorenzo Bianconi
2026-07-27  7:42 ` [PATCH v7 21/34] pinctrl: airoha: an7581: remove en7581 prefix from variable names Mikhail Kshevetskiy
2026-07-27  7:42 ` [PATCH v7 22/34] pinctrl: airoha: an7583: remove an7583 prefix from variable names and definitions Mikhail Kshevetskiy
2026-07-27  7:42 ` [PATCH v7 23/34] pinctrl: airoha: an7583: rename registers to match its an7583 names Mikhail Kshevetskiy
2026-07-27  7:42 ` [PATCH v7 24/34] pinctrl: airoha: an7583: add support for npu_uart pinmux Mikhail Kshevetskiy
2026-07-27  8:01   ` sashiko-bot
2026-07-27  7:42 ` [PATCH v7 25/34] dt-bindings: pinctrl: airoha: an7583: add npu_uart pin group Mikhail Kshevetskiy
2026-07-27  7:42 ` [PATCH v7 26/34] pinctrl: airoha: an7583: add support for pon_alt pinmux Mikhail Kshevetskiy
2026-07-27  8:05   ` sashiko-bot
2026-07-27  7:42 ` [PATCH v7 27/34] dt-bindings: pinctrl: airoha: an7583: add pon_alt pin group Mikhail Kshevetskiy
2026-07-27  7:42 ` [PATCH v7 28/34] pinctrl: airoha: an7583: add support for olt pinmux Mikhail Kshevetskiy
2026-07-27  7:42 ` [PATCH v7 29/34] dt-bindings: pinctrl: airoha: an7583: add olt function/group Mikhail Kshevetskiy
2026-07-27  7:42 ` [PATCH v7 30/34] pinctrl: airoha: add support of en7523 SoC Mikhail Kshevetskiy
2026-07-27  8:13   ` sashiko-bot
2026-07-27  7:42 ` [PATCH v7 31/34] pinctrl: airoha: try to find chip scu node by phandle first Mikhail Kshevetskiy
2026-07-27  8:06   ` sashiko-bot
2026-07-27  7:42 ` [PATCH v7 32/34] dt-bindings: pinctrl: airoha: add support of en7523 pin controller Mikhail Kshevetskiy
2026-07-27  8:06   ` sashiko-bot
2026-07-27  7:42 ` [PATCH v7 33/34] pinctrl: airoha: add support of an7563 SoC Mikhail Kshevetskiy
2026-07-27  8:07   ` sashiko-bot
2026-07-27  7:42 ` [PATCH v7 34/34] dt-bindings: pinctrl: airoha: add support of an7563 pin controller Mikhail Kshevetskiy
2026-07-27  8:10   ` sashiko-bot

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20260727075845.89D301F000E9@smtp.kernel.org \
    --to=sashiko-bot@kernel.org \
    --cc=conor+dt@kernel.org \
    --cc=devicetree@vger.kernel.org \
    --cc=mikhail.kshevetskiy@iopsys.eu \
    --cc=robh@kernel.org \
    --cc=sashiko-reviews@lists.linux.dev \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.