All of lore.kernel.org
 help / color / mirror / Atom feed
From: Jan Beulich <jbeulich@suse.com>
To: "Jürgen Groß" <jgross@suse.com>
Cc: Anthony PERARD <anthony.perard@vates.tech>,
	Andrew Cooper <andrew.cooper3@citrix.com>,
	xen-devel@lists.xenproject.org
Subject: Re: [PATCH v2 2/4] docs: replace @xxx@ markers at build time
Date: Mon, 17 Nov 2025 14:00:49 +0100	[thread overview]
Message-ID: <45c6d3dd-3901-4609-918b-ba6b685d6496@suse.com> (raw)
In-Reply-To: <0ed9b152-6465-4736-be59-352d68b77e6f@suse.com>

On 17.11.2025 13:55, Jürgen Groß wrote:
> On 17.11.25 13:33, Jan Beulich wrote:
>> On 14.11.2025 14:00, Jürgen Groß wrote:
>>> On 14.11.25 12:40, Andrew Cooper wrote:
>>>> On 14/11/2025 11:32 am, Juergen Gross wrote:
>>>>> diff --git a/docs/Makefile b/docs/Makefile
>>>>> index 37776d303c..e5f4a8ca86 100644
>>>>> --- a/docs/Makefile
>>>>> +++ b/docs/Makefile
>>>>> @@ -8,8 +8,11 @@ DATE		:= $(call date,"+%Y-%m-%d")
>>>>>    DOC_ARCHES      := arm ppc riscv x86_32 x86_64
>>>>>    MAN_SECTIONS    := 1 5 7 8
>>>>>    
>>>>> +IN_FILES := man/xl-disk-configuration.5.pod man/xl-network-configuration.5.pod
>>>>> +IN_FILES += man/xl.1.pod man/xl.cfg.5.pod man/xl.conf.5.pod
>>>>
>>>> Sorry, I meant to say this on the previous revision.  Can we please list
>>>> these one per line, for the future ease of inserting/removing.
>>>
>>> Okay.
>>>
>>>> Is IN_FILES really correct?  These are the generated (non-.in) files,
>>>> rather than the .in files themselves.  GEN_FILES from v1 would seem to
>>>> be a better fit.
>>>
>>> I wanted to make clear this is related to *.in files. And IMHO GEN_FILES
>>> was too generic on a second thought.
>>>
>>> GENERATED_FROM_IN_SUFFIXED_FILES seems a little bit clumsy. ;-)
>>> Seriously, if you have any better name, I'd be happy to use it.
>>
>> GEN_POD_FILES, seeing they're all *.pod?
> 
> For this case, maybe. OTOH in case someone adds a .podman file we'd need
> to rename again.
> 
> And I think using the same make variable name in all Makefiles needing to
> specify *.in derived files would be preferable.
> 
> Maybe IN_TARGETS?

Better than IN_FILES, but still potentially ambiguous. How about sticking
to IN_FILES but indeed enumerating the .in there (zapping the suffix upon
use)? And/or would $(wildcard <path>/*.in) perhaps make sense to use?

Jan


  reply	other threads:[~2025-11-17 13:01 UTC|newest]

Thread overview: 29+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2025-11-14 11:32 [PATCH v2 0/4] configure: reduce number of files created Juergen Gross
2025-11-14 11:32 ` [PATCH v2 1/4] build: add make macro for making file from file.in Juergen Gross
2025-11-14 11:42   ` Andrew Cooper
2025-11-14 12:54     ` Jürgen Groß
2025-11-17 12:24       ` Jan Beulich
2025-11-17 12:30         ` Andrew Cooper
2025-11-17 12:51           ` Jürgen Groß
2025-11-17 12:37         ` Jürgen Groß
2025-11-17 12:51           ` Jan Beulich
2025-11-17 13:03             ` Jürgen Groß
2025-11-17 12:29   ` Jan Beulich
2025-11-17 12:48     ` Jürgen Groß
2025-11-17 12:54       ` Jan Beulich
2025-11-17 13:10         ` Jürgen Groß
2025-11-17 14:05           ` Jan Beulich
2025-11-14 11:32 ` [PATCH v2 2/4] docs: replace @xxx@ markers at build time Juergen Gross
2025-11-14 11:40   ` Andrew Cooper
2025-11-14 13:00     ` Jürgen Groß
2025-11-17 12:33       ` Jan Beulich
2025-11-17 12:55         ` Jürgen Groß
2025-11-17 13:00           ` Jan Beulich [this message]
2025-11-17 13:17             ` Jürgen Groß
2025-11-17 14:06               ` Jan Beulich
2025-11-14 11:32 ` [PATCH v2 3/4] config: remove unused paths from config/Paths.mk.in Juergen Gross
2025-11-14 11:47   ` Andrew Cooper
2025-11-14 13:00     ` Jürgen Groß
2025-11-14 11:32 ` [PATCH v2 4/4] tools: replace @xxx@ markers at build time Juergen Gross
2025-11-14 11:54   ` Andrew Cooper
2025-11-14 13:03     ` Jürgen Groß

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=45c6d3dd-3901-4609-918b-ba6b685d6496@suse.com \
    --to=jbeulich@suse.com \
    --cc=andrew.cooper3@citrix.com \
    --cc=anthony.perard@vates.tech \
    --cc=jgross@suse.com \
    --cc=xen-devel@lists.xenproject.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.