* [RFC] Rename soc_camera to camera_bus
@ 2008-07-18 14:01 Paulius Zaleckas
2008-07-18 14:12 ` Guennadi Liakhovetski
0 siblings, 1 reply; 2+ messages in thread
From: Paulius Zaleckas @ 2008-07-18 14:01 UTC (permalink / raw)
To: video4linux-list
I suggest to rename soc_camera to camera_bus or something similar.
This should be done, because soc_camera framework can (IMHO should)
be used with USB webcams (not uvc), SoC camera interfaces, PCI device
(like cafe) and any other devices where it is possible to control camera
bus and i2c separately.
BR,
Paulius Zaleckas
--
video4linux-list mailing list
Unsubscribe mailto:video4linux-list-request@redhat.com?subject=unsubscribe
https://www.redhat.com/mailman/listinfo/video4linux-list
^ permalink raw reply [flat|nested] 2+ messages in thread
* Re: [RFC] Rename soc_camera to camera_bus
2008-07-18 14:01 [RFC] Rename soc_camera to camera_bus Paulius Zaleckas
@ 2008-07-18 14:12 ` Guennadi Liakhovetski
0 siblings, 0 replies; 2+ messages in thread
From: Guennadi Liakhovetski @ 2008-07-18 14:12 UTC (permalink / raw)
To: Paulius Zaleckas; +Cc: video4linux-list
On Fri, 18 Jul 2008, Paulius Zaleckas wrote:
> I suggest to rename soc_camera to camera_bus or something similar.
> This should be done, because soc_camera framework can (IMHO should)
> be used with USB webcams (not uvc), SoC camera interfaces, PCI device (like
> cafe) and any other devices where it is possible to control camera
> bus and i2c separately.
It is not the first time this idea appears, I certainly would be pleased
if this interface could find wider application in USB- and PCI-camera
drivers, and I also think it should be quite possible. As for the name -
let's be pragmatic once again. Personally, I have nothing against any
other reasonable name, camera_bus sounds good too, but let's wait until
the first such (USB or PCI) driver appears, then we will politely ask the
submitter to prepare a patch to rename the interface and all internal
functions, structs, etc.:-)
Thanks
Guennadi
---
Guennadi Liakhovetski, Ph.D.
Freelance Open-Source Software Developer
--
video4linux-list mailing list
Unsubscribe mailto:video4linux-list-request@redhat.com?subject=unsubscribe
https://www.redhat.com/mailman/listinfo/video4linux-list
^ permalink raw reply [flat|nested] 2+ messages in thread
end of thread, other threads:[~2008-07-18 14:12 UTC | newest]
Thread overview: 2+ messages (download: mbox.gz follow: Atom feed
-- links below jump to the message on this page --
2008-07-18 14:01 [RFC] Rename soc_camera to camera_bus Paulius Zaleckas
2008-07-18 14:12 ` Guennadi Liakhovetski
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.