From: John Garry <john.g.garry@oracle.com>
To: Hannes Reinecke <hare@suse.de>,
Bart Van Assche <bvanassche@acm.org>,
"Martin K . Petersen" <martin.petersen@oracle.com>
Cc: linux-scsi@vger.kernel.org,
"James E.J. Bottomley" <James.Bottomley@HansenPartnership.com>
Subject: Re: [PATCH 04/24] scsi: core: Implement reserved command handling
Date: Wed, 16 Apr 2025 09:23:00 +0100 [thread overview]
Message-ID: <49a1e0c0-4e9e-40f4-8a74-ebb63ebccfe2@oracle.com> (raw)
In-Reply-To: <7455bff3-97f6-4156-87e0-197f2d3d8350@suse.de>
On 16/04/2025 08:39, Hannes Reinecke wrote:
>> JFYI, I was working on another solution (different to Hannes') which
>> allows reserved requests pass through scsi_queue_rq(), but I stopped
>> that work when I changed employer.
>>
> Oh, really?
> Do you have the patchset still around?
> I'd be very much interested in that...
Yeah, if you remember, I was working on that for libsas/libata, but
started to get bogged down in how to handle reserved commands for
libsas/libata:
https://lore.kernel.org/linux-scsi/1666693096-180008-1-git-send-email-john.garry@huawei.com/T/#m35ad9a27320077f55c2be5549f036628fe79dcf7
It would be a lot simpler to support for HBAs which plug directly into
the SCSI midlayer - like aacraid.
>
>>> Although it is easy
>>> to create an additional request queue for reserved requests, that
>>> request queue shares its tag set with the SCSI host and hence also the
>>> request submission function. From scsi_host.h:
>>>
>>> struct Scsi_Host {
>>> struct blk_mq_tag_set tag_set;
>>> [ ... ]
>>> };
>>>
>>> From blk-mq.h:
>>>
>>> struct blk_mq_tag_set {
>>> const struct blk_mq_ops *ops;
>>> [ ... ]
>>> };
>>>
>>> Unless someone comes up with an elegant proposal, I will keep the
>>> approach where ufshcd_tag_to_cmd() handles reserved tags and regular
>>> tags differently.
>>>
>>> It should be possible to do this without referencing tags->static_rqs[]
>>> directly from the UFS driver.
>>
>> I'm not sure how that will look, but my preference is to fully
>> implement reserved tags support which can be used by all SCSI LLDs.
>>
> Sure, that was my goal, too.
> But then I got stuck as some drivers (most notably aacraid) use internal
> commands to detect the hardware and allocate SCSI devices, so with my
> approach we need a 'fake' SCSI device for the host to handle that.
> If you have other ideas I'd be very interested in thems.
My solution still involved supporting a fake sdev also for times like
you describe, e.g. shost needs to send reserved commands.
Thanks,
John
next prev parent reply other threads:[~2025-04-16 8:23 UTC|newest]
Thread overview: 65+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-04-03 21:17 [PATCH 00/24] Optimize the hot path in the UFS driver Bart Van Assche
2025-04-03 21:17 ` [PATCH 01/24] scsi: core: Make scsi_cmd_to_rq() accept const arguments Bart Van Assche
2025-04-04 10:39 ` John Garry
2025-04-04 16:23 ` Bart Van Assche
2025-08-18 6:03 ` Hannes Reinecke
2025-08-18 17:17 ` Bart Van Assche
2025-04-03 21:17 ` [PATCH 02/24] scsi: core: Make scsi_cmd_priv() " Bart Van Assche
2025-04-03 21:17 ` [PATCH 03/24] scsi: core: Use scsi_cmd_priv() instead of open-coding it Bart Van Assche
2025-04-03 21:17 ` [PATCH 04/24] scsi: core: Implement reserved command handling Bart Van Assche
2025-04-04 10:49 ` John Garry
2025-04-04 16:34 ` Bart Van Assche
2025-04-04 17:34 ` John Garry
2025-04-14 21:59 ` Bart Van Assche
2025-04-15 17:21 ` Bart Van Assche
2025-04-16 7:16 ` John Garry
2025-04-16 7:39 ` Hannes Reinecke
2025-04-16 8:23 ` John Garry [this message]
2025-04-17 21:25 ` Bart Van Assche
2025-04-22 6:54 ` Hannes Reinecke
2025-08-05 22:33 ` Bart Van Assche
2025-08-07 15:40 ` Bart Van Assche
2025-04-16 7:33 ` Hannes Reinecke
2025-08-07 16:35 ` Bart Van Assche
2025-04-03 21:17 ` [PATCH 05/24] scsi: core: Introduce scsi_host_update_can_queue() Bart Van Assche
2025-04-03 21:17 ` [PATCH 06/24] scsi: ufs: core: Change the type of one ufshcd_add_cmd_upiu_trace() argument Bart Van Assche
2025-04-09 5:34 ` Avri Altman
2025-04-14 12:47 ` Peter Wang (王信友)
2025-04-03 21:17 ` [PATCH 07/24] scsi: ufs: core: Only call ufshcd_add_command_trace() for SCSI commands Bart Van Assche
2025-04-09 6:24 ` Avri Altman
2025-04-14 12:47 ` Peter Wang (王信友)
2025-04-03 21:17 ` [PATCH 08/24] scsi: ufs: core: Change the type of one ufshcd_add_command_trace() argument Bart Van Assche
2025-04-09 6:32 ` Avri Altman
2025-04-09 16:37 ` Bart Van Assche
2025-04-14 12:47 ` Peter Wang (王信友)
2025-04-03 21:17 ` [PATCH 09/24] scsi: ufs: core: Change the type of one ufshcd_send_command() argument Bart Van Assche
2025-04-09 6:34 ` Avri Altman
2025-04-14 12:48 ` Peter Wang (王信友)
2025-04-03 21:17 ` [PATCH 10/24] scsi: ufs: core: Only call ufshcd_should_inform_monitor() for SCSI commands Bart Van Assche
2025-04-15 7:34 ` Peter Wang (王信友)
2025-04-03 21:17 ` [PATCH 11/24] scsi: ufs: core: Change the monitor function argument types Bart Van Assche
2025-04-15 7:37 ` Peter Wang (王信友)
2025-04-15 20:10 ` Bart Van Assche
2025-04-03 21:17 ` [PATCH 12/24] scsi: ufs: core: Rework ufshcd_mcq_compl_pending_transfer() Bart Van Assche
2025-04-15 8:00 ` Peter Wang (王信友)
2025-04-15 20:22 ` Bart Van Assche
2025-04-17 12:39 ` Peter Wang (王信友)
2025-04-17 21:33 ` Bart Van Assche
2025-04-22 13:07 ` Peter Wang (王信友)
2025-04-03 21:17 ` [PATCH 13/24] scsi: ufs: core: Rework ufshcd_eh_device_reset_handler() Bart Van Assche
2025-04-03 21:17 ` [PATCH 14/24] scsi: ufs: core: Cache the DMA buffer sizes Bart Van Assche
2025-04-03 21:17 ` [PATCH 15/24] scsi: ufs: core: Add an argument to ufshcd_mcq_decide_queue_depth() Bart Van Assche
2025-04-03 21:18 ` [PATCH 16/24] scsi: ufs: core: Add an argument to ufshcd_alloc_mcq() Bart Van Assche
2025-04-03 21:18 ` [PATCH 17/24] scsi: ufs: core: Call ufshcd_mcq_init() once Bart Van Assche
2025-04-09 6:52 ` Avri Altman
2025-04-09 16:42 ` Bart Van Assche
2025-04-03 21:18 ` [PATCH 18/24] scsi: ufs: core: Allocate the SCSI host earlier Bart Van Assche
2025-04-03 21:18 ` [PATCH 19/24] scsi: ufs: core: Call ufshcd_init_lrb() later Bart Van Assche
2025-04-03 21:18 ` [PATCH 20/24] scsi: ufs: core: Use hba->reserved_slot Bart Van Assche
2025-04-03 21:18 ` [PATCH 21/24] scsi: ufs: core: Allocate the reserved slot as a reserved request Bart Van Assche
2025-04-03 21:18 ` [PATCH 22/24] scsi: ufs: core: Do not clear driver-private command data Bart Van Assche
2025-04-03 21:18 ` [PATCH 23/24] scsi: ufs: core: Optimize the hot path Bart Van Assche
2025-04-03 21:18 ` [PATCH 24/24] scsi: ufs: core: Remove the ufshcd_lrb task_tag member Bart Van Assche
2025-04-04 10:15 ` [PATCH 00/24] Optimize the hot path in the UFS driver John Garry
2025-04-04 17:05 ` Bart Van Assche
2025-04-05 12:03 ` Avri Altman
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=49a1e0c0-4e9e-40f4-8a74-ebb63ebccfe2@oracle.com \
--to=john.g.garry@oracle.com \
--cc=James.Bottomley@HansenPartnership.com \
--cc=bvanassche@acm.org \
--cc=hare@suse.de \
--cc=linux-scsi@vger.kernel.org \
--cc=martin.petersen@oracle.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.