From: John Garry <john.g.garry@oracle.com>
To: Bart Van Assche <bvanassche@acm.org>,
"Martin K . Petersen" <martin.petersen@oracle.com>
Cc: linux-scsi@vger.kernel.org
Subject: Re: [PATCH 00/24] Optimize the hot path in the UFS driver
Date: Fri, 4 Apr 2025 11:15:34 +0100 [thread overview]
Message-ID: <bcc48e7a-8d83-46dd-ad71-d7587d2b0434@oracle.com> (raw)
In-Reply-To: <20250403211937.2225615-1-bvanassche@acm.org>
On 03/04/2025 22:17, Bart Van Assche wrote:
> Hi Martin,
>
> This patch series increases IOPS by 1% and reduces CPU per I/O by 10% on my
> UFS 4.0 test setup. Please consider this patch series for the next merge
> window.
That cover letter is a bit thin for something which now implements SCSI
reserved command handling (in addition to any UFS optimisation).
>
> Thanks,
>
> Bart.
>
> Bart Van Assche (23):
> scsi: core: Make scsi_cmd_to_rq() accept const arguments
> scsi: core: Make scsi_cmd_priv() accept const arguments
> scsi: core: Use scsi_cmd_priv() instead of open-coding it
> scsi: core: Introduce scsi_host_update_can_queue()
> scsi: ufs: core: Change the type of one ufshcd_add_cmd_upiu_trace()
> argument
> scsi: ufs: core: Only call ufshcd_add_command_trace() for SCSI
> commands
> scsi: ufs: core: Change the type of one ufshcd_add_command_trace()
> argument
> scsi: ufs: core: Change the type of one ufshcd_send_command() argument
> scsi: ufs: core: Only call ufshcd_should_inform_monitor() for SCSI
> commands
> scsi: ufs: core: Change the monitor function argument types
> scsi: ufs: core: Rework ufshcd_mcq_compl_pending_transfer()
> scsi: ufs: core: Rework ufshcd_eh_device_reset_handler()
> scsi: ufs: core: Cache the DMA buffer sizes
> scsi: ufs: core: Add an argument to ufshcd_mcq_decide_queue_depth()
> scsi: ufs: core: Add an argument to ufshcd_alloc_mcq()
> scsi: ufs: core: Call ufshcd_mcq_init() once
> scsi: ufs: core: Allocate the SCSI host earlier
> scsi: ufs: core: Call ufshcd_init_lrb() later
> scsi: ufs: core: Use hba->reserved_slot
> scsi: ufs: core: Allocate the reserved slot as a reserved request
> scsi: ufs: core: Do not clear driver-private command data
> scsi: ufs: core: Optimize the hot path
> scsi: ufs: core: Remove the ufshcd_lrb task_tag member
>
> Hannes Reinecke (1):
> scsi: core: Implement reserved command handling
>
> drivers/scsi/hosts.c | 3 +
> drivers/scsi/scsi.c | 26 ++
> drivers/scsi/scsi_lib.c | 6 +-
> drivers/scsi/scsi_logging.c | 10 +-
> drivers/ufs/core/ufs-mcq.c | 31 +-
> drivers/ufs/core/ufshcd-crypto.h | 18 +-
> drivers/ufs/core/ufshcd-priv.h | 27 +-
> drivers/ufs/core/ufshcd.c | 660 +++++++++++++++++--------------
> include/scsi/scsi_cmnd.h | 17 +-
> include/scsi/scsi_host.h | 24 +-
> include/ufs/ufshcd.h | 11 +-
> 11 files changed, 487 insertions(+), 346 deletions(-)
>
>
next prev parent reply other threads:[~2025-04-04 10:15 UTC|newest]
Thread overview: 65+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-04-03 21:17 [PATCH 00/24] Optimize the hot path in the UFS driver Bart Van Assche
2025-04-03 21:17 ` [PATCH 01/24] scsi: core: Make scsi_cmd_to_rq() accept const arguments Bart Van Assche
2025-04-04 10:39 ` John Garry
2025-04-04 16:23 ` Bart Van Assche
2025-08-18 6:03 ` Hannes Reinecke
2025-08-18 17:17 ` Bart Van Assche
2025-04-03 21:17 ` [PATCH 02/24] scsi: core: Make scsi_cmd_priv() " Bart Van Assche
2025-04-03 21:17 ` [PATCH 03/24] scsi: core: Use scsi_cmd_priv() instead of open-coding it Bart Van Assche
2025-04-03 21:17 ` [PATCH 04/24] scsi: core: Implement reserved command handling Bart Van Assche
2025-04-04 10:49 ` John Garry
2025-04-04 16:34 ` Bart Van Assche
2025-04-04 17:34 ` John Garry
2025-04-14 21:59 ` Bart Van Assche
2025-04-15 17:21 ` Bart Van Assche
2025-04-16 7:16 ` John Garry
2025-04-16 7:39 ` Hannes Reinecke
2025-04-16 8:23 ` John Garry
2025-04-17 21:25 ` Bart Van Assche
2025-04-22 6:54 ` Hannes Reinecke
2025-08-05 22:33 ` Bart Van Assche
2025-08-07 15:40 ` Bart Van Assche
2025-04-16 7:33 ` Hannes Reinecke
2025-08-07 16:35 ` Bart Van Assche
2025-04-03 21:17 ` [PATCH 05/24] scsi: core: Introduce scsi_host_update_can_queue() Bart Van Assche
2025-04-03 21:17 ` [PATCH 06/24] scsi: ufs: core: Change the type of one ufshcd_add_cmd_upiu_trace() argument Bart Van Assche
2025-04-09 5:34 ` Avri Altman
2025-04-14 12:47 ` Peter Wang (王信友)
2025-04-03 21:17 ` [PATCH 07/24] scsi: ufs: core: Only call ufshcd_add_command_trace() for SCSI commands Bart Van Assche
2025-04-09 6:24 ` Avri Altman
2025-04-14 12:47 ` Peter Wang (王信友)
2025-04-03 21:17 ` [PATCH 08/24] scsi: ufs: core: Change the type of one ufshcd_add_command_trace() argument Bart Van Assche
2025-04-09 6:32 ` Avri Altman
2025-04-09 16:37 ` Bart Van Assche
2025-04-14 12:47 ` Peter Wang (王信友)
2025-04-03 21:17 ` [PATCH 09/24] scsi: ufs: core: Change the type of one ufshcd_send_command() argument Bart Van Assche
2025-04-09 6:34 ` Avri Altman
2025-04-14 12:48 ` Peter Wang (王信友)
2025-04-03 21:17 ` [PATCH 10/24] scsi: ufs: core: Only call ufshcd_should_inform_monitor() for SCSI commands Bart Van Assche
2025-04-15 7:34 ` Peter Wang (王信友)
2025-04-03 21:17 ` [PATCH 11/24] scsi: ufs: core: Change the monitor function argument types Bart Van Assche
2025-04-15 7:37 ` Peter Wang (王信友)
2025-04-15 20:10 ` Bart Van Assche
2025-04-03 21:17 ` [PATCH 12/24] scsi: ufs: core: Rework ufshcd_mcq_compl_pending_transfer() Bart Van Assche
2025-04-15 8:00 ` Peter Wang (王信友)
2025-04-15 20:22 ` Bart Van Assche
2025-04-17 12:39 ` Peter Wang (王信友)
2025-04-17 21:33 ` Bart Van Assche
2025-04-22 13:07 ` Peter Wang (王信友)
2025-04-03 21:17 ` [PATCH 13/24] scsi: ufs: core: Rework ufshcd_eh_device_reset_handler() Bart Van Assche
2025-04-03 21:17 ` [PATCH 14/24] scsi: ufs: core: Cache the DMA buffer sizes Bart Van Assche
2025-04-03 21:17 ` [PATCH 15/24] scsi: ufs: core: Add an argument to ufshcd_mcq_decide_queue_depth() Bart Van Assche
2025-04-03 21:18 ` [PATCH 16/24] scsi: ufs: core: Add an argument to ufshcd_alloc_mcq() Bart Van Assche
2025-04-03 21:18 ` [PATCH 17/24] scsi: ufs: core: Call ufshcd_mcq_init() once Bart Van Assche
2025-04-09 6:52 ` Avri Altman
2025-04-09 16:42 ` Bart Van Assche
2025-04-03 21:18 ` [PATCH 18/24] scsi: ufs: core: Allocate the SCSI host earlier Bart Van Assche
2025-04-03 21:18 ` [PATCH 19/24] scsi: ufs: core: Call ufshcd_init_lrb() later Bart Van Assche
2025-04-03 21:18 ` [PATCH 20/24] scsi: ufs: core: Use hba->reserved_slot Bart Van Assche
2025-04-03 21:18 ` [PATCH 21/24] scsi: ufs: core: Allocate the reserved slot as a reserved request Bart Van Assche
2025-04-03 21:18 ` [PATCH 22/24] scsi: ufs: core: Do not clear driver-private command data Bart Van Assche
2025-04-03 21:18 ` [PATCH 23/24] scsi: ufs: core: Optimize the hot path Bart Van Assche
2025-04-03 21:18 ` [PATCH 24/24] scsi: ufs: core: Remove the ufshcd_lrb task_tag member Bart Van Assche
2025-04-04 10:15 ` John Garry [this message]
2025-04-04 17:05 ` [PATCH 00/24] Optimize the hot path in the UFS driver Bart Van Assche
2025-04-05 12:03 ` Avri Altman
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=bcc48e7a-8d83-46dd-ad71-d7587d2b0434@oracle.com \
--to=john.g.garry@oracle.com \
--cc=bvanassche@acm.org \
--cc=linux-scsi@vger.kernel.org \
--cc=martin.petersen@oracle.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.