From: Sui Jingfeng <sui.jingfeng@linux.dev>
To: Bjorn Helgaas <helgaas@kernel.org>
Cc: linux-fbdev@vger.kernel.org,
Sui Jingfeng <suijingfeng@loongson.cn>,
kvm@vger.kernel.org, linux-pci@vger.kernel.org,
intel-gfx@lists.freedesktop.org, linux-kernel@vger.kernel.org,
dri-devel@lists.freedesktop.org, amd-gfx@lists.freedesktop.org,
David Airlie <airlied@gmail.com>
Subject: Re: [PATCH v3 0/9] PCI/VGA: Improve the default VGA device selection
Date: Thu, 20 Jul 2023 17:17:31 +0800 [thread overview]
Message-ID: <5c91b8dd-5342-0eb2-aef4-dbb865d6dfda@linux.dev> (raw)
In-Reply-To: <20230719193241.GA510805@bhelgaas>
Hi,
On 2023/7/20 03:32, Bjorn Helgaas wrote:
>> drm/amdgpu: Implement the is_primary_gpu callback of
>> vga_client_register()
>> drm/radeon: Add an implement for the is_primary_gpu function callback
>> drm/i915: Add an implement for the is_primary_gpu hook
>> drm/ast: Register as a vga client to vgaarb by calling
>> vga_client_register()
>> drm/loongson: Add an implement for the is_primary_gpu function
>> callback
> There's unnecessary variation in the subject lines (and the commit
> logs) of these patches. If they all do the same thing but in
> different drivers, it's useful if the patches all*look* the same.
>
> You might be able to write these subjects as
> "Implement .is_primary_gpu() callback" for brevity.
This is a very good suggestion, I will adopt this.
Thanks, really.
WARNING: multiple messages have this Message-ID (diff)
From: Sui Jingfeng <sui.jingfeng@linux.dev>
To: Bjorn Helgaas <helgaas@kernel.org>
Cc: linux-fbdev@vger.kernel.org,
Sui Jingfeng <suijingfeng@loongson.cn>,
kvm@vger.kernel.org, linux-pci@vger.kernel.org,
intel-gfx@lists.freedesktop.org, linux-kernel@vger.kernel.org,
dri-devel@lists.freedesktop.org, amd-gfx@lists.freedesktop.org,
David Airlie <airlied@gmail.com>
Subject: Re: [Intel-gfx] [PATCH v3 0/9] PCI/VGA: Improve the default VGA device selection
Date: Thu, 20 Jul 2023 17:17:31 +0800 [thread overview]
Message-ID: <5c91b8dd-5342-0eb2-aef4-dbb865d6dfda@linux.dev> (raw)
In-Reply-To: <20230719193241.GA510805@bhelgaas>
Hi,
On 2023/7/20 03:32, Bjorn Helgaas wrote:
>> drm/amdgpu: Implement the is_primary_gpu callback of
>> vga_client_register()
>> drm/radeon: Add an implement for the is_primary_gpu function callback
>> drm/i915: Add an implement for the is_primary_gpu hook
>> drm/ast: Register as a vga client to vgaarb by calling
>> vga_client_register()
>> drm/loongson: Add an implement for the is_primary_gpu function
>> callback
> There's unnecessary variation in the subject lines (and the commit
> logs) of these patches. If they all do the same thing but in
> different drivers, it's useful if the patches all*look* the same.
>
> You might be able to write these subjects as
> "Implement .is_primary_gpu() callback" for brevity.
This is a very good suggestion, I will adopt this.
Thanks, really.
WARNING: multiple messages have this Message-ID (diff)
From: Sui Jingfeng <sui.jingfeng@linux.dev>
To: Bjorn Helgaas <helgaas@kernel.org>
Cc: David Airlie <airlied@gmail.com>,
amd-gfx@lists.freedesktop.org, dri-devel@lists.freedesktop.org,
linux-kernel@vger.kernel.org, intel-gfx@lists.freedesktop.org,
kvm@vger.kernel.org, linux-fbdev@vger.kernel.org,
Sui Jingfeng <suijingfeng@loongson.cn>,
linux-pci@vger.kernel.org
Subject: Re: [PATCH v3 0/9] PCI/VGA: Improve the default VGA device selection
Date: Thu, 20 Jul 2023 17:17:31 +0800 [thread overview]
Message-ID: <5c91b8dd-5342-0eb2-aef4-dbb865d6dfda@linux.dev> (raw)
In-Reply-To: <20230719193241.GA510805@bhelgaas>
Hi,
On 2023/7/20 03:32, Bjorn Helgaas wrote:
>> drm/amdgpu: Implement the is_primary_gpu callback of
>> vga_client_register()
>> drm/radeon: Add an implement for the is_primary_gpu function callback
>> drm/i915: Add an implement for the is_primary_gpu hook
>> drm/ast: Register as a vga client to vgaarb by calling
>> vga_client_register()
>> drm/loongson: Add an implement for the is_primary_gpu function
>> callback
> There's unnecessary variation in the subject lines (and the commit
> logs) of these patches. If they all do the same thing but in
> different drivers, it's useful if the patches all*look* the same.
>
> You might be able to write these subjects as
> "Implement .is_primary_gpu() callback" for brevity.
This is a very good suggestion, I will adopt this.
Thanks, really.
WARNING: multiple messages have this Message-ID (diff)
From: Sui Jingfeng <sui.jingfeng@linux.dev>
To: Bjorn Helgaas <helgaas@kernel.org>
Cc: linux-fbdev@vger.kernel.org,
Sui Jingfeng <suijingfeng@loongson.cn>,
kvm@vger.kernel.org, linux-pci@vger.kernel.org,
intel-gfx@lists.freedesktop.org, linux-kernel@vger.kernel.org,
dri-devel@lists.freedesktop.org, amd-gfx@lists.freedesktop.org
Subject: Re: [PATCH v3 0/9] PCI/VGA: Improve the default VGA device selection
Date: Thu, 20 Jul 2023 17:17:31 +0800 [thread overview]
Message-ID: <5c91b8dd-5342-0eb2-aef4-dbb865d6dfda@linux.dev> (raw)
In-Reply-To: <20230719193241.GA510805@bhelgaas>
Hi,
On 2023/7/20 03:32, Bjorn Helgaas wrote:
>> drm/amdgpu: Implement the is_primary_gpu callback of
>> vga_client_register()
>> drm/radeon: Add an implement for the is_primary_gpu function callback
>> drm/i915: Add an implement for the is_primary_gpu hook
>> drm/ast: Register as a vga client to vgaarb by calling
>> vga_client_register()
>> drm/loongson: Add an implement for the is_primary_gpu function
>> callback
> There's unnecessary variation in the subject lines (and the commit
> logs) of these patches. If they all do the same thing but in
> different drivers, it's useful if the patches all*look* the same.
>
> You might be able to write these subjects as
> "Implement .is_primary_gpu() callback" for brevity.
This is a very good suggestion, I will adopt this.
Thanks, really.
next prev parent reply other threads:[~2023-07-20 10:23 UTC|newest]
Thread overview: 103+ messages / expand[flat|nested] mbox.gz Atom feed top
2023-07-11 16:43 [PATCH v3 0/9] PCI/VGA: Improve the default VGA device selection Sui Jingfeng
2023-07-11 16:43 ` Sui Jingfeng
2023-07-11 16:43 ` [Intel-gfx] " Sui Jingfeng
2023-07-11 16:43 ` [PATCH v3 1/9] video/aperture: Add a helper to detect if an aperture contains firmware FB Sui Jingfeng
2023-07-11 16:43 ` Sui Jingfeng
2023-07-11 16:43 ` [Intel-gfx] " Sui Jingfeng
2023-07-19 20:43 ` Bjorn Helgaas
2023-07-19 20:43 ` Bjorn Helgaas
2023-07-19 20:43 ` Bjorn Helgaas
2023-07-19 20:43 ` [Intel-gfx] " Bjorn Helgaas
2023-07-19 21:18 ` suijingfeng
2023-07-19 21:18 ` suijingfeng
2023-07-19 21:18 ` suijingfeng
2023-07-19 21:18 ` [Intel-gfx] " suijingfeng
2023-07-11 16:43 ` [PATCH v3 2/9] video/aperture: Add a helper for determining if an unmoved aperture contain FB Sui Jingfeng
2023-07-11 16:43 ` Sui Jingfeng
2023-07-11 16:43 ` [Intel-gfx] " Sui Jingfeng
2023-07-11 16:43 ` [PATCH v3 3/9] PCI/VGA: Switch to aperture_contain_firmware_fb_nonreloc() Sui Jingfeng
2023-07-11 16:43 ` Sui Jingfeng
2023-07-11 16:43 ` [Intel-gfx] " Sui Jingfeng
2023-07-19 20:43 ` Bjorn Helgaas
2023-07-19 20:43 ` Bjorn Helgaas
2023-07-19 20:43 ` Bjorn Helgaas
2023-07-19 22:04 ` suijingfeng
2023-07-19 22:04 ` suijingfeng
2023-07-19 22:04 ` suijingfeng
2023-07-11 16:43 ` [PATCH v3 4/9] PCI/VGA: Improve the default VGA device selection Sui Jingfeng
2023-07-11 16:43 ` Sui Jingfeng
2023-07-11 16:43 ` Sui Jingfeng
2023-07-11 16:43 ` [Intel-gfx] " Sui Jingfeng
2023-07-17 14:07 ` suijingfeng
2023-07-17 14:07 ` suijingfeng
2023-07-17 14:07 ` suijingfeng
2023-07-17 14:07 ` [Intel-gfx] " suijingfeng
2023-07-19 19:32 ` Bjorn Helgaas
2023-07-19 19:32 ` Bjorn Helgaas
2023-07-19 19:32 ` Bjorn Helgaas
2023-07-19 19:32 ` [Intel-gfx] " Bjorn Helgaas
2023-07-19 22:32 ` suijingfeng
2023-07-19 22:32 ` suijingfeng
2023-07-19 22:32 ` suijingfeng
2023-07-19 22:32 ` [Intel-gfx] " suijingfeng
2023-07-19 22:44 ` Sui Jingfeng
2023-07-19 22:44 ` Sui Jingfeng
2023-07-19 22:44 ` Sui Jingfeng
2023-07-19 22:44 ` [Intel-gfx] " Sui Jingfeng
2023-07-19 22:51 ` suijingfeng
2023-07-19 22:51 ` suijingfeng
2023-07-19 22:51 ` suijingfeng
2023-07-19 22:51 ` [Intel-gfx] " suijingfeng
2023-07-24 11:56 ` suijingfeng
2023-07-24 11:56 ` suijingfeng
2023-07-24 11:56 ` suijingfeng
2023-07-24 11:56 ` [Intel-gfx] " suijingfeng
2023-07-24 12:16 ` suijingfeng
2023-07-24 12:16 ` suijingfeng
2023-07-24 12:16 ` suijingfeng
2023-07-24 12:16 ` [Intel-gfx] " suijingfeng
2023-07-25 21:30 ` Bjorn Helgaas
2023-07-25 21:30 ` Bjorn Helgaas
2023-07-25 21:30 ` Bjorn Helgaas
2023-07-25 21:30 ` [Intel-gfx] " Bjorn Helgaas
2023-07-24 12:28 ` suijingfeng
2023-07-24 12:28 ` suijingfeng
2023-07-24 12:28 ` suijingfeng
2023-07-24 12:28 ` [Intel-gfx] " suijingfeng
2023-07-11 16:43 ` [PATCH v3 5/9] drm/amdgpu: Implement the is_primary_gpu callback of vga_client_register() Sui Jingfeng
2023-07-11 16:43 ` Sui Jingfeng
2023-07-11 16:43 ` [Intel-gfx] " Sui Jingfeng
2023-07-11 16:43 ` [PATCH v3 6/9] drm/radeon: Add an implement for the is_primary_gpu function callback Sui Jingfeng
2023-07-11 16:43 ` Sui Jingfeng
2023-07-11 16:43 ` Sui Jingfeng
2023-07-11 16:43 ` [Intel-gfx] " Sui Jingfeng
2023-07-11 16:43 ` [PATCH v3 7/9] drm/i915: Add an implement for the is_primary_gpu hook Sui Jingfeng
2023-07-11 16:43 ` Sui Jingfeng
2023-07-11 16:43 ` Sui Jingfeng
2023-07-11 16:43 ` [Intel-gfx] " Sui Jingfeng
2023-07-11 16:43 ` [PATCH v3 8/9] drm/ast: Register as a vga client to vgaarb by calling vga_client_register() Sui Jingfeng
2023-07-11 16:43 ` Sui Jingfeng
2023-07-11 16:43 ` Sui Jingfeng
2023-07-11 16:43 ` [Intel-gfx] " Sui Jingfeng
2023-07-11 16:43 ` [PATCH v3 9/9] drm/loongson: Add an implement for the is_primary_gpu function callback Sui Jingfeng
2023-07-11 16:43 ` Sui Jingfeng
2023-07-11 16:43 ` [Intel-gfx] " Sui Jingfeng
2023-07-11 18:24 ` [Intel-gfx] ✗ Fi.CI.BUILD: failure for PCI/VGA: Improve the default VGA device selection Patchwork
2023-07-19 19:32 ` [PATCH v3 0/9] " Bjorn Helgaas
2023-07-19 19:32 ` Bjorn Helgaas
2023-07-19 19:32 ` Bjorn Helgaas
2023-07-19 19:32 ` [Intel-gfx] " Bjorn Helgaas
2023-07-20 9:17 ` Sui Jingfeng [this message]
2023-07-20 9:17 ` Sui Jingfeng
2023-07-20 9:17 ` Sui Jingfeng
2023-07-20 9:17 ` [Intel-gfx] " Sui Jingfeng
2023-07-24 12:47 ` suijingfeng
2023-07-24 12:47 ` suijingfeng
2023-07-24 12:47 ` suijingfeng
2023-07-24 12:47 ` [Intel-gfx] " suijingfeng
2023-07-25 21:32 ` Bjorn Helgaas
2023-07-25 21:32 ` Bjorn Helgaas
2023-07-25 21:32 ` Bjorn Helgaas
2023-07-25 21:32 ` [Intel-gfx] " Bjorn Helgaas
-- strict thread matches above, loose matches on Subject: below --
2023-07-11 16:31 Sui Jingfeng
2023-07-11 16:31 ` Sui Jingfeng
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=5c91b8dd-5342-0eb2-aef4-dbb865d6dfda@linux.dev \
--to=sui.jingfeng@linux.dev \
--cc=airlied@gmail.com \
--cc=amd-gfx@lists.freedesktop.org \
--cc=dri-devel@lists.freedesktop.org \
--cc=helgaas@kernel.org \
--cc=intel-gfx@lists.freedesktop.org \
--cc=kvm@vger.kernel.org \
--cc=linux-fbdev@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-pci@vger.kernel.org \
--cc=suijingfeng@loongson.cn \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.