All of lore.kernel.org
 help / color / mirror / Atom feed
From: Markus Armbruster <armbru@redhat.com>
To: "Daniel P. Berrangé" <berrange@redhat.com>
Cc: "Markus Armbruster" <armbru@redhat.com>,
	qemu-devel@nongnu.org, devel@lists.libvirt.org,
	"Marc-André Lureau" <marcandre.lureau@redhat.com>,
	"Paolo Bonzini" <pbonzini@redhat.com>,
	"Dr. David Alan Gilbert" <dave@treblig.org>,
	"Alex Bennée" <alex.bennee@linaro.org>,
	"Christian Brauner" <brauner@kernel.org>,
	"Philippe Mathieu-Daudé" <philmd@mailo.com>,
	"Peter Krempa" <pkrempa@redhat.com>
Subject: Re: [PATCH v5 01/35] qom: replace 'can_be_deleted' with 'prepare_delete'
Date: Wed, 01 Jul 2026 15:03:30 +0200	[thread overview]
Message-ID: <8733y26evx.fsf@pond.sub.org> (raw)
In-Reply-To: <akOJbvaI7lvoW6Xw@redhat.com> ("Daniel P. Berrangé"'s message of "Tue, 30 Jun 2026 10:16:30 +0100")

Daniel P. Berrangé <berrange@redhat.com> writes:

> On Tue, Jun 30, 2026 at 09:34:26AM +0200, Markus Armbruster wrote:
>> Daniel P. Berrangé <berrange@redhat.com> writes:
>> 
>> > While most objects can perform all their cleanup in the finalizer
>> > method, there can be interactions with other resources / subsystems
>> > / threads which require that some cleanup be performed on an user
>> > creatable object before unparenting it and entering finalization.
>> >
>> > The current 'can_be_deleted' method runs in the deletion path and
>> > is intended to be used to block deletion. While it could be used
>> > to perform cleanup tasks, its name suggests it should be free of
>> > side-effects.
>> >
>> > Generalize this by renaming it to 'prepare_delete', explicitly
>> > allowing for cleanup to be provided. Existing users of 'can_be_deleted'
>> > are re-written, which provides them with more detailed/tailored error
>> > messages.
>> >
>> > Reviewed-by: Marc-André Lureau <marcandre.lureau@redhat.com>
>> > Tested-by: Peter Krempa <pkrempa@redhat.com>
>> > Signed-off-by: Daniel P. Berrangé <berrange@redhat.com>
>> 
>> [...]
>> 
>> > diff --git a/qom/object_interfaces.c b/qom/object_interfaces.c
>> > index 7080f85f95..6faa0b2fd9 100644
>> > --- a/qom/object_interfaces.c
>> > +++ b/qom/object_interfaces.c
>> > @@ -32,16 +32,15 @@ bool user_creatable_complete(UserCreatable *uc, Error **errp)
>> >      return !*errp;
>> >  }
>> >  
>> > -bool user_creatable_can_be_deleted(UserCreatable *uc)
>> > +bool user_creatable_prepare_delete(UserCreatable *uc, Error **errp)
>> >  {
>> > -
>> >      UserCreatableClass *ucc = USER_CREATABLE_GET_CLASS(uc);
>> > +    ERRP_GUARD();
>> >  
>> > -    if (ucc->can_be_deleted) {
>> > -        return ucc->can_be_deleted(uc);
>> > -    } else {
>> > -        return true;
>> > +    if (ucc->prepare_delete) {
>> > +        ucc->prepare_delete(uc, errp);
>> >      }
>> > +    return !*errp;
>> >  }
>> 
>> Simpler:
>> 
>>        if (ucc->prepare_delete) {
>>            return ucc->prepare_delete(uc, errp);
>>        }
>> 
>>        return true;
>
> ok
>
>> 
>> >  
>> >  void user_creatable_add_qapi(ObjectOptions *options, Error **errp)
>> > @@ -253,8 +252,7 @@ bool user_creatable_del(const char *id, Error **errp)
>> >          return false;
>> >      }
>> >  
>> > -    if (!user_creatable_can_be_deleted(USER_CREATABLE(obj))) {
>> > -        error_setg(errp, "object '%s' is in use, can not be deleted", id);
>> > +    if (!user_creatable_prepare_delete(USER_CREATABLE(obj), errp)) {
>> 
>> This changes error messages.
>> 
>> The old ones mention @id.
>> 
>> The new ones don't:
>> 
>>         error_setg(errp, "Cryptodev backend is still in use");
>>         error_setg(errp, "Host memory backend is still mapped");
>>         error_setg(errp, "IOMMUFD backend still has %d users", be->users);
>>         error_setg(errp, "Throttle group still has multiple references");
>>     error_setg(errp, "Deleting can bus devices is not supported");

Spel it CAN, please.

>>     error_setg(errp, "Deleting main loop is not supported");
>> 
>> Visible in the diff to tests/qemu-iotests/245 below.
>> 
>> Because this runs within object-del, and @id is the argument provided by
>> the user there, the error message is still sufficiently clear, I guess.
>> 
>> If this ever gets used where the object isn't obvious to the user from
>> context, the error messages become sub-par.  Observation, not a demand.
>> 
>> Please cover this change in the commit message.
>
> Oh yes, I remember being slightly annoyed at the need to do
> this - I was surprised to realize that an Object does not
> actually know its own 'id'. The 'id' only exists as the
> name of the property in the parent.
>
> We could add an  object_get_id() API which traveres obj->parent
> and then iterates over child properties. Annoyingly O(n) time
> for that, but perhaps not a big enough problem to worry about ?
> At least for error reporting we're probably ok with that time
> complexity even if there are 1000 objects registered as children.

Could you use object_get_canonical_path_component()?

[...]



  reply	other threads:[~2026-07-01 13:04 UTC|newest]

Thread overview: 71+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2026-06-24 17:37 [PATCH v5 00/35] monitor: turn QMP and HMP into QOM objects Daniel P. Berrangé
2026-06-24 17:37 ` [PATCH v5 01/35] qom: replace 'can_be_deleted' with 'prepare_delete' Daniel P. Berrangé
2026-06-30  7:34   ` Markus Armbruster
2026-06-30  9:16     ` Daniel P. Berrangé
2026-07-01 13:03       ` Markus Armbruster [this message]
2026-07-01 13:08         ` Daniel P. Berrangé
2026-06-24 17:37 ` [PATCH v5 02/35] monitor: replace 'common' with 'parent_obj' in MonitorHMP Daniel P. Berrangé
2026-06-24 17:37 ` [PATCH v5 03/35] monitor: replace 'common' with 'parent_obj' in MonitorQMP Daniel P. Berrangé
2026-06-24 17:37 ` [PATCH v5 04/35] monitor: rename monitor_init* to monitor_new* Daniel P. Berrangé
2026-06-24 17:37 ` [PATCH v5 05/35] monitor: minimal conversion of monitors to QOM Daniel P. Berrangé
2026-06-30 11:55   ` Markus Armbruster
2026-06-30 12:43     ` Daniel P. Berrangé
2026-07-01 13:19       ` Markus Armbruster
2026-07-01 13:26         ` Daniel P. Berrangé
2026-07-02 13:10         ` Daniel P. Berrangé
2026-07-03 11:42           ` Markus Armbruster
2026-06-24 17:37 ` [PATCH v5 06/35] monitor: add 'chardev' property to Monitor base class Daniel P. Berrangé
2026-06-24 17:37 ` [PATCH v5 07/35] monitor: add 'readline' property to HMP Monitor class Daniel P. Berrangé
2026-06-24 17:37 ` [PATCH v5 08/35] monitor: add 'pretty' property to QMP " Daniel P. Berrangé
2026-06-24 17:37 ` [PATCH v5 09/35] monitor: remove 'skip_flush' field Daniel P. Berrangé
2026-06-24 17:37 ` [PATCH v5 10/35] monitor: move monitor_data_(init|destroy) into QOM init/finalize Daniel P. Berrangé
2026-06-24 17:37 ` [PATCH v5 11/35] monitor: use class methods for monitor_vprintf Daniel P. Berrangé
2026-06-24 17:37 ` [PATCH v5 12/35] monitor: use class methods for monitor_qapi_event_emit Daniel P. Berrangé
2026-06-24 17:37 ` [PATCH v5 13/35] monitor: use class methods for monitor_accept_input Daniel P. Berrangé
2026-06-24 17:37 ` [PATCH v5 14/35] monitor: use class method for I/O thread request Daniel P. Berrangé
2026-06-24 17:37 ` [PATCH v5 15/35] monitor: use dynamic cast in monitor_qmp_requests_pop_any_with_lock Daniel P. Berrangé
2026-06-24 17:37 ` [PATCH v5 16/35] util: use dynamic cast in error vreport Daniel P. Berrangé
2026-06-24 17:37 ` [PATCH v5 17/35] monitor: drop unused monitor_cur_is_qmp Daniel P. Berrangé
2026-06-24 17:37 ` [PATCH v5 18/35] monitor: use dynamic cast in QMP commands Daniel P. Berrangé
2026-06-24 17:37 ` [PATCH v5 19/35] monitor: use dynamic cast in monitor_is_hmp_non_interactive Daniel P. Berrangé
2026-06-24 17:37 ` [PATCH v5 20/35] monitor: drop unused monitor_is_qmp method Daniel P. Berrangé
2026-06-24 17:37 ` [PATCH v5 21/35] monitor: eliminate monitor_is_hmp_non_interactive method Daniel P. Berrangé
2026-06-24 17:37 ` [PATCH v5 22/35] monitor: implement "user creatable" interface for adding monitors Daniel P. Berrangé
2026-06-30 14:55   ` Markus Armbruster
2026-06-24 17:37 ` [PATCH v5 23/35] monitor: convert from oneshot BH to persistent BH Daniel P. Berrangé
2026-06-24 17:37 ` [PATCH v5 24/35] monitor: reject attempts to delete the current monitor Daniel P. Berrangé
2026-06-24 17:37 ` [PATCH v5 25/35] monitor: protect qemu_chr_fe_accept_input with monitor lock Daniel P. Berrangé
2026-06-24 17:37 ` [PATCH v5 26/35] monitor: implement support for deleting QMP objects Daniel P. Berrangé
2026-06-24 17:37 ` [PATCH v5 27/35] tests/qtest: add tests for dynamic monitor add/remove Daniel P. Berrangé
2026-06-24 17:37 ` [PATCH v5 28/35] tests/functional: add e2e test for dynamic QMP monitor hotplug Daniel P. Berrangé
2026-06-24 17:37 ` [PATCH v5 29/35] tests/functional: add a stress test for monitor hot unplug Daniel P. Berrangé
2026-06-24 17:37 ` [PATCH v5 30/35] qom: add method for getting the "id" of a QOM object Daniel P. Berrangé
2026-07-01 12:57   ` Markus Armbruster
2026-07-01 13:00     ` Daniel P. Berrangé
2026-06-24 17:37 ` [PATCH v5 31/35] qom: add trace events for user creatable create/delete APIs Daniel P. Berrangé
2026-06-24 17:37 ` [PATCH v5 32/35] monitor: add support for auto-deleting monitors upon close Daniel P. Berrangé
2026-06-24 20:47   ` marcandre.lureau
2026-07-01  6:32     ` Markus Armbruster
2026-07-01  8:10       ` Daniel P. Berrangé
2026-07-01 13:37         ` Markus Armbruster
2026-07-01 13:45           ` Daniel P. Berrangé
2026-07-01 14:19             ` Dr. David Alan Gilbert
2026-07-02 13:32       ` Daniel P. Berrangé
2026-07-02 14:07         ` Markus Armbruster
2026-07-02 14:10           ` Daniel P. Berrangé
2026-06-24 17:37 ` [PATCH v5 33/35] tests: switch from -mon to -object monitor-qmp Daniel P. Berrangé
2026-07-01  7:35   ` Markus Armbruster
2026-07-01  8:14     ` Daniel P. Berrangé
2026-06-24 17:37 ` [PATCH v5 34/35] qemu-options: document new monitor-hmp and monitor-qmp objects Daniel P. Berrangé
2026-07-01  7:27   ` Markus Armbruster
2026-07-01  8:16     ` Daniel P. Berrangé
2026-06-24 17:37 ` [PATCH v5 35/35] docs: mark '-mon' as deprecated in favour of -object Daniel P. Berrangé
2026-07-01 13:00   ` Markus Armbruster
2026-06-26 13:35 ` [PATCH v5 00/35] monitor: turn QMP and HMP into QOM objects Daniel P. Berrangé
2026-06-29 11:01   ` Markus Armbruster
2026-06-29 11:06     ` Daniel P. Berrangé
2026-06-30 12:22       ` Markus Armbruster
2026-07-01  7:52 ` Markus Armbruster
2026-07-01  8:21   ` Daniel P. Berrangé
2026-07-01 13:41     ` Markus Armbruster
2026-07-01 13:46       ` Daniel P. Berrangé

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=8733y26evx.fsf@pond.sub.org \
    --to=armbru@redhat.com \
    --cc=alex.bennee@linaro.org \
    --cc=berrange@redhat.com \
    --cc=brauner@kernel.org \
    --cc=dave@treblig.org \
    --cc=devel@lists.libvirt.org \
    --cc=marcandre.lureau@redhat.com \
    --cc=pbonzini@redhat.com \
    --cc=philmd@mailo.com \
    --cc=pkrempa@redhat.com \
    --cc=qemu-devel@nongnu.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.