All of lore.kernel.org
 help / color / mirror / Atom feed
From: "Daniel P. Berrangé" <berrange@redhat.com>
To: Markus Armbruster <armbru@redhat.com>
Cc: qemu-devel@nongnu.org, devel@lists.libvirt.org,
	"Marc-André Lureau" <marcandre.lureau@redhat.com>,
	"Paolo Bonzini" <pbonzini@redhat.com>,
	"Dr. David Alan Gilbert" <dave@treblig.org>,
	"Alex Bennée" <alex.bennee@linaro.org>,
	"Christian Brauner" <brauner@kernel.org>,
	"Philippe Mathieu-Daudé" <philmd@mailo.com>,
	"Peter Krempa" <pkrempa@redhat.com>
Subject: Re: [PATCH v5 05/35] monitor: minimal conversion of monitors to QOM
Date: Wed, 1 Jul 2026 14:26:30 +0100	[thread overview]
Message-ID: <akUVhiXlz_wisGhV@redhat.com> (raw)
In-Reply-To: <87tsqi4zk6.fsf@pond.sub.org>

On Wed, Jul 01, 2026 at 03:19:53PM +0200, Markus Armbruster wrote:
> Daniel P. Berrangé <berrange@redhat.com> writes:
> 
> > On Tue, Jun 30, 2026 at 01:55:52PM +0200, Markus Armbruster wrote:
> >> Daniel P. Berrangé <berrange@redhat.com> writes:
> >> 
> >> > This introduces a Monitor QOM object, with MonitorHMP and
> >> > MonitorQMP subclasses. This is the bare minimum conversion
> >> > of just the type declarations and replacing g_new/g_free
> >> > with object_new/object_unref.
> >> >
> >> > Reviewed-by: Marc-André Lureau <marcandre.lureau@redhat.com>
> >> > Tested-by: Peter Krempa <pkrempa@redhat.com>
> >> > Signed-off-by: Daniel P. Berrangé <berrange@redhat.com>
> >> > ---
> >> >  include/monitor/monitor.h  | 11 ++++++++++-
> >> >  monitor/hmp.c              | 29 +++++++++++++++++++++++++++--
> >> >  monitor/monitor-internal.h | 18 ++++++++++++++++--
> >> >  monitor/monitor.c          | 18 ++++++++++++++++--
> >> >  monitor/qmp-cmds.c         | 15 ++++++++-------
> >> >  monitor/qmp.c              | 29 +++++++++++++++++++++++++++--
> >> >  6 files changed, 104 insertions(+), 16 deletions(-)
> >> >
> >> > diff --git a/include/monitor/monitor.h b/include/monitor/monitor.h
> >> > index b9642b58ba..2e9f9e12e9 100644
> >> > --- a/include/monitor/monitor.h
> >> > +++ b/include/monitor/monitor.h
> >> > @@ -5,8 +5,17 @@
> >> >  #include "qapi/qapi-types-misc.h"
> >> >  #include "qemu/readline.h"
> >> >  #include "exec/hwaddr.h"
> >> > +#include "qom/object.h"
> >> > +
> >> > +#define TYPE_MONITOR "monitor"
> >> > +OBJECT_DECLARE_TYPE(Monitor, MonitorClass, MONITOR);
> >> > +
> >> > +#define TYPE_MONITOR_HMP "monitor-hmp"
> >> > +OBJECT_DECLARE_TYPE(MonitorHMP, MonitorHMPClass, MONITOR_HMP);
> >> > +
> >> > +#define TYPE_MONITOR_QMP "monitor-qmp"
> >> > +OBJECT_DECLARE_TYPE(MonitorQMP, MonitorQMPClass, MONITOR_QMP);
> >> >  
> >> > -typedef struct MonitorHMP MonitorHMP;
> >> >  typedef struct MonitorOptions MonitorOptions;
> >> >  
> >> >  #define QMP_REQ_QUEUE_LEN_MAX 8
> >> > diff --git a/monitor/hmp.c b/monitor/hmp.c
> >> > index 4e4468424a..81047d2513 100644
> >> > --- a/monitor/hmp.c
> >> > +++ b/monitor/hmp.c
> >> > @@ -43,6 +43,20 @@
> >> >  #include "system/block-backend.h"
> >> >  #include "trace.h"
> >> >  
> >> > +OBJECT_DEFINE_TYPE(MonitorHMP, monitor_hmp, MONITOR_HMP, MONITOR);
> >> > +
> >> > +static void monitor_hmp_finalize(Object *obj)
> >> > +{
> >> > +}
> >> > +
> >> > +static void monitor_hmp_class_init(ObjectClass *cls, const void *data)
> >> > +{
> >> > +}
> >> > +
> >> > +static void monitor_hmp_init(Object *obj)
> >> > +{
> >> > +}
> >> > +
> >> >  static void monitor_command_cb(void *opaque, const char *cmdline,
> >> >                                 void *readline_opaque)
> >> >  {
> >> > @@ -1526,10 +1540,21 @@ static void monitor_readline_flush(void *opaque)
> >> >  
> >> >  void monitor_new_hmp(Chardev *chr, bool use_readline, Error **errp)
> >> >  {
> >> > -    MonitorHMP *mon = g_new0(MonitorHMP, 1);
> >> > +    MonitorHMP *mon;
> >> > +    static int counter;
> >> > +    g_autofree char *id = g_strdup_printf("hmpcompat%d", counter++);
> >> 
> >> Hmm.  The system picking IDs is problematic when they can clash with the
> >> user's IDs.  If we had an ounce of common sense, we'd restrict both
> >> across the board so they cannot clash.  But we don't.
> >> 
> >> We need an ID here, because we need to make the new object the child of
> >> something (actually: child of /objects/), which requires a child name.
> >> 
> >> Non-problem with -object / object-add, because @id is mandatory there.
> >> 
> >> Non-problem with -device / device_add, because we use separate parents
> >> for devices with and without @id (/machine/peripheral/ and
> >> /machine/peripheral-anon/, plus the /machine/unattached/ orphanage).
> >> 
> >> Example for an existing problem:
> >> 
> >>     $ qemu-system-x86_64 -nodefaults -monitor stdio -chardev null,id=chr0 -mon id=compat_monitor0,chardev=chr0
> >>     qemu-system-x86_64: -mon id=compat_monitor0,chardev=chr0: Duplicate ID 'compat_monitor0' for mon
> >> 
> >> Example for a problem created by this series:
> >> 
> >>     $  qemu-system-x86_64 -nodefaults -display none -S -monitor stdio -chardev null,id=chr0 -object monitor-hmp,id=hmpcompat0,chardev=chr0
> >>     qemu-system-x86_64: -monitor stdio: attempt to add duplicate property 'hmpcompat0' to object (type 'container')
> >> 
> >> I readily admit that these clashes are *unlikely*.  Still, do we really
> >> want to define an interface that claims to let you pick any ID, then
> >> rejects some of them sometimes?  Feels rather 1990s to me.  At the very
> >> least, cover the wart in the commit message.
> >
> > The way I looked at it was aything using -object with the new
> > monitor-qmp/monitor-hmp types is new code. They can:
> >
> >   1. Trivially abide the warning about "hmpcompatNN" / "qmpcompatNN"
> >      being internal usage for compat syntax
> 
> A wart you can easily cope with is still a wart.  Oh well, we'll live.
> However, the wart should be documented.
> 
> >   2. Not use both  -monitor and -object on the same QEMU instance
> >      so not have a clash between the two to begin with
> 
> Management applications aware of the monitor QOM types should use
> -object / object-add exclusively.
> 
> Human users will use -monitor to save typing.  If they then need to plug
> an additional one at run time, they have no choice but use object-add.
> Again, we'll live.
> 
> > The remaining danger where is some existing code using -object with
> > a *non-monitor* type, and calling it "hmpcompatNN" / "qmpcompatNN",
> > which would be insanity. Never say never, but I think that's an
> > acceptable risk.
> 
> The risk is acceptable.  The documentation complexity that comes with
> the wart bothers me.
> 
> Could we use id_generate()?

Yes,  we could.

With regards,
Daniel
-- 
|: https://berrange.com       ~~        https://hachyderm.io/@berrange :|
|: https://libvirt.org          ~~          https://entangle-photo.org :|
|: https://pixelfed.art/berrange   ~~    https://fstop138.berrange.com :|



  reply	other threads:[~2026-07-01 13:27 UTC|newest]

Thread overview: 71+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2026-06-24 17:37 [PATCH v5 00/35] monitor: turn QMP and HMP into QOM objects Daniel P. Berrangé
2026-06-24 17:37 ` [PATCH v5 01/35] qom: replace 'can_be_deleted' with 'prepare_delete' Daniel P. Berrangé
2026-06-30  7:34   ` Markus Armbruster
2026-06-30  9:16     ` Daniel P. Berrangé
2026-07-01 13:03       ` Markus Armbruster
2026-07-01 13:08         ` Daniel P. Berrangé
2026-06-24 17:37 ` [PATCH v5 02/35] monitor: replace 'common' with 'parent_obj' in MonitorHMP Daniel P. Berrangé
2026-06-24 17:37 ` [PATCH v5 03/35] monitor: replace 'common' with 'parent_obj' in MonitorQMP Daniel P. Berrangé
2026-06-24 17:37 ` [PATCH v5 04/35] monitor: rename monitor_init* to monitor_new* Daniel P. Berrangé
2026-06-24 17:37 ` [PATCH v5 05/35] monitor: minimal conversion of monitors to QOM Daniel P. Berrangé
2026-06-30 11:55   ` Markus Armbruster
2026-06-30 12:43     ` Daniel P. Berrangé
2026-07-01 13:19       ` Markus Armbruster
2026-07-01 13:26         ` Daniel P. Berrangé [this message]
2026-07-02 13:10         ` Daniel P. Berrangé
2026-07-03 11:42           ` Markus Armbruster
2026-06-24 17:37 ` [PATCH v5 06/35] monitor: add 'chardev' property to Monitor base class Daniel P. Berrangé
2026-06-24 17:37 ` [PATCH v5 07/35] monitor: add 'readline' property to HMP Monitor class Daniel P. Berrangé
2026-06-24 17:37 ` [PATCH v5 08/35] monitor: add 'pretty' property to QMP " Daniel P. Berrangé
2026-06-24 17:37 ` [PATCH v5 09/35] monitor: remove 'skip_flush' field Daniel P. Berrangé
2026-06-24 17:37 ` [PATCH v5 10/35] monitor: move monitor_data_(init|destroy) into QOM init/finalize Daniel P. Berrangé
2026-06-24 17:37 ` [PATCH v5 11/35] monitor: use class methods for monitor_vprintf Daniel P. Berrangé
2026-06-24 17:37 ` [PATCH v5 12/35] monitor: use class methods for monitor_qapi_event_emit Daniel P. Berrangé
2026-06-24 17:37 ` [PATCH v5 13/35] monitor: use class methods for monitor_accept_input Daniel P. Berrangé
2026-06-24 17:37 ` [PATCH v5 14/35] monitor: use class method for I/O thread request Daniel P. Berrangé
2026-06-24 17:37 ` [PATCH v5 15/35] monitor: use dynamic cast in monitor_qmp_requests_pop_any_with_lock Daniel P. Berrangé
2026-06-24 17:37 ` [PATCH v5 16/35] util: use dynamic cast in error vreport Daniel P. Berrangé
2026-06-24 17:37 ` [PATCH v5 17/35] monitor: drop unused monitor_cur_is_qmp Daniel P. Berrangé
2026-06-24 17:37 ` [PATCH v5 18/35] monitor: use dynamic cast in QMP commands Daniel P. Berrangé
2026-06-24 17:37 ` [PATCH v5 19/35] monitor: use dynamic cast in monitor_is_hmp_non_interactive Daniel P. Berrangé
2026-06-24 17:37 ` [PATCH v5 20/35] monitor: drop unused monitor_is_qmp method Daniel P. Berrangé
2026-06-24 17:37 ` [PATCH v5 21/35] monitor: eliminate monitor_is_hmp_non_interactive method Daniel P. Berrangé
2026-06-24 17:37 ` [PATCH v5 22/35] monitor: implement "user creatable" interface for adding monitors Daniel P. Berrangé
2026-06-30 14:55   ` Markus Armbruster
2026-06-24 17:37 ` [PATCH v5 23/35] monitor: convert from oneshot BH to persistent BH Daniel P. Berrangé
2026-06-24 17:37 ` [PATCH v5 24/35] monitor: reject attempts to delete the current monitor Daniel P. Berrangé
2026-06-24 17:37 ` [PATCH v5 25/35] monitor: protect qemu_chr_fe_accept_input with monitor lock Daniel P. Berrangé
2026-06-24 17:37 ` [PATCH v5 26/35] monitor: implement support for deleting QMP objects Daniel P. Berrangé
2026-06-24 17:37 ` [PATCH v5 27/35] tests/qtest: add tests for dynamic monitor add/remove Daniel P. Berrangé
2026-06-24 17:37 ` [PATCH v5 28/35] tests/functional: add e2e test for dynamic QMP monitor hotplug Daniel P. Berrangé
2026-06-24 17:37 ` [PATCH v5 29/35] tests/functional: add a stress test for monitor hot unplug Daniel P. Berrangé
2026-06-24 17:37 ` [PATCH v5 30/35] qom: add method for getting the "id" of a QOM object Daniel P. Berrangé
2026-07-01 12:57   ` Markus Armbruster
2026-07-01 13:00     ` Daniel P. Berrangé
2026-06-24 17:37 ` [PATCH v5 31/35] qom: add trace events for user creatable create/delete APIs Daniel P. Berrangé
2026-06-24 17:37 ` [PATCH v5 32/35] monitor: add support for auto-deleting monitors upon close Daniel P. Berrangé
2026-06-24 20:47   ` marcandre.lureau
2026-07-01  6:32     ` Markus Armbruster
2026-07-01  8:10       ` Daniel P. Berrangé
2026-07-01 13:37         ` Markus Armbruster
2026-07-01 13:45           ` Daniel P. Berrangé
2026-07-01 14:19             ` Dr. David Alan Gilbert
2026-07-02 13:32       ` Daniel P. Berrangé
2026-07-02 14:07         ` Markus Armbruster
2026-07-02 14:10           ` Daniel P. Berrangé
2026-06-24 17:37 ` [PATCH v5 33/35] tests: switch from -mon to -object monitor-qmp Daniel P. Berrangé
2026-07-01  7:35   ` Markus Armbruster
2026-07-01  8:14     ` Daniel P. Berrangé
2026-06-24 17:37 ` [PATCH v5 34/35] qemu-options: document new monitor-hmp and monitor-qmp objects Daniel P. Berrangé
2026-07-01  7:27   ` Markus Armbruster
2026-07-01  8:16     ` Daniel P. Berrangé
2026-06-24 17:37 ` [PATCH v5 35/35] docs: mark '-mon' as deprecated in favour of -object Daniel P. Berrangé
2026-07-01 13:00   ` Markus Armbruster
2026-06-26 13:35 ` [PATCH v5 00/35] monitor: turn QMP and HMP into QOM objects Daniel P. Berrangé
2026-06-29 11:01   ` Markus Armbruster
2026-06-29 11:06     ` Daniel P. Berrangé
2026-06-30 12:22       ` Markus Armbruster
2026-07-01  7:52 ` Markus Armbruster
2026-07-01  8:21   ` Daniel P. Berrangé
2026-07-01 13:41     ` Markus Armbruster
2026-07-01 13:46       ` Daniel P. Berrangé

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=akUVhiXlz_wisGhV@redhat.com \
    --to=berrange@redhat.com \
    --cc=alex.bennee@linaro.org \
    --cc=armbru@redhat.com \
    --cc=brauner@kernel.org \
    --cc=dave@treblig.org \
    --cc=devel@lists.libvirt.org \
    --cc=marcandre.lureau@redhat.com \
    --cc=pbonzini@redhat.com \
    --cc=philmd@mailo.com \
    --cc=pkrempa@redhat.com \
    --cc=qemu-devel@nongnu.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.