All of lore.kernel.org
 help / color / mirror / Atom feed
From: Markus Armbruster <armbru@redhat.com>
To: "Daniel P. Berrangé" <berrange@redhat.com>
Cc: qemu-devel@nongnu.org, "Paolo Bonzini" <pbonzini@redhat.com>,
	"Dr. David Alan Gilbert" <dave@treblig.org>,
	"Marc-André Lureau" <marcandre.lureau@redhat.com>,
	"Alex Bennée" <alex.bennee@linaro.org>,
	"Philippe Mathieu-Daudé" <philmd@mailo.com>,
	"Christian Brauner" <brauner@kernel.org>,
	devel@lists.libvirt.org
Subject: Re: [PATCH v6 01/34] qom: replace 'can_be_deleted' with 'prepare_delete'
Date: Fri, 03 Jul 2026 08:40:28 +0200	[thread overview]
Message-ID: <87mrw8y3s3.fsf@pond.sub.org> (raw)
In-Reply-To: <20260702160337.1910921-2-berrange@redhat.com> ("Daniel P. Berrangé"'s message of "Thu, 2 Jul 2026 17:03:04 +0100")

Daniel P. Berrangé <berrange@redhat.com> writes:

> While most objects can perform all their cleanup in the finalizer
> method, there can be interactions with other resources / subsystems
> / threads which require that some cleanup be performed on an user
> creatable object before unparenting it and entering finalization.
>
> The current 'can_be_deleted' method runs in the deletion path and
> is intended to be used to block deletion. While it could be used
> to perform cleanup tasks, its name suggests it should be free of
> side-effects.
>
> Generalize this by renaming it to 'prepare_delete', explicitly
> allowing for cleanup to be provided. Existing users of 'can_be_deleted'
> are re-written, which provides them with more detailed/tailored error
> messages.

Old message:

        error_setg(errp, "object '%s' is in use, can not be deleted", id);

New messages:

        error_setg(errp, "Cryptodev backend '%s' is still in use",
        error_setg(errp, "Host memory backend '%s' is still mapped",
        error_setg(errp, "IOMMUFD backend '%s' still has %d users",
        error_setg(errp, "Throttle group '%s' still has multiple references",
    error_setg(errp, "Deleting CAN bus device '%s' is not supported",
    error_setg(errp, "Deleting main loop '%s' is not supported",

All now mention what kind of object it is.  Users could probably figure
this out from context easily.  Welcome small improvement.

The two unconditional ones become more accurate: they now report "not
supported" instead of "in use".

The other four lose "can not be deleted".  Users can probably figure
this out from context.  Still, I lean towards error messages like "Can't
DO-SOMETHING because REASON" until that becomes overly verbose.  What do
you think?

> Signed-off-by: Daniel P. Berrangé <berrange@redhat.com>

[...]

> diff --git a/qom/object_interfaces.c b/qom/object_interfaces.c
> index 7080f85f95..ac992aa786 100644
> --- a/qom/object_interfaces.c
> +++ b/qom/object_interfaces.c
> @@ -32,16 +32,15 @@ bool user_creatable_complete(UserCreatable *uc, Error **errp)
>      return !*errp;
>  }
>  
> -bool user_creatable_can_be_deleted(UserCreatable *uc)
> +bool user_creatable_prepare_delete(UserCreatable *uc, Error **errp)
>  {
> -
>      UserCreatableClass *ucc = USER_CREATABLE_GET_CLASS(uc);
> +    ERRP_GUARD();

No longer necessary.

>  
> -    if (ucc->can_be_deleted) {
> -        return ucc->can_be_deleted(uc);
> -    } else {
> -        return true;
> +    if (ucc->prepare_delete) {
> +        return ucc->prepare_delete(uc, errp);
>      }
> +    return true;
>  }
>  
>  void user_creatable_add_qapi(ObjectOptions *options, Error **errp)
> @@ -253,8 +252,7 @@ bool user_creatable_del(const char *id, Error **errp)
>          return false;
>      }
>  
> -    if (!user_creatable_can_be_deleted(USER_CREATABLE(obj))) {
> -        error_setg(errp, "object '%s' is in use, can not be deleted", id);
> +    if (!user_creatable_prepare_delete(USER_CREATABLE(obj), errp)) {
>          return false;
>      }
>  

[...]



  reply	other threads:[~2026-07-03  6:41 UTC|newest]

Thread overview: 49+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2026-07-02 16:03 [PATCH v6 00/34] monitor: turn QMP and HMP into QOM objects Daniel P. Berrangé
2026-07-02 16:03 ` [PATCH v6 01/34] qom: replace 'can_be_deleted' with 'prepare_delete' Daniel P. Berrangé
2026-07-03  6:40   ` Markus Armbruster [this message]
2026-07-06 13:00     ` Daniel P. Berrangé
2026-07-06 13:49       ` Markus Armbruster
2026-07-02 16:03 ` [PATCH v6 02/34] monitor: replace 'common' with 'parent_obj' in MonitorHMP Daniel P. Berrangé
2026-07-02 16:03 ` [PATCH v6 03/34] monitor: replace 'common' with 'parent_obj' in MonitorQMP Daniel P. Berrangé
2026-07-02 16:03 ` [PATCH v6 04/34] monitor: rename monitor_init* to monitor_new* Daniel P. Berrangé
2026-07-02 16:03 ` [PATCH v6 05/34] monitor: minimal conversion of monitors to QOM Daniel P. Berrangé
2026-07-03 11:38   ` Markus Armbruster
2026-07-03 11:42     ` Daniel P. Berrangé
2026-07-03 12:48   ` Markus Armbruster
2026-07-06 13:09     ` Daniel P. Berrangé
2026-07-02 16:03 ` [PATCH v6 06/34] monitor: add 'chardev' property to Monitor base class Daniel P. Berrangé
2026-07-03 13:17   ` Markus Armbruster
2026-07-06 13:19     ` Daniel P. Berrangé
2026-07-02 16:03 ` [PATCH v6 07/34] monitor: add 'readline' property to HMP Monitor class Daniel P. Berrangé
2026-07-02 16:03 ` [PATCH v6 08/34] monitor: add 'pretty' property to QMP " Daniel P. Berrangé
2026-07-02 16:03 ` [PATCH v6 09/34] monitor: remove 'skip_flush' field Daniel P. Berrangé
2026-07-02 16:03 ` [PATCH v6 10/34] monitor: move monitor_data_(init|destroy) into QOM init/finalize Daniel P. Berrangé
2026-07-02 16:03 ` [PATCH v6 11/34] monitor: use class methods for monitor_vprintf Daniel P. Berrangé
2026-07-02 16:03 ` [PATCH v6 12/34] monitor: use class methods for monitor_qapi_event_emit Daniel P. Berrangé
2026-07-02 16:03 ` [PATCH v6 13/34] monitor: use class methods for monitor_accept_input Daniel P. Berrangé
2026-07-02 16:03 ` [PATCH v6 14/34] monitor: use class method for I/O thread request Daniel P. Berrangé
2026-07-02 16:03 ` [PATCH v6 15/34] monitor: use dynamic cast in monitor_qmp_requests_pop_any_with_lock Daniel P. Berrangé
2026-07-02 16:03 ` [PATCH v6 16/34] util: use dynamic cast in error vreport Daniel P. Berrangé
2026-07-02 16:03 ` [PATCH v6 17/34] monitor: drop unused monitor_cur_is_qmp Daniel P. Berrangé
2026-07-02 16:03 ` [PATCH v6 18/34] monitor: use dynamic cast in QMP commands Daniel P. Berrangé
2026-07-02 16:03 ` [PATCH v6 19/34] monitor: use dynamic cast in monitor_is_hmp_non_interactive Daniel P. Berrangé
2026-07-02 16:03 ` [PATCH v6 20/34] monitor: drop unused monitor_is_qmp method Daniel P. Berrangé
2026-07-02 16:03 ` [PATCH v6 21/34] monitor: eliminate monitor_is_hmp_non_interactive method Daniel P. Berrangé
2026-07-02 16:03 ` [PATCH v6 22/34] monitor: implement "user creatable" interface for adding monitors Daniel P. Berrangé
2026-07-02 16:03 ` [PATCH v6 23/34] monitor: convert from oneshot BH to persistent BH Daniel P. Berrangé
2026-07-02 16:03 ` [PATCH v6 24/34] monitor: reject attempts to delete the current monitor Daniel P. Berrangé
2026-07-02 16:03 ` [PATCH v6 25/34] monitor: protect qemu_chr_fe_accept_input with monitor lock Daniel P. Berrangé
2026-07-02 16:03 ` [PATCH v6 26/34] monitor: implement support for deleting QMP objects Daniel P. Berrangé
2026-07-02 16:03 ` [PATCH v6 27/34] tests/qtest: add tests for dynamic monitor add/remove Daniel P. Berrangé
2026-07-02 16:03 ` [PATCH v6 28/34] tests/functional: add e2e test for dynamic QMP monitor hotplug Daniel P. Berrangé
2026-07-02 16:03 ` [PATCH v6 29/34] tests/functional: add a stress test for monitor hot unplug Daniel P. Berrangé
2026-07-02 16:03 ` [PATCH v6 30/34] qom: add trace events for user creatable create/delete APIs Daniel P. Berrangé
2026-07-02 16:03 ` [PATCH v6 31/34] monitor: add support for auto-deleting monitors upon close Daniel P. Berrangé
2026-07-03 13:42   ` Markus Armbruster
2026-07-06 13:32     ` Daniel P. Berrangé
2026-07-02 16:03 ` [PATCH v6 32/34] tests: switch from -mon to -object monitor-qmp Daniel P. Berrangé
2026-07-02 16:03 ` [PATCH v6 33/34] qemu-options: document new monitor-hmp and monitor-qmp objects Daniel P. Berrangé
2026-07-06 10:56   ` Markus Armbruster
2026-07-06 13:38     ` Daniel P. Berrangé
2026-07-02 16:03 ` [PATCH v6 34/34] docs: mark '-mon' as deprecated in favour of -object Daniel P. Berrangé
2026-07-06 11:00   ` Markus Armbruster

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=87mrw8y3s3.fsf@pond.sub.org \
    --to=armbru@redhat.com \
    --cc=alex.bennee@linaro.org \
    --cc=berrange@redhat.com \
    --cc=brauner@kernel.org \
    --cc=dave@treblig.org \
    --cc=devel@lists.libvirt.org \
    --cc=marcandre.lureau@redhat.com \
    --cc=pbonzini@redhat.com \
    --cc=philmd@mailo.com \
    --cc=qemu-devel@nongnu.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.