From: "Daniel P. Berrangé" <berrange@redhat.com>
To: Markus Armbruster <armbru@redhat.com>
Cc: qemu-devel@nongnu.org, "Paolo Bonzini" <pbonzini@redhat.com>,
"Dr. David Alan Gilbert" <dave@treblig.org>,
"Marc-André Lureau" <marcandre.lureau@redhat.com>,
"Alex Bennée" <alex.bennee@linaro.org>,
"Philippe Mathieu-Daudé" <philmd@mailo.com>,
"Christian Brauner" <brauner@kernel.org>,
devel@lists.libvirt.org
Subject: Re: [PATCH v6 05/34] monitor: minimal conversion of monitors to QOM
Date: Mon, 6 Jul 2026 14:09:21 +0100 [thread overview]
Message-ID: <akupAVHa227qQeXh@redhat.com> (raw)
In-Reply-To: <87echkw86p.fsf@pond.sub.org>
On Fri, Jul 03, 2026 at 02:48:14PM +0200, Markus Armbruster wrote:
> Daniel P. Berrangé <berrange@redhat.com> writes:
>
> > This introduces a Monitor QOM object, with MonitorHMP and
> > MonitorQMP subclasses. This is the bare minimum conversion
> > of just the type declarations and replacing g_new/g_free
> > with object_new/object_unref. The Monitor base class is
> > abstract since only the HMP/QMP variants should ever be
> > created.
> >
> > When created through the existing QemuOpts interfaces, the
> > new internal QOM object will get assigned a dynamic ID with
> > the format "compat_monitorNNN" which is the historical
> > QemuOpts ID naming pattern.
> >
> > Signed-off-by: Daniel P. Berrangé <berrange@redhat.com>
> > ---
> > chardev/char.c | 2 +-
> > gdbstub/system.c | 2 +-
> > include/monitor/monitor.h | 18 +++++++++++++++---
> > monitor/hmp.c | 31 ++++++++++++++++++++++++++++---
> > monitor/monitor-internal.h | 18 ++++++++++++++++--
> > monitor/monitor.c | 31 +++++++++++++++++++++++++++----
> > monitor/qmp-cmds.c | 15 ++++++++-------
> > monitor/qmp.c | 31 ++++++++++++++++++++++++++++---
> > stubs/monitor-internal.c | 3 ++-
> > system/vl.c | 7 +++----
> > 10 files changed, 129 insertions(+), 29 deletions(-)
> >
> > diff --git a/chardev/char.c b/chardev/char.c
> > index 813c04d953..c71ffa7963 100644
> > --- a/chardev/char.c
> > +++ b/chardev/char.c
> > @@ -805,7 +805,7 @@ static Chardev *qemu_chr_new_from_name(const char *label, const char *filename,
> >
> > if (qemu_opt_get_bool(opts, "mux", 0)) {
> > assert(permit_mux_mon);
> > - monitor_new_hmp(chr, true, &err);
> > + monitor_new_hmp(NULL, chr, true, &err);
>
> Yet another way to create a monitor, not covered by the commit message.
>
> We get here for legacy chardev syntax "mon:...", I think. Where exactly
> in the external interface this is accepted I'm not sure. It's
> documented for -serial. See qemu-options.hx.
Yes, I confirmed this codepath hits for -serial (which means it will
apply to -parallel too, but no one cares about that )
> There is no "mon" QemuOpts.
>
> You pass NULL to monitor_new_hmp(), which makes it create the object as
> /objects/compat_monitorNNN.
Yes.
> > diff --git a/gdbstub/system.c b/gdbstub/system.c
> > index 18f6a62b2e..fda8ef9352 100644
> > --- a/gdbstub/system.c
> > +++ b/gdbstub/system.c
> > @@ -389,7 +389,7 @@ bool gdbserver_start(const char *device, Error **errp)
> > /* Initialize a monitor terminal for gdb */
> > mon_chr = qemu_chardev_new(NULL, TYPE_CHARDEV_GDB,
> > NULL, NULL, &error_abort);
> > - monitor_new_hmp(mon_chr, false, &error_abort);
> > + monitor_new_hmp(NULL, mon_chr, false, &error_abort);
>
> And yet another, also no "mon" QemuOpts, and also
> /objects/compat_monitorNNN.
Yep, triggered with -gdbstub arg
> > diff --git a/system/vl.c b/system/vl.c
> > index 6643242729..4737c03872 100644
> > --- a/system/vl.c
> > +++ b/system/vl.c
> > @@ -1252,7 +1252,6 @@ static int mon_init_func(void *opaque, QemuOpts *opts, Error **errp)
> >
> > static void monitor_parse(const char *str, const char *mode, bool pretty)
> > {
> > - static int monitor_device_index = 0;
> > QemuOpts *opts;
> > const char *p;
> > char label[32];
> > @@ -1260,8 +1259,9 @@ static void monitor_parse(const char *str, const char *mode, bool pretty)
> > if (strstart(str, "chardev:", &p)) {
> > snprintf(label, sizeof(label), "%s", p);
> > } else {
> > - snprintf(label, sizeof(label), "compat_monitor%d",
> > - monitor_device_index);
> > + g_autofree char *id = monitor_compat_id();
> > + assert(strlen(id) < sizeof(label));
> > + memcpy(label, id, strlen(id) + 1);
> > opts = qemu_chr_parse_compat(label, str, true);
> > if (!opts) {
> > error_report("parse error: %s", str);
> > @@ -1277,7 +1277,6 @@ static void monitor_parse(const char *str, const char *mode, bool pretty)
> > } else {
> > assert(pretty == false);
> > }
> > - monitor_device_index++;
>
> Before the patch, we increment the NNN in "compat_monitorNNN" exactly
> here.
>
> Afterwards, we increment it in monitor_compat_id(), which gets called
> from here and several additional places.
>
> If any of the additional places execute before an execution of the
> original place, NNN change.
>
> Feels tolerable, but needs a mention in the commit message.
Yes, will mention the change in NNN incrementing.
With regards,
Daniel
--
|: https://berrange.com ~~ https://hachyderm.io/@berrange :|
|: https://libvirt.org ~~ https://entangle-photo.org :|
|: https://pixelfed.art/berrange ~~ https://fstop138.berrange.com :|
next prev parent reply other threads:[~2026-07-06 13:09 UTC|newest]
Thread overview: 49+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-07-02 16:03 [PATCH v6 00/34] monitor: turn QMP and HMP into QOM objects Daniel P. Berrangé
2026-07-02 16:03 ` [PATCH v6 01/34] qom: replace 'can_be_deleted' with 'prepare_delete' Daniel P. Berrangé
2026-07-03 6:40 ` Markus Armbruster
2026-07-06 13:00 ` Daniel P. Berrangé
2026-07-06 13:49 ` Markus Armbruster
2026-07-02 16:03 ` [PATCH v6 02/34] monitor: replace 'common' with 'parent_obj' in MonitorHMP Daniel P. Berrangé
2026-07-02 16:03 ` [PATCH v6 03/34] monitor: replace 'common' with 'parent_obj' in MonitorQMP Daniel P. Berrangé
2026-07-02 16:03 ` [PATCH v6 04/34] monitor: rename monitor_init* to monitor_new* Daniel P. Berrangé
2026-07-02 16:03 ` [PATCH v6 05/34] monitor: minimal conversion of monitors to QOM Daniel P. Berrangé
2026-07-03 11:38 ` Markus Armbruster
2026-07-03 11:42 ` Daniel P. Berrangé
2026-07-03 12:48 ` Markus Armbruster
2026-07-06 13:09 ` Daniel P. Berrangé [this message]
2026-07-02 16:03 ` [PATCH v6 06/34] monitor: add 'chardev' property to Monitor base class Daniel P. Berrangé
2026-07-03 13:17 ` Markus Armbruster
2026-07-06 13:19 ` Daniel P. Berrangé
2026-07-02 16:03 ` [PATCH v6 07/34] monitor: add 'readline' property to HMP Monitor class Daniel P. Berrangé
2026-07-02 16:03 ` [PATCH v6 08/34] monitor: add 'pretty' property to QMP " Daniel P. Berrangé
2026-07-02 16:03 ` [PATCH v6 09/34] monitor: remove 'skip_flush' field Daniel P. Berrangé
2026-07-02 16:03 ` [PATCH v6 10/34] monitor: move monitor_data_(init|destroy) into QOM init/finalize Daniel P. Berrangé
2026-07-02 16:03 ` [PATCH v6 11/34] monitor: use class methods for monitor_vprintf Daniel P. Berrangé
2026-07-02 16:03 ` [PATCH v6 12/34] monitor: use class methods for monitor_qapi_event_emit Daniel P. Berrangé
2026-07-02 16:03 ` [PATCH v6 13/34] monitor: use class methods for monitor_accept_input Daniel P. Berrangé
2026-07-02 16:03 ` [PATCH v6 14/34] monitor: use class method for I/O thread request Daniel P. Berrangé
2026-07-02 16:03 ` [PATCH v6 15/34] monitor: use dynamic cast in monitor_qmp_requests_pop_any_with_lock Daniel P. Berrangé
2026-07-02 16:03 ` [PATCH v6 16/34] util: use dynamic cast in error vreport Daniel P. Berrangé
2026-07-02 16:03 ` [PATCH v6 17/34] monitor: drop unused monitor_cur_is_qmp Daniel P. Berrangé
2026-07-02 16:03 ` [PATCH v6 18/34] monitor: use dynamic cast in QMP commands Daniel P. Berrangé
2026-07-02 16:03 ` [PATCH v6 19/34] monitor: use dynamic cast in monitor_is_hmp_non_interactive Daniel P. Berrangé
2026-07-02 16:03 ` [PATCH v6 20/34] monitor: drop unused monitor_is_qmp method Daniel P. Berrangé
2026-07-02 16:03 ` [PATCH v6 21/34] monitor: eliminate monitor_is_hmp_non_interactive method Daniel P. Berrangé
2026-07-02 16:03 ` [PATCH v6 22/34] monitor: implement "user creatable" interface for adding monitors Daniel P. Berrangé
2026-07-02 16:03 ` [PATCH v6 23/34] monitor: convert from oneshot BH to persistent BH Daniel P. Berrangé
2026-07-02 16:03 ` [PATCH v6 24/34] monitor: reject attempts to delete the current monitor Daniel P. Berrangé
2026-07-02 16:03 ` [PATCH v6 25/34] monitor: protect qemu_chr_fe_accept_input with monitor lock Daniel P. Berrangé
2026-07-02 16:03 ` [PATCH v6 26/34] monitor: implement support for deleting QMP objects Daniel P. Berrangé
2026-07-02 16:03 ` [PATCH v6 27/34] tests/qtest: add tests for dynamic monitor add/remove Daniel P. Berrangé
2026-07-02 16:03 ` [PATCH v6 28/34] tests/functional: add e2e test for dynamic QMP monitor hotplug Daniel P. Berrangé
2026-07-02 16:03 ` [PATCH v6 29/34] tests/functional: add a stress test for monitor hot unplug Daniel P. Berrangé
2026-07-02 16:03 ` [PATCH v6 30/34] qom: add trace events for user creatable create/delete APIs Daniel P. Berrangé
2026-07-02 16:03 ` [PATCH v6 31/34] monitor: add support for auto-deleting monitors upon close Daniel P. Berrangé
2026-07-03 13:42 ` Markus Armbruster
2026-07-06 13:32 ` Daniel P. Berrangé
2026-07-02 16:03 ` [PATCH v6 32/34] tests: switch from -mon to -object monitor-qmp Daniel P. Berrangé
2026-07-02 16:03 ` [PATCH v6 33/34] qemu-options: document new monitor-hmp and monitor-qmp objects Daniel P. Berrangé
2026-07-06 10:56 ` Markus Armbruster
2026-07-06 13:38 ` Daniel P. Berrangé
2026-07-02 16:03 ` [PATCH v6 34/34] docs: mark '-mon' as deprecated in favour of -object Daniel P. Berrangé
2026-07-06 11:00 ` Markus Armbruster
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=akupAVHa227qQeXh@redhat.com \
--to=berrange@redhat.com \
--cc=alex.bennee@linaro.org \
--cc=armbru@redhat.com \
--cc=brauner@kernel.org \
--cc=dave@treblig.org \
--cc=devel@lists.libvirt.org \
--cc=marcandre.lureau@redhat.com \
--cc=pbonzini@redhat.com \
--cc=philmd@mailo.com \
--cc=qemu-devel@nongnu.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.