All of lore.kernel.org
 help / color / mirror / Atom feed
From: Markus Armbruster <armbru@redhat.com>
To: "Daniel P. Berrangé" <berrange@redhat.com>
Cc: qemu-devel@nongnu.org, "Paolo Bonzini" <pbonzini@redhat.com>,
	"Dr. David Alan Gilbert" <dave@treblig.org>,
	"Markus Armbruster" <armbru@redhat.com>,
	"Marc-André Lureau" <marcandre.lureau@redhat.com>,
	"Alex Bennée" <alex.bennee@linaro.org>,
	"Philippe Mathieu-Daudé" <philmd@mailo.com>,
	"Christian Brauner" <brauner@kernel.org>,
	devel@lists.libvirt.org, "Peter Krempa" <pkrempa@redhat.com>
Subject: Re: [PATCH v6 06/34] monitor: add 'chardev' property to Monitor base class
Date: Fri, 03 Jul 2026 15:17:11 +0200	[thread overview]
Message-ID: <87zf08usa0.fsf@pond.sub.org> (raw)
In-Reply-To: <20260702160337.1910921-7-berrange@redhat.com> ("Daniel P. Berrangé"'s message of "Thu, 2 Jul 2026 17:03:09 +0100")

Daniel P. Berrangé <berrange@redhat.com> writes:

> This is associates both QMP and HMP monitors with a character
> device backend.
>
> Reviewed-by: Marc-André Lureau <marcandre.lureau@redhat.com>
> Tested-by: Peter Krempa <pkrempa@redhat.com>
> Signed-off-by: Daniel P. Berrangé <berrange@redhat.com>
> ---
>  chardev/char.c             |  3 ++-
>  gdbstub/system.c           |  4 ++--
>  include/monitor/monitor.h  |  4 ++--
>  monitor/hmp.c              | 10 ++++++--
>  monitor/monitor-internal.h |  2 ++
>  monitor/monitor.c          | 47 ++++++++++++++++++++++++++++++--------
>  monitor/qmp.c              | 18 ++++++++++-----
>  stubs/monitor-internal.c   |  2 +-
>  8 files changed, 67 insertions(+), 23 deletions(-)
>
> diff --git a/chardev/char.c b/chardev/char.c
> index c71ffa7963..22e5bae388 100644
> --- a/chardev/char.c
> +++ b/chardev/char.c
> @@ -804,8 +804,9 @@ static Chardev *qemu_chr_new_from_name(const char *label, const char *filename,
>      }
>  
>      if (qemu_opt_get_bool(opts, "mux", 0)) {
> +        const char *chardev_id = qemu_opts_id(opts);
>          assert(permit_mux_mon);
> -        monitor_new_hmp(NULL, chr, true, &err);
> +        monitor_new_hmp(NULL, chardev_id, true, &err);
>          if (err) {
>              error_report_err(err);
>              object_unparent(OBJECT(chr));
> diff --git a/gdbstub/system.c b/gdbstub/system.c
> index fda8ef9352..d681476f5e 100644
> --- a/gdbstub/system.c
> +++ b/gdbstub/system.c
> @@ -387,9 +387,9 @@ bool gdbserver_start(const char *device, Error **errp)
>          qemu_add_vm_change_state_handler(gdb_vm_state_change, NULL);
>  
>          /* Initialize a monitor terminal for gdb */
> -        mon_chr = qemu_chardev_new(NULL, TYPE_CHARDEV_GDB,
> +        mon_chr = qemu_chardev_new("gdbchrdev0", TYPE_CHARDEV_GDB,
>                                     NULL, NULL, &error_abort);

This chardev now gets ID "gdbchrdev0" instead of id_generate(ID_CHR).

If you truly need this, you have to mention it in the commit message.

> -        monitor_new_hmp(NULL, mon_chr, false, &error_abort);
> +        monitor_new_hmp(NULL, "gdbchrdev0", false, &error_abort);

If you don't, then passing mon_chr->label here should do the trick.

>      } else {
>          qemu_chr_fe_deinit(&gdbserver_system_state.chr, true);
>          mon_chr = gdbserver_system_state.mon_chr;
> diff --git a/include/monitor/monitor.h b/include/monitor/monitor.h
> index 83723f705a..bfbeedec9b 100644
> --- a/include/monitor/monitor.h
> +++ b/include/monitor/monitor.h
> @@ -29,9 +29,9 @@ bool monitor_cur_is_qmp(void);
>  void monitor_init_globals(void);
>  void monitor_init_globals_core(void);
>  char *monitor_compat_id(void);
> -void monitor_new_qmp(const char *id, Chardev *chr,
> +void monitor_new_qmp(const char *id, const char *chardev_id,
>                       bool pretty, Error **errp);
> -void monitor_new_hmp(const char *id, Chardev *chr,
> +void monitor_new_hmp(const char *id, const char *chardev_id,
>                       bool use_readline, Error **errp);
>  int monitor_new(MonitorOptions *opts, bool allow_hmp, Error **errp);
>  int monitor_new_opts(QemuOpts *opts, Error **errp);
> diff --git a/monitor/hmp.c b/monitor/hmp.c
> index da11e56854..be59b6ca65 100644
> --- a/monitor/hmp.c
> +++ b/monitor/hmp.c
> @@ -23,6 +23,7 @@
>   */
>  
>  #include "qemu/osdep.h"
> +#include "qapi/error.h"
>  #include <dirent.h>
>  #include "hw/core/qdev.h"
>  #include "hw/core/sysemu-cpu-ops.h"
> @@ -1538,22 +1539,27 @@ static void monitor_readline_flush(void *opaque)
>      monitor_flush(&mon->parent_obj);
>  }
>  
> -void monitor_new_hmp(const char *id, Chardev *chr,
> +void monitor_new_hmp(const char *id, const char *chardev_id,
>                       bool use_readline, Error **errp)

You now pass a chardev ID instead of a Chardev *.

I *guess* that's possible because chardev_new() asserts it's passed an
ID.

I should now check all callers of monitor_new_hmp() to make sure they
pass the correct ID.  On a Friday afternoon.  I hoist the white flag.

Such refactorings should be mentioned in the commit message.  Even
better would be a separate patch.

>  {
> +    ERRP_GUARD();
>      MonitorHMP *mon;
>      g_autofree char *autoid = id ? NULL : monitor_compat_id();
>      Object *obj = object_new_with_props(TYPE_MONITOR_HMP,
>                                          object_get_objects_root(),
>                                          id ? id : autoid,
>                                          errp,
> +                                        "chardev", chardev_id,
>                                          NULL);
> +
>      if (!obj) {
>          return;
>      }
> +
>      mon = MONITOR_HMP(obj);
>  
> -    if (!qemu_chr_fe_init(&mon->parent_obj.chr, chr, errp)) {
> +    monitor_complete(MONITOR(mon), errp);
> +    if (*errp) {
>          object_unparent(OBJECT(mon));
>          return;
>      }

[...]



  reply	other threads:[~2026-07-03 13:17 UTC|newest]

Thread overview: 49+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2026-07-02 16:03 [PATCH v6 00/34] monitor: turn QMP and HMP into QOM objects Daniel P. Berrangé
2026-07-02 16:03 ` [PATCH v6 01/34] qom: replace 'can_be_deleted' with 'prepare_delete' Daniel P. Berrangé
2026-07-03  6:40   ` Markus Armbruster
2026-07-06 13:00     ` Daniel P. Berrangé
2026-07-06 13:49       ` Markus Armbruster
2026-07-02 16:03 ` [PATCH v6 02/34] monitor: replace 'common' with 'parent_obj' in MonitorHMP Daniel P. Berrangé
2026-07-02 16:03 ` [PATCH v6 03/34] monitor: replace 'common' with 'parent_obj' in MonitorQMP Daniel P. Berrangé
2026-07-02 16:03 ` [PATCH v6 04/34] monitor: rename monitor_init* to monitor_new* Daniel P. Berrangé
2026-07-02 16:03 ` [PATCH v6 05/34] monitor: minimal conversion of monitors to QOM Daniel P. Berrangé
2026-07-03 11:38   ` Markus Armbruster
2026-07-03 11:42     ` Daniel P. Berrangé
2026-07-03 12:48   ` Markus Armbruster
2026-07-06 13:09     ` Daniel P. Berrangé
2026-07-02 16:03 ` [PATCH v6 06/34] monitor: add 'chardev' property to Monitor base class Daniel P. Berrangé
2026-07-03 13:17   ` Markus Armbruster [this message]
2026-07-06 13:19     ` Daniel P. Berrangé
2026-07-02 16:03 ` [PATCH v6 07/34] monitor: add 'readline' property to HMP Monitor class Daniel P. Berrangé
2026-07-02 16:03 ` [PATCH v6 08/34] monitor: add 'pretty' property to QMP " Daniel P. Berrangé
2026-07-02 16:03 ` [PATCH v6 09/34] monitor: remove 'skip_flush' field Daniel P. Berrangé
2026-07-02 16:03 ` [PATCH v6 10/34] monitor: move monitor_data_(init|destroy) into QOM init/finalize Daniel P. Berrangé
2026-07-02 16:03 ` [PATCH v6 11/34] monitor: use class methods for monitor_vprintf Daniel P. Berrangé
2026-07-02 16:03 ` [PATCH v6 12/34] monitor: use class methods for monitor_qapi_event_emit Daniel P. Berrangé
2026-07-02 16:03 ` [PATCH v6 13/34] monitor: use class methods for monitor_accept_input Daniel P. Berrangé
2026-07-02 16:03 ` [PATCH v6 14/34] monitor: use class method for I/O thread request Daniel P. Berrangé
2026-07-02 16:03 ` [PATCH v6 15/34] monitor: use dynamic cast in monitor_qmp_requests_pop_any_with_lock Daniel P. Berrangé
2026-07-02 16:03 ` [PATCH v6 16/34] util: use dynamic cast in error vreport Daniel P. Berrangé
2026-07-02 16:03 ` [PATCH v6 17/34] monitor: drop unused monitor_cur_is_qmp Daniel P. Berrangé
2026-07-02 16:03 ` [PATCH v6 18/34] monitor: use dynamic cast in QMP commands Daniel P. Berrangé
2026-07-02 16:03 ` [PATCH v6 19/34] monitor: use dynamic cast in monitor_is_hmp_non_interactive Daniel P. Berrangé
2026-07-02 16:03 ` [PATCH v6 20/34] monitor: drop unused monitor_is_qmp method Daniel P. Berrangé
2026-07-02 16:03 ` [PATCH v6 21/34] monitor: eliminate monitor_is_hmp_non_interactive method Daniel P. Berrangé
2026-07-02 16:03 ` [PATCH v6 22/34] monitor: implement "user creatable" interface for adding monitors Daniel P. Berrangé
2026-07-02 16:03 ` [PATCH v6 23/34] monitor: convert from oneshot BH to persistent BH Daniel P. Berrangé
2026-07-02 16:03 ` [PATCH v6 24/34] monitor: reject attempts to delete the current monitor Daniel P. Berrangé
2026-07-02 16:03 ` [PATCH v6 25/34] monitor: protect qemu_chr_fe_accept_input with monitor lock Daniel P. Berrangé
2026-07-02 16:03 ` [PATCH v6 26/34] monitor: implement support for deleting QMP objects Daniel P. Berrangé
2026-07-02 16:03 ` [PATCH v6 27/34] tests/qtest: add tests for dynamic monitor add/remove Daniel P. Berrangé
2026-07-02 16:03 ` [PATCH v6 28/34] tests/functional: add e2e test for dynamic QMP monitor hotplug Daniel P. Berrangé
2026-07-02 16:03 ` [PATCH v6 29/34] tests/functional: add a stress test for monitor hot unplug Daniel P. Berrangé
2026-07-02 16:03 ` [PATCH v6 30/34] qom: add trace events for user creatable create/delete APIs Daniel P. Berrangé
2026-07-02 16:03 ` [PATCH v6 31/34] monitor: add support for auto-deleting monitors upon close Daniel P. Berrangé
2026-07-03 13:42   ` Markus Armbruster
2026-07-06 13:32     ` Daniel P. Berrangé
2026-07-02 16:03 ` [PATCH v6 32/34] tests: switch from -mon to -object monitor-qmp Daniel P. Berrangé
2026-07-02 16:03 ` [PATCH v6 33/34] qemu-options: document new monitor-hmp and monitor-qmp objects Daniel P. Berrangé
2026-07-06 10:56   ` Markus Armbruster
2026-07-06 13:38     ` Daniel P. Berrangé
2026-07-02 16:03 ` [PATCH v6 34/34] docs: mark '-mon' as deprecated in favour of -object Daniel P. Berrangé
2026-07-06 11:00   ` Markus Armbruster

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=87zf08usa0.fsf@pond.sub.org \
    --to=armbru@redhat.com \
    --cc=alex.bennee@linaro.org \
    --cc=berrange@redhat.com \
    --cc=brauner@kernel.org \
    --cc=dave@treblig.org \
    --cc=devel@lists.libvirt.org \
    --cc=marcandre.lureau@redhat.com \
    --cc=pbonzini@redhat.com \
    --cc=philmd@mailo.com \
    --cc=pkrempa@redhat.com \
    --cc=qemu-devel@nongnu.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.