All of lore.kernel.org
 help / color / mirror / Atom feed
From: Darrick J. Wong <djwong@kernel.org>
To: cluster-devel.redhat.com
Subject: [Cluster-devel] [RFC v6 04/10] iomap: Add iomap_get_folio helper
Date: Sun, 15 Jan 2023 09:01:22 -0800	[thread overview]
Message-ID: <Y8QxYjy+4Kjg05rB@magnolia> (raw)
In-Reply-To: <Y71pWJ0JHwGrJ/iv@casper.infradead.org>

On Tue, Jan 10, 2023 at 01:34:16PM +0000, Matthew Wilcox wrote:
> On Tue, Jan 10, 2023 at 12:46:45AM -0800, Christoph Hellwig wrote:
> > On Mon, Jan 09, 2023 at 01:46:42PM +0100, Andreas Gruenbacher wrote:
> > > We can handle that by adding a new IOMAP_NOCREATE iterator flag and
> > > checking for that in iomap_get_folio().  Your patch then turns into
> > > the below.
> > 
> > Exactly.  And as I already pointed out in reply to Dave's original
> > patch what we really should be doing is returning an ERR_PTR from
> > __filemap_get_folio instead of reverse-engineering the expected
> > error code.
> 
> Ouch, we have a nasty problem.
> 
> If somebody passes FGP_ENTRY, we can return a shadow entry.  And the
> encodings for shadow entries overlap with the encodings for ERR_PTR,
> meaning that some shadow entries will look like errors.  The way I
> solved this in the XArray code is by shifting the error values by
> two bits and encoding errors as XA_ERROR(-ENOMEM) (for example).
> 
> I don't _object_ to introducing XA_ERROR() / xa_err() into the VFS,
> but so far we haven't, and I'd like to make that decision intentionally.

Sorry, I'm not following this at all -- where in buffered-io.c does
anyone pass FGP_ENTRY?  Andreas' code doesn't seem to introduce it
either...?

--D


WARNING: multiple messages have this Message-ID (diff)
From: "Darrick J. Wong" <djwong@kernel.org>
To: Matthew Wilcox <willy@infradead.org>
Cc: Christoph Hellwig <hch@infradead.org>,
	Andreas Gruenbacher <agruenba@redhat.com>,
	Dave Chinner <dchinner@redhat.com>,
	Alexander Viro <viro@zeniv.linux.org.uk>,
	linux-xfs@vger.kernel.org, linux-fsdevel@vger.kernel.org,
	linux-ext4@vger.kernel.org, cluster-devel@redhat.com,
	Christoph Hellwig <hch@lst.de>
Subject: Re: [RFC v6 04/10] iomap: Add iomap_get_folio helper
Date: Sun, 15 Jan 2023 09:01:22 -0800	[thread overview]
Message-ID: <Y8QxYjy+4Kjg05rB@magnolia> (raw)
In-Reply-To: <Y71pWJ0JHwGrJ/iv@casper.infradead.org>

On Tue, Jan 10, 2023 at 01:34:16PM +0000, Matthew Wilcox wrote:
> On Tue, Jan 10, 2023 at 12:46:45AM -0800, Christoph Hellwig wrote:
> > On Mon, Jan 09, 2023 at 01:46:42PM +0100, Andreas Gruenbacher wrote:
> > > We can handle that by adding a new IOMAP_NOCREATE iterator flag and
> > > checking for that in iomap_get_folio().  Your patch then turns into
> > > the below.
> > 
> > Exactly.  And as I already pointed out in reply to Dave's original
> > patch what we really should be doing is returning an ERR_PTR from
> > __filemap_get_folio instead of reverse-engineering the expected
> > error code.
> 
> Ouch, we have a nasty problem.
> 
> If somebody passes FGP_ENTRY, we can return a shadow entry.  And the
> encodings for shadow entries overlap with the encodings for ERR_PTR,
> meaning that some shadow entries will look like errors.  The way I
> solved this in the XArray code is by shifting the error values by
> two bits and encoding errors as XA_ERROR(-ENOMEM) (for example).
> 
> I don't _object_ to introducing XA_ERROR() / xa_err() into the VFS,
> but so far we haven't, and I'd like to make that decision intentionally.

Sorry, I'm not following this at all -- where in buffered-io.c does
anyone pass FGP_ENTRY?  Andreas' code doesn't seem to introduce it
either...?

--D

  parent reply	other threads:[~2023-01-15 17:01 UTC|newest]

Thread overview: 82+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2023-01-08 19:40 [Cluster-devel] [RFC v6 00/10] Turn iomap_page_ops into iomap_folio_ops Andreas Gruenbacher
2023-01-08 19:40 ` Andreas Gruenbacher
2023-01-08 19:40 ` [Cluster-devel] [RFC v6 01/10] iomap: Add __iomap_put_folio helper Andreas Gruenbacher
2023-01-08 19:40   ` Andreas Gruenbacher
2023-01-08 19:40 ` [Cluster-devel] [RFC v6 02/10] iomap/gfs2: Unlock and put folio in page_done handler Andreas Gruenbacher
2023-01-08 19:40   ` Andreas Gruenbacher
2023-01-08 19:40 ` [Cluster-devel] [RFC v6 03/10] iomap: Rename page_done handler to put_folio Andreas Gruenbacher
2023-01-08 19:40   ` Andreas Gruenbacher
2023-01-08 19:40 ` [Cluster-devel] [RFC v6 04/10] iomap: Add iomap_get_folio helper Andreas Gruenbacher
2023-01-08 19:40   ` Andreas Gruenbacher
2023-01-08 21:33   ` [Cluster-devel] " Dave Chinner
2023-01-08 21:33     ` Dave Chinner
2023-01-09 12:46     ` [Cluster-devel] " Andreas Gruenbacher
2023-01-09 12:46       ` Andreas Gruenbacher
2023-01-10  8:46       ` [Cluster-devel] " Christoph Hellwig
2023-01-10  8:46         ` Christoph Hellwig
2023-01-10  9:07         ` [Cluster-devel] " Andreas Grünbacher
2023-01-10  9:07           ` Andreas Grünbacher
2023-01-10 13:34         ` [Cluster-devel] " Matthew Wilcox
2023-01-10 13:34           ` Matthew Wilcox
2023-01-10 15:24           ` [Cluster-devel] " Christoph Hellwig
2023-01-10 15:24             ` Christoph Hellwig
2023-01-11 19:36             ` [Cluster-devel] " Matthew Wilcox
2023-01-11 19:36               ` Matthew Wilcox
2023-01-11 20:52               ` [Cluster-devel] " Dave Chinner
2023-01-11 20:52                 ` Dave Chinner
2023-01-12  8:41                 ` [Cluster-devel] " Christoph Hellwig
2023-01-12  8:41                   ` Christoph Hellwig
2023-01-15 17:01           ` Darrick J. Wong [this message]
2023-01-15 17:01             ` Darrick J. Wong
2023-01-15 17:06             ` [Cluster-devel] " Darrick J. Wong
2023-01-15 17:06               ` Darrick J. Wong
2023-01-16  5:46               ` [Cluster-devel] " Matthew Wilcox
2023-01-16  5:46                 ` Matthew Wilcox
2023-01-16  7:34                 ` [Cluster-devel] " Christoph Hellwig
2023-01-16  7:34                   ` Christoph Hellwig
2023-01-16 13:18                   ` [Cluster-devel] " Matthew Wilcox
2023-01-16 13:18                     ` Matthew Wilcox
2023-01-16 16:02                     ` [Cluster-devel] " Christoph Hellwig
2023-01-16 16:02                       ` Christoph Hellwig
2023-01-08 19:40 ` [Cluster-devel] [RFC v6 05/10] iomap/gfs2: Get page in page_prepare handler Andreas Gruenbacher
2023-01-08 19:40   ` Andreas Gruenbacher
2023-01-31 19:37   ` [Cluster-devel] " Matthew Wilcox
2023-01-31 19:37     ` Matthew Wilcox
2023-01-31 21:33     ` [Cluster-devel] " Andreas Gruenbacher
2023-01-31 21:33       ` Andreas Gruenbacher
2023-01-08 19:40 ` [Cluster-devel] [RFC v6 06/10] iomap: Add __iomap_get_folio helper Andreas Gruenbacher
2023-01-08 19:40   ` Andreas Gruenbacher
2023-01-10  8:48   ` [Cluster-devel] " Christoph Hellwig
2023-01-10  8:48     ` Christoph Hellwig
2023-01-08 19:40 ` [Cluster-devel] [RFC v6 07/10] iomap: Rename page_prepare handler to get_folio Andreas Gruenbacher
2023-01-08 19:40   ` Andreas Gruenbacher
2023-01-08 19:40 ` [Cluster-devel] [RFC v6 08/10] iomap/xfs: Eliminate the iomap_valid handler Andreas Gruenbacher
2023-01-08 19:40   ` Andreas Gruenbacher
2023-01-08 21:59   ` [Cluster-devel] " Dave Chinner
2023-01-08 21:59     ` Dave Chinner
2023-01-09 18:45     ` [Cluster-devel] " Andreas Gruenbacher
2023-01-09 18:45       ` Andreas Gruenbacher
2023-01-09 22:54       ` [Cluster-devel] " Dave Chinner
2023-01-09 22:54         ` Dave Chinner
2023-01-10  1:09         ` [Cluster-devel] " Andreas Grünbacher
2023-01-10  1:09           ` Andreas Grünbacher
2023-01-15 17:29           ` [Cluster-devel] " Darrick J. Wong
2023-01-15 17:29             ` Darrick J. Wong
2023-01-18  7:21             ` [Cluster-devel] " Christoph Hellwig
2023-01-18  7:21               ` Christoph Hellwig
2023-01-18  9:11               ` [Cluster-devel] " Damien Le Moal
2023-01-18  9:11                 ` Damien Le Moal
2023-01-18 19:04               ` [Cluster-devel] " Darrick J. Wong
2023-01-18 19:04                 ` Darrick J. Wong
2023-01-18 19:57                 ` [Cluster-devel] " Andreas Grünbacher
2023-01-18 19:57                   ` Andreas Grünbacher
2023-01-18 21:42             ` [Cluster-devel] " Dave Chinner
2023-01-18 21:42               ` Dave Chinner
2023-01-10  8:51     ` [Cluster-devel] " Christoph Hellwig
2023-01-10  8:51       ` Christoph Hellwig
2023-01-10  8:52   ` [Cluster-devel] " Christoph Hellwig
2023-01-10  8:52     ` Christoph Hellwig
2023-01-08 19:40 ` [Cluster-devel] [RFC v6 09/10] iomap: Rename page_ops to folio_ops Andreas Gruenbacher
2023-01-08 19:40   ` Andreas Gruenbacher
2023-01-08 19:40 ` [Cluster-devel] [RFC v6 10/10] xfs: Make xfs_iomap_folio_ops static Andreas Gruenbacher
2023-01-08 19:40   ` Andreas Gruenbacher

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=Y8QxYjy+4Kjg05rB@magnolia \
    --to=djwong@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.