From: Baoquan He <bhe@redhat.com>
To: Christophe Leroy <christophe.leroy@csgroup.eu>
Cc: "linux-kernel@vger.kernel.org" <linux-kernel@vger.kernel.org>,
"linux-mm@kvack.org" <linux-mm@kvack.org>,
"akpm@linux-foundation.org" <akpm@linux-foundation.org>,
"hch@infradead.org" <hch@infradead.org>,
"agordeev@linux.ibm.com" <agordeev@linux.ibm.com>,
"wangkefeng.wang@huawei.com" <wangkefeng.wang@huawei.com>,
"linux-arm-kernel@lists.infradead.org"
<linux-arm-kernel@lists.infradead.org>
Subject: Re: [PATCH v2 01/11] mm/ioremap: change the return value of io[re|un]map_allowed and rename
Date: Tue, 23 Aug 2022 08:20:22 +0800 [thread overview]
Message-ID: <YwQdRg/IS0+3tbNu@MiWiFi-R3L-srv> (raw)
In-Reply-To: <d5272f42-f3e3-b2a8-428e-bd7815cf7518@csgroup.eu>
On 08/22/22 at 06:25am, Christophe Leroy wrote:
>
>
> Le 20/08/2022 à 02:31, Baoquan He a écrit :
> > In some architectures, there are ARCH specifici io address mapping
> > handling when calling ioremap() or ioremap_prot(), e.g, arc, ia64,
> > openrisc, s390, sh.
> >
> > In oder to convert them to take GENERIC_IOREMAP method, we need change
> > the return value of hook ioremap_allowed() and iounmap_allowed().
> > Meanwhile, rename them to arch_ioremap() and arch_iounmap() to reflect
> > their current behaviour.
Thanks for reviewing.
>
> Please don't just say you need to change the return value. Explain why.
The 1st paragraph and the sentence 'In oder to convert them to take
GENERIC_IOREMAP method' tell the reason, no?
>
> And why does it need a name change ? The new name suggests that what was
> simply a check function becomes now a function doing the job. Is that
> the intention ?
Yes, it's not a simple checking any more. It could do io address mapping
inside arch_ioremap(), and could modify the passed in 'phys_addr' and
'prot' in patch 2. The ioremap_allowed() isn't appropriate to reflect
those.
>
>
> >
> > ===
> > arch_ioremap() return a bool,
>
> It is not a bool. A bool is either true or false.
Thanks, I forgot to update this accordingly.
>
> > - IS_ERR means return an error
> > - NULL means continue to remap
> > - a non-NULL, non-IS_ERR pointer is returned directly
> > arch_iounmap() return a bool,
>
> Same here, not a bool either.
And this place.
>
> > - 0 means continue to vunmap
> > - error code means skip vunmap and return directly
> >
> > This is taken from Kefeng's below old patch. Christoph suggested the
> > return value because he foresaw the doablity of converting to take
> > GENERIC_IOREMAP on more architectures.
> > - [PATCH v3 4/6] mm: ioremap: Add arch_ioremap/iounmap()
> > - https://lore.kernel.org/all/20220519082552.117736-5-wangkefeng.wang@huawei.com/T/#u
> >
> > While at it, the invocation of arch_ioremap() need be moved to the
> > beginning of ioremap_prot() because architectures like sh, openrisc,
> > ia64, need do the ARCH specific io address mapping on the original
> > physical address. And in the later patch, the address fix up code
> > in arch_ioremap() also need be done on the original addre on some
> > architectures.
> >
> > This is preparation for later patch, no functionality change.
>
> No functionnal change, really ?
You mean the new arch_ioremap() owning different definition or the
invocation of arch_ioremap() moved up is functional change? Now I am
not sure about the latter one, may need update my knowledge base.
Thanks
Baoquan
_______________________________________________
linux-arm-kernel mailing list
linux-arm-kernel@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-arm-kernel
WARNING: multiple messages have this Message-ID (diff)
From: Baoquan He <bhe@redhat.com>
To: Christophe Leroy <christophe.leroy@csgroup.eu>
Cc: "linux-kernel@vger.kernel.org" <linux-kernel@vger.kernel.org>,
"linux-mm@kvack.org" <linux-mm@kvack.org>,
"akpm@linux-foundation.org" <akpm@linux-foundation.org>,
"hch@infradead.org" <hch@infradead.org>,
"agordeev@linux.ibm.com" <agordeev@linux.ibm.com>,
"wangkefeng.wang@huawei.com" <wangkefeng.wang@huawei.com>,
"linux-arm-kernel@lists.infradead.org"
<linux-arm-kernel@lists.infradead.org>
Subject: Re: [PATCH v2 01/11] mm/ioremap: change the return value of io[re|un]map_allowed and rename
Date: Tue, 23 Aug 2022 08:20:22 +0800 [thread overview]
Message-ID: <YwQdRg/IS0+3tbNu@MiWiFi-R3L-srv> (raw)
In-Reply-To: <d5272f42-f3e3-b2a8-428e-bd7815cf7518@csgroup.eu>
On 08/22/22 at 06:25am, Christophe Leroy wrote:
>
>
> Le 20/08/2022 à 02:31, Baoquan He a écrit :
> > In some architectures, there are ARCH specifici io address mapping
> > handling when calling ioremap() or ioremap_prot(), e.g, arc, ia64,
> > openrisc, s390, sh.
> >
> > In oder to convert them to take GENERIC_IOREMAP method, we need change
> > the return value of hook ioremap_allowed() and iounmap_allowed().
> > Meanwhile, rename them to arch_ioremap() and arch_iounmap() to reflect
> > their current behaviour.
Thanks for reviewing.
>
> Please don't just say you need to change the return value. Explain why.
The 1st paragraph and the sentence 'In oder to convert them to take
GENERIC_IOREMAP method' tell the reason, no?
>
> And why does it need a name change ? The new name suggests that what was
> simply a check function becomes now a function doing the job. Is that
> the intention ?
Yes, it's not a simple checking any more. It could do io address mapping
inside arch_ioremap(), and could modify the passed in 'phys_addr' and
'prot' in patch 2. The ioremap_allowed() isn't appropriate to reflect
those.
>
>
> >
> > ===
> > arch_ioremap() return a bool,
>
> It is not a bool. A bool is either true or false.
Thanks, I forgot to update this accordingly.
>
> > - IS_ERR means return an error
> > - NULL means continue to remap
> > - a non-NULL, non-IS_ERR pointer is returned directly
> > arch_iounmap() return a bool,
>
> Same here, not a bool either.
And this place.
>
> > - 0 means continue to vunmap
> > - error code means skip vunmap and return directly
> >
> > This is taken from Kefeng's below old patch. Christoph suggested the
> > return value because he foresaw the doablity of converting to take
> > GENERIC_IOREMAP on more architectures.
> > - [PATCH v3 4/6] mm: ioremap: Add arch_ioremap/iounmap()
> > - https://lore.kernel.org/all/20220519082552.117736-5-wangkefeng.wang@huawei.com/T/#u
> >
> > While at it, the invocation of arch_ioremap() need be moved to the
> > beginning of ioremap_prot() because architectures like sh, openrisc,
> > ia64, need do the ARCH specific io address mapping on the original
> > physical address. And in the later patch, the address fix up code
> > in arch_ioremap() also need be done on the original addre on some
> > architectures.
> >
> > This is preparation for later patch, no functionality change.
>
> No functionnal change, really ?
You mean the new arch_ioremap() owning different definition or the
invocation of arch_ioremap() moved up is functional change? Now I am
not sure about the latter one, may need update my knowledge base.
Thanks
Baoquan
next prev parent reply other threads:[~2022-08-23 0:21 UTC|newest]
Thread overview: 155+ messages / expand[flat|nested] mbox.gz Atom feed top
2022-08-20 0:31 [PATCH v2 00/11] mm: ioremap: Convert architectures to take GENERIC_IOREMAP way Baoquan He
2022-08-20 0:31 ` Baoquan He
2022-08-20 0:31 ` [PATCH v2 01/11] mm/ioremap: change the return value of io[re|un]map_allowed and rename Baoquan He
2022-08-20 0:31 ` Baoquan He
2022-08-21 6:53 ` Christoph Hellwig
2022-08-21 6:53 ` Christoph Hellwig
2022-08-22 23:55 ` Baoquan He
2022-08-22 23:55 ` Baoquan He
2022-08-22 6:25 ` Christophe Leroy
2022-08-22 6:25 ` Christophe Leroy
2022-08-23 0:20 ` Baoquan He [this message]
2022-08-23 0:20 ` Baoquan He
2022-08-23 5:24 ` Christophe Leroy
2022-08-23 5:24 ` Christophe Leroy
2022-08-23 15:14 ` Baoquan He
2022-08-23 15:14 ` Baoquan He
2022-08-23 15:26 ` Christophe Leroy
2022-08-23 15:26 ` Christophe Leroy
2022-08-24 8:16 ` David Laight
2022-08-24 8:16 ` David Laight
2022-08-28 14:44 ` Baoquan He
2022-08-28 14:44 ` Baoquan He
2022-08-28 8:36 ` Alexander Gordeev
2022-08-28 8:36 ` Alexander Gordeev
2022-08-28 9:55 ` Baoquan He
2022-08-28 9:55 ` Baoquan He
2022-08-20 0:31 ` [PATCH v2 02/11] mm: ioremap: fixup the physical address and page prot Baoquan He
2022-08-20 0:31 ` Baoquan He
2022-08-21 6:54 ` Christoph Hellwig
2022-08-21 6:54 ` Christoph Hellwig
2022-08-23 1:13 ` Baoquan He
2022-08-23 1:13 ` Baoquan He
2022-08-22 6:30 ` Christophe Leroy
2022-08-22 6:30 ` Christophe Leroy
2022-08-23 1:19 ` Baoquan He
2022-08-23 1:19 ` Baoquan He
2022-08-23 5:33 ` Christophe Leroy
2022-08-23 5:33 ` Christophe Leroy
2022-08-23 12:32 ` Baoquan He
2022-08-23 12:32 ` Baoquan He
2022-08-23 19:03 ` Christophe Leroy
2022-08-23 19:03 ` Christophe Leroy
2022-08-28 11:10 ` Baoquan He
2022-08-28 11:10 ` Baoquan He
2022-09-12 2:55 ` Baoquan He
2022-09-12 2:55 ` Baoquan He
2022-09-12 7:10 ` Christophe Leroy
2022-09-12 7:10 ` Christophe Leroy
2022-09-13 15:11 ` Baoquan He
2022-09-13 15:11 ` Baoquan He
2022-09-21 16:40 ` Christophe Leroy
2022-09-21 16:40 ` Christophe Leroy
2022-09-22 13:23 ` Baoquan He
2022-09-22 13:23 ` Baoquan He
2022-08-20 0:31 ` [PATCH v2 03/11] mm: ioremap: allow ARCH to have its own ioremap definition Baoquan He
2022-08-20 0:31 ` Baoquan He
2022-08-21 6:57 ` Christoph Hellwig
2022-08-21 6:57 ` Christoph Hellwig
2022-08-23 2:42 ` Baoquan He
2022-08-23 2:42 ` Baoquan He
2022-08-20 0:31 ` [PATCH v2 04/11] arc: mm: Convert to GENERIC_IOREMAP Baoquan He
2022-08-20 0:31 ` Baoquan He
2022-08-20 0:31 ` Baoquan He
2022-08-20 0:31 ` [PATCH v2 05/11] hexagon: " Baoquan He
2022-08-20 0:31 ` Baoquan He
2022-08-20 1:23 ` Brian Cain
2022-08-20 1:23 ` Brian Cain
2022-08-21 7:00 ` Christoph Hellwig
2022-08-21 7:00 ` Christoph Hellwig
2022-08-28 15:08 ` Baoquan He
2022-08-28 15:08 ` Baoquan He
2022-08-22 6:38 ` Christophe Leroy
2022-08-22 6:38 ` Christophe Leroy
2022-08-28 15:12 ` Baoquan He
2022-08-28 15:12 ` Baoquan He
2022-08-20 0:31 ` [PATCH v2 06/11] ia64: " Baoquan He
2022-08-20 0:31 ` Baoquan He
2022-08-20 0:31 ` Baoquan He
2022-08-21 6:58 ` Christoph Hellwig
2022-08-21 7:02 ` Christoph Hellwig
2022-08-21 7:02 ` Christoph Hellwig
2022-08-28 15:12 ` Baoquan He
2022-08-28 15:12 ` Baoquan He
2022-08-28 15:12 ` Baoquan He
2022-08-20 0:31 ` [PATCH v2 07/11] openrisc: " Baoquan He
2022-08-20 0:31 ` Baoquan He
2022-08-20 0:31 ` Baoquan He
2022-08-21 7:03 ` Christoph Hellwig
2022-08-21 7:03 ` Christoph Hellwig
2022-08-21 7:03 ` Christoph Hellwig
2022-08-29 1:40 ` Baoquan He
2022-08-29 1:40 ` Baoquan He
2022-08-29 1:40 ` Baoquan He
2022-08-29 6:42 ` Stafford Horne
2022-08-29 6:42 ` Stafford Horne
2022-08-29 6:42 ` Stafford Horne
2022-08-29 8:18 ` Baoquan He
2022-08-29 8:18 ` Baoquan He
2022-08-29 8:18 ` Baoquan He
2022-08-30 6:05 ` Christophe Leroy
2022-08-30 6:05 ` Christophe Leroy
2022-08-30 6:05 ` Christophe Leroy
2022-08-29 6:32 ` Stafford Horne
2022-08-29 6:32 ` Stafford Horne
2022-08-29 6:32 ` Stafford Horne
2022-08-29 8:19 ` Baoquan He
2022-08-29 8:19 ` Baoquan He
2022-08-29 8:19 ` Baoquan He
2022-08-20 0:31 ` [PATCH v2 08/11] parisc: " Baoquan He
2022-08-20 0:31 ` Baoquan He
2022-08-20 4:03 ` kernel test robot
2022-08-20 4:03 ` kernel test robot
2022-08-21 10:26 ` Baoquan He
2022-08-21 10:26 ` Baoquan He
2022-08-21 14:18 ` Helge Deller
2022-08-21 14:18 ` Helge Deller
2022-08-30 13:00 ` Baoquan He
2022-08-30 13:00 ` Baoquan He
2022-08-30 13:00 ` Baoquan He
2022-08-20 0:31 ` [PATCH v2 09/11] s390: " Baoquan He
2022-08-20 0:31 ` Baoquan He
2022-08-21 7:05 ` Christoph Hellwig
2022-08-21 7:05 ` Christoph Hellwig
2022-08-22 15:08 ` Niklas Schnelle
2022-08-22 15:08 ` Niklas Schnelle
2022-08-31 8:59 ` Baoquan He
2022-08-31 8:59 ` Baoquan He
2022-08-22 15:19 ` Niklas Schnelle
2022-08-22 15:19 ` Niklas Schnelle
2022-08-31 8:58 ` Baoquan He
2022-08-31 8:58 ` Baoquan He
2022-08-23 12:30 ` Niklas Schnelle
2022-08-23 12:30 ` Niklas Schnelle
2022-08-31 8:50 ` Baoquan He
2022-08-31 8:50 ` Baoquan He
2022-08-20 0:31 ` [PATCH v2 10/11] sh: " Baoquan He
2022-08-20 0:31 ` Baoquan He
2022-08-20 3:41 ` kernel test robot
2022-09-01 10:39 ` Baoquan He
2022-09-01 10:39 ` Baoquan He
2022-09-01 10:39 ` Baoquan He
2022-09-01 12:11 ` [kbuild-all] " Chen, Rong A
2022-09-01 12:11 ` Chen, Rong A
2022-09-01 12:31 ` Baoquan He
2022-09-01 12:31 ` Baoquan He
2022-09-01 12:31 ` [kbuild-all] " Baoquan He
2022-09-02 9:48 ` Baoquan He
2022-09-02 9:48 ` Baoquan He
2022-09-02 9:48 ` Baoquan He
2022-08-21 7:06 ` Christoph Hellwig
2022-08-21 7:06 ` Christoph Hellwig
2022-09-01 7:36 ` Baoquan He
2022-09-01 7:36 ` Baoquan He
2022-08-20 0:31 ` [PATCH v2 11/11] xtensa: " Baoquan He
2022-08-20 0:31 ` Baoquan He
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=YwQdRg/IS0+3tbNu@MiWiFi-R3L-srv \
--to=bhe@redhat.com \
--cc=agordeev@linux.ibm.com \
--cc=akpm@linux-foundation.org \
--cc=christophe.leroy@csgroup.eu \
--cc=hch@infradead.org \
--cc=linux-arm-kernel@lists.infradead.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-mm@kvack.org \
--cc=wangkefeng.wang@huawei.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.