From: Andy Shevchenko <andriy.shevchenko@intel.com>
To: "Nuno Sá" <noname.nuno@gmail.com>
Cc: Andy Shevchenko <andy.shevchenko@gmail.com>,
nuno.sa@analog.com, linux-iio@vger.kernel.org,
Jonathan Cameron <jic23@kernel.org>,
David Lechner <dlechner@baylibre.com>,
Andy Shevchenko <andy@kernel.org>
Subject: Re: [PATCH 3/6] iio: buffer-dma: Turn iio_dma_buffer_init() void
Date: Fri, 2 Jan 2026 14:42:31 +0200 [thread overview]
Message-ID: <aVe9N4rvCEaI6OyP@smile.fi.intel.com> (raw)
In-Reply-To: <9b92a721cefe9ace63b15d049c463f4c26079d9d.camel@gmail.com>
On Fri, Jan 02, 2026 at 10:25:20AM +0000, Nuno Sá wrote:
> On Sat, 2025-12-27 at 16:02 +0200, Andy Shevchenko wrote:
> > On Fri, Dec 19, 2025 at 5:03 PM Nuno Sá <noname.nuno@gmail.com> wrote:
> > > On Wed, 2025-12-03 at 18:34 +0200, Andy Shevchenko wrote:
> > > > On Wed, Dec 03, 2025 at 03:11:38PM +0000, Nuno Sá via B4 Relay wrote:
...
> > > > > While at it, fix a mismatch between the function declaration and definition
> > > > > regarding the struct device (dma_dev != dev).
> > > >
> > > > So, all others use simple dev?
> > >
> > > Totally forgot about this. What do you mean by the above? If other functions in the
> > > header use just dev? If so, the one I changed is the only one that uses struct device
> > > (in that header). It is also consistent with what we have for the devm_iio_dmaengine_*
> > > APIs.
> >
> > Does the device, that is physical, DMA? Or is it a separate device for
> > that purpose? I mean that naming may suggest that they are different
> > devices. The original Q was about APIs. Are all of them, after your
> > patch, use the same device semantically?
>
> This device is the DMA capable device which provides the DMA chan
A side note, DMA capable device and device that provides DMA chan depending on
the topology can be still different devices. So, the sentence above makes a
little sense to me due to "DMA capable device which provides DMA chan" passage.
> which indeed is not the same as the struct device in the devm APIs (that one
> is the consumer). So dma_dev might be a better name even though the docs
> already make it clear.
Thanks for confirming this!
--
With Best Regards,
Andy Shevchenko
next prev parent reply other threads:[~2026-01-02 12:42 UTC|newest]
Thread overview: 30+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-12-03 15:11 [PATCH 0/6] iio: buffer-dma: Minor cleanups and improvements Nuno Sá
2025-12-03 15:11 ` Nuno Sá via B4 Relay
2025-12-03 15:11 ` [PATCH 1/6] iio: buffer-dma: use lockdep instead of WARN() Nuno Sá
2025-12-03 15:11 ` Nuno Sá via B4 Relay
2025-12-03 16:20 ` Andy Shevchenko
2025-12-04 11:20 ` Nuno Sá
2025-12-03 15:11 ` [PATCH 2/6] iio: buffer-dma: Use the cleanup.h API Nuno Sá
2025-12-03 15:11 ` Nuno Sá via B4 Relay
2025-12-03 16:23 ` Andy Shevchenko
2025-12-06 21:12 ` Jonathan Cameron
2025-12-03 15:11 ` [PATCH 3/6] iio: buffer-dma: Turn iio_dma_buffer_init() void Nuno Sá
2025-12-03 15:11 ` Nuno Sá via B4 Relay
2025-12-03 16:34 ` Andy Shevchenko
2025-12-19 15:03 ` Nuno Sá
2025-12-27 14:02 ` Andy Shevchenko
2026-01-02 10:25 ` Nuno Sá
2026-01-02 12:42 ` Andy Shevchenko [this message]
2025-12-03 15:11 ` [PATCH 4/6] iio: buffer-dma: Fix coding style complains Nuno Sá
2025-12-03 15:11 ` Nuno Sá via B4 Relay
2025-12-03 16:29 ` Andy Shevchenko
2025-12-04 11:25 ` Nuno Sá
2025-12-06 21:09 ` Jonathan Cameron
2025-12-03 15:11 ` [PATCH 5/6] iio: buffer-dmaengine: Use the cleanup.h API Nuno Sá
2025-12-03 15:11 ` Nuno Sá via B4 Relay
2025-12-03 15:11 ` [PATCH 6/6] iio: buffer-dmaengine: Fix coding style complains Nuno Sá
2025-12-03 15:11 ` Nuno Sá via B4 Relay
2025-12-03 16:31 ` Andy Shevchenko
2025-12-03 16:33 ` Andy Shevchenko
2025-12-04 11:21 ` Nuno Sá
2025-12-04 11:55 ` Andy Shevchenko
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=aVe9N4rvCEaI6OyP@smile.fi.intel.com \
--to=andriy.shevchenko@intel.com \
--cc=andy.shevchenko@gmail.com \
--cc=andy@kernel.org \
--cc=dlechner@baylibre.com \
--cc=jic23@kernel.org \
--cc=linux-iio@vger.kernel.org \
--cc=noname.nuno@gmail.com \
--cc=nuno.sa@analog.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.