* [PATCH v2] staging: rtl8723bs: Split multiple assignments in _rtw_open_pktfile
@ 2026-07-16 8:38 Amin Madani
2026-07-16 8:51 ` Dan Carpenter
0 siblings, 1 reply; 2+ messages in thread
From: Amin Madani @ 2026-07-16 8:38 UTC (permalink / raw)
To: gregkh; +Cc: linux-staging, linux-kernel, dan.carpenter, Amin Madani
In _rtw_open_pktfile(), multiple variables are assigned on the same
line. According to the Linux kernel coding style, multiple assignments
on a single line should be avoided. Split them into separate lines to
improve readability.
Signed-off-by: Amin Madani <aminmadani112@gmail.com>
---
v2: Assign pktptr values directly to variables instead of chaining them,
as suggested by Dan Carpenter.
(https://lore.kernel.org/all/aZ_0OratIkUBNHmy@stanley.mountain/)
drivers/staging/rtl8723bs/os_dep/xmit_linux.c | 6 ++++--
1 file changed, 4 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/rtl8723bs/os_dep/xmit_linux.c b/drivers/staging/rtl8723bs/os_dep/xmit_linux.c
index 4260ed5f4..ea60320c0 100644
--- a/drivers/staging/rtl8723bs/os_dep/xmit_linux.c
+++ b/drivers/staging/rtl8723bs/os_dep/xmit_linux.c
@@ -15,8 +15,10 @@ uint rtw_remainder_len(struct pkt_file *pfile)
void _rtw_open_pktfile(struct sk_buff *pktptr, struct pkt_file *pfile)
{
pfile->pkt = pktptr;
- pfile->cur_addr = pfile->buf_start = pktptr->data;
- pfile->pkt_len = pfile->buf_len = pktptr->len;
+ pfile->buf_start = pktptr->data;
+ pfile->cur_addr = pktptr->data;
+ pfile->buf_len = pktptr->len;
+ pfile->pkt_len = pktptr->len;
pfile->cur_buffer = pfile->buf_start;
}
--
2.53.0
^ permalink raw reply related [flat|nested] 2+ messages in thread* Re: [PATCH v2] staging: rtl8723bs: Split multiple assignments in _rtw_open_pktfile
2026-07-16 8:38 [PATCH v2] staging: rtl8723bs: Split multiple assignments in _rtw_open_pktfile Amin Madani
@ 2026-07-16 8:51 ` Dan Carpenter
0 siblings, 0 replies; 2+ messages in thread
From: Dan Carpenter @ 2026-07-16 8:51 UTC (permalink / raw)
To: Amin Madani; +Cc: gregkh, linux-staging, linux-kernel, dan.carpenter
On Thu, Jul 16, 2026 at 12:08:22PM +0330, Amin Madani wrote:
> In _rtw_open_pktfile(), multiple variables are assigned on the same
> line. According to the Linux kernel coding style, multiple assignments
> on a single line should be avoided. Split them into separate lines to
> improve readability.
>
> Signed-off-by: Amin Madani <aminmadani112@gmail.com>
> ---
> v2: Assign pktptr values directly to variables instead of chaining them,
> as suggested by Dan Carpenter.
> (https://lore.kernel.org/all/aZ_0OratIkUBNHmy@stanley.mountain/)
>
Thanks!
Reviewed-by: Dan Carpenter <error27@gmail.com>
regards,
dan carpenter
^ permalink raw reply [flat|nested] 2+ messages in thread
end of thread, other threads:[~2026-07-16 8:52 UTC | newest]
Thread overview: 2+ messages (download: mbox.gz follow: Atom feed
-- links below jump to the message on this page --
2026-07-16 8:38 [PATCH v2] staging: rtl8723bs: Split multiple assignments in _rtw_open_pktfile Amin Madani
2026-07-16 8:51 ` Dan Carpenter
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.