From: "Lukáš Czerner" <lczerner@redhat.com>
To: "Theodore Ts'o" <tytso@mit.edu>
Cc: Dave Chinner <david@fromorbit.com>,
linux-ext4@vger.kernel.org, linux-fsdevel@vger.kernel.org,
xfs@oss.sgi.com
Subject: Re: [PATCH 0/6][RFC] Introduce FALLOC_FL_ZERO_RANGE flag for fallocate
Date: Tue, 18 Feb 2014 15:42:10 +0100 (CET) [thread overview]
Message-ID: <alpine.LFD.2.00.1402181536110.2216@localhost.localdomain> (raw)
In-Reply-To: <20140218142305.GN26580@thunk.org>
[-- Attachment #1: Type: TEXT/PLAIN, Size: 2103 bytes --]
On Tue, 18 Feb 2014, Theodore Ts'o wrote:
> Date: Tue, 18 Feb 2014 09:23:05 -0500
> From: Theodore Ts'o <tytso@mit.edu>
> To: Lukáš Czerner <lczerner@redhat.com>
> Cc: Dave Chinner <david@fromorbit.com>, linux-ext4@vger.kernel.org,
> linux-fsdevel@vger.kernel.org, xfs@oss.sgi.com
> Subject: Re: [PATCH 0/6][RFC] Introduce FALLOC_FL_ZERO_RANGE flag for
> fallocate
>
> On Tue, Feb 18, 2014 at 01:04:24PM +0100, Lukáš Czerner wrote:
> >
> > > Ok, so it's a "fallocate" test group, then?
> >
> > More like "fsx_fsstress" group, which might sound as a terrible name
> > for the group but it explains it quite well. So if you do not have
> > anything against that I'll call the new group "fsx_fsstress"
>
> How about "block_map" group? I like Dave's suggestion about naming
> the group after what it is trying to test, as opposed to how it does
> that testing. This is also consistent with how the other tests groups
> are named in xfstests.
>
> However, extents are an implementation strategy, and you might just as
> easily use this test to verify whether or not the punch hole
> functionality for indirect block maps worked correctly.
(it does not :) But I am still having trouble deciphering Al Viro
code ;)
>
> What I think using fsx and fstress together have in common is that
> it's a great way of stress testing whatever the file system uses for
> creating and maintaining the translation map between (inode, logical
> block) to physical block, so that's why perhaps "block_map" might be a
> good test group name.
To be honest "block_map" group name does not mean anything to me.
- "fallocate" is not really the right name as it does much more than
that
- "extents" is not the right name as there is not really anything
extents specific.
- "fsx_fsstress" while this gives information about how it is tested
it's not immediately clear what it is good for.
So I do not know and frankly I do not care very much about the name
of this group so if anyone has a strong opinion about the name feel
free to create such group.
Thanks!
-Lukas
>
> Regards,
>
> - Ted
>
WARNING: multiple messages have this Message-ID (diff)
From: "Lukáš Czerner" <lczerner@redhat.com>
To: Theodore Ts'o <tytso@mit.edu>
Cc: linux-fsdevel@vger.kernel.org, linux-ext4@vger.kernel.org,
xfs@oss.sgi.com
Subject: Re: [PATCH 0/6][RFC] Introduce FALLOC_FL_ZERO_RANGE flag for fallocate
Date: Tue, 18 Feb 2014 15:42:10 +0100 (CET) [thread overview]
Message-ID: <alpine.LFD.2.00.1402181536110.2216@localhost.localdomain> (raw)
In-Reply-To: <20140218142305.GN26580@thunk.org>
[-- Attachment #1: Type: TEXT/PLAIN, Size: 2103 bytes --]
On Tue, 18 Feb 2014, Theodore Ts'o wrote:
> Date: Tue, 18 Feb 2014 09:23:05 -0500
> From: Theodore Ts'o <tytso@mit.edu>
> To: Lukáš Czerner <lczerner@redhat.com>
> Cc: Dave Chinner <david@fromorbit.com>, linux-ext4@vger.kernel.org,
> linux-fsdevel@vger.kernel.org, xfs@oss.sgi.com
> Subject: Re: [PATCH 0/6][RFC] Introduce FALLOC_FL_ZERO_RANGE flag for
> fallocate
>
> On Tue, Feb 18, 2014 at 01:04:24PM +0100, Lukáš Czerner wrote:
> >
> > > Ok, so it's a "fallocate" test group, then?
> >
> > More like "fsx_fsstress" group, which might sound as a terrible name
> > for the group but it explains it quite well. So if you do not have
> > anything against that I'll call the new group "fsx_fsstress"
>
> How about "block_map" group? I like Dave's suggestion about naming
> the group after what it is trying to test, as opposed to how it does
> that testing. This is also consistent with how the other tests groups
> are named in xfstests.
>
> However, extents are an implementation strategy, and you might just as
> easily use this test to verify whether or not the punch hole
> functionality for indirect block maps worked correctly.
(it does not :) But I am still having trouble deciphering Al Viro
code ;)
>
> What I think using fsx and fstress together have in common is that
> it's a great way of stress testing whatever the file system uses for
> creating and maintaining the translation map between (inode, logical
> block) to physical block, so that's why perhaps "block_map" might be a
> good test group name.
To be honest "block_map" group name does not mean anything to me.
- "fallocate" is not really the right name as it does much more than
that
- "extents" is not the right name as there is not really anything
extents specific.
- "fsx_fsstress" while this gives information about how it is tested
it's not immediately clear what it is good for.
So I do not know and frankly I do not care very much about the name
of this group so if anyone has a strong opinion about the name feel
free to create such group.
Thanks!
-Lukas
>
> Regards,
>
> - Ted
>
[-- Attachment #2: Type: text/plain, Size: 121 bytes --]
_______________________________________________
xfs mailing list
xfs@oss.sgi.com
http://oss.sgi.com/mailman/listinfo/xfs
next prev parent reply other threads:[~2014-02-18 14:42 UTC|newest]
Thread overview: 51+ messages / expand[flat|nested] mbox.gz Atom feed top
2014-02-17 15:08 [PATCH 0/6][RFC] Introduce FALLOC_FL_ZERO_RANGE flag for fallocate Lukas Czerner
2014-02-17 15:08 ` Lukas Czerner
2014-02-17 15:08 ` [PATCH 1/6] ext4: Update inode i_size after the preallocation Lukas Czerner
2014-02-17 15:08 ` Lukas Czerner
2014-02-17 23:12 ` Andreas Dilger
2014-02-17 23:12 ` Andreas Dilger
2014-02-17 23:21 ` Theodore Ts'o
2014-02-18 8:13 ` Lukáš Czerner
2014-02-18 8:13 ` Lukáš Czerner
2014-02-17 15:08 ` [PATCH 2/6] ext4: refactor ext4_fallocate code Lukas Czerner
2014-02-17 15:08 ` Lukas Czerner
2014-02-18 8:25 ` jon ernst
2014-02-17 15:08 ` [PATCH 3/6] ext4: translate fallocate mode bits to strings Lukas Czerner
2014-02-17 15:08 ` Lukas Czerner
2014-02-17 15:08 ` [PATCH 4/6] fs: Introduce FALLOC_FL_ZERO_RANGE flag for fallocate Lukas Czerner
2014-02-17 15:08 ` Lukas Czerner
2014-02-18 2:51 ` Dave Chinner
2014-02-18 8:10 ` Lukáš Czerner
2014-02-18 8:10 ` Lukáš Czerner
2014-02-17 15:08 ` [PATCH 5/6] ext4: " Lukas Czerner
2014-02-17 15:08 ` Lukas Czerner
2014-02-18 8:27 ` jon ernst
2014-02-17 15:08 ` [PATCH 6/6] xfs: Add support for FALLOC_FL_ZERO_RANGE Lukas Czerner
2014-02-17 15:08 ` Lukas Czerner
2014-02-18 4:51 ` Dave Chinner
2014-02-18 1:01 ` [PATCH 0/6][RFC] Introduce FALLOC_FL_ZERO_RANGE flag for fallocate Dave Chinner
2014-02-18 1:01 ` Dave Chinner
2014-02-18 8:33 ` Dave Chinner
2014-02-18 8:33 ` Dave Chinner
2014-02-18 9:09 ` Lukáš Czerner
2014-02-18 9:41 ` Dave Chinner
2014-02-18 12:04 ` Lukáš Czerner
2014-02-18 12:04 ` Lukáš Czerner
2014-02-18 14:23 ` Theodore Ts'o
2014-02-18 14:23 ` Theodore Ts'o
2014-02-18 14:42 ` Lukáš Czerner [this message]
2014-02-18 14:42 ` Lukáš Czerner
2014-02-19 0:33 ` Theodore Ts'o
2014-02-19 14:52 ` Dongsu Park
2014-02-19 14:52 ` Dongsu Park
2014-02-19 15:18 ` Lukáš Czerner
2014-02-19 15:18 ` Lukáš Czerner
2014-02-19 15:51 ` Dongsu Park
2014-02-20 11:16 ` Lukáš Czerner
2014-02-20 11:16 ` Lukáš Czerner
2014-02-24 1:07 ` Dave Chinner
2014-02-24 13:47 ` Lukáš Czerner
2014-02-24 13:47 ` Lukáš Czerner
2014-04-16 6:36 ` Christoph Hellwig
[not found] ` <20140416063618.GA12498-wEGCiKHe2LqWVfeAwA7xHQ@public.gmane.org>
2014-04-16 10:43 ` Lukáš Czerner
2014-04-16 10:43 ` Lukáš Czerner
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=alpine.LFD.2.00.1402181536110.2216@localhost.localdomain \
--to=lczerner@redhat.com \
--cc=david@fromorbit.com \
--cc=linux-ext4@vger.kernel.org \
--cc=linux-fsdevel@vger.kernel.org \
--cc=tytso@mit.edu \
--cc=xfs@oss.sgi.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.