All of lore.kernel.org
 help / color / mirror / Atom feed
From: tglx@linutronix.de (Thomas Gleixner)
To: linux-arm-kernel@lists.infradead.org
Subject: [PATCH] genirq: allow an alternative setup for the mask cache
Date: Fri, 15 Mar 2013 20:55:56 +0100 (CET)	[thread overview]
Message-ID: <alpine.LFD.2.02.1303152046180.22263@ionos> (raw)
In-Reply-To: <51434BC2.70105@keymile.com>

On Fri, 15 Mar 2013, Gerlando Falauto wrote:

> Hi Simon,
> 
> On 03/14/2013 06:45 PM, Simon Guinot wrote:
> > On Thu, Mar 14, 2013 at 05:10:30PM +0100, Holger Brunck wrote:
> > > @@ -243,9 +243,12 @@ void irq_setup_generic_chip(struct irq_chip_generic
> > > *gc, u32 msk,
> > >   	list_add_tail(&gc->list, &gc_list);
> > >   	raw_spin_unlock(&gc_lock);
> > > 
> > > +	/* Setup pointer to mask_cache */
> > > +	gc->pmask_cache = &gc->mask_cache;
> > 
> > You need a flag here to choose between gc->mask_cache and
> > ct->mask_cache.
> 
> I'm sorry, I don't understand...
> Shouldn't pmask_cache be a pointer within ct, so that the pointers for all
> instances could either be the same (in case of a single register) or all
> different (in case of multiple registers)?

You are right. gc->pmask_cache wont solve the issue.

We need a ct->pmask_cache, so the various instances of gc->ct[] can
have their own selector, which default to gc-mask_cache if not
requested to be separate by a flag. In that case we need to initialize
the ct->mask_cache at setup time for each ct. No modifications to
setup_alt_chip() required then.

> I already have a patch which seems to work, but I'm afraid I've come to YAM
> (Yet Another Misunderstanding (R) ) in regards to Thomas' suggestion.

No, that was my brain going backwards :)

Care to send your patch ?

Thanks,

	tglx

  reply	other threads:[~2013-03-15 19:55 UTC|newest]

Thread overview: 45+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2013-03-14 16:10 [PATCH] genirq: allow an alternative setup for the mask cache Holger Brunck
2013-03-14 17:45 ` Simon Guinot
2013-03-15 10:43   ` Holger Brunck
2013-03-15 11:02     ` Thomas Gleixner
2013-03-15 16:26   ` Gerlando Falauto
2013-03-15 19:55     ` Thomas Gleixner [this message]
2013-03-14 19:08 ` Thomas Gleixner
2013-03-14 19:42 ` Ezequiel Garcia
2013-03-18 11:05   ` Gerlando Falauto
2013-03-15 19:36 ` [PATCH v2 0/2] refactoring for mask_cache Gerlando Falauto
2013-03-15 19:36   ` [PATCH 1/2] genirq: cosmetic: remove cur_regs Gerlando Falauto
2013-03-15 19:36   ` [PATCH 2/2] genirq: move mask_cache into struct irq_chip_type Gerlando Falauto
2013-03-15 20:47     ` Thomas Gleixner
2013-03-18  7:59       ` Gerlando Falauto
2013-03-18  8:56         ` Thomas Gleixner
2013-03-15 21:25   ` [PATCH v2 0/2] refactoring for mask_cache Andrew Lunn
2013-03-15 23:34     ` Simon Guinot
2013-03-18 14:00 ` [PATCH v3 0/9] " Gerlando Falauto
2013-03-18 14:00   ` [PATCH v3 1/9] genirq: cosmetic: remove cur_regs Gerlando Falauto
2013-03-18 14:00   ` [PATCH v3 2/9] genirq: add mask_cache and pmask_cache into struct irq_chip_type Gerlando Falauto
2013-03-19 11:32     ` Thomas Gleixner
2013-03-18 14:00   ` [PATCH v3 3/9] gpio: mvebu: convert to usage of *pmask_cache within irq_chip_type Gerlando Falauto
2013-03-18 14:00   ` [PATCH v3 4/9] MIPS: JZ4740: " Gerlando Falauto
2013-03-18 14:00   ` [PATCH v3 5/9] ARM: SAMSUNG: " Gerlando Falauto
2013-03-18 14:00   ` [PATCH v3 6/9] genirq: rename mask_cache to shared_mask_cache Gerlando Falauto
2013-03-18 14:00   ` [PATCH v3 7/9] genirq: handle separate mask registers Gerlando Falauto
2013-03-18 14:00   ` [PATCH v3 8/9] orion-gpio: enable IRQ_GC_SEPARATE_MASK_REGISTERS Gerlando Falauto
2013-03-18 14:00   ` [PATCH v3 9/9] gpio: mvebu: " Gerlando Falauto
2013-03-18 14:28   ` [PATCH v3 0/9] refactoring for mask_cache Simon Guinot
2013-03-18 14:39     ` Simon Guinot
2013-03-19 10:03   ` Ezequiel Garcia
2013-03-19 10:09     ` Gerlando Falauto
2013-03-19 11:25       ` Ezequiel Garcia
2013-03-19 11:06     ` Jason Cooper
2013-03-19 11:10       ` Gerlando Falauto
2013-03-19 11:44         ` Jason Cooper
2013-03-19 11:56           ` Jason Cooper
2013-03-20 17:40             ` Gerlando Falauto
2013-03-20 21:42               ` Thomas Gleixner
2013-03-21 10:37                 ` Gerlando Falauto
2013-03-21 10:59               ` Simon Guinot
2013-03-19 11:19       ` Ezequiel Garcia
2013-03-21 10:51   ` Simon Guinot
2013-03-21 11:24     ` Gerlando Falauto
2013-04-04  9:31   ` Ezequiel Garcia

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=alpine.LFD.2.02.1303152046180.22263@ionos \
    --to=tglx@linutronix.de \
    --cc=linux-arm-kernel@lists.infradead.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.