From: Quentin Schulz <quentin.schulz@cherry.de>
To: Marek Vasut <marek.vasut+renesas@mailbox.org>, u-boot@lists.denx.de
Cc: Adam Ford <aford173@gmail.com>,
Biju Das <biju.das.jz@bp.renesas.com>,
Lad Prabhakar <prabhakar.mahadev-lad.rj@bp.renesas.com>,
Nobuhiro Iwamatsu <iwamatsu@nigauri.org>,
Paul Barker <paul.barker.ct@bp.renesas.com>,
Simon Glass <sjg@chromium.org>, Tom Rini <trini@konsulko.com>
Subject: Re: [PATCH 8/8] arm64: renesas: Deduplicate R-Car Gen3 and Gen4 SPL
Date: Wed, 15 Jan 2025 11:34:44 +0100 [thread overview]
Message-ID: <b2ed3bad-9c9f-433e-979b-557d646978f3@cherry.de> (raw)
In-Reply-To: <20250112223528.179828-8-marek.vasut+renesas@mailbox.org>
Hi Marek,
On 1/12/25 11:34 PM, Marek Vasut wrote:
> Move R-Car Gen3 and Gen4 jump_to_image_no_args() into dedicated
> rcar64-spl.c file. The implementation of jump_to_image_no_args()
> is identical. No functional change.
>
> Signed-off-by: Marek Vasut <marek.vasut+renesas@mailbox.org>
This is just factoring code and looks fine to me,
Reviewed-by: Quentin Schulz <quentin.schulz@cherry.de>
> ---
> Cc: Adam Ford <aford173@gmail.com>
> Cc: Biju Das <biju.das.jz@bp.renesas.com>
> Cc: Lad Prabhakar <prabhakar.mahadev-lad.rj@bp.renesas.com>
> Cc: Nobuhiro Iwamatsu <iwamatsu@nigauri.org>
> Cc: Paul Barker <paul.barker.ct@bp.renesas.com>
> Cc: Simon Glass <sjg@chromium.org>
> Cc: Tom Rini <trini@konsulko.com>
> Cc: u-boot@lists.denx.de
> ---
> board/renesas/common/Makefile | 4 +++-
> board/renesas/common/gen3-spl.c | 21 ---------------------
> board/renesas/common/gen4-spl.c | 17 -----------------
> board/renesas/common/rcar64-spl.c | 24 ++++++++++++++++++++++++
> 4 files changed, 27 insertions(+), 39 deletions(-)
> create mode 100644 board/renesas/common/rcar64-spl.c
>
> diff --git a/board/renesas/common/Makefile b/board/renesas/common/Makefile
> index e6dde3c2597..7a9f3a25440 100644
> --- a/board/renesas/common/Makefile
> +++ b/board/renesas/common/Makefile
> @@ -15,7 +15,9 @@ endif
>
> # 64 bit SoCs
> ifdef CONFIG_RCAR_64
> -ifndef CONFIG_XPL_BUILD
> +ifdef CONFIG_XPL_BUILD
> +obj-y += rcar64-spl.o
> +else
> obj-y += rcar64-common.o
> endif
>
Wondering if we couldn't use variables to make the Makefile a bit easier
on the eye (though not necessarily more readable)?
Something like
ifdef CONFIG_XPL_BUILD
SPL_COMMON := spl
else
SPL_COMMON := common
endif
obj-y += rcar64-$(SPL_COMMON).o
Then we could use it for gen3 and gen4 object files as well for example.
I really struggle to parse Makefile/C code when there are a lot of
ifdefs especially once they get nested, but maybe that's just me :)
Thanks!
Quentin
next prev parent reply other threads:[~2025-01-15 10:34 UTC|newest]
Thread overview: 17+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-01-12 22:34 [PATCH 1/8] ARM: renesas: Rename board/renesas/rcar-common to board/renesas/common Marek Vasut
2025-01-12 22:34 ` [PATCH 2/8] ARM: renesas: Simplify board Makefiles Marek Vasut
2025-01-15 10:22 ` Quentin Schulz
2025-01-18 7:53 ` Marek Vasut
2025-01-12 22:34 ` [PATCH 3/8] ARM: renesas: Rename common/common.c to common/rcar64-common.c Marek Vasut
2025-01-15 10:27 ` Quentin Schulz
2025-01-18 8:03 ` Marek Vasut
2025-01-12 22:34 ` [PATCH 4/8] arm64: renesas: Drop unused code and clean up headers on R-Car D3 Draak Marek Vasut
2025-01-12 22:34 ` [PATCH 5/8] arm64: renesas: Drop unused code and clean up headers on Salvator-X boards Marek Vasut
2025-01-12 22:34 ` [PATCH 6/8] arm64: renesas: Drop unused code and clean up headers on ULCB boards Marek Vasut
2025-01-12 22:34 ` [PATCH 7/8] arm64: renesas: Deduplicate board_early_init_f() Marek Vasut
2025-01-13 15:40 ` Adam Ford
2025-01-18 7:59 ` Marek Vasut
2025-01-12 22:34 ` [PATCH 8/8] arm64: renesas: Deduplicate R-Car Gen3 and Gen4 SPL Marek Vasut
2025-01-15 10:34 ` Quentin Schulz [this message]
2025-01-18 7:56 ` Marek Vasut
2025-01-15 9:58 ` [PATCH 1/8] ARM: renesas: Rename board/renesas/rcar-common to board/renesas/common Quentin Schulz
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=b2ed3bad-9c9f-433e-979b-557d646978f3@cherry.de \
--to=quentin.schulz@cherry.de \
--cc=aford173@gmail.com \
--cc=biju.das.jz@bp.renesas.com \
--cc=iwamatsu@nigauri.org \
--cc=marek.vasut+renesas@mailbox.org \
--cc=paul.barker.ct@bp.renesas.com \
--cc=prabhakar.mahadev-lad.rj@bp.renesas.com \
--cc=sjg@chromium.org \
--cc=trini@konsulko.com \
--cc=u-boot@lists.denx.de \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.