From: Nicolas Dufresne <nicolas.dufresne@collabora.com>
To: Sascha Hauer <s.hauer@pengutronix.de>,
Benjamin Gaignard <benjamin.gaignard@collabora.com>,
Philipp Zabel <p.zabel@pengutronix.de>,
Mauro Carvalho Chehab <mchehab@kernel.org>,
Heiko Stuebner <heiko@sntech.de>,
Ezequiel Garcia <ezequiel@vanguardiasur.com.ar>,
Andrzej Pietrasiewicz <andrzej.p@collabora.com>,
Hans Verkuil <hverkuil@kernel.org>,
Chen-Yu Tsai <wenst@chromium.org>, Rob Herring <robh@kernel.org>,
Krzysztof Kozlowski <krzk+dt@kernel.org>,
Conor Dooley <conor+dt@kernel.org>,
Lucas Sinn <lucas.sinn@wolfvision.net>
Cc: Mauro Carvalho Chehab <mchehab+huawei@kernel.org>,
linux-media@vger.kernel.org, linux-rockchip@lists.infradead.org,
linux-kernel@vger.kernel.org,
linux-arm-kernel@lists.infradead.org,
devicetree@vger.kernel.org
Subject: Re: [PATCH 1/7] media: verisilicon: Fix the cleanup when a codec ->run() fails
Date: Wed, 19 Aug 2026 11:05:35 -0400 [thread overview]
Message-ID: <ea57db621f1267c1cd3079cebed543180d82ed95.camel@collabora.com> (raw)
In-Reply-To: <20260819-rk3588-jpegdec-v1-1-33d74cdf369c@pengutronix.de>
[-- Attachment #1: Type: text/plain, Size: 401 bytes --]
Hi Sascha,
Le mercredi 19 août 2026 à 12:37 +0200, Sascha Hauer a écrit :
> ret = start_prepare_run(ctx, &decode_params);
> if (ret) {
> - hantro_end_prepare_run(ctx);
> + hantro_end_prepare_run(ctx, ret);
Since its already in an if (ret) branch, and for code readability, can you use
hantro_abort_prepare_run(ctx) instead and leave all other sucessful calls as-is.
Nicolas
[-- Attachment #2: This is a digitally signed message part --]
[-- Type: application/pgp-signature, Size: 228 bytes --]
WARNING: multiple messages have this Message-ID (diff)
From: Nicolas Dufresne <nicolas.dufresne@collabora.com>
To: Sascha Hauer <s.hauer@pengutronix.de>,
Benjamin Gaignard <benjamin.gaignard@collabora.com>,
Philipp Zabel <p.zabel@pengutronix.de>,
Mauro Carvalho Chehab <mchehab@kernel.org>,
Heiko Stuebner <heiko@sntech.de>,
Ezequiel Garcia <ezequiel@vanguardiasur.com.ar>,
Andrzej Pietrasiewicz <andrzej.p@collabora.com>,
Hans Verkuil <hverkuil@kernel.org>,
Chen-Yu Tsai <wenst@chromium.org>, Rob Herring <robh@kernel.org>,
Krzysztof Kozlowski <krzk+dt@kernel.org>,
Conor Dooley <conor+dt@kernel.org>,
Lucas Sinn <lucas.sinn@wolfvision.net>
Cc: Mauro Carvalho Chehab <mchehab+huawei@kernel.org>,
linux-media@vger.kernel.org, linux-rockchip@lists.infradead.org,
linux-kernel@vger.kernel.org,
linux-arm-kernel@lists.infradead.org,
devicetree@vger.kernel.org
Subject: Re: [PATCH 1/7] media: verisilicon: Fix the cleanup when a codec ->run() fails
Date: Wed, 19 Aug 2026 11:05:35 -0400 [thread overview]
Message-ID: <ea57db621f1267c1cd3079cebed543180d82ed95.camel@collabora.com> (raw)
In-Reply-To: <20260819-rk3588-jpegdec-v1-1-33d74cdf369c@pengutronix.de>
[-- Attachment #1.1: Type: text/plain, Size: 401 bytes --]
Hi Sascha,
Le mercredi 19 août 2026 à 12:37 +0200, Sascha Hauer a écrit :
> ret = start_prepare_run(ctx, &decode_params);
> if (ret) {
> - hantro_end_prepare_run(ctx);
> + hantro_end_prepare_run(ctx, ret);
Since its already in an if (ret) branch, and for code readability, can you use
hantro_abort_prepare_run(ctx) instead and leave all other sucessful calls as-is.
Nicolas
[-- Attachment #1.2: This is a digitally signed message part --]
[-- Type: application/pgp-signature, Size: 228 bytes --]
[-- Attachment #2: Type: text/plain, Size: 170 bytes --]
_______________________________________________
Linux-rockchip mailing list
Linux-rockchip@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-rockchip
next prev parent reply other threads:[~2026-08-19 15:05 UTC|newest]
Thread overview: 35+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-08-19 10:37 [PATCH 0/7] media: verisilicon: Add RK3588 VPU720 JPEG decoder Sascha Hauer
2026-08-19 10:37 ` Sascha Hauer
2026-08-19 10:37 ` [PATCH 1/7] media: verisilicon: Fix the cleanup when a codec ->run() fails Sascha Hauer
2026-08-19 10:37 ` Sascha Hauer
2026-08-19 11:23 ` sashiko-bot
2026-08-19 15:05 ` Nicolas Dufresne [this message]
2026-08-19 15:05 ` Nicolas Dufresne
2026-08-19 10:37 ` [PATCH 2/7] media: verisilicon: Complete the request on the ->run() error paths Sascha Hauer
2026-08-19 10:37 ` Sascha Hauer
2026-08-19 12:19 ` sashiko-bot
2026-08-19 10:37 ` [PATCH 3/7] media: verisilicon: Allow the EOS event to be subscribed Sascha Hauer
2026-08-19 10:37 ` Sascha Hauer
2026-08-19 10:37 ` [PATCH 4/7] media: dt-bindings: Add Rockchip RK3588 VPU720 JPEG decoder Sascha Hauer
2026-08-19 10:37 ` Sascha Hauer
2026-08-19 10:37 ` [PATCH 5/7] media: verisilicon: Add Rockchip " Sascha Hauer
2026-08-19 10:37 ` Sascha Hauer
2026-08-19 11:24 ` sashiko-bot
2026-08-19 12:46 ` Heiko Stübner
2026-08-19 12:46 ` Heiko Stübner
2026-08-19 14:12 ` Sascha Hauer
2026-08-19 14:12 ` Sascha Hauer
2026-08-19 15:48 ` Nicolas Dufresne
2026-08-19 15:48 ` Nicolas Dufresne
2026-08-20 10:03 ` Sascha Hauer
2026-08-20 10:03 ` Sascha Hauer
2026-08-20 16:02 ` Nicolas Dufresne
2026-08-20 16:02 ` Nicolas Dufresne
2026-08-21 6:28 ` Sascha Hauer
2026-08-21 6:28 ` Sascha Hauer
2026-08-21 13:05 ` Nicolas Dufresne
2026-08-21 13:05 ` Nicolas Dufresne
2026-08-19 10:37 ` [PATCH 6/7] media: verisilicon: Enforce a minimum sizeimage for the " Sascha Hauer
2026-08-19 10:37 ` Sascha Hauer
2026-08-19 10:37 ` [PATCH 7/7] arm64: dts: rockchip: rk3588: Add VPU720 JPEG decoder node Sascha Hauer
2026-08-19 10:37 ` Sascha Hauer
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=ea57db621f1267c1cd3079cebed543180d82ed95.camel@collabora.com \
--to=nicolas.dufresne@collabora.com \
--cc=andrzej.p@collabora.com \
--cc=benjamin.gaignard@collabora.com \
--cc=conor+dt@kernel.org \
--cc=devicetree@vger.kernel.org \
--cc=ezequiel@vanguardiasur.com.ar \
--cc=heiko@sntech.de \
--cc=hverkuil@kernel.org \
--cc=krzk+dt@kernel.org \
--cc=linux-arm-kernel@lists.infradead.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-media@vger.kernel.org \
--cc=linux-rockchip@lists.infradead.org \
--cc=lucas.sinn@wolfvision.net \
--cc=mchehab+huawei@kernel.org \
--cc=mchehab@kernel.org \
--cc=p.zabel@pengutronix.de \
--cc=robh@kernel.org \
--cc=s.hauer@pengutronix.de \
--cc=wenst@chromium.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.