* [PATCH 11/11] sound/oxygen_io: take msecs_to_jiffies_min into use [not found] ` <1368188011-23661-1-git-send-email-imre.deak@intel.com> @ 2013-05-10 12:13 ` Imre Deak 2013-05-13 14:00 ` Takashi Iwai 2013-05-14 14:48 ` [PATCH v2 8/8] sound/oxygen_io: take msecs_to_jiffies_timeout " Imre Deak 1 sibling, 1 reply; 7+ messages in thread From: Imre Deak @ 2013-05-10 12:13 UTC (permalink / raw) To: linux-kernel Cc: Andrew Morton, Daniel Vetter, Clemens Ladisch, Jaroslav Kysela, Takashi Iwai, alsa-devel Use msecs_to_jiffies_min instead of open-coding the same. Signed-off-by: Imre Deak <imre.deak@intel.com> --- sound/pci/oxygen/oxygen_io.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/sound/pci/oxygen/oxygen_io.c b/sound/pci/oxygen/oxygen_io.c index 521eae4..132ecbe 100644 --- a/sound/pci/oxygen/oxygen_io.c +++ b/sound/pci/oxygen/oxygen_io.c @@ -108,7 +108,7 @@ static int oxygen_ac97_wait(struct oxygen *chip, unsigned int mask) wait_event_timeout(chip->ac97_waitqueue, ({ status |= oxygen_read8(chip, OXYGEN_AC97_INTERRUPT_STATUS); status & mask; }), - msecs_to_jiffies(1) + 1); + msecs_to_jiffies_min(1)); /* * Check even after a timeout because this function should not require * the AC'97 interrupt to be enabled. -- 1.7.10.4 ^ permalink raw reply related [flat|nested] 7+ messages in thread
* Re: [PATCH 11/11] sound/oxygen_io: take msecs_to_jiffies_min into use 2013-05-10 12:13 ` [PATCH 11/11] sound/oxygen_io: take msecs_to_jiffies_min into use Imre Deak @ 2013-05-13 14:00 ` Takashi Iwai 2013-05-13 14:24 ` Imre Deak 2013-05-13 14:30 ` Clemens Ladisch 0 siblings, 2 replies; 7+ messages in thread From: Takashi Iwai @ 2013-05-13 14:00 UTC (permalink / raw) To: Imre Deak Cc: linux-kernel, Andrew Morton, Daniel Vetter, Clemens Ladisch, Jaroslav Kysela, alsa-devel At Fri, 10 May 2013 15:13:29 +0300, Imre Deak wrote: > > Use msecs_to_jiffies_min instead of open-coding the same. > > Signed-off-by: Imre Deak <imre.deak@intel.com> > --- > sound/pci/oxygen/oxygen_io.c | 2 +- > 1 file changed, 1 insertion(+), 1 deletion(-) > > diff --git a/sound/pci/oxygen/oxygen_io.c b/sound/pci/oxygen/oxygen_io.c > index 521eae4..132ecbe 100644 > --- a/sound/pci/oxygen/oxygen_io.c > +++ b/sound/pci/oxygen/oxygen_io.c > @@ -108,7 +108,7 @@ static int oxygen_ac97_wait(struct oxygen *chip, unsigned int mask) > wait_event_timeout(chip->ac97_waitqueue, > ({ status |= oxygen_read8(chip, OXYGEN_AC97_INTERRUPT_STATUS); > status & mask; }), > - msecs_to_jiffies(1) + 1); > + msecs_to_jiffies_min(1)); This would change the behavior, I guess. (Though, I'm not sure whether the original code was intentional.) And, isn't msecs_to_jiffies_min(1) identical with msecs_to_jiffies(1)? thanks, Takashi ^ permalink raw reply [flat|nested] 7+ messages in thread
* Re: [PATCH 11/11] sound/oxygen_io: take msecs_to_jiffies_min into use 2013-05-13 14:00 ` Takashi Iwai @ 2013-05-13 14:24 ` Imre Deak 2013-05-13 14:35 ` Takashi Iwai 2013-05-13 14:30 ` Clemens Ladisch 1 sibling, 1 reply; 7+ messages in thread From: Imre Deak @ 2013-05-13 14:24 UTC (permalink / raw) To: Takashi Iwai Cc: linux-kernel, Andrew Morton, Daniel Vetter, Clemens Ladisch, Jaroslav Kysela, alsa-devel On Mon, 2013-05-13 at 16:00 +0200, Takashi Iwai wrote: > At Fri, 10 May 2013 15:13:29 +0300, > Imre Deak wrote: > > > > Use msecs_to_jiffies_min instead of open-coding the same. > > > > Signed-off-by: Imre Deak <imre.deak@intel.com> > > --- > > sound/pci/oxygen/oxygen_io.c | 2 +- > > 1 file changed, 1 insertion(+), 1 deletion(-) > > > > diff --git a/sound/pci/oxygen/oxygen_io.c b/sound/pci/oxygen/oxygen_io.c > > index 521eae4..132ecbe 100644 > > --- a/sound/pci/oxygen/oxygen_io.c > > +++ b/sound/pci/oxygen/oxygen_io.c > > @@ -108,7 +108,7 @@ static int oxygen_ac97_wait(struct oxygen *chip, unsigned int mask) > > wait_event_timeout(chip->ac97_waitqueue, > > ({ status |= oxygen_read8(chip, OXYGEN_AC97_INTERRUPT_STATUS); > > status & mask; }), > > - msecs_to_jiffies(1) + 1); > > + msecs_to_jiffies_min(1)); > > This would change the behavior, I guess. Not to my understanding, the new macro should end up doing the same thing. > (Though, I'm not sure whether the original code was intentional.) Well, I only assumed that.. But using wait_event_timeout() without the +1 would make little sense to me. In that case we may not wait at all for the condition to become true, if we are close to the next scheduling clock tick. > And, isn't msecs_to_jiffies_min(1) identical with msecs_to_jiffies(1)? No, it should be one more in value. --Imre ^ permalink raw reply [flat|nested] 7+ messages in thread
* Re: [PATCH 11/11] sound/oxygen_io: take msecs_to_jiffies_min into use 2013-05-13 14:24 ` Imre Deak @ 2013-05-13 14:35 ` Takashi Iwai 0 siblings, 0 replies; 7+ messages in thread From: Takashi Iwai @ 2013-05-13 14:35 UTC (permalink / raw) To: imre.deak Cc: alsa-devel, Daniel Vetter, Clemens Ladisch, linux-kernel, Andrew Morton At Mon, 13 May 2013 17:24:38 +0300, Imre Deak wrote: > > On Mon, 2013-05-13 at 16:00 +0200, Takashi Iwai wrote: > > At Fri, 10 May 2013 15:13:29 +0300, > > Imre Deak wrote: > > > > > > Use msecs_to_jiffies_min instead of open-coding the same. > > > > > > Signed-off-by: Imre Deak <imre.deak@intel.com> > > > --- > > > sound/pci/oxygen/oxygen_io.c | 2 +- > > > 1 file changed, 1 insertion(+), 1 deletion(-) > > > > > > diff --git a/sound/pci/oxygen/oxygen_io.c b/sound/pci/oxygen/oxygen_io.c > > > index 521eae4..132ecbe 100644 > > > --- a/sound/pci/oxygen/oxygen_io.c > > > +++ b/sound/pci/oxygen/oxygen_io.c > > > @@ -108,7 +108,7 @@ static int oxygen_ac97_wait(struct oxygen *chip, unsigned int mask) > > > wait_event_timeout(chip->ac97_waitqueue, > > > ({ status |= oxygen_read8(chip, OXYGEN_AC97_INTERRUPT_STATUS); > > > status & mask; }), > > > - msecs_to_jiffies(1) + 1); > > > + msecs_to_jiffies_min(1)); > > > > This would change the behavior, I guess. > > Not to my understanding, the new macro should end up doing the same > thing. Ah, OK, I just saw your patch 01/11. But then msecs_to_jiffies_min() sounds confusing, if it plus one implicitly. Takashi > > (Though, I'm not sure whether the original code was intentional.) > > Well, I only assumed that.. But using wait_event_timeout() without the > +1 would make little sense to me. In that case we may not wait at all > for the condition to become true, if we are close to the next scheduling > clock tick. > > > And, isn't msecs_to_jiffies_min(1) identical with msecs_to_jiffies(1)? > > No, it should be one more in value. ^ permalink raw reply [flat|nested] 7+ messages in thread
* Re: [PATCH 11/11] sound/oxygen_io: take msecs_to_jiffies_min into use 2013-05-13 14:00 ` Takashi Iwai 2013-05-13 14:24 ` Imre Deak @ 2013-05-13 14:30 ` Clemens Ladisch 1 sibling, 0 replies; 7+ messages in thread From: Clemens Ladisch @ 2013-05-13 14:30 UTC (permalink / raw) To: Takashi Iwai Cc: Imre Deak, linux-kernel, Andrew Morton, Daniel Vetter, Jaroslav Kysela, alsa-devel Takashi Iwai wrote: > Imre Deak wrote: >> Use msecs_to_jiffies_min instead of open-coding the same. >> >> +++ b/sound/pci/oxygen/oxygen_io.c >> @@ -108,7 +108,7 @@ static int oxygen_ac97_wait(struct oxygen *chip, unsigned int mask) >> wait_event_timeout(chip->ac97_waitqueue, >> ({ status |= oxygen_read8(chip, OXYGEN_AC97_INTERRUPT_STATUS); >> status & mask; }), >> - msecs_to_jiffies(1) + 1); >> + msecs_to_jiffies_min(1)); > > This would change the behavior, I guess. No, that's exactly how msecs_to_jiffies_min would be implemented. > (Though, I'm not sure whether the original code was intentional.) When I wrote this, I was not able to prove that msecs_to_jiffies always rounds up. (And I guess it doesn't; otherwise the _min variant would not be needed.) Regards, Clemens ^ permalink raw reply [flat|nested] 7+ messages in thread
* [PATCH v2 8/8] sound/oxygen_io: take msecs_to_jiffies_timeout into use [not found] ` <1368188011-23661-1-git-send-email-imre.deak@intel.com> 2013-05-10 12:13 ` [PATCH 11/11] sound/oxygen_io: take msecs_to_jiffies_min into use Imre Deak @ 2013-05-14 14:48 ` Imre Deak 2013-05-14 14:50 ` Takashi Iwai 1 sibling, 1 reply; 7+ messages in thread From: Imre Deak @ 2013-05-14 14:48 UTC (permalink / raw) To: linux-kernel Cc: Andrew Morton, Daniel Vetter, Clemens Ladisch, Jaroslav Kysela, Takashi Iwai, alsa-devel Use msecs_to_jiffies_timeout instead of open-coding the same. Signed-off-by: Imre Deak <imre.deak@intel.com> --- sound/pci/oxygen/oxygen_io.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/sound/pci/oxygen/oxygen_io.c b/sound/pci/oxygen/oxygen_io.c index 521eae4..51bfcd0 100644 --- a/sound/pci/oxygen/oxygen_io.c +++ b/sound/pci/oxygen/oxygen_io.c @@ -108,7 +108,7 @@ static int oxygen_ac97_wait(struct oxygen *chip, unsigned int mask) wait_event_timeout(chip->ac97_waitqueue, ({ status |= oxygen_read8(chip, OXYGEN_AC97_INTERRUPT_STATUS); status & mask; }), - msecs_to_jiffies(1) + 1); + msecs_to_jiffies_timeout(1)); /* * Check even after a timeout because this function should not require * the AC'97 interrupt to be enabled. -- 1.7.10.4 ^ permalink raw reply related [flat|nested] 7+ messages in thread
* Re: [PATCH v2 8/8] sound/oxygen_io: take msecs_to_jiffies_timeout into use 2013-05-14 14:48 ` [PATCH v2 8/8] sound/oxygen_io: take msecs_to_jiffies_timeout " Imre Deak @ 2013-05-14 14:50 ` Takashi Iwai 0 siblings, 0 replies; 7+ messages in thread From: Takashi Iwai @ 2013-05-14 14:50 UTC (permalink / raw) To: Imre Deak Cc: linux-kernel, Andrew Morton, Daniel Vetter, Clemens Ladisch, Jaroslav Kysela, alsa-devel At Tue, 14 May 2013 17:48:38 +0300, Imre Deak wrote: > > Use msecs_to_jiffies_timeout instead of open-coding the same. > > Signed-off-by: Imre Deak <imre.deak@intel.com> Acked-by: Takashi Iwai <tiwai@suse.de> Takashi > --- > sound/pci/oxygen/oxygen_io.c | 2 +- > 1 file changed, 1 insertion(+), 1 deletion(-) > > diff --git a/sound/pci/oxygen/oxygen_io.c b/sound/pci/oxygen/oxygen_io.c > index 521eae4..51bfcd0 100644 > --- a/sound/pci/oxygen/oxygen_io.c > +++ b/sound/pci/oxygen/oxygen_io.c > @@ -108,7 +108,7 @@ static int oxygen_ac97_wait(struct oxygen *chip, unsigned int mask) > wait_event_timeout(chip->ac97_waitqueue, > ({ status |= oxygen_read8(chip, OXYGEN_AC97_INTERRUPT_STATUS); > status & mask; }), > - msecs_to_jiffies(1) + 1); > + msecs_to_jiffies_timeout(1)); > /* > * Check even after a timeout because this function should not require > * the AC'97 interrupt to be enabled. > -- > 1.7.10.4 > ^ permalink raw reply [flat|nested] 7+ messages in thread
end of thread, other threads:[~2013-05-14 14:50 UTC | newest]
Thread overview: 7+ messages (download: mbox.gz follow: Atom feed
-- links below jump to the message on this page --
[not found] <1368542918-8861-1-git-send-email-imre.deak@intel.com>
[not found] ` <1368188011-23661-1-git-send-email-imre.deak@intel.com>
2013-05-10 12:13 ` [PATCH 11/11] sound/oxygen_io: take msecs_to_jiffies_min into use Imre Deak
2013-05-13 14:00 ` Takashi Iwai
2013-05-13 14:24 ` Imre Deak
2013-05-13 14:35 ` Takashi Iwai
2013-05-13 14:30 ` Clemens Ladisch
2013-05-14 14:48 ` [PATCH v2 8/8] sound/oxygen_io: take msecs_to_jiffies_timeout " Imre Deak
2013-05-14 14:50 ` Takashi Iwai
This is a public inbox, see mirroring instructions for how to clone and mirror all data and code used for this inbox