From: Takashi Iwai <tiwai@suse.de>
To: Alan Stern <stern@rowland.harvard.edu>
Cc: alsa-devel@alsa-project.org, Joe Perches <joe@perches.com>,
Kernel team list <kernel-team@lists.ubuntu.com>,
Andy Whitcroft <apw@canonical.com>,
leann.ogasawara@canonical.com,
David Henningsson <david.henningsson@canonical.com>
Subject: Re: CONFIG_SND_DEBUG
Date: Wed, 05 Jun 2013 16:28:13 +0200 [thread overview]
Message-ID: <s5hhahctywy.wl%tiwai@suse.de> (raw)
In-Reply-To: <Pine.LNX.4.44L0.1306051008410.1078-100000@iolanthe.rowland.org>
At Wed, 5 Jun 2013 10:11:12 -0400 (EDT),
Alan Stern wrote:
>
> On Wed, 5 Jun 2013, Takashi Iwai wrote:
>
> > > >> Andy/Leann - apparently CONFIG_SND_DEBUG is on by default from
> > > >> upstream, and we explicitly disable it. Is there any reason why we
> > > >> do that?
> > > >
> > > > config SND_DEBUG
> > > > bool "Debug"
> > > > help
> > > > Say Y here to enable ALSA debug code.
> > > >
> > > > It is off by default in upstream, and the really helpful description
> > > > would cirtainly tend to lead to it being disabled. But if it is helpful
> > > > to your debugging efforts David then I suspect we can enable it in Saucy
> > > > and see what happens.
> > >
> > > Okay, so then the ball is back in Takashi's area - if we're recommended
> > > to turn CONFIG_SND_DEBUG on, why is it off by default in the upstream
> > > Linux kernel?
> >
> > It's not off as default. Simply there is no default, just like most
> > of other options.
> >
> > As already mentioned, if the device is known to work well with the
> > kernel, there is no reason to set it on. Then it'll saves the memory
> > and code space. That is, for custom kernels, it's good to be off.
> > But for generic kernels like distro kernel, it'd be better to take a
> > safer side with more safety checks that is built in by that option.
>
> Given this description, the symbol's name is very misleading. Instead
> of being called CONFIG_SND_DEBUG, it should be called
> CONFIG_SND_SAFETY_CHECKS or something like that.
Very true. Actually this option has multiple implicit meanings. It
also enables some debug things, of course, too.
> IMO, distributions are completely justified in turning off any symbol
> which is named (and described in the help text!) as being used for
> debugging only.
Heh, I don't blame distros but just recommend to turn it on :)
Anyway, since 3.10, safety checks with snd_BUG_ON() have been already
enabled even without CONFIG_SND_DEBUG. But this won't give an error
message via WARN() but simply returns the error when built
CONFIG_SND_DEBUG, so it won't help for debugging much, as expected.
And, Alan, please don't work on a patch to correct Kconfig text yet.
I see on my crystalball that you'd send a patch in this very minute ;)
We'll need to work on the debug print things, so the whole kconfig
options need revisited. Let's sort out what to be changed for
messages, split the sanity check codes and debug codes, and then go on
fixing/improving Kconfig appropriately.
thanks,
Takashi
next prev parent reply other threads:[~2013-06-05 14:27 UTC|newest]
Thread overview: 44+ messages / expand[flat|nested] mbox.gz Atom feed top
2013-06-03 20:18 [PATCH] ALSA: get rid of CONFIG_SND_VERBOSE_PRINTK Alan Stern
2013-06-03 20:24 ` Joe Perches
2013-06-03 20:40 ` Alan Stern
2013-06-03 20:49 ` Joe Perches
2013-06-04 9:13 ` Takashi Iwai
2013-06-04 14:49 ` Alan Stern
2013-06-04 15:03 ` Takashi Iwai
2013-06-04 17:20 ` [PATCH 1/2] ALSA: convert "snd_printk(KERN_INFO" to "pr_info(" Alan Stern
2013-06-05 5:52 ` Takashi Iwai
2013-06-05 6:07 ` Joe Perches
2013-06-05 6:16 ` Takashi Iwai
2013-06-06 20:54 ` Alan Stern
2013-06-07 5:41 ` Takashi Iwai
2013-06-07 15:51 ` Alan Stern
2013-06-04 17:20 ` [PATCH 2/2 v.2] ALSA: get rid of CONFIG_SND_VERBOSE_PRINTK Alan Stern
2013-06-04 19:32 ` [PATCH] " Alan Stern
2013-06-04 19:45 ` Joe Perches
2013-06-04 20:54 ` Alan Stern
2013-06-04 21:19 ` Joe Perches
2013-06-06 20:42 ` Alan Stern
2013-06-06 20:59 ` Joe Perches
2013-06-07 14:40 ` Alan Stern
2013-06-07 16:10 ` Joe Perches
2013-06-05 6:04 ` Takashi Iwai
2013-06-05 6:15 ` Joe Perches
2013-06-05 6:32 ` Takashi Iwai
2013-06-05 6:52 ` Joe Perches
2013-06-05 6:54 ` Takashi Iwai
2013-06-05 7:07 ` Joe Perches
2013-06-05 7:22 ` Takashi Iwai
2013-06-05 7:34 ` Joe Perches
2013-06-05 7:47 ` CONFIG_SND_DEBUG (was: Re: [alsa-devel] [PATCH] ALSA: get rid of CONFIG_SND_VERBOSE_PRINTK) David Henningsson
2013-06-05 8:46 ` CONFIG_SND_DEBUG (was: " Takashi Iwai
2013-06-05 10:53 ` CONFIG_SND_DEBUG (was: Re: [alsa-devel] " Andy Whitcroft
2013-06-05 11:38 ` CONFIG_SND_DEBUG David Henningsson
2013-06-05 11:43 ` CONFIG_SND_DEBUG Takashi Iwai
2013-06-05 14:11 ` CONFIG_SND_DEBUG Alan Stern
2013-06-05 14:28 ` Takashi Iwai [this message]
2013-06-05 14:47 ` CONFIG_SND_DEBUG Alan Stern
2013-06-06 21:28 ` [PATCH] ALSA: get rid of CONFIG_SND_VERBOSE_PRINTK Alan Stern
2013-06-06 21:50 ` Joe Perches
2013-06-07 5:57 ` Takashi Iwai
2013-06-07 15:34 ` Alan Stern
2013-06-07 5:53 ` Takashi Iwai
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=s5hhahctywy.wl%tiwai@suse.de \
--to=tiwai@suse.de \
--cc=alsa-devel@alsa-project.org \
--cc=apw@canonical.com \
--cc=david.henningsson@canonical.com \
--cc=joe@perches.com \
--cc=kernel-team@lists.ubuntu.com \
--cc=leann.ogasawara@canonical.com \
--cc=stern@rowland.harvard.edu \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox