From: Takashi Iwai <tiwai@suse.de>
To: Chris Wilson <chris@chris-wilson.co.uk>
Cc: alsa-devel@alsa-project.org,
"Ville Syrjälä" <ville.syrjala@linux.intel.com>
Subject: Re: [PATCH 2/3] ALSA: hda - Move in_pm accessors to HDA core
Date: Thu, 28 Jun 2018 00:05:49 +0200 [thread overview]
Message-ID: <s5hy3ez6g1u.wl-tiwai@suse.de> (raw)
In-Reply-To: <153009232054.8693.169642523536241126@mail.alporthouse.com>
On Wed, 27 Jun 2018 11:38:40 +0200,
Chris Wilson wrote:
>
> Quoting Takashi Iwai (2018-06-27 10:10:33)
> > The in_pm atomic in hdac_device is an important field used as a flag
> > as well as a refcount for PM. The existing snd_hdac_power_up/down
> > helpers already refer to it in the HD-audio core code, while the code
> > to actually setting the value (atomic_inc() / _dec()) is open-coded in
> > HDA legacy side, which is hard to find.
> >
> > This patch adds the helper functions to set/reset the in_pm counter to
> > HDA core and use them in HDA legacy side, for making it clearer who /
> > where the PM is managed.
> >
> > There is no functional changes, just code refactoring.
> >
> > Signed-off-by: Takashi Iwai <tiwai@suse.de>
>
> Mechanical code change that helps explain what it is doing,
> Reviewed-by: Chris Wilson <chris@chris-wilson.co.uk>
This patch still seems OK, so merged to for-next branch alone.
Takashi
next prev parent reply other threads:[~2018-06-27 22:05 UTC|newest]
Thread overview: 15+ messages / expand[flat|nested] mbox.gz Atom feed top
2018-06-27 9:10 [PATCH 0/3] ALSA: PM-related fixes/cleanups Takashi Iwai
2018-06-27 9:10 ` [PATCH 1/3] ALSA: hda - Handle error from snd_hda_power_up*() Takashi Iwai
2018-06-27 9:36 ` Chris Wilson
2018-06-27 9:50 ` Takashi Iwai
2018-06-27 15:54 ` Chris Wilson
2018-06-27 16:09 ` Takashi Iwai
2018-06-27 21:48 ` Takashi Iwai
2018-06-27 16:12 ` Ville Syrjälä
2018-06-27 21:49 ` Takashi Iwai
2018-06-28 9:02 ` [alsa-devel] " Dan Carpenter
2018-06-27 9:10 ` [PATCH 2/3] ALSA: hda - Move in_pm accessors to HDA core Takashi Iwai
2018-06-27 9:38 ` Chris Wilson
2018-06-27 22:05 ` Takashi Iwai [this message]
2018-06-27 9:10 ` [PATCH 3/3] ALSA: hda/hdmi - Don't fall back to generic when i915 binding fails Takashi Iwai
2018-06-27 13:57 ` [PATCH 0/3] ALSA: PM-related fixes/cleanups Chris Wilson
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=s5hy3ez6g1u.wl-tiwai@suse.de \
--to=tiwai@suse.de \
--cc=alsa-devel@alsa-project.org \
--cc=chris@chris-wilson.co.uk \
--cc=ville.syrjala@linux.intel.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox