* [PATCH 1/2] drm/doc: Add amdgpu hwmon/power documentation
@ 2018-06-01 18:03 Alex Deucher
[not found] ` <20180601180358.3462-1-alexander.deucher-5C7GfCeVMHo@public.gmane.org>
0 siblings, 1 reply; 6+ messages in thread
From: Alex Deucher @ 2018-06-01 18:03 UTC (permalink / raw)
To: amd-gfx-PD4FTy7X32lNgt0PjOBp9y5qC8QIuHrW; +Cc: Alex Deucher
Document the hwmon and power control interfaces exposed
by the amdgpu driver.
Signed-off-by: Alex Deucher <alexander.deucher@amd.com>
---
Documentation/gpu/amdgpu.rst | 52 ++++++++++++++++++++++++++++++++++
drivers/gpu/drm/amd/amdgpu/amdgpu_pm.c | 45 +++++++++++++++++++++++------
2 files changed, 89 insertions(+), 8 deletions(-)
diff --git a/Documentation/gpu/amdgpu.rst b/Documentation/gpu/amdgpu.rst
index f557866f6788..1d726b90a619 100644
--- a/Documentation/gpu/amdgpu.rst
+++ b/Documentation/gpu/amdgpu.rst
@@ -18,3 +18,55 @@ PRIME Buffer Sharing
.. kernel-doc:: drivers/gpu/drm/amd/amdgpu/amdgpu_prime.c
:internal:
+
+GPU Power/Thermal Controls and Monitoring
+=========================================
+
+This chapter covers hwmon and power/thermal controls.
+
+HWMON Interfaces
+----------------
+
+.. kernel-doc:: drivers/gpu/drm/amd/amdgpu/amdgpu_pm.c
+ :doc: hwmon
+
+GPU sysfs Power State Interfaces
+--------------------------------
+
+GPU power controls are exposed via sysfs files.
+
+power_dpm_state
+~~~~~~~~~~~~~~~
+
+.. kernel-doc:: drivers/gpu/drm/amd/amdgpu/amdgpu_pm.c
+ :doc: power_dpm_state
+
+power_dpm_force_performance_level
+~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+
+.. kernel-doc:: drivers/gpu/drm/amd/amdgpu/amdgpu_pm.c
+ :doc: power_dpm_force_performance_level
+
+pp_table
+~~~~~~~~
+
+.. kernel-doc:: drivers/gpu/drm/amd/amdgpu/amdgpu_pm.c
+ :doc: pp_table
+
+pp_od_clk_voltage
+~~~~~~~~~~~~~~~~~
+
+.. kernel-doc:: drivers/gpu/drm/amd/amdgpu/amdgpu_pm.c
+ :doc: pp_od_clk_voltage
+
+pp_dpm_sclk pp_dpm_mclk pp_dpm_pcie
+~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+
+.. kernel-doc:: drivers/gpu/drm/amd/amdgpu/amdgpu_pm.c
+ :doc: pp_dpm_sclk pp_dpm_mclk pp_dpm_pcie
+
+pp_power_profile_mode
+~~~~~~~~~~~~~~~~~~~~~
+
+.. kernel-doc:: drivers/gpu/drm/amd/amdgpu/amdgpu_pm.c
+ :doc: pp_power_profile_mode
diff --git a/drivers/gpu/drm/amd/amdgpu/amdgpu_pm.c b/drivers/gpu/drm/amd/amdgpu/amdgpu_pm.c
index b455da487782..f667cb9eb614 100644
--- a/drivers/gpu/drm/amd/amdgpu/amdgpu_pm.c
+++ b/drivers/gpu/drm/amd/amdgpu/amdgpu_pm.c
@@ -80,12 +80,15 @@ void amdgpu_pm_acpi_event_handler(struct amdgpu_device *adev)
/**
* DOC: power_dpm_state
*
- * This is a legacy interface and is only provided for backwards compatibility.
- * The amdgpu driver provides a sysfs API for adjusting certain power
- * related parameters. The file power_dpm_state is used for this.
+ * The power_dpm_state file is a legacy interface and is only provided for
+ * backwards compatibility. The amdgpu driver provides a sysfs API for adjusting
+ * certain power related parameters. The file power_dpm_state is used for this.
* It accepts the following arguments:
+ *
* - battery
+ *
* - balanced
+ *
* - performance
*
* battery
@@ -169,14 +172,21 @@ static ssize_t amdgpu_set_dpm_state(struct device *dev,
* The amdgpu driver provides a sysfs API for adjusting certain power
* related parameters. The file power_dpm_force_performance_level is
* used for this. It accepts the following arguments:
+ *
* - auto
+ *
* - low
+ *
* - high
+ *
* - manual
- * - GPU fan
+ *
* - profile_standard
+ *
* - profile_min_sclk
+ *
* - profile_min_mclk
+ *
* - profile_peak
*
* auto
@@ -463,8 +473,11 @@ static ssize_t amdgpu_set_pp_table(struct device *dev,
* this.
*
* Reading the file will display:
+ *
* - a list of engine clock levels and voltages labeled OD_SCLK
+ *
* - a list of memory clock levels and voltages labeled OD_MCLK
+ *
* - a list of valid ranges for sclk, mclk, and voltage labeled OD_RANGE
*
* To manually adjust these settings, first select manual using
@@ -1285,35 +1298,51 @@ static ssize_t amdgpu_hwmon_set_power_cap(struct device *dev,
* DOC: hwmon
*
* The amdgpu driver exposes the following sensor interfaces:
+ *
* - GPU temperature (via the on-die sensor)
+ *
* - GPU voltage
+ *
* - Northbridge voltage (APUs only)
+ *
* - GPU power
+ *
* - GPU fan
*
* hwmon interfaces for GPU temperature:
+ *
* - temp1_input: the on die GPU temperature in millidegrees Celsius
+ *
* - temp1_crit: temperature critical max value in millidegrees Celsius
+ *
* - temp1_crit_hyst: temperature hysteresis for critical limit in millidegrees Celsius
*
* hwmon interfaces for GPU voltage:
+ *
* - in0_input: the voltage on the GPU in millivolts
+ *
* - in1_input: the voltage on the Northbridge in millivolts
*
* hwmon interfaces for GPU power:
+ *
* - power1_average: average power used by the GPU in microWatts
+ *
* - power1_cap_min: minimum cap supported in microWatts
+ *
* - power1_cap_max: maximum cap supported in microWatts
+ *
* - power1_cap: selected power cap in microWatts
*
* hwmon interfaces for GPU fan:
+ *
* - pwm1: pulse width modulation fan level (0-255)
- * - pwm1_enable: pulse width modulation fan control method
- * 0: no fan speed control
- * 1: manual fan speed control using pwm interface
- * 2: automatic fan speed control
+ *
+ * - pwm1_enable: pulse width modulation fan control method (0: no fan speed control, 1: manual fan speed control using pwm interface, 2: automatic fan speed control)
+ *
* - pwm1_min: pulse width modulation fan control minimum level (0)
+ *
* - pwm1_max: pulse width modulation fan control maximum level (255)
+ *
* - fan1_input: fan speed in RPM
*
* You can use hwmon tools like sensors to view this information on your system.
--
2.13.6
_______________________________________________
amd-gfx mailing list
amd-gfx@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/amd-gfx
^ permalink raw reply related [flat|nested] 6+ messages in thread
* [PATCH 2/2] drm/doc: Make naming consistent for Core Driver Infrastructure
[not found] ` <20180601180358.3462-1-alexander.deucher-5C7GfCeVMHo@public.gmane.org>
@ 2018-06-01 18:03 ` Alex Deucher
[not found] ` <20180601180358.3462-2-alexander.deucher-5C7GfCeVMHo@public.gmane.org>
2018-06-04 9:13 ` [PATCH 1/2] drm/doc: Add amdgpu hwmon/power documentation Michel Dänzer
1 sibling, 1 reply; 6+ messages in thread
From: Alex Deucher @ 2018-06-01 18:03 UTC (permalink / raw)
To: amd-gfx-PD4FTy7X32lNgt0PjOBp9y5qC8QIuHrW; +Cc: Alex Deucher
Use chapter rather than section to align with the rst markup.
Signed-off-by: Alex Deucher <alexander.deucher@amd.com>
---
Documentation/gpu/amdgpu.rst | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/Documentation/gpu/amdgpu.rst b/Documentation/gpu/amdgpu.rst
index 1d726b90a619..e99732553c71 100644
--- a/Documentation/gpu/amdgpu.rst
+++ b/Documentation/gpu/amdgpu.rst
@@ -8,7 +8,7 @@ Next (GCN) architecture.
Core Driver Infrastructure
==========================
-This section covers core driver infrastructure.
+This chapter covers core driver infrastructure.
PRIME Buffer Sharing
--------------------
--
2.13.6
_______________________________________________
amd-gfx mailing list
amd-gfx@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/amd-gfx
^ permalink raw reply related [flat|nested] 6+ messages in thread
* Re: [PATCH 2/2] drm/doc: Make naming consistent for Core Driver Infrastructure
[not found] ` <20180601180358.3462-2-alexander.deucher-5C7GfCeVMHo@public.gmane.org>
@ 2018-06-04 9:11 ` Michel Dänzer
[not found] ` <f3dcab41-b0ad-fb14-5268-b40821e51410-otUistvHUpPR7s880joybQ@public.gmane.org>
0 siblings, 1 reply; 6+ messages in thread
From: Michel Dänzer @ 2018-06-04 9:11 UTC (permalink / raw)
To: Alex Deucher
Cc: Alex Deucher, dri-devel-PD4FTy7X32lNgt0PjOBp9y5qC8QIuHrW,
amd-gfx-PD4FTy7X32lNgt0PjOBp9y5qC8QIuHrW
Adding dri-devel.
On 2018-06-01 08:03 PM, Alex Deucher wrote:
> Use chapter rather than section to align with the rst markup.
>
> Signed-off-by: Alex Deucher <alexander.deucher@amd.com>
> ---
> Documentation/gpu/amdgpu.rst | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/Documentation/gpu/amdgpu.rst b/Documentation/gpu/amdgpu.rst
> index 1d726b90a619..e99732553c71 100644
> --- a/Documentation/gpu/amdgpu.rst
> +++ b/Documentation/gpu/amdgpu.rst
> @@ -8,7 +8,7 @@ Next (GCN) architecture.
> Core Driver Infrastructure
> ==========================
>
> -This section covers core driver infrastructure.
> +This chapter covers core driver infrastructure.
>
> PRIME Buffer Sharing
> --------------------
I don't mind either way, but I copied the "section" wording from i915.rst.
--
Earthling Michel Dänzer | http://www.amd.com
Libre software enthusiast | Mesa and X developer
_______________________________________________
amd-gfx mailing list
amd-gfx@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/amd-gfx
^ permalink raw reply [flat|nested] 6+ messages in thread
* Re: [PATCH 1/2] drm/doc: Add amdgpu hwmon/power documentation
[not found] ` <20180601180358.3462-1-alexander.deucher-5C7GfCeVMHo@public.gmane.org>
2018-06-01 18:03 ` [PATCH 2/2] drm/doc: Make naming consistent for Core Driver Infrastructure Alex Deucher
@ 2018-06-04 9:13 ` Michel Dänzer
1 sibling, 0 replies; 6+ messages in thread
From: Michel Dänzer @ 2018-06-04 9:13 UTC (permalink / raw)
To: Alex Deucher; +Cc: Alex Deucher, amd-gfx-PD4FTy7X32lNgt0PjOBp9y5qC8QIuHrW
On 2018-06-01 08:03 PM, Alex Deucher wrote:
> Document the hwmon and power control interfaces exposed
> by the amdgpu driver.
>
> Signed-off-by: Alex Deucher <alexander.deucher@amd.com>
> ---
> Documentation/gpu/amdgpu.rst | 52 ++++++++++++++++++++++++++++++++++
> drivers/gpu/drm/amd/amdgpu/amdgpu_pm.c | 45 +++++++++++++++++++++++------
> 2 files changed, 89 insertions(+), 8 deletions(-)
>
> diff --git a/Documentation/gpu/amdgpu.rst b/Documentation/gpu/amdgpu.rst
> index f557866f6788..1d726b90a619 100644
> --- a/Documentation/gpu/amdgpu.rst
> +++ b/Documentation/gpu/amdgpu.rst
> @@ -18,3 +18,55 @@ PRIME Buffer Sharing
>
> .. kernel-doc:: drivers/gpu/drm/amd/amdgpu/amdgpu_prime.c
> :internal:
> +
> +GPU Power/Thermal Controls and Monitoring
> +=========================================
> +
> +This chapter covers hwmon and power/thermal controls.
Apart from the chapter/section question raised by patch 2, this patch is
Reviewed-by: Michel Dänzer <michel.daenzer@amd.com>
--
Earthling Michel Dänzer | http://www.amd.com
Libre software enthusiast | Mesa and X developer
_______________________________________________
amd-gfx mailing list
amd-gfx@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/amd-gfx
^ permalink raw reply [flat|nested] 6+ messages in thread
* Re: [PATCH 2/2] drm/doc: Make naming consistent for Core Driver Infrastructure
[not found] ` <f3dcab41-b0ad-fb14-5268-b40821e51410-otUistvHUpPR7s880joybQ@public.gmane.org>
@ 2018-06-13 17:45 ` Alex Deucher
[not found] ` <CADnq5_OdOKzkYgH5+anMPdCUHDYAbRtJtyVKEk8zyccq40ah8w-JsoAwUIsXosN+BqQ9rBEUg@public.gmane.org>
0 siblings, 1 reply; 6+ messages in thread
From: Alex Deucher @ 2018-06-13 17:45 UTC (permalink / raw)
To: Michel Dänzer
Cc: Alex Deucher, Maling list - DRI developers, amd-gfx list
On Mon, Jun 4, 2018 at 5:11 AM, Michel Dänzer <michel@daenzer.net> wrote:
>
> Adding dri-devel.
>
Any opinions?
Alex
>
> On 2018-06-01 08:03 PM, Alex Deucher wrote:
>> Use chapter rather than section to align with the rst markup.
>>
>> Signed-off-by: Alex Deucher <alexander.deucher@amd.com>
>> ---
>> Documentation/gpu/amdgpu.rst | 2 +-
>> 1 file changed, 1 insertion(+), 1 deletion(-)
>>
>> diff --git a/Documentation/gpu/amdgpu.rst b/Documentation/gpu/amdgpu.rst
>> index 1d726b90a619..e99732553c71 100644
>> --- a/Documentation/gpu/amdgpu.rst
>> +++ b/Documentation/gpu/amdgpu.rst
>> @@ -8,7 +8,7 @@ Next (GCN) architecture.
>> Core Driver Infrastructure
>> ==========================
>>
>> -This section covers core driver infrastructure.
>> +This chapter covers core driver infrastructure.
>>
>> PRIME Buffer Sharing
>> --------------------
>
> I don't mind either way, but I copied the "section" wording from i915.rst.
>
>
> --
> Earthling Michel Dänzer | http://www.amd.com
> Libre software enthusiast | Mesa and X developer
_______________________________________________
amd-gfx mailing list
amd-gfx@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/amd-gfx
^ permalink raw reply [flat|nested] 6+ messages in thread
* Re: [PATCH 2/2] drm/doc: Make naming consistent for Core Driver Infrastructure
[not found] ` <CADnq5_OdOKzkYgH5+anMPdCUHDYAbRtJtyVKEk8zyccq40ah8w-JsoAwUIsXosN+BqQ9rBEUg@public.gmane.org>
@ 2018-06-18 8:37 ` Daniel Vetter
0 siblings, 0 replies; 6+ messages in thread
From: Daniel Vetter @ 2018-06-18 8:37 UTC (permalink / raw)
To: Alex Deucher
Cc: Alex Deucher, Michel Dänzer, amd-gfx list,
Maling list - DRI developers
On Wed, Jun 13, 2018 at 01:45:23PM -0400, Alex Deucher wrote:
> On Mon, Jun 4, 2018 at 5:11 AM, Michel Dänzer <michel@daenzer.net> wrote:
> >
> > Adding dri-devel.
> >
>
> Any opinions?
100% meh, i.e. if you care, go with whatever, you have my ack. Anyone who
cares about making docs more consistent makes me a happy camper :-)
Cheers, Daniel
>
> Alex
>
> >
> > On 2018-06-01 08:03 PM, Alex Deucher wrote:
> >> Use chapter rather than section to align with the rst markup.
> >>
> >> Signed-off-by: Alex Deucher <alexander.deucher@amd.com>
> >> ---
> >> Documentation/gpu/amdgpu.rst | 2 +-
> >> 1 file changed, 1 insertion(+), 1 deletion(-)
> >>
> >> diff --git a/Documentation/gpu/amdgpu.rst b/Documentation/gpu/amdgpu.rst
> >> index 1d726b90a619..e99732553c71 100644
> >> --- a/Documentation/gpu/amdgpu.rst
> >> +++ b/Documentation/gpu/amdgpu.rst
> >> @@ -8,7 +8,7 @@ Next (GCN) architecture.
> >> Core Driver Infrastructure
> >> ==========================
> >>
> >> -This section covers core driver infrastructure.
> >> +This chapter covers core driver infrastructure.
> >>
> >> PRIME Buffer Sharing
> >> --------------------
> >
> > I don't mind either way, but I copied the "section" wording from i915.rst.
> >
> >
> > --
> > Earthling Michel Dänzer | http://www.amd.com
> > Libre software enthusiast | Mesa and X developer
> _______________________________________________
> dri-devel mailing list
> dri-devel@lists.freedesktop.org
> https://lists.freedesktop.org/mailman/listinfo/dri-devel
--
Daniel Vetter
Software Engineer, Intel Corporation
http://blog.ffwll.ch
_______________________________________________
amd-gfx mailing list
amd-gfx@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/amd-gfx
^ permalink raw reply [flat|nested] 6+ messages in thread
end of thread, other threads:[~2018-06-18 8:37 UTC | newest]
Thread overview: 6+ messages (download: mbox.gz follow: Atom feed
-- links below jump to the message on this page --
2018-06-01 18:03 [PATCH 1/2] drm/doc: Add amdgpu hwmon/power documentation Alex Deucher
[not found] ` <20180601180358.3462-1-alexander.deucher-5C7GfCeVMHo@public.gmane.org>
2018-06-01 18:03 ` [PATCH 2/2] drm/doc: Make naming consistent for Core Driver Infrastructure Alex Deucher
[not found] ` <20180601180358.3462-2-alexander.deucher-5C7GfCeVMHo@public.gmane.org>
2018-06-04 9:11 ` Michel Dänzer
[not found] ` <f3dcab41-b0ad-fb14-5268-b40821e51410-otUistvHUpPR7s880joybQ@public.gmane.org>
2018-06-13 17:45 ` Alex Deucher
[not found] ` <CADnq5_OdOKzkYgH5+anMPdCUHDYAbRtJtyVKEk8zyccq40ah8w-JsoAwUIsXosN+BqQ9rBEUg@public.gmane.org>
2018-06-18 8:37 ` Daniel Vetter
2018-06-04 9:13 ` [PATCH 1/2] drm/doc: Add amdgpu hwmon/power documentation Michel Dänzer
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox