From: Kalle Valo <kvalo@qca.qualcomm.com>
To: Ryan Hsu <ryanhsu@qca.qualcomm.com>
Cc: "ath10k@lists.infradead.org" <ath10k@lists.infradead.org>
Subject: Re: [PATCH v6 06/10] ath10k: add sdio extra initializations
Date: Thu, 23 Mar 2017 15:59:53 +0000 [thread overview]
Message-ID: <87h92kyoef.fsf@kamboji.qca.qualcomm.com> (raw)
In-Reply-To: <9eb52257-2753-d9d0-2590-dd05c7aedea6@qca.qualcomm.com> (Ryan Hsu's message of "Thu, 16 Mar 2017 01:18:58 +0000")
Ryan Hsu <ryanhsu@qca.qualcomm.com> writes:
> On 03/15/2017 08:46 AM, Kalle Valo wrote:
>
>> From: Erik Stromdahl <erik.stromdahl@gmail.com>
>>
>> Extra initializations needed by all sdio boards.
>> Derived from qcacld.
>>
>> Signed-off-by: Erik Stromdahl <erik.stromdahl@gmail.com>
>> Signed-off-by: Kalle Valo <kvalo@qca.qualcomm.com>
>> ---
>> drivers/net/wireless/ath/ath10k/core.c | 22 ++++++++++++++++++++--
>> 1 file changed, 20 insertions(+), 2 deletions(-)
>>
>> diff --git a/drivers/net/wireless/ath/ath10k/core.c b/drivers/net/wireless/ath/ath10k/core.c
>> index f450ebbb28d5..6b6ea8a571fa 100644
>> --- a/drivers/net/wireless/ath/ath10k/core.c
>> +++ b/drivers/net/wireless/ath/ath10k/core.c
>> @@ -377,7 +377,22 @@ static void ath10k_send_suspend_complete(struct ath10k *ar)
>> complete(&ar->target_suspend);
>> }
>>
>> -static int ath10k_init_configure_target(struct ath10k *ar)
>> +static void ath10k_sdio_extra_initialization(struct ath10k *ar)
>> +{
>> + u32 param = 0;
>> +
>> + ath10k_bmi_write32(ar, hi_mbox_io_block_sz, 256);
>> + ath10k_bmi_write32(ar, hi_mbox_isr_yield_limit, 99);
>> + ath10k_bmi_read32(ar, hi_acs_flags, ¶m);
>> +
>> + param |= (HI_ACS_FLAGS_SDIO_SWAP_MAILBOX_SET |
>> + HI_ACS_FLAGS_SDIO_REDUCE_TX_COMPL_SET |
>> + HI_ACS_FLAGS_ALT_DATA_CREDIT_SIZE);
>> +
>> + ath10k_bmi_write32(ar, hi_acs_flags, param);
>> +}
>> +
>> +static int ath10k_init_sdio(struct ath10k *ar)
>
> Shouldn't we just keep the ath10k_init_configure_target() and move the
> sdio specific to ath10k_sdio_extra_initialization()?
> instead of renaming this to ath10k_init_sdio()? not sure if this is
> just a local hack that didn't revert?
Ouch, I was supposed to rename ath10k_sdio_extra_initialization() to
ath10k_init_sdio() but accidentally renamed the wrong function. Will fix
in v7.
Thanks for catching this!
--
Kalle Valo
_______________________________________________
ath10k mailing list
ath10k@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/ath10k
next prev parent reply other threads:[~2017-03-23 16:00 UTC|newest]
Thread overview: 21+ messages / expand[flat|nested] mbox.gz Atom feed top
2017-03-15 15:44 [PATCH v6 00/10] ath10k: sdio support Kalle Valo
2017-03-15 15:44 ` [PATCH v6 01/10] ath10k: htc: made static function public Kalle Valo
2017-03-15 15:45 ` [PATCH v6 02/10] ath10k: htc: rx trailer lookahead support Kalle Valo
2017-03-15 15:45 ` [PATCH v6 03/10] ath10k: htc: move htc ctrl ep connect to htc_init Kalle Valo
2017-03-16 1:06 ` Ryan Hsu
2017-03-16 16:13 ` Erik Stromdahl
2017-03-15 15:45 ` [PATCH v6 04/10] ath10k: htc: refactorization Kalle Valo
2017-03-15 15:45 ` [PATCH v6 05/10] ath10k: various sdio related definitions Kalle Valo
2017-03-15 15:46 ` [PATCH v6 06/10] ath10k: add sdio extra initializations Kalle Valo
2017-03-16 1:18 ` Ryan Hsu
2017-03-23 15:59 ` Kalle Valo [this message]
2017-03-15 15:46 ` [PATCH v6 07/10] ath10k: sdio get target info Kalle Valo
2017-03-15 15:46 ` [PATCH v6 08/10] ath10k: htc: ready_ext msg support Kalle Valo
2017-03-15 15:46 ` [PATCH v6 09/10] ath10k: different fw file names for usb and sdio Kalle Valo
2017-03-16 21:08 ` Ryan Hsu
2017-03-23 15:51 ` Kalle Valo
2017-03-15 15:46 ` [PATCH v6 10/10] ath10k: sdio support Kalle Valo
2017-03-23 15:23 ` Kalle Valo
2017-03-28 11:53 ` [PATCH v6 00/10] " Kalle Valo
2017-03-28 16:40 ` Erik Stromdahl
2017-03-29 6:14 ` Kalle Valo
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=87h92kyoef.fsf@kamboji.qca.qualcomm.com \
--to=kvalo@qca.qualcomm.com \
--cc=ath10k@lists.infradead.org \
--cc=ryanhsu@qca.qualcomm.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox