From: sashiko-bot@kernel.org
To: "SJ Park" <sj@kernel.org>
Cc: damon@lists.linux.dev
Subject: Re: [RFC PATCH v2.2 4/7] mm/damon/sysfs-schemes: rename sysfs_filter->sz_range to range_{min,max}
Date: Fri, 11 Sep 2026 01:19:55 +0000 [thread overview]
Message-ID: <20260911011956.58D201F000FF@smtp.kernel.org> (raw)
In-Reply-To: <20260911011330.93678-5-sj@kernel.org>
> DAMON sysfs interface provides 'min' and 'max' files under the DAMOS
> filter directory. The purpose is setting the general range arguments
> for hugepage_size like filters that require range arguments. So far,
> hugepage_size was the only filter using it. Hence sz_range field of
> damon_sysfs_scheme_filter struct was connected to the files.
>
> In future, we could add a new filter that can reuse the 'min' and 'max'
> files. And the filter might use a range of a type that is not size. For
> example, probe_hits weighted sum. In this case, simply reusing the
> sz_range field would make it a little confusing. Rename sz_range to
> range_{min,max} to avoid such confusion.
>
> Signed-off-by: SJ Park <sj@kernel.org>
Sashiko has reviewed this patch and found no issues. It looks great!
--
Sashiko AI review · https://sashiko.dev/#/patchset/20260911011330.93678-1-sj@kernel.org?part=4
next prev parent reply other threads:[~2026-09-11 1:19 UTC|newest]
Thread overview: 17+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-09-11 1:13 [RFC PATCH v2.2 0/7] mm/damon: introduce probe_hits_wsum DAMOS core filter SJ Park
2026-09-11 1:13 ` [RFC PATCH v2.2 1/7] mm/damon/api: introduce DAMOS_FILTER_TYPE_PROBE_HITS_WSUM SJ Park
2026-09-11 1:20 ` sashiko-bot
2026-09-11 1:27 ` SJ Park
2026-09-11 1:13 ` [RFC PATCH v2.2 2/7] mm/damon/core: extend probe_hits_wsum() for moving sum based calculation SJ Park
2026-09-11 1:21 ` sashiko-bot
2026-09-11 1:13 ` [RFC PATCH v2.2 3/7] mm/damon/core: support probe_hits_wsum damos core filter SJ Park
2026-09-11 1:22 ` sashiko-bot
2026-09-11 1:28 ` SJ Park
2026-09-11 1:13 ` [RFC PATCH v2.2 4/7] mm/damon/sysfs-schemes: rename sysfs_filter->sz_range to range_{min,max} SJ Park
2026-09-11 1:19 ` sashiko-bot [this message]
2026-09-11 1:13 ` [RFC PATCH v2.2 5/7] mm/damon/sysfs-schemes: support probe_hits_wsum damos core filter SJ Park
2026-09-11 1:21 ` sashiko-bot
2026-09-11 1:13 ` [RFC PATCH v2.2 6/7] Docs/mm/damon/design: update for probe_hits_wsum DAMOS " SJ Park
2026-09-11 1:15 ` sashiko-bot
2026-09-11 1:13 ` [RFC PATCH v2.2 7/7] Docs/admin-guide/mm/damon/usage: update for probe_hits_wsum DAMOS filter SJ Park
2026-09-11 1:15 ` sashiko-bot
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20260911011956.58D201F000FF@smtp.kernel.org \
--to=sashiko-bot@kernel.org \
--cc=damon@lists.linux.dev \
--cc=sashiko-reviews@lists.linux.dev \
--cc=sj@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox