From: sashiko-bot@kernel.org
To: "SJ Park" <sj@kernel.org>
Cc: damon@lists.linux.dev
Subject: Re: [RFC PATCH v2.2 1/7] mm/damon/api: introduce DAMOS_FILTER_TYPE_PROBE_HITS_WSUM
Date: Fri, 11 Sep 2026 01:20:06 +0000 [thread overview]
Message-ID: <20260911012007.0397B1F000FF@smtp.kernel.org> (raw)
In-Reply-To: <20260911011330.93678-2-sj@kernel.org>
Thank you for your contribution! Sashiko AI review found 1 potential issue(s) to consider:
- [Low] The kernel-doc update for `enum damos_filter_type` creates ambiguity regarding the handling of `DAMOS_FILTER_TYPE_PROBE_HITS_WSUM`.
--
commit 901df9c4ed650529dec43469f4e3c96f3bf07c6f
Author: SJ Park <sj@kernel.org>
mm/damon/api: introduce DAMOS_FILTER_TYPE_PROBE_HITS_WSUM
This commit updates the DAMON kernel API to introduce a new DAMOS core
filter type, PROBE_HITS_WSUM. It allows API callers to describe the DAMOS
action target regions based on their probe_hits weighted sum.
> diff --git a/include/linux/damon.h b/include/linux/damon.h
> index 871d26adf6ae5..ef99ff778ae10 100644
> --- a/include/linux/damon.h
> +++ b/include/linux/damon.h
> @@ -399,14 +399,15 @@ struct damos_stat {
> * @DAMOS_FILTER_TYPE_UNMAPPED: Unmapped pages.
> * @DAMOS_FILTER_TYPE_ADDR: Address range.
> * @DAMOS_FILTER_TYPE_TARGET: Data Access Monitoring target.
> + * @DAMOS_FILTER_TYPE_PROBE_HITS_WSUM: probe_hits weighted sum range.
> * @NR_DAMOS_FILTER_TYPES: Number of filter types.
> *
> - * All types except &DAMOS_FILTER_TYPE_ADDR and &DAMOS_FILTER_TYPE_TARGET
> - * are handled by the underlying &struct damon_operations as a part of scheme
> - * action trying, and therefore accounted as 'tried'. In contrast,
> - * &DAMOS_FILTER_TYPE_ADDR and &DAMOS_FILTER_TYPE_TARGET filters are handled
> - * by the core layer before trying of the action, and therefore not accounted
> - * as 'tried'.
> + * All types except &DAMOS_FILTER_TYPE_ADDR, &DAMOS_FILTER_TYPE_TARGET and
> + * &DAMOS_FILTER_TYPE_PROBE_HITS_WSUM are handled by the underlying &struct
> + * damon_operations as a part of scheme action trying, and therefore accounted
> + * as 'tried'. In contrast, &DAMOS_FILTER_TYPE_ADDR and
> + * &DAMOS_FILTER_TYPE_TARGET filters are handled by the core layer before
> + * trying of the action, and therefore not accounted as 'tried'.
[Severity: Low]
Does this documentation update leave the handling of
DAMOS_FILTER_TYPE_PROBE_HITS_WSUM ambiguous?
The first sentence excludes DAMOS_FILTER_TYPE_PROBE_HITS_WSUM from being
handled by damon_operations, but the second sentence does not add it to the
list of filters handled by the core layer.
Could the second sentence be updated to explicitly mention
DAMOS_FILTER_TYPE_PROBE_HITS_WSUM so developers reading the kernel-doc for
enum damos_filter_type know exactly when its evaluation phase occurs?
[ ... ]
--
Sashiko AI review · https://sashiko.dev/#/patchset/20260911011330.93678-1-sj@kernel.org?part=1
next prev parent reply other threads:[~2026-09-11 1:20 UTC|newest]
Thread overview: 17+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-09-11 1:13 [RFC PATCH v2.2 0/7] mm/damon: introduce probe_hits_wsum DAMOS core filter SJ Park
2026-09-11 1:13 ` [RFC PATCH v2.2 1/7] mm/damon/api: introduce DAMOS_FILTER_TYPE_PROBE_HITS_WSUM SJ Park
2026-09-11 1:20 ` sashiko-bot [this message]
2026-09-11 1:27 ` SJ Park
2026-09-11 1:13 ` [RFC PATCH v2.2 2/7] mm/damon/core: extend probe_hits_wsum() for moving sum based calculation SJ Park
2026-09-11 1:21 ` sashiko-bot
2026-09-11 1:13 ` [RFC PATCH v2.2 3/7] mm/damon/core: support probe_hits_wsum damos core filter SJ Park
2026-09-11 1:22 ` sashiko-bot
2026-09-11 1:28 ` SJ Park
2026-09-11 1:13 ` [RFC PATCH v2.2 4/7] mm/damon/sysfs-schemes: rename sysfs_filter->sz_range to range_{min,max} SJ Park
2026-09-11 1:19 ` sashiko-bot
2026-09-11 1:13 ` [RFC PATCH v2.2 5/7] mm/damon/sysfs-schemes: support probe_hits_wsum damos core filter SJ Park
2026-09-11 1:21 ` sashiko-bot
2026-09-11 1:13 ` [RFC PATCH v2.2 6/7] Docs/mm/damon/design: update for probe_hits_wsum DAMOS " SJ Park
2026-09-11 1:15 ` sashiko-bot
2026-09-11 1:13 ` [RFC PATCH v2.2 7/7] Docs/admin-guide/mm/damon/usage: update for probe_hits_wsum DAMOS filter SJ Park
2026-09-11 1:15 ` sashiko-bot
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20260911012007.0397B1F000FF@smtp.kernel.org \
--to=sashiko-bot@kernel.org \
--cc=damon@lists.linux.dev \
--cc=sashiko-reviews@lists.linux.dev \
--cc=sj@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox