From: Marat Khalili <qm2k21@gmail.com>
Cc: dev@dpdk.org, Marat Khalili <marat.khalili@huawei.com>,
Marat Khalili <qm2k21@gmail.com>
Subject: [PATCH v3 0/1] bpf_def.h cleanups
Date: Thu, 17 Sep 2026 15:19:15 +0000 [thread overview]
Message-ID: <20260917151916.48749-1-qm2k21@gmail.com> (raw)
In-Reply-To: <20260911124414.63321-1-marat.khalili@huawei.com>
The goal of this patch is to clarify the public/private status of the eBPF
definitions and prevent name conflicts. It achieves this by moving the
required public symbols into the public ``rte_bpf.h`` header with a proper
``RTE_`` prefix, and making the remaining ``bpf_def.h`` header private.
v3:
* Dropped part 2 (renaming macros) as there was no consensus on it.
* Added a release notes entry detailing the API change (bpf_def.h
becoming private and public symbols moved to rte_bpf.h).
v2:
* Following the AI suggestion renamed `RTE_EBPF_FUNC_MAX_ARGS` to
`RTE_BPF_FUNC_MAX_ARGS`.
* Rebased on fresh main hoping to overcome the unrelated CI issues.
* Cautiously re-posting without the RFC label.
Marat Khalili (1):
bpf: make bpf_def.h private
app/test/test_bpf.c | 79 +++++++++++++-------------
app/test/test_bpf_validate.c | 74 ++++++++++++------------
doc/guides/rel_notes/release_26_11.rst | 6 ++
lib/bpf/bpf_convert.c | 38 ++++++-------
lib/bpf/bpf_def.h | 15 -----
lib/bpf/bpf_dump.c | 13 +++--
lib/bpf/bpf_exec.c | 8 +--
lib/bpf/bpf_impl.h | 3 +-
lib/bpf/bpf_jit_arm64.c | 4 +-
lib/bpf/bpf_jit_x86.c | 2 +-
lib/bpf/bpf_load.c | 2 +-
lib/bpf/bpf_load_elf.c | 10 ++--
lib/bpf/bpf_validate.c | 44 +++++++-------
lib/bpf/bpf_validate.h | 6 +-
lib/bpf/bpf_validate_debug.c | 6 +-
lib/bpf/meson.build | 1 -
lib/bpf/rte_bpf.h | 33 ++++++++---
lib/bpf/rte_bpf_validate_debug.h | 8 +--
18 files changed, 180 insertions(+), 172 deletions(-)
--
2.43.0
next prev parent reply other threads:[~2026-09-17 15:19 UTC|newest]
Thread overview: 16+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-08-05 9:46 [RFC 0/2] bpf_def.h cleanups Marat Khalili
2026-08-05 9:46 ` [RFC 1/2] bpf: make bpf_def.h private Marat Khalili
2026-08-05 9:46 ` [RFC 2/2] bpf: rename macros to match Linux kernel Marat Khalili
2026-09-11 12:44 ` [PATCH v2 0/2] bpf_def.h cleanups Marat Khalili
2026-09-11 12:44 ` [PATCH v2 1/2] bpf: make bpf_def.h private Marat Khalili
2026-09-16 12:59 ` Konstantin Ananyev
2026-09-11 12:44 ` [PATCH v2 2/2] bpf: rename macros to match Linux kernel Marat Khalili
2026-09-16 13:07 ` Konstantin Ananyev
2026-09-17 15:19 ` Marat Khalili [this message]
2026-09-17 15:19 ` [PATCH v3 1/1] bpf: make bpf_def.h private Marat Khalili
2026-09-17 19:29 ` Marat Khalili
2026-09-18 9:21 ` [PATCH v4 0/1] bpf_def.h cleanups Marat Khalili
2026-09-18 9:21 ` [PATCH v4 1/1] bpf: make bpf_def.h private Marat Khalili
2026-09-18 10:28 ` Marat Khalili
2026-09-21 10:16 ` Marat Khalili
2026-09-21 20:19 ` Marat Khalili
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20260917151916.48749-1-qm2k21@gmail.com \
--to=qm2k21@gmail.com \
--cc=dev@dpdk.org \
--cc=marat.khalili@huawei.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox